UomoCapra

Kerbal Space Program 1.6: “To Vee or not To Vee” Grand Discussion Thread

Recommended Posts

36 minutes ago, DJWyre said:


Stage 1: Kerbin ASL for initial ascent.
Stage 2: Vacuum for circularisation and Duna injection.
Stage 3: Duna upper atmo/surface.

KER didn't do that either though

Share this post


Link to post
Share on other sites
1 hour ago, DJWyre said:

Stage 1: Kerbin ASL for initial ascent.
Stage 2: Vacuum for circularisation and Duna injection.
Stage 3: Duna upper atmo/surface.

This would be the only thing that would make it better than KER.

Peace.

Share this post


Link to post
Share on other sites
15 hours ago, Jesusthebird said:

blast..I was about to edit my post lol. seems theres an issue with r-clicking parts. But I still had my mods installed...time for the ol "one by one" install method...

Something to check before you go on a lengthy "which mod is the problem" expedition.  (TL;DR:  It might not be your mods-- it could be an issue with local corrupted files.)

 

Share this post


Link to post
Share on other sites

Guys, has anyone noticed a problem with Stock Craft? Apparently the Ravenspear mk3, Mallard, VTOL and the Stearwing don't load as the lack the following part - noseCone. 

@SQUAD? You did rebuild them...

Share this post


Link to post
Share on other sites
18 minutes ago, Xurkitree said:

Guys, has anyone noticed a problem with Stock Craft? Apparently the Ravenspear mk3, Mallard, VTOL and the Stearwing don't load as the lack the following part - noseCone. 

@SQUAD? You did rebuild them...

I see no issues with these craft, it might just be something on your end.

Share this post


Link to post
Share on other sites

Can confirm Laythe has breathable air - science defs have been changed accordingly.

Breathe through mouth only lmao

Share this post


Link to post
Share on other sites
7 hours ago, GrandProtectorDark said:

KER didn't do that either though

I know, but I kinda gave the impression I thought it did. Just a suggestion though. <Stares at Squad.>

Edited by DJWyre

Share this post


Link to post
Share on other sites
3 hours ago, Snark said:

Something to check before you go on a lengthy "which mod is the problem" expedition.  (TL;DR:  It might not be your mods-- it could be an issue with local corrupted files.)

 

Hmm indeed thats a pesky boof by steam..ive noticed almost every time I validate install recently..2 files were missing or corrupted. Its a regular occurance it seems. I wish it told us which files...

Share this post


Link to post
Share on other sites

From @Lupi's post, here is what I see:

[EXC 11:53:09.282] NullReferenceException: Object reference not set to an instance of an object
    UIPartActionVariantSelector.RefreshVariantButtons ()
    UIPartActionVariantSelector.Setup (.UIPartActionWindow window, .Part part, .PartModule partModule, UI_Scene scene, .UI_Control control, .BaseField field)
    UIPartActionWindow.AddFieldControl (.BaseField field, .Part part, .PartModule module)
    UIPartActionWindow.CreatePartList (Boolean clearFirst)
    UIPartActionWindow.UpdateWindow ()
    UIPartActionController.UpdateActiveWindows ()
    UIPartActionController.UpdateEditor ()
    UIPartActionController.Update ()

Share this post


Link to post
Share on other sites
9 hours ago, DJWyre said:

 

Eg.
Stage 1: Kerbin ASL for initial ascent.
Stage 2: Vacuum for circularisation and Duna injection.
Stage 3: Duna upper atmo/surface.

Excellent idea.

That along with integrating 'Alarm Clock' and 'Launch Window Planning' tools would be awesome.

Share this post


Link to post
Share on other sites

I found some bugs while playing around with a Rover I made -

bgYsDJo.png

As you can see, the collider names are popping up - not the Runway.

1A02lVg.png

And Kerbals can phase through wheels.

But in other news -

zgA4RdM.png

This is what I was talking about.

SEb1NYM.png

This is my rover. Pretty cool neh?

Share this post


Link to post
Share on other sites
On 12/22/2018 at 1:17 AM, tater said:

I have a PC as well. I'm not very fond of it (it's ugly, and noisy (I built it, myself, but the available choices for parts/cases doesn't escape ugly and noisy easily)).

 

JUst up this thread are some answers from Squad that are not in the support forum at all regarding the issues with getting the Mac version to run. You, like me appear to have DLed the zip version---for good reason, since as far as any of us knew, the "Installer" has never worked, and so we never bothered to use it. It apparently actually works! Try DLing the installer and running that instead of the usual use of the zip file. Don't use the "Launcher" that's in the file structure, that doesn't work (I'm curious does it work for anyone?). Seems like a waste of 53MB of DL.

To be clear, go to the KSP Store, to your account, then under Kerbal Space Program, DL the "Installer (.pkg)" instead of the zip, and run that once it's downloaded.

Thanks. You called it, nail on the head. Wow the installer works. 

Share this post


Link to post
Share on other sites

I'm liking what I've seen of 1.6 so far, especially the removable neck ring and kerbal idle anims. The Mk2 Lander Can variant is a cool addition to the part too.

However I've notice some strange behaviour of the Mk2 Lander Can rover variant, when driven around. I've posted a bug about this, but thought I'd post here in case others have noticed the same behaviour.

The behaviour is that when powered is applied the vehicle veers strongly to the right, as if the center of mass of the Lander Can is off center (although it appears centered in the VAB).

The detail of the behaviour is that from a standing start the vehicle pulls a few degrees to the right, then continues straight ahead until a certain speed is reach at which point it steers continuously in a steady right turn.

I tried out both the RoveMax Model M1 and the TR-2L wheels and both had the same behaviour. I tested out the RoveMax with some different bodies for the rover (Mk1 Cockpit with a Structural Fuselage as well as Mk1 Lander Can and some girders) and those behaved normally.

Something else I noticed was that the Mk2 Lander Can based rover exhibited much stronger movement of the suspension that the other designs, regardless of whether it was lighter or heavier than them. It was generally bouncy as well as a pronounced dive down at the front when accelerating (opposite of what I'd expect) and at the back when braking.

All the wheel settings were default and the wheel positions were definitely symmetrical (positioned then snapped into place after to be sure) for all vehicles tested.

Here's a couple of pics of to show what I mean.

Braking.

eO883Po.png

Accelerating.

2qbx2tv.png

 

Edited by purpleivan

Share this post


Link to post
Share on other sites
2 hours ago, purpleivan said:

I've notice some strange behaviour of the Mk2 Lander Can rover variant

Sorry if I'm just repeating what was written earlier in the thread, but are you on Steam? Have you tried verifying the KSP files?

Share this post


Link to post
Share on other sites
8 hours ago, Xurkitree said:

And Kerbals can phase through wheels.

Since 1.1 I think.  Squad couldn't figure out how to keep the Kraken away when Kerbal's got ran over by the new, improved Unity wheel code.  So, they just made Kerbal's phase through wheels instead. 

Edited by klgraham1013

Share this post


Link to post
Share on other sites
2 hours ago, Deddly said:

Sorry if I'm just repeating what was written earlier in the thread, but are you on Steam? Have you tried verifying the KSP files?

Didn't do a verify but it was a fresh install, not over an existing one. Away from my PC for next few days but can try that when I'm back.

Share this post


Link to post
Share on other sites
5 hours ago, purpleivan said:

The behaviour is that when powered is applied the vehicle veers strongly to the right, as if the center of mass of the Lander Can is off center (although it appears centered in the VAB).

Try toggling the control point to Forwards in the right click menu.

TvH3ANQ.png

The nav ball should be showing you the horizon in front of the vehicle, not the sky.

Share this post


Link to post
Share on other sites
12 hours ago, purpleivan said:

...The behaviour is that when powered is applied the vehicle veers strongly to the right, as if the center of mass of the Lander Can is off center (although it appears centered in the VAB)....

 

Another thing to check is if you have the reaction wheel disabled - that catches me with every rover I build till I remember to turn it off so the wheels are in control

Share this post


Link to post
Share on other sites
On 12/23/2018 at 9:37 AM, HebaruSan said:

Try toggling the control point to Forwards in the right click menu.

TvH3ANQ.png

The nav ball should be showing you the horizon in front of the vehicle, not the sky.

"The nav ball should be showing you the horizon in front of the vehicle, not the sky."  Thanks for this. Perfect way to visualize it.

Share this post


Link to post
Share on other sites
34 minutes ago, The-Doctor said:

Bug, I can't right click whenever I choose the MK2 can, it is a fairly game killing bug. 

Have you verified the files? ;)

Share this post


Link to post
Share on other sites
2 hours ago, Deddly said:

Have you verified the files? ;)

As in? If I chose the mk2 I can't right click. It's a common bugs others have faced it. 

 

I deleted my game folder and reinstalled and the bug still exists 

Edited by The-Doctor

Share this post


Link to post
Share on other sites
1 minute ago, The-Doctor said:

As in? If I chose the mk2 I can't right click. It's a common bugs others have faced it. 

 

I deleted my game folder and reinstalled and the bug still exists 

Verify game files, open game, go to editor, close game open it again.
And I have no idea why, but it works (sorta-ish)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.