• 0
A35K

Strange SSTO glitch/bug?

Question

So I am playing carreer mode in 1.5.1 with the following mods:

-Interstellar Extended

-Kopernicus with OPM

-KAS

-KW Rocketry

I built an SSTO plane a few weeks ago, made of stock parts only  (mk2 fuselage with 2 whiplashes and 2 aerospikes). It worked great and I have used it multiple times, then today I went to launch it (in the same configuration, no additional payload) and it couldn't even break the sound barrier. I tried a few other previously successful SSTOs and the same thing: All except the smallest of spaceplanes get 'stuck' at about 300m/s. I relaunched KSP and they all worked again, but today I was playing and the same thing happened. Its annoying because I have to restart KSP multiple times to get rid of it. I am always following the same ascent profile and everything is the same. I have no idea what could be causing this, as I have definitely not updated KSP or any of my mods before this problem started. I know Interstellar adds certain mechanics to the stock jets but as I said these planes worked perfecty just yesterday. Any ideas or something similar happening to anyone?

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Thanks for the help, but it turns out it was my fault after all. I was editing some small things on the payload and in putting the cargo bay back, it attached to a node on the payload rather than the rest of the fuselage, but it looked normal unless you really zoomed in on the joint (which is why I only caught it by accident). Apparently that little uneven bump on the fuselage is enough to completely ruin my Mk2 SSTOs. The reason why it worked when I restarted was because it reverted back to the craft file with the proper cargo bay attachment.

Edited by A35K

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.