_Zee

[KSP 1.7.0] - Probes Before Crew [PBC] Version 2.7

Recommended Posts

4 hours ago, brispo said:

Hoping to get a little guidance as I'm having trouble with the "Explore the Mun (Probe)" and "Explore Minmus (probe)" missions.

I built a probe, flew to minmus, landed, recovered a little science, and flew back and splashed down on Kerbin, but the contract didn't complete. It appears that I got the rewards, but the contract is still showing up as active. Any ideas?

You need to check your ship type. Make sure it's the right type for the contract to complete. Was it labelled as a probe.

Share this post


Link to post
Share on other sites

Yep it was definitely a probe. I flew the mission twice last night to be sure. I got credit for the Minmus flyby, but the Situation: Landed: under "Land on Minmus" wasn't showing as completed, even though I was sitting on it.

I can take a screenshot of the mission window while I'm landed on Minmus if that would help?

It didn't recognize when I landed back on Kerbin either. I seems that the flyby of Minmus registered, but both landings didnt (minmus and Kerbin return.)

Share this post


Link to post
Share on other sites

So I tried another mission today, with a brand new build of a probe, and this time the mun landing registered, but when I splashed down on Kerbin, the splashdown didn't register. But what I did was, before clicking "recover vessel", I went out to the tracking station, then went back to my splashed down craft. As soon as I did that, the mission registered as completed.

Seems like it's some sort of bug for the dev to look into when they have time. Amazing mod btw I love it!

Share this post


Link to post
Share on other sites
11 hours ago, brispo said:

So I tried another mission today, with a brand new build of a probe, and this time the mun landing registered, but when I splashed down on Kerbin, the splashdown didn't register. But what I did was, before clicking "recover vessel", I went out to the tracking station, then went back to my splashed down craft. As soon as I did that, the mission registered as completed.

Seems like it's some sort of bug for the dev to look into when they have time. Amazing mod btw I love it!

What game version was this? PBC relies on what the stock contract system tells it, so there's not much it can do about recognizing whether or not something is landed. It could be a bug in the stock contract system or contract configurator though.
1.7.2.02556 fixed several bugs that were introduced in 1.7.1 though so if you experienced the problem in 1.7.1 or 1.7.2.02555 then I'd recommend checking if it's still a problem on 1.7.2.02556.

Share this post


Link to post
Share on other sites
1 minute ago, Jognt said:

What game version was this? PBC relies on what the stock contract system tells it, so there's not much it can do about recognizing whether or not something is landed. It could be a bug in the stock contract system or contract configurator though.
1.7.2.02556 fixed several bugs that were introduced in 1.7.1 though so if you experienced the problem in 1.7.1 or 1.7.2.02555 then I'd recommend checking if it's still a problem on 1.7.2.02556.

Interesting suggestion. I thought I had the latest version since I just got back into the game maybe two weeks ago, but I'm on version 1.7.1.2539. I'll update to the latest version right now and see if that helps. I'll report back with me findings.

Share this post


Link to post
Share on other sites
Posted (edited)

@_Zee 
Hey, what do you have in mind about the mods,
designed for making home planet trucks before any space exploration? (OSUV, Grounded, etc)

They usually place their parts in the start node, and if you will leave that,
there are enormous amount of science in the KSC biomes available right after start of the game from the grounded manned vehicles. 
Does there a way to nerf only the KSC biomes manned science?

 

Edited by flart

Share this post


Link to post
Share on other sites

@brispo what Jognt said is more or less the case. Its a stock bug, that gets translated into contract configurator, that then gets translated into PBC contracts. There's nothing we as modders can do about it. Last I heard Nightingale was working on a fix but not sure if they've found one yet.

@flart I'm going to try and do my best to make sense of what you're asking... You want to know if I've accounted for the mods that add ground rovers to the beginning of the start nodes, since they can farm a ton of science from the local KSP biomes? If so, any mod that is listed in the SUPPORTED MODS list will NOT have any thing like this near the start node. My entire design definitely intends for you to earn your science trying to get into space, not dwelling on the ground. But if it's not supported yet, then it goes wherever the original author wants it. This is also why you should go VOTE in the PBC Poll if you haven't yet!! :P

Share this post


Link to post
Share on other sites
Posted (edited)

Hey does anyone know if the contract pack for PBC would work with JNSQ? Since as far as I'm aware all of the planet names remain the same, it's just that they are all natively upscaled by 2.7x. If so I'm presuming it would not however work with the newly added bodies by JNSQ as they are not in the stock game?

Edited by CoriW

Share this post


Link to post
Share on other sites
Just now, CoriW said:

Hey does anyone know if the contract pack for PBC would work with JNSQ? Since as far as I'm aware all of the planet names remain the same, it's just that they are all natively upscaled by 2.7x. If so I'm presuming it would not however work with the newly added bodies by JNSQ as they are not in the stock game?

I use Sigma Dimensions on 4x scale and PBC works fine.

Share this post


Link to post
Share on other sites
Just now, lordcirth said:

I use Sigma Dimensions on 4x scale and PBC works fine.

I will note that JNSQ does not use any rescaling mods such as Sigma Dimensions, hence why I said "Natively" upscaled. JNSQ was designed and built at 2.7x, no scaling necessary. Though since it does work in your rescaled game then that should mean the scale of the system won't have any issues, so it's just the naming scheme as I suspected. Thanks!

Share this post


Link to post
Share on other sites

Trying to use this on 1.7.3 but looks like it halves my FPS every time I install it. No errors on log.

Would it be a mod conflict or version?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.