• 0
ItCameFromDuna

Some joystick axis not detected, others are.

Question

I'm using a custom joystick made with an Arduino Leonardo. But wait! I'm pretty sure it's not causing the issue! When I open up windows game controller settings, I can see the troublesome axis (throttle) is being detected. I have also confirmed that it works in other games. However, it is not being detected within KSP. I have tried binding throttle to pitch, and it works just fine. When I try to bind throttle to the actual throttle, the game simply doesn't detect it. I've tried editing settings.cfg to the axis (axis 7) that the throttle shows up as in other programs, but it still doesn't work. Any help would be much appreciated. Thanks!

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Not really a solution, but may help diagnosis and could serve as a band-aid.

I have to use this mod because they borked native joystick support completely in Linux with the 1.4 update.  AFAIK it's still not fixed. (I don't know about 1.6 yet on that.)

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

misery loves company,, my Logitech attack3 is detected by windows but I can only assign the button's to a item. I cannot add X,Y,Z, axis or axis of throttle control either, to the any assignment thru KSP 1.6.1 interface settings(I didn't try any mods or manual config's to assist this device).

 windows 10, joystick works fine with other games, thus I cannot use it to fly. to be clear I hadn't tried using it since like 1.3.1 and just thought I would give it a try after reading this.

FYI

Jammer-TD

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now