• 0
Sign in to follow this  
Turbo Ben

Updated to 1.6 - ships gone.

Question

I've been playing 1.5.1 for a while and had a few ships in orbit and landed on Minmus, and a satellite around Ike. I downloaded 1.6 and copied my save game and mods across, and all but a sattelite around Minmus have vanished, including many of my Kerbals.

I noticed that the poodle and spark engines were not available in the VAB. When I had a look at the tech tree, they were there and I had to purchase them again. Could this be the cause of my missing ships, or is it more likely a non compatible mod (I have a couple including KAS and Interstellar extended)? If the former, is there a file I can modify to mark the poodle/spark as purchased so it's available from my save game?

Thankfully I still have the copy of 1.5.1 so it's not a complete loss, but I would like to move to 1.6.

Thanks

 

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

If you didn't get a warning before loading the save game (missing parts because of a incompatible mod), the vessel should be still there.

It sounds like you have two separate copies of KSP so there is a chance that the satellite is just not displayed in the tracking station. Check the filter at the top to be sure, all vessel types are active.

Indeed, some parts like the poodle got replaced by a new version but to keep compatibility with old save files, the old parts are not deleted or updated but moved and marked as deprecated, so they are still available for vessels which uses the old part. 

For this reason, the new part got new internal names which causes them to be locked/not purchased in the techtree. I guess, it is possible that you can port the save game to 1.6, load it, close the game again and then edit the save game to unlock these parts again but I cannot test it right now so I cannot tell you how it works.

Share this post


Link to post
Share on other sites
  • 0

Thanks for the reply.

That makes sense. I tried loading up one of the missing ships in the VAB and the old style poodle was still there.

They're definately gone, not just hidden. I have checked the tracking station tabs and nothing. Besides, I had 2 satellites, now I only have 1. My mining base, fuel transport (both landed) and a very large orbital fuel depot have just vanished, along with a satellite left around Ike.

I didn't get any warnings when loading the save game. The only warning I got was on the initial loading screen saying a mod called "scale" was not compatible. I assumed that was tweekscale, but it seems to work fine in the VAB. I did forget to update kopernicus to 1.6, but fixed that before loading up the save.

Share this post


Link to post
Share on other sites
  • 0
35 minutes ago, Turbo Ben said:

OK, I'm new to dropbox, so bear with me if this doesn't work... 

https://www.dropbox.com/sh/i0rxpj76y19u4bf/AAAP9EM3bsZn1sKfn7GyF7uaa?dl=0

Thanks

Works fine :)

I found the issue in your savegame: for same reason (probably a mod compatibility issue), every astroids in your game crashed into Kerbin and created a null reference exception. Since an astroid is treated like a vessel, the game didn't load anything else after the first astroid. So, I removed every astroid from your savegame and all the missing vessels reappeared in the game :) (Don't worry, astroids will respawn but the new ones should work properly. If not, you may have to wait for all the mods beeing updated to 1.6)

Here is your fixed savegame: https://www.dropbox.com/s/w3zxcbgw88gteyi/Bens Career.zip?dl=0

 

Share this post


Link to post
Share on other sites
  • 0

Thanks for the attempt, but I can't load the save. It says it's not compatible with the version of KSP I have and won't load at all :(

Had quite a few warnings from MM on start-up, including one just named "scale". I'll update as many of the mods as I can and see if that helps.

Thanks again for taking the time to help.

Share this post


Link to post
Share on other sites
  • 0
10 minutes ago, Turbo Ben said:

Thanks for the attempt, but I can't load the save. It says it's not compatible with the version of KSP I have and won't load at all :(

That's strange...I did the changes in the 1.5.1 savegame without loading it into 1.6.1 so the version of the savegame didn't change.

Well, you can try something similar without editing the file: load the game in your 1.5.1 game, go to the tracking station and 'untrack' every astroid. Should work like removing any of your vessel from the game with a button in the lower left corner.
Then close the game, copy the savegame to your 1.6 install and try again.

Share this post


Link to post
Share on other sites
  • 0

I'll give it a try shortly. I'm just reading the tweekscale forum and it looks like that might be the cause of my woes. Some changes in 1.6 mean tweekscale doesn't work and many of my ships have scaled parts. I may be able to recover my Minmus station as I don't think I scaled any of those parts, but there is a ship docked that does.

Share this post


Link to post
Share on other sites
  • 0

Yep, that looks like all of them.

Interestingly, I just tried a save where I undocked my nuclear transport stage from the fuel station and terminated it. Everything else came back! I did mess with the unknown objects a bit, but most of them are in the "worlds beyond" systems, and I couldn't be bothered tracking them all down.

Even more interestingly, I've just tried the original save and now it seems to be working. Maybe there's been a MM patch introduced to fix the problem?

Thanks again for all the help.

 

Share this post


Link to post
Share on other sites
  • 0

No clue. Maybe just a glitch the first time I tried or maybe there's been a fix applied in the last few days since I first tried.

I'm just happy to have my fuel depot back, that thing took 4 launches, 3 hours of orbital construction, an encounter with the Kraken, 4 more launches, 3 more hours construction and a very delicate transfer to MInmus. I'm hoping to take it to Jool with me when I go, but I've got a feeling the Kraken might have other ideas! By the time I've got a new shuttle, mining base and the engine stage attached it's going to be massive!

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this