Recommended Posts

I have a problem...

I tired everything but I can't solve it.The particles don't stay on their place.I want a normal engine plume.

nOggLxI.png

[noparse]

//Ren1
//d_s___3
PART
{
	name = ds3_engine_Ren1
	module = Part
	author = d_s___3
	mesh = Ren1-M
	
	scale = 1
	rescaleFactor = 1
	node_stack_top = 0.0, 0.1, 0.0, 0.0, 1.0, 0.0, 1
	node_stack_bottom = 0.0, -0.5, 0.0, 0.0, -1.0, 0.0, 1
	
	fx_smokeTrail_light = 0.0, -1.6, 0.0, 0.0, 1.0, 0.0, running
						
	TechRequired = nuclearPropulsion
	entryCost = 450000
	cost = 9000
	category = Engine
	subcategory = 0
	
	title = Ren1
	manufacturer = #autoLOC_501627 //#autoLOC_501627 = Jebediah Kerman's Junkyard and Spacecraft Parts Co
	description = --MOD-- Ein tolles Triebwerk!
	attachRules = 1,0,1,0,0
	mass = 3
	
	heatConductivity = 0.06 // half default
	skinInternalConductionMult = 4.0
	emissiveConstant = 0.85 // engine nozzles are good at radiating, NTRs even better
	dragModelType = default
	maximum_drag = 0.2
	minimum_drag = 0.2
	angularDrag = 2
	crashTolerance = 9
	maxTemp = 2500 // = 4000
	bulkheadProfiles = size1
	radiatorMax = 0.15 //Kühler
	tags = #autoLOC_500438 //#autoLOC_500438 = active atom efficient engine inter liquid (nerv nuclear nuke orbit propuls radio reactor vacuum
	
    MODULE
    {
       name = ModuleEnginesFX
       engineID = ds3_exhaust_Ren1
	   thrustVectorTransformName = particleFX
       runningEffectName = running_closed
	   exhaustDamage = True
       ignitionThreshold = 0.1
       minThrust = 0
       maxThrust = 90
       heatProduction = 150
       fxOffset = 0, 0, 1.5
     PROPELLANT
     {
       name = LiquidFuel
       ratio = 0.9
       DrawGauge = True 
     }
	 atmosphereCurve
     {
	   key = 0 800
	   key = 1 185
	   key = 2 0.001
     }
    }
	MODULE
	{
		name = ModuleSurfaceFX
		thrustProviderModuleIndex = 0
		fxMax = 0.7
		maxDistance = 50
		falloff = 2.5
		thrustTransformName = thrustTransform
	}

   EFFECTS
    {
      running_closed
	  {
	    MODEL_MULTI_PARTICLE
	    {
	  	    modelName = Exhaust2/FX/Ren1_Exhaust
			transformName = thrustTransform
			emission = 0.0 0.0
			emission = 0.1 0.5
			emission = 1.0 1.0
			speed = 0.0 0.8
			speed = 1.0 1.0
	    }    				
	  }

}

 

 

 

 

Edited by d_s___3

Share this post


Link to post
Share on other sites

Hi to get the  exhaust plume to stick to the engine  you need to  uncheck  simulate in world space, doing so forces  the FX  to be simulated in local space and  to stay attached to the nozzle .   To test in unity  create a simple particle effect  with simulate in worldspace checked  and move it around the screen , now do the same with the value unchecked and notice the difference in behavior

Share this post


Link to post
Share on other sites

I noticed your trouble with thrust. Unless you already figured it out, the way to fix it is to set your config to use a GameObject within the engine part, not the name of the particle's GameObject.

  • You have thrustVectorTransformName = particleFX
  • You should have thrustVectorTransformName = thrustTransform

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now