Thomas P.

[1.6.1-2 + Backports] Kopernicus & KittopiaTech

Recommended Posts

26 minutes ago, chubbyassasin123 said:

I tried to use DDS images but it would just make my planets a solid black color. I can try again when I get home though.

How are you converting the textures to dds?

Share this post


Link to post
Share on other sites
8 hours ago, Galileo said:

How are you converting the textures to dds?

I was using SpaceEngine so I have the option to choose what format I want. This is the first mod I have ever made for Kerbal.

Edit: Some areas of the planets are lit, even though not facing the sun at all, but not the entire planet is lit. Also some spots are a lot brighter than others. I will post a screenshot in about 15 minutes.

Screenshot 1 (Planet not being lit on the correct parts) I noticed that when I land on the back side of a planet, even though the texture is lit up it is night on the surface. (no bright blinding lights here, normal textures)

Screenshot 2: Landed on surface. (Not a texture problem as textures can be seen fine at night and in shadows)

Edited by chubbyassasin123

Share this post


Link to post
Share on other sites
3 hours ago, chubbyassasin123 said:

Edit: Some areas of the planets are lit, even though not facing the sun at all, but not the entire planet is lit.

I know of somebody else who was having some weird problems like that, though I don't really recall all the details.  I loaded up his mod and got the same problems.  I resaved his images in the format/compression that I typically use and it started working for me.  I'm not sure if he ever did get it working right on his end.

Share this post


Link to post
Share on other sites

It seems that the latest version of Kopernicus has broken a stock function to do with biomes (I don't really get all the details!), and is causing problems in quite a few mods, including SCANSat and VOID, that I've noticed so far (

).

Here's a log file.

Share this post


Link to post
Share on other sites
20 minutes ago, cyberpunkdreams said:

It seems that the latest version of Kopernicus has broken a stock function to do with biomes (I don't really get all the details!), and is causing problems in quite a few mods, including SCANSat and VOID, that I've noticed so far (

).

Here's a log file.

This issue has been brought up a couple of time already and the dev knows about it. It will be fixed in a later update. 

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, Galileo said:

This issue has been brought up a couple of time already and the dev knows about it. It will be fixed in a later update. 

Okay, thanks. I did try looking through the last few pages of this thread but couldn't find anything to do with it.

Share this post


Link to post
Share on other sites

Aside from Galileo (doesn't add a separate star), does anybody know of any planet packs that work with the current version of Kopernicus? I've been having some trouble tracking any down. I'd like another star system to travel to.  Everything I try just breaks under the current Kopernicus version.

Share this post


Link to post
Share on other sites

My 2 kerbals shall be stranded on Minmus until the mod updates.

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, Saint Anthony said:

Aside from Galileo (doesn't add a separate star), does anybody know of any planet packs that work with the current version of Kopernicus? I've been having some trouble tracking any down. I'd like another star system to travel to.  Everything I try just breaks under the current Kopernicus version.

Gameslinx’s Planet Overhaul works with it, but I don’t know of any others.

  • Like 1

Share this post


Link to post
Share on other sites

https://nofile.io/f/MZAWEOxsSM1/output_log.txt
While in orbit around minmus picking a landing target does not display coordinates and only focuses on minmus. As far as I can tell, minmus is the only planet/moon affected. Disabling OPM/Kopernicus fixes this but its one of my favorite mods and I'd rather not play without it if possible. Below are two screenshots, one showing the mod working without OPM and Kopernicus, the other showing that you cant see or select coordinates with OPM and Kopernicus installed. https://nofile.io/f/MZAWEOxsSM1/output_log.txt I've noticed you've been messing around with minmus in your updates and I believe one of them may have caused this.
With OPM and Kopernicus36637625-24abe2c8-19ae-11e8-9692-2e780e2
Without OPM and Kopernicus
36637621-1a7cb084-19ae-11e8-9244-2016d76

Edited by GhastlyKerbal

Share this post


Link to post
Share on other sites

I released Kopernicus 1.3.1-7, it should fix the biome map issue, the issue with scatter materials and the issue of orbit lines fading out incorrectly. Sadly, for the last fix I had to revert the code I wrote to remove the flickering orbit lines, so that issue is back now.

Edited by Thomas P.
  • Like 2

Share this post


Link to post
Share on other sites
On 25/02/2018 at 6:04 PM, Thomas P. said:

Sadly, for the last fix I had to revert the code I wrote to remove the flickering orbit lines, so that issue is back now.

hum, I may have an idea for that since I had to deal with a similar problem recently. I ll have a look :)

  • Like 2

Share this post


Link to post
Share on other sites

Can anyone could explain me how to get the right coordinates for "flattenArea"?

This is a code I found somewhere, but i cannot figure how to get the right "position" values.

FlattenArea
	{
	enabled = true
	outerRadius = 9350
	innerRadius = 8200
	position = 16294.55, -261408.8, 149497.9
	flattenTo = 670
	DEBUG_showColors = false
	smoothStart = 0
	smoothEnd = 0
	}			

The radius I think should be in meters, "flattenTo" I'm not completely sure (the height of flat terrain?), but what is position? Is not in the classic coodinates value.

Thank you for any help.

Share this post


Link to post
Share on other sites
9 hours ago, HansonKerman said:

Is there a download for 1.3.1-3?

Yes. In the same place you will find the latest download. Just scroll down on the releases page.

Edited by Galileo

Share this post


Link to post
Share on other sites
30 minutes ago, HansonKerman said:

Is there a download for 1.3.1-3?

Look at first page of this thread and click on the GitHub download link. Next, you are on latest GitHub release page, so click on the second "Kopernicus" in "Kopernicus/Kopernicus" that there is on top of page, then click on "67 releases" and scroll down to find 1.3.1-3 release.

Well, now you know how to find all release on GitHub.:cool:

Edited by Vandest
  • Like 1

Share this post


Link to post
Share on other sites

I installed this and the Galileo Planet Pack per the instructions after moving all other mods out of the Gamedata folder. It worked. Then I moved my mods back and got an error. The log indicated that it failed to load minmus, Here is the error in the log:

[LOG 19:09:00]: [Kopernicus]: Configuration.Loader: Failed to load Body: Minmus
[LOG 19:09:02]: [Kopernicus] RuntimeUtility Started
[LOG 19:09:02]: StarLightSwitcher.Awake(): Begin
[LOG 19:09:44]: Injector.OnDestroy(): Complete

It seems some other mod I'm trying to use is messing with this, any ideas or is it a one at a time re-add until I find which one errors? I'm debating just not using Kopernicus and the GPP for now.

Share this post


Link to post
Share on other sites
42 minutes ago, Ygdrasill said:

I installed this and the Galileo Planet Pack per the instructions after moving all other mods out of the Gamedata folder. It worked. Then I moved my mods back and got an error. The log indicated that it failed to load minmus, Here is the error in the log:

[LOG 19:09:00]: [Kopernicus]: Configuration.Loader: Failed to load Body: Minmus
[LOG 19:09:02]: [Kopernicus] RuntimeUtility Started
[LOG 19:09:02]: StarLightSwitcher.Awake(): Begin
[LOG 19:09:44]: Injector.OnDestroy(): Complete

It seems some other mod I'm trying to use is messing with this, any ideas or is it a one at a time re-add until I find which one errors? I'm debating just not using Kopernicus and the GPP for now.

you are going to need to post more info for me to look at.

You can find what I need by following the instructions here. 
https://forum.kerbalspaceprogram.com/index.php?/topic/140580-131-kopernicus-release-6-feb-14/&do=findComment&comment=2793409

 

Share this post


Link to post
Share on other sites
2 hours ago, RussWong said:

hi,i have a problem in game will stuck in loading,the game report of this problem,what haappen?can you hlep me plz

Album https://imgur.com/a/7rPsl will appear when post is submitted

 

We cannot help you until you provide us the information listed here.

https://forum.kerbalspaceprogram.com/index.php?/topic/140580-131-kopernicus-release-6-feb-14/&do=findComment&comment=2793409

 

Edited by Galileo

Share this post


Link to post
Share on other sites
12 hours ago, Vandest said:

Look at first page of this thread and click on the GitHub download link. Next, you are on latest GitHub release page, so click on the second "Kopernicus" in "Kopernicus/Kopernicus" that there is on top of page, then click on "67 releases" and scroll down to find 1.3.1-3 release.

Well, now you know how to find all release on GitHub.:cool:

Never mind, already found it. But thanks!

  • Like 1

Share this post


Link to post
Share on other sites

[Maybe resolved] No terrain scatter colliders? How to enable?

Loaded up the current Stock Visual Terrain. Tree and boulder colliders don't appear to work, but I noticed two different settings for scatter colliders and wondered which one was the correct one.

In Kopernicus 1.3.1-3 and previous, this was used:

LandControl
{
	scatters
	{
		Scatter
		{
			collide = True
		}
	}
}

The current SVT, released two days ago, does this:

LandControl
{
	scatters
	{
		Scatter
		{
			Components
			{
				ScatterColliders 
				{ 
				}
			}
		}
	}
}

No settings, just an empty configuration section named "ScatterColliders."

Neither of these appear to work in Kopernicus 1.3.1-7. Scatter objects, like the trees west of KSC, are immaterial.

[Update] Combining the two settings seems to work:

LandControl
{
	scatters
	{
		Scatter
		{
			collide = True
			Components
			{
				ScatterColliders 
				{ 
				}
			}
		}
	}
}

I'll take this to the SVT thread, then.

Edited by Gordon Fecyk
Testing results

Share this post


Link to post
Share on other sites
15 minutes ago, Gordon Fecyk said:

[Maybe resolved] No terrain scatter colliders? How to enable?

Loaded up the current Stock Visual Terrain. Tree and boulder colliders don't appear to work, but I noticed two different settings for scatter colliders and wondered which one was the correct one.

In Kopernicus 1.3.1-3 and previous, this was used:


LandControl
{
	scatters
	{
		Scatter
		{
			collide = True
		}
	}
}

The current SVT, released two days ago, does this:


LandControl
{
	scatters
	{
		Scatter
		{
			Components
			{
				ScatterColliders 
				{ 
				}
			}
		}
	}
}

No settings, just an empty configuration section named "ScatterColliders."

Neither of these appear to work in Kopernicus 1.3.1-7. Scatter objects, like the trees west of KSC, are immaterial.

[Update] Combining the two settings seems to work:


LandControl
{
	scatters
	{
		Scatter
		{
			collide = True
			Components
			{
				ScatterColliders 
				{ 
				}
			}
		}
	}
}

I'll take this to the SVT thread, then.

Works fine in 1.3.1-7.. tested thoroughly before releasing.

you don’t need to have collide = true as Kopernicus doesn’t even use that any longer. I was just too lazy to remove it from my cfgs.

Edited by Galileo

Share this post


Link to post
Share on other sites
1 minute ago, Galileo said:

Works fine in 1.3.1-7.. tested thoroughly before releasing.

It does appear the colliders are set to a default of "False" in the SVT download for 2.1.2. From Kerbin.cfg as of right now:

scatters
{
	Scatter
	{
		collide = False
	}
}

...and from EnableColliders.cfg as of right now:

@scatters
{
	@Scatter:HAS[~name[Grass00]]
	{
		%Components
		{
			%ScatterColliders 
			{ 
			}
		}
	}
}

This produces a result of collide = False with an empty ScatterColliders key in the Module Manager config cache. Adding collide = True to EnableColliders.cfg's Scatter key seems to fix it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now