Thomas P.

[1.6.1-2 + Backports] Kopernicus & KittopiaTech

Recommended Posts

I know you are updating now to 1.4.3... could you please also remove the strict handling of the max KSP version? Your mod is the only one I have installed that does not work with a higher patch version. It's ok for me to get a warning like "not tested with"... but shutting down the system because of this? That's to extreme I think.

Share this post


Link to post
Share on other sites
20 minutes ago, Rudolf Meier said:

I know you are updating now to 1.4.3... could you please also remove the strict handling of the max KSP version? Your mod is the only one I have installed that does not work with a higher patch version. It's ok for me to get a warning like "not tested with"... but shutting down the system because of this? That's to extreme I think.

I think it was put in place that way for a reason. We've had plenty of warning that 1.4.3 was coming, and modded games are always at risk of breaking when new versions of the main game release. If you want to back up to the previous KSP, you can do that within Steam (I think?) -- and it's always a good idea to make a copy/backup of the steam directory just for this kind of occurrence.

I'm in the same boat as you, though -- I have a game going that probably will have no solar panel functionality until the1.4.3 version is released. :) 

Edited by Beetlecat

Share this post


Link to post
Share on other sites
2 hours ago, Beetlecat said:

I think it was put in place that way for a reason. We've had plenty of warning that 1.4.3 was coming, and modded games are always at risk of breaking when new versions of the main game release. If you want to back up to the previous KSP, you can do that within Steam (I think?) -- and it's always a good idea to make a copy/backup of the steam directory just for this kind of occurrence.

I'm in the same boat as you, though -- I have a game going that probably will have no solar panel functionality until the1.4.3 version is released. :) 

Can confirm that you can go back to previous versions of KSP in steam if need be. 

I mean if you don't want to you could mess with the version file, which may make it work, but I have no idea. More likely it would break everything.

Edited by Mark Kerbin

Share this post


Link to post
Share on other sites
5 minutes ago, Mark Kerbin said:

Can confirm that you can go back to previous versions of KSP in steam if need be. 

I mean if you don't want to you could mess with the version file, which may make it work, but I have no idea. More likely it would break everything.

no, unfortunatelly the version file editing doesn't work for Kopernicus (the only mod I've installed that doesn't allow this) and... just because of a patch level, I don't think there is a big chance that it wont work after an update

at least I'm pretty confident and for example marking Infernal Robotics as good to go for every 1.4.x ... I didn't see any problems during 1.4 to 1.4.3 updates... could be sometimes... but... every update is always a risk

Share this post


Link to post
Share on other sites

Yep. Looks like I will have to uninstall it for the time being. The Steam going 1.4.3 then me reverting seems to have broken it.

Share this post


Link to post
Share on other sites
17 hours ago, Thomas P. said:

InnerRadiusMultiplier
{
	key = <angle (degrees)> <multiplier> <in-tangent (optional)> <out-tangent (optional)>
   	// add as many key values as you need
}

Same applies for OuterRadiusMultiplier

Thank you good sir. Will be playing around with that today. 

Share this post


Link to post
Share on other sites

Kopernicus 1.4.3-1 is released on Github!

Changelog:

- Removed the sun occlusion code again, it will be rereleased in KopernicusExpansion
- Fixed the NullReferenceException spam with terrain scatters
- Updated ModularFlightIntegrator
- Fixed the rings rendering over EVE clouds
- Bodies that are orbiting the main menu body are no longer shown in the main menu
- Updated to KSP 1.4.3

I have also started to do backports of Kopernicus again, this time for KSP 1.3.1. Kopernicus 1.3.1-8 is basically just 1.4.3-1 compiled for 1.3.1.

Link to 1.4.3-1: https://github.com/Kopernicus/Kopernicus/releases/tag/release-1.4.3-1

Link to 1.3.1-8: https://github.com/Kopernicus/Kopernicus-Backport/releases/tag/backport-1.3.1-8

  • Like 14

Share this post


Link to post
Share on other sites
1 hour ago, Thomas P. said:

Kopernicus 1.4.3-1 is released on Github!

 

So great! Thank you :) 

Share this post


Link to post
Share on other sites

Thank you for the update! Now with all the new assets released lately and KK updated, it's time to play in my 2.5x scaled KSP!

01kcjEN.png

Share this post


Link to post
Share on other sites

Whoops, how badly did I bork my game if I kept playing with kopernicus version locked? I have no active missions outside off of kerbin, so never much went to the tracking station, etc.

I was going to simply test that solar panels work in my sandbox game... ;)

Share this post


Link to post
Share on other sites
38 minutes ago, Beetlecat said:

Whoops, how badly did I bork my game if I kept playing with kopernicus version locked? I have no active missions outside off of kerbin, so never much went to the tracking station, etc.

I was going to simply test that solar panels work in my sandbox game... ;)

Very Very Badly. (Maybe)

Those panels may be broken. Updating may fix. You probably were fine tho.

Share this post


Link to post
Share on other sites
1 minute ago, Mark Kerbin said:

Very Very Badly. (Maybe)

Those panels may be broken. Updating may fix. You probably were fine tho.

well, solar panels seem fine -- though now my game has lost about ~25 FPS. That's curious. Not looking forward to this round of troubleshooting :)

Share this post


Link to post
Share on other sites
16 minutes ago, Beetlecat said:

well, solar panels seem fine -- though now my game has lost about ~25 FPS. That's curious. Not looking forward to this round of troubleshooting :)

Well thats a whole new sort of screwed. Had  a similar problem a while ago.

Delete all Kopernious folders and anything using it, remove all MM stuff. Then move in fresh copies . worked for me.

 

BTW do you have SVT installed? that causes mayhem sometimes with updates.

Edited by Mark Kerbin

Share this post


Link to post
Share on other sites
31 minutes ago, Mark Kerbin said:

Well thats a whole new sort of screwed. Had  a similar problem a while ago.

Delete all Kopernious folders and anything using it, remove all MM stuff. Then move in fresh copies . worked for me.

 

BTW do you have SVT installed? that causes mayhem sometimes with updates.

Yeah -- SVT + Eve + Scatterer is the main graphical setup. My current game got wildly cluttered anyway, so I think it may be a good point to reset. I'll try some of the cache clearing first.

 

Share this post


Link to post
Share on other sites
1 hour ago, Beetlecat said:

well, solar panels seem fine -- though now my game has lost about ~25 FPS. That's curious. Not looking forward to this round of troubleshooting :)

I've got the same thing with FPS.

Share this post


Link to post
Share on other sites
3 hours ago, damonvv said:

Thank you for the update! Now with all the new assets released lately and KK updated, it's time to play in my 2.5x scaled KSP!

01kcjEN.png

How are you getting sigmadimensions and rescale running? They were (sorta) working under Kopernicus 1.4.2. They don't work at all under 1.4.3.

If you have a solution please share  :)

Share this post


Link to post
Share on other sites
2 minutes ago, Tyko said:

How are you getting sigmadimensions and rescale running? They were (sorta) working under Kopernicus 1.4.2. They don't work at all under 1.4.3.

If you have a solution please share  :)

I just installed them and they worked? I don't know haha

Share this post


Link to post
Share on other sites
49 minutes ago, damonvv said:

I just installed them and they worked? I don't know haha

you're using the 1.3.1 variants or downloaded some dev copy? thanks again

Share this post


Link to post
Share on other sites

No SVT here, but EVE+SVE+OPM and also lower fps.

I made a copy of my 1.4.2 install for 1.4.3, synced it with Steam download and updated mods so far:

  • BDAnimationModules
  • DockRotate
  • Drop-in Replacement Textures
  • Kopernicus
  • Trajectories

Share this post


Link to post
Share on other sites
15 minutes ago, Tyko said:

you're using the 1.3.1 variants or downloaded some dev copy? thanks again

I used the latest on all the githubs I could find really, not sure which versions they all are as most of the .versions weren't even updated

Share this post


Link to post
Share on other sites

Looks like new Kopernicus don't like old "AtmosphereFromGround". Using StockVisualEnhancements caused kopernicus issue (with Eve error loading), but there is only "AtmosphereFromGround" kopernicus modification. There is some new syntax in 1.4.3?

Share this post


Link to post
Share on other sites

Is there another way to Fix the NullReferenceException spam with terrain scatters, instead of updating to Kopernicus 1.4.3-1 which it wont let me do cause of KSP 1.4.2?

Solved!

 

Edited by Euer_Hochwuergen

Share this post


Link to post
Share on other sites

I AM HAVING AN ISSUE WITH SOLAR PANELS plz fix many people have this problem with that too

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now