Thomas P.

[1.7.3-1 + Backports] Kopernicus & KittopiaTech

Recommended Posts

Public Service Announcement:

With the delisting of ModuleManager from CKAN at Sarbians request, I am hereby dropping all support for CKAN installations, simply because Kopernicus isn't installable through it anymore. Even if you manage to do it, I wont support it.
This has nothing to do with CKAN's policies, in fact I gained huge respect for @politas for submitting a PR to change it and acting like it would've been merged already (which could kick him out of the project). It is simply a matter of available options.

Share this post


Link to post
Share on other sites

At last, I've started the highly-requested video series on Kopernicus that will cover everything I know. Here's the first video.

Here's the thread I've made where I'll list the videos.

 

Edited by The White Guardian

Share this post


Link to post
Share on other sites
1 hour ago, Thomas P. said:

Public Service Announcement:

With the delisting of ModuleManager from CKAN at Sarbians request, I am hereby dropping all support for CKAN installations, simply because Kopernicus isn't installable through it anymore. Even if you manage to do it, I wont support it.
This has nothing to do with CKAN's policies, in fact I gained huge respect for @politas for submitting a PR to change it and acting like it would've been merged already (which could kick him out of the project). It is simply a matter of available options.

In addition, installing Kopernicus manually is rather easy. KSP's rocket science is harder to understand.

Share this post


Link to post
Share on other sites
6 minutes ago, electricpants said:

Why is the Github download still for 1.1.2?

Why? :(

Because 1.1.2 is the Kopernicus version. 1.1.3 is the KSP version 1.1.2 is compatible with

Yes I know the versioning evolved a bit unfortunately :D

Share this post


Link to post
Share on other sites
33 minutes ago, Thomas P. said:

Because 1.1.2 is the Kopernicus version. 1.1.3 is the KSP version 1.1.2 is compatible with

Yes I know the versioning evolved a bit unfortunately :D

Then perhaps you should skip a few versions and jump to 2.0 or something like that to avoid confusion like this, because, to quote Engie from TF2 here:

"Son, this here is just gonna keep happening, and happening, and happening."

Everytime Squad releases an update it'll be the same flood of questions all over again. While it doens't bother me, I don't know if you'd get tired of it eventually. Plus, I've even seen some people panic a bit because they can't find the version they're looking for and thus can't use all those amazing planet mods out there.

Share this post


Link to post
Share on other sites
Just now, The White Guardian said:

Then perhaps you should skip a few versions and jump to 2.0 or something like that to avoid confusion like this, because, to quote Engie from TF2 here:

"Son, this here is just gonna keep happening, and happening, and happening."

Everytime Squad releases an update it'll be the same flood of questions all over again. While it doens't bother me, I don't know if you'd get tired of it eventually. Plus, I've even seen some people panic a bit because they can't find the version they're looking for and thus can't use all those amazing planet mods out there.

or just rename the release: Kopernicus 1.1.2 for KSP 1.1.3

Share this post


Link to post
Share on other sites
2 minutes ago, Sigma88 said:

KSP 1.1.3

That's what  want! I want a download that actually gives you the version of the mod that works with the newest version of KSP!

Share this post


Link to post
Share on other sites

Or, if desired, outright track the KSP versioning? For example KSP 1.2 releases, then you have Kopernicus 1.2a, 1.2b, then KSP 1.2.1 drops and you have Kopernicus 1.2.1a, 1.2.1b, 1.2.1c, and so on.

Share this post


Link to post
Share on other sites

I wonder if Kopernicus 1.1.3 will be for ksp 1.1.4 or 1.2.0 XD 

btw great video thewhiteguardian

Share this post


Link to post
Share on other sites

I removed Kerbin's Ocean but now if i go below the original sea level, Weird stuff happens, How do i fix this? Also when i try to remove the atmosphere, It removes sucessfully but if i try to start any kind of thruster than everything instantly goes black.

Edited by daniel l.

Share this post


Link to post
Share on other sites
4 hours ago, daniel l. said:

I removed Kerbin's Ocean but now if i go below the original sea level, Weird stuff happens, How do i fix this? Also when i try to remove the atmosphere, It removes sucessfully but if i try to start any kind of thruster than everything instantly goes black.

Please use a little common sense.  How do you expect anyone to help you if you give virtually no details of what you've done or what is going wrong?  You should be posting your planet config(s), logs and screenshots or people will just have to guess how to help you...

Share this post


Link to post
Share on other sites
5 hours ago, daniel l. said:

I removed Kerbin's Ocean but now if i go below the original sea level, Weird stuff happens, How do i fix this? Also when i try to remove the atmosphere, It removes sucessfully but if i try to start any kind of thruster than everything instantly goes black.

even if you remove an ocean from a planet you will still have regions with altitude lower than zero.

that will make the camera do weird stuff even if the ocean isn't visible

you should add a PQS mod to raise the altitude to eliminate those lower than 0 altitudes

 

something like this:

VertexHeightOffset
{
  offset = 2000
  order = 9999999
}

 

keep in mind that the 2000 is a number I put in there at random, basically you need to know which is the lowest point on kerbin and make sure you are offsetting that to be at least zero using the PQS mod

Share this post


Link to post
Share on other sites
25 minutes ago, Sigma88 said:

basically you need to know which is the lowest point on kerbin and make sure you are offsetting that to be at least zero using the PQS mod

This website should help. It has maps of the stock planets, along with indications of the highest or lowest points. On Kerbin, this is -1391m, and Duna is 124.512m.

Strangely, the lowest point on Mun seems to be -248...

Share this post


Link to post
Share on other sites
6 hours ago, daniel l. said:

I removed Kerbin's Ocean but now if i go below the original sea level, Weird stuff happens, How do i fix this? Also when i try to remove the atmosphere, It removes sucessfully but if i try to start any kind of thruster than everything instantly goes black.

exactly what @Sigma88 said, but remember you'll need to adjust the atmosphere too, as the pressure at the KSC will be lower if you raise the terrain higher :wink:

basically the weirdness comes form going below 0m altitude, the only instance where you can go below it is when you have an ocean there otherwise, as you found out, weird things happen. you could also patch the VertexHeitMap instead of adding an offset, instead of the VertexHeightOffset you can use;

				VertexHeightMap
				{
					offset = 0 //Kerbin's is set to -1500 so start at 0 and work up
					order = 10 //Kerbin's actual VertexHeightMap order
					enabled =true
				}

 

Bare in mind, however, that altering the height of Kerbin's terrain will make it so that it's LandControl colors will appear at the wrong height. You'll need to adjust each landClass to set the height

Share this post


Link to post
Share on other sites

is there a way to enable random main menu body for all objects with one config instead of manually adding it to every planet config?

Share this post


Link to post
Share on other sites
12 minutes ago, Kepler68 said:

is there a way to enable random main menu body for all objects with one config instead of manually adding it to every planet config?

yes,

use @Body,* and the patch will get applied to all bodies

Share this post


Link to post
Share on other sites
17 hours ago, daniel l. said:

I removed Kerbin's Ocean but now if i go below the original sea level, Weird stuff happens, How do i fix this? Also when i try to remove the atmosphere, It removes sucessfully but if i try to start any kind of thruster than everything instantly goes black.

Engine ISP is calculated using atmospheric pressure at Kerbin Sea Level. Therefore, removing Kerbin's atmosphere makes all the engines ISP a division by zero.

Share this post


Link to post
Share on other sites

A very minor complaint--I noticed the planet (Kerbin) in the title screen is still missing part of its cloud cover, towards the bottom. Has anyone else running the update encountered this issue?

Cloud_zps6fcctvgh.png

(look at the lower edge of the screen)

Also, exiting out of the game back to the menu makes the whole planet texture blank white (clouds are still there). That's a new issue, I think.

Nothing serious by any means, but if anyone else is running into this it'd be good to know. 

 

 

Share this post


Link to post
Share on other sites

The cloud issue is an EVE thing IIRC - either way it's been there since the newer EVE versions, and def before this Kopernicus update. Doesn't affect in-game rendering. Prob a half-hearted attempt by rbray to bring back main menu clouds after they initially went away with the clouds overhaul - he did lament slightly at ever making it a feature :P  would not recommend bugging him about it

Share this post


Link to post
Share on other sites
1 hour ago, Gaiiden said:

The cloud issue is an EVE thing IIRC - either way it's been there since the newer EVE versions, and def before this Kopernicus update. Doesn't affect in-game rendering. Prob a half-hearted attempt by rbray to bring back main menu clouds after they initially went away with the clouds overhaul - he did lament slightly at ever making it a feature :P  would not recommend bugging him about it

I believe you are correct sir! Thanks, it is interesting to hear how this came about (sort of). I definitely remember it being a thing back in 1.0.5.

At the risk of being annoying, here's a picture of the "missing planet texture" bug too--and like the other bug, it only effects the planet in the main screen (who knew that could be so problematic). It's not related to EVE at least. Please ignore the watermark. Of course, it's just the main menu--everyone looks fine in game, where it really matters!

screenshot45_zpsyjiaun0q.png

Edited by Synthesis

Share this post


Link to post
Share on other sites

I found a conflict with Ferram Aerospace and Kopernikus. The problem is that solar panels do not send energy. They receive sunlight but do not work.

Share this post


Link to post
Share on other sites
16 minutes ago, CSA said:

I found a conflict with Ferram Aerospace and Kopernikus. The problem is that solar panels do not send energy. They receive sunlight but do not work.

FAR includes version 1.1.4 of ModularFlightIntegrator and Kopernicus includes version 1.1.5 which has this bug fixed.  You have overwritten the fixed version with the broken one from FAR.  Copy the ModularFlightIntegrator folder from the Kopernicus install zip into your GameData folder and tell it to replace any existing files.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.