Thomas P.

[1.7.3-1 + Backports] Kopernicus & KittopiaTech

Recommended Posts

2 hours ago, Agustin said:

Does the last version work with KSP 1.3.1 with RSS and RO?

Kopernicus will only work with the exact version of KSP it was built for.

For KSP 1.3.1 there is a backport (with current features) at https://github.com/Kopernicus/Kopernicus-Backport/releases/tag/backport-1.3.1-15 .  There are also older releases for 1.3.1 at https://github.com/Kopernicus/Kopernicus-Backport/releases and https://github.com/Kopernicus/Kopernicus/releases 

Share this post


Link to post
Share on other sites
On ‎10‎/‎29‎/‎2018 at 10:35 AM, OhioBob said:

From my experimentation, the "luminosity" of the home star is the solar constant at the home world.  For instance, the stock sun has a luminosity of 1360, so that means the solar constant at Kerbin will be 1360 W/m2.  It doesn't matter how far away from the star the home world is positioned.

You gave me an important clue to solve a balance problem with Alien Space Programs with this. It seems, much like the staticPressureASL problem with atmospheric specific impulse, the game computes sunlight exposure based on the luminosity setting for the parent star and the location of the home world. I was getting almost thirty times the solar energy at Homeworld-Laythe, for instance, than I should have.

I ended up changing the sun's luminosity setting per-homeworld to correct for this.

Share this post


Link to post
Share on other sites

I have 3 issues that I have tracked down to kopernicus, minor but worth mentioning:

1. No visuals in Main Menu 

2. A superimposed sun flare is on top of my scatterer sun flare. The superimposed one doesn't instantly diappear when the sun is covered by a planet, it slowly fades away.

3. A thick black bar over the horizon when on a planet.

Anyone know about any fixes?

Share this post


Link to post
Share on other sites
9 hours ago, kostik said:

1. No visuals in Main Menu

Do you mean that the start up menu is just showing you the stock Kerbin without any of the visual enhancements?  If so, that's normal.  Nothing you can do about it.
 

Quote

2. A superimposed sun flare is on top of my scatterer sun flare. The superimposed one doesn't instantly diappear when the sun is covered by a planet, it slowly fades away.

You have to delete the stock sunflare.  Try this:

Spoiler

@Kopernicus:NEEDS[scatterer]
{
	@Body:HAS[@Template:HAS[#name[Sun]]]
	{
		%ScaledVersion
		{
			%Light
			{
				%sunLensFlareColor = 0,0,0,0
			}
		}
    	}
}

 

 

Quote

3. A thick black bar over the horizon when on a planet.

I don't know anything about a "thick" black bar.  Scatterer produces a thin black bar over the horizon.  This is  inherent to scatterer, nothing you can do about it.

 

Edited by OhioBob

Share this post


Link to post
Share on other sites

Thank you, the config got rid of the main flare but there are still a few circles from the ghosts, really not that big of a deal.

 

As for the black line, it only appears when I have Kopernicus + Scatterer. If I only have Scatterer it doesn't appear.

9mZjmdD.png

 

Share this post


Link to post
Share on other sites
On 11/19/2018 at 5:54 PM, kostik said:

If I only have Scatterer it doesn't appear. 

Does it occur only with Kopernicus installed?

Share this post


Link to post
Share on other sites

I’m actually kind of embarrassed to ask this, but how do I use the new version of KittopiaTech for KSP 1.5.1? Not only is the setup pretty new to me, but I can’t access the ScaledVersion section in the menu, and I don’t know where or how to update a planet’s scaled space with this new version. 

Share this post


Link to post
Share on other sites

So I was fooling around with Gource earlier and decided to test it out on Kopernicus... It really shows you just how much goes on behind the scenes.

 

Share this post


Link to post
Share on other sites

logs zip (hope this works... bit of a noob at sharing!)

Hi
I think I am ready for RO/RSS/RP-0 but I do not even seem able to install Kopernicus (is this a sign!?).

I can happily add Kopernicus to a clean/new KSP 1.5.1 install - no troubles at all, it creates the log files for the stock planets and everything!

Whenever I try to add Kopernicus to a clean/new 1.3.1 I get the "... not able to load custom planetary system...".

I think I have tried every version of Kopernicus for 1.3.1 - the logs are from the latest 1.3.1-15 backport. To my untrained eye every version seems to give the same errors.

FWIW if I add Kopernicus to 1.3.1 then whenever I try to load or start a new game I get a black screen with planet icons rotating next to the Loading message in the bottom right corner.
Also I noticed that I am not able to get to the Settings menu (when I click Settings I get the black screen with planet icons rotating next to the Loading message in the bottom right corner).

I would really appreciate help getting this working - would also appreciate pointers for how to troubleshoot this sort of thing for myself - I've read through this thread, reddit posts, github issues but so far I'm stumped... it feels as though there is something missing but I can't quite identify what!!

FYI I run my games offline in a Sandboxie sandbox. This does not seem to interfere with 1.5.1 + Kopernicus so I'm guessing it doesn't interfere with 1.3.1 either? I have even tried running 1.3.1 in my 1.5.1 sandbox just in case there was something screwy going on but still no good :(

Share this post


Link to post
Share on other sites

I am playing RP1 in RSS. What version of kopernicus should I use? Because I have terrain dissapearing bug and I read this was fixed.
I am not applying DX11 nor OpenGl. Nothing. Just RP1 dependencies and Scatterer and RSSVE

Edited by Agustin

Share this post


Link to post
Share on other sites

Lets try this again a bit more formally...

KSP: 1.3.1 x64 (tried all DX9, DX11, OGL)

Problem: Kopernicus breaks my clean KSP 1.3.1

Mods installed:

Kopernicus 1.3.1-15 backport (but same for every 1.3.1 version I've tried)

Module Manager 3.0.4 (packed with Kopernicus)

ModuleFlightIntegrator (packed with Kopernicus)

Reproduction steps:

Fresh install of KSP. Run once for initialisation? Start New Game. Close KSP. Add Kopernicus (manually or CKAN) and dependencies to GameData. Start KSP. Start New Game. Black screen with "Loading..." image.

Logs:

Output_log.txt

ModuleManager.ConfigCache

GameData.jpg

Kopernicus.log

Kopernicus.Runtime.log (Only 2 Kopernicus log files so I listed them)

KSP.log

All these files and the Kopernicus logs folder are in a shared drive (KSP logs) along with a zip with all of the files.

Let me know if you need more info or if you have ideas about what I can do.

Share this post


Link to post
Share on other sites
1 hour ago, Uwain said:

Lets try this again a bit more formally...

KSP: 1.3.1 x64 (tried all DX9, DX11, OGL)

Problem: Kopernicus breaks my clean KSP 1.3.1

Mods installed:

Kopernicus 1.3.1-15 backport (but same for every 1.3.1 version I've tried)

Module Manager 3.0.4 (packed with Kopernicus)

ModuleFlightIntegrator (packed with Kopernicus)

Reproduction steps:

Fresh install of KSP. Run once for initialisation? Start New Game. Close KSP. Add Kopernicus (manually or CKAN) and dependencies to GameData. Start KSP. Start New Game. Black screen with "Loading..." image.

Logs:

Output_log.txt

ModuleManager.ConfigCache

GameData.jpg

Kopernicus.log

Kopernicus.Runtime.log (Only 2 Kopernicus log files so I listed them)

KSP.log

All these files and the Kopernicus logs folder are in a shared drive (KSP logs) along with a zip with all of the files.

Let me know if you need more info or if you have ideas about what I can do.

yeah i cant get 1.3.1 to work with kopernicus either. 1.2.2 and 1.4.5 work fine. 

same setup as you clean 1.3.1 install nothing but kopernicus installed. same setup works with 1.2.2 and 1.4.5 tried every version of 1.3.1 kopernicus and all backports all of them quit. 

Share this post


Link to post
Share on other sites
On 11/19/2018 at 8:54 AM, kostik said:

Thank you, the config got rid of the main flare but there are still a few circles from the ghosts, really not that big of a deal.

 

As for the black line, it only appears when I have Kopernicus + Scatterer. If I only have Scatterer it doesn't appear.

9mZjmdD.png

 

hate to tell you thats just a scatterer problem, i used to get it all the time before i used koper

Share this post


Link to post
Share on other sites
On 12/7/2018 at 1:20 PM, COL.R.Neville said:

yeah i cant get 1.3.1 to work with kopernicus either. 1.2.2 and 1.4.5 work fine. 

same setup as you clean 1.3.1 install nothing but kopernicus installed. same setup works with 1.2.2 and 1.4.5 tried every version of 1.3.1 kopernicus and all backports all of them quit. 

Thanks, at least I'm not the only one. Thing is, I wanted to try RSS/RO/RP-0 (or 1) and I thought that was possible with 1.3.1?

I seem to remember that 1.3 brought some pretty good changes (brought me back to KSP after a break) that I would miss if I dropped to 1.2.2.

Looks like I might have to wait until the mods are all up to 1.5.1 (some of the mods seem to be skipping 1.4.5) :(

I thought this was the place to get my log files analysed and a solution... is there somewhere else I should be posting? Or is Kopernicus 1.3.1 just never gonna work for me?

I probably need a bit more patience... I forget other people have lives!!

Share this post


Link to post
Share on other sites

this mod doesn't work for me in 1.4.1.
do you know why?.

oh i'm sory. i mean RSS doesn't work

Share this post


Link to post
Share on other sites
On 12/7/2018 at 1:20 PM, COL.R.Neville said:

yeah i cant get 1.3.1 to work with kopernicus either. 1.2.2 and 1.4.5 work fine. 

same setup as you clean 1.3.1 install nothing but kopernicus installed. same setup works with 1.2.2 and 1.4.5 tried every version of 1.3.1 kopernicus and all backports all of them quit. 

tl;dr Kopernicus in CKAN RP-1 build works for me??

Just FYI... I've been fiddling with this ever since first posting... today I did another clean install of KSP 1.3.1 (in another new sandboxie sandbox), started a new game then exited KSP. Using CKAN I checked RP-1 and installed only what was necessary. Fired up KSP and it worked! No Kopernicus error!!

The only thing I can think is that my previous clean 1.3.1 installs were being corrupted somehow before I even tried RO/RP/RSS - I can't figure out how though because I'm usually very careful about such things?

I did see in the logs that when it wasn't working I was getting the shaderloader error that you reported on discord - so maybe you have a similar problem?

Anyways, if there is anything (files, versions, screen shots, logs whatever) I can do to help you spot differences just let me know.

All I have to do now is figure out RP-1 :p

Share this post


Link to post
Share on other sites
56 minutes ago, Cyrus Playz said:

Help me I ca't open kittopia tech ui

First question, did you install it?  KittopiaTech is a Kopernicus addon that must be downloaded and installed separately.

If you did install it, then accessing it is done per the instructions:

Quote

You can open the KittopiaTech UI by pressing Ctrl + P. The UI layout pretty much reflects the config structure of a planet loaded by Kopernicus, so making changes in the UI should feel more familiar to making them in the config. Due to the UI framework KittopiaTech is using, every sub-editor becomes it's own window that can only be closed by clicking the button that also opened it. To close them without going back to the button that opened them, you can open the Kittopia Window Manager using Ctrl + T, and close them from there.

 

Share this post


Link to post
Share on other sites
On 12/13/2018 at 4:57 PM, Uwain said:

Using CKAN I checked RP-1 and installed only what was necessary. Fired up KSP and it worked! No Kopernicus error!!

I'd  recommend installing all recommended (:rolleyes:) mods too (you can skip RT and TACLS if you want) and FASA+Taerobee from suggested mods list. Make sure that you configure KCT to use RP-0 config.

Share this post


Link to post
Share on other sites
On 12/13/2018 at 9:57 AM, Uwain said:

tl;dr Kopernicus in CKAN RP-1 build works for me??

Just FYI... I've been fiddling with this ever since first posting... today I did another clean install of KSP 1.3.1 (in another new sandboxie sandbox), started a new game then exited KSP. Using CKAN I checked RP-1 and installed only what was necessary. Fired up KSP and it worked! No Kopernicus error!!

The only thing I can think is that my previous clean 1.3.1 installs were being corrupted somehow before I even tried RO/RP/RSS - I can't figure out how though because I'm usually very careful about such things?

I did see in the logs that when it wasn't working I was getting the shaderloader error that you reported on discord - so maybe you have a similar problem?

Anyways, if there is anything (files, versions, screen shots, logs whatever) I can do to help you spot differences just let me know.

All I have to do now is figure out RP-1 :p

[Kopernicus] Running Kopernicus 1.3.1-15 on KSP 1.3.1
[LOG 11:17:42.721] [Kopernicus] Default logger initialized as Kopernicus
[LOG 11:17:42.727] [Kopernicus] ShaderLoader: Loading asset bundle at path E:/ksp_rp1/KSP_win64/KSP_x64_Data/../GameData/Kopernicus/Shaders\kopernicusshaders-windows.unity3d
[EXC 11:17:42.733] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.Components.ShaderLoader.LoadAssetBundle (System.String path, System.String bundleName)
    Kopernicus.Configuration.Loader.Kopernicus.IParserEventSubscriber.Apply (.ConfigNode node)
    Kopernicus.Parser.LoadObjectFromConfigurationNode (System.Object o, .ConfigNode node, System.String configName, Boolean getChilds)
    Kopernicus.Parser.CreateObjectFromConfigNode[Loader] (.ConfigNode node, System.String configName, Boolean getChilds)
    Kopernicus.Injector.Awake ()
    UnityEngine.Debug:LogException(Exception)
    Kopernicus.Injector:Awake()
    UnityEngine.GameObject:AddComponent(Type)
    AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
    AddonLoader:StartAddons(Startup)
    AddonLoader:OnLevelLoaded(Int32)
    AddonLoader:OnSceneLoaded(Scene, LoadSceneMode)
    UnityEngine.SceneManagement.SceneManager:Internal_SceneLoaded(Scene, LoadSceneMode)

[LOG 11:17:44.611] [ApplicationLauncher] OnSceneLoadedGUIReady: scene MAINMENU ShouldBeVisible() True ShouldBeOnTop() True iIsPositionedAtTop True
[ERR 11:17:44.613] Exception handling event onLevelWasLoadedGUIReady in class <>c:System.NullReferenceException: Object reference not set to an instance of an object
  at Kopernicus.StarLightSwitcher+<>c.<Start>b__2_1 (GameScenes scene) [0x00000] in <filename unknown>:0 
  at EventData`1[GameScenes].Fire (GameScenes data) [0x00000] in <filename unknown>:0 

[EXC 11:17:44.615] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.StarLightSwitcher+<>c.<Start>b__2_1 (GameScenes scene)
    EventData`1[GameScenes].Fire (GameScenes data)
    UnityEngine.Debug:LogException(Exception)
    EventData`1:Fire(GameScenes)
    <FireLoadedEventGUIReady>c__Iterator6D:MoveNext()
    UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
[EXC 11:17:44.617] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.Components.KopernicusStar.LateUpdate ()
 

yeah i tried the same thing redl 1.3.1 use ckan and just choose rp0 which uses the 1.3.1-7 version that is loaded with real solar system. still got the popup saying kopernicus died trying to load the planets. 

so i tried to use the 1.3.1-15 thinking maybe that might work still the same problem. dont understand why i can get it to work on 1.2.2 1.4.5 but 1.3.1 just wont do it.

glad you were able to yours going though. 

crawl walk run is the key to going thru rp0.  

also in real fuels there is a file realsettings.cfg

        simulateUllage = true
        limitedIgnitions = true

where you can set the limited ignitions to false that way it will work better with mech jeb. i leave the ullage on but turn the limited ignitions off just gets in the way of having fun at least to me. 

gonna try updating my drivers. ive got a 1080ti and everything works with 1.2.2 and 1.4.5 just ponderous why I cant seem to get it going on 1.3.1 .

Share this post


Link to post
Share on other sites

I wanted to replace the textures of ice caps on Kerbin and found it unexpectedly difficult. I believe there must be a rather simple solution, which I have failed to find. Could someone give me an advice, please?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.