Thomas P.

[1.7.3-1 + Backports] Kopernicus & KittopiaTech

Recommended Posts

On 12/15/2018 at 5:35 PM, COL.R.Neville said:

...

yeah i tried the same thing redl 1.3.1 use ckan and just choose rp0 which uses the 1.3.1-7 version that is loaded with real solar system. still got the popup saying kopernicus died trying to load the planets. 

...

Apologies if I gave you the impression that I could troubleshoot this for you... I only meant that I would be happy to share my files or checksums so that you could see if anything jumped out at you. I can't fix this I'm afraid :(

It really looked like the problem was the shaderloader thing but I have tried copying the shader file from my working install and that doesnt help. I also copied the squad folder from my working install and no help. I don't get that error in my working install:

[LOG 13:56:30.719] [AddonLoader]: Instantiating addon 'AtmosphereFixer' from assembly 'Kopernicus'
[LOG 13:56:30.720] [AddonLoader]: Instantiating addon 'Injector' from assembly 'Kopernicus'
[LOG 13:56:30.723] [Kopernicus] Running Kopernicus 1.3.1-7 on KSP 1.3.1
[LOG 13:56:30.759] [Kopernicus] ShaderLoader: Loading asset bundle at path Y:/games/ksp131rp1/KSP_x64_Data/../GameData/Kopernicus/Shaders\kopernicusshaders-windows.unity3d
[LOG 13:56:30.776] [Kopernicus] ShaderLoader: adding Kopernicus/Rings
[LOG 13:56:31.098] [Kopernicus] CalculateArrayLengthOffset using offset of -8
[LOG 13:56:31.100] [Kopernicus] LoadWholeFile reallocating buffer to 1048576
[LOG 13:56:31.155] [Kopernicus] LoadRestOfReader reallocating buffer to 4194304

I tried looking through the Kopernicus source code - but I learned to program back in the procedural days... I struggle to read all these objects/events. I did consider getting a dev environment setup so that I could step through the code, but fortunately for me the thing worked on my final attempt! You could look into that... but its a bit of messing about.

The only thing I have noticed is you said you chose RP-0 in ckan... I actually chose RP-1 (it was added recently)... but it didn't fix my broken installs.

I'm only using a 750ti but my video drivers are up-to-date. It's a bit of a puzzler for sure... sorry I couldn't be of any real help.

Thanks for those tips... the failed engine starts are pretty annoying - but I wanted a challenge! I've nearly finished my first year and just managed to push a 10kg payload out to 300km... crashing back to Earth. I feel like such a noob! Sub-Orbit-return next!!

Share this post


Link to post
Share on other sites
7 hours ago, SpacePixel said:

I wanted to replace the textures of ice caps on Kerbin and found it unexpectedly difficult. I believe there must be a rather simple solution, which I have failed to find. Could someone give me an advice, please?

If you're trying to do it with PQSmods, I'm not sure that's possible.  I don't know of any height mods that allows you to target specific latitudes, such as the ice caps.

Your best bet might be to add a second height map.  The height map should be black all over except for just the areas that you want the change, i.e. the ice caps.  Whatever height detail you draw into the height map will be added to the stock height map.  So if you draw in hills, or whatever, they'll be added on top of Kerbin's flat ice caps.

To get the new height map to execute, you'll need to write a config that adds it in.  Probably something like this:

@Kopernicus:AFTER[Kopernicus]
{
	@Body[Kerbin]
	{
		%PQS
		{
			%Mods
			{
				VertexHeightMap
				{
					map = path/heightmapName
					offset = 0
					deformity = 1000
					scaleDeformityByRadius = False
					order = 20
					enabled = True
					name = _IceCaps
				}
			}
		}
	}
}

 

Edited by OhioBob

Share this post


Link to post
Share on other sites
8 hours ago, Cyrus Playz said:

here have an output log.The bug is caused when I just load up ksp.

Image

Then host your log somewhere and link it. You've posted 6 times about your issue and haven't followed the first guideline in getting your problem solved.

Share this post


Link to post
Share on other sites

@Cyrus Playz, I see you are trying to use Kittopia with a plant pack.  Maybe the problem is with your configs.  Does Kittopia work for you in stock?

 

Share this post


Link to post
Share on other sites

I seem to be having a problem with Kopernicus on KSP 1.5.1. I can have Kopernicus installed just fine without using it, but if I launch the game with a planet pack, or even really anything that changes or adds planets, the game freezes after it finishes loading. I have the latest version of KSP. I have tested this with and without Kittopia tech. I am using the latest version of kopernicus.

Mods: Community category kit, community resource pack, community tech tree, kittopia tech, kopernicus, modular flight integrator, patch manager, KSP mod file localizer, module manager 3.1.1, and whatever planet pack I try to use. 

Edited by Some random person

Share this post


Link to post
Share on other sites
17 hours ago, OhioBob said:

@Cyrus Playz, I see you are trying to use Kittopia with a plant pack.  Maybe the problem is with your configs.  Does Kittopia work for you in stock?

 

It doesn't work in stock too

 

Share this post


Link to post
Share on other sites
6 hours ago, Cyrus Playz said:

It doesn't work in stock too

 

do you happen to use scatterer?

Share this post


Link to post
Share on other sites
8 hours ago, Cyrus Playz said:

It doesn't work in stock too

Sounds like something is wrong with your installation.  But since you've given us absolutely none of the information needed to diagnose your problem, there is really nothing anybody can do to help you.
 

Edited by OhioBob

Share this post


Link to post
Share on other sites
20 hours ago, Some random person said:

I seem to be having a problem with Kopernicus on KSP 1.5.1. I can have Kopernicus installed just fine without using it, but if I launch the game with a planet pack, or even really anything that changes or adds planets, the game freezes after it finishes loading. I have the latest version of KSP. I have tested this with and without Kittopia tech. I am using the latest version of kopernicus.

Mods: Community category kit, community resource pack, community tech tree, kittopia tech, kopernicus, modular flight integrator, patch manager, KSP mod file localizer, module manager 3.1.1, and whatever planet pack I try to use. 

*latest* version of KSP (v1.6) or v1.5.1?  You stated both, so just wanted to confirm.

Share this post


Link to post
Share on other sites
2 hours ago, bobjonesisthebest:D said:

halp where 1.6 support

 You are very impatient! 1. 6 was just released 2 days ago, and you are now demanding a 1.6 update for Kopernicus. 

Be advised that these mods are written by people who do not get paid for it. They do it in their spare time for fun.

So be patient, and 1. 6 will be ready when 1 that 6 is ready. 

Share this post


Link to post
Share on other sites
4 hours ago, Some random person said:

KSP updates that fast these days? wow

I have 1.5.1

Yeah, it's on a quarterly release schedule now. This'll make the wait for Kopernicus each time a bit more !FUN! ;)

Share this post


Link to post
Share on other sites

@Cyrus Playz, we've removed a number of your posts because you are simply repeating your question without providing folks with the information they need to help you. People cannot help you if you don't provide the info described here. 

Please do that before asking for help again. 

Share this post


Link to post
Share on other sites
On 12/24/2018 at 10:04 AM, Beetlecat said:

Yeah, it's on a quarterly release schedule now. This'll make the wait for Kopernicus each time a bit more !FUN! ;)

having major release quarterly make managing mods very fun since modders cannot decide when they update their mods lol

and we dunno what ksp version to use

Edited by ssd21345

Share this post


Link to post
Share on other sites

KSP: 1.5.1 windows bit

Problem: kittopia ui does not show up even when I press ctrl+p

Mods installed:

Sigma binary

Module Manager.3.1.0

scatterer

squad

squad  expansion

kopernicus 1.5.1

kittopia tech 1.5.1

kerbaltek

Reproduction steps:

load up ksp,go into the tracking station and press ctrl+p  and watch that nothing will pop up

Log:

http://www.mediafire.com/file/w108uzttbl6mp2p/output_log(2).txt

Share this post


Link to post
Share on other sites

heya! merry christmas to all and happy holidays. 
so i think kopernicus is making it that my solar panels don't produce EC. this isn't a for sure thing, but I've read this has happened before when new versions of KSP came out. i was just wondering if there was a quick and dirty fix that's been used in the past to get them working again without deleting the mod. maybe a small change in a CFG file somewhere? no worries if not, just thought i'd try!

ho ho ho

Edited by dresoccer4

Share this post


Link to post
Share on other sites
On 12/24/2018 at 7:34 AM, Beetlecat said:

Yeah, it's on a quarterly release schedule now. This'll make the wait for Kopernicus each time a bit more !FUN! ;)

Oh boy, this is where the fun begins.

Its kinda sad though, since 1.5.1 is roughly as slow as my old 2GB ram laptop (its 8GB) now, but then I do have a bunch more mods than my old install. 1.6.0 is working better with all of them, glad to see SQUAD fixed that, but Kopernicus is the only thing left that won't work on 1.6 so yay!

here's hoping it comes out quick

Share this post


Link to post
Share on other sites
1 hour ago, Cyrus Playz said:

pLZ CHECK ME REPORT

A lot of people are away visiting family right now. Please wait patiently like everyone else. 

Share this post


Link to post
Share on other sites
3 hours ago, Cyrus Playz said:

pLZ CHECK ME REPORT

So I'm far from a kopernicus expert (or even a KSP modder), and I've never actually used Kittopia, but I took a look.

 

The Kittopia window opens with control-P for me in a minimal install.  (Kopernicus plus the versions of module manager, and modular flight integrator that are bundled with the 1.5.1 Github Kopernicus release (https://github.com/Kopernicus/Kopernicus/releases/tag/release-1.5.1-1), plus KittopiaTech from https://github.com/Kopernicus/KittopiaTech/releases/tag/release-1.5.1-1).

 

From a quick look at your logfile it looks like you have multiple copies of the Kopernicus, Sigma Binary, module manager and modular flight integrator .dlls installed.  That is likely to cause problems.  (However I can't say whether that is the only cause of your problems.  After spotting this, I stopped looking for other problems).  From your logfile

Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\ModuleManager.3.1.0.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Kerbaltek\HyperEdit.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Kopernicus\Plugins\Kopernicus.OnDemand.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Kopernicus-release-1.5.1-1\build\GameData\ModularFlightIntegrator\ModularFlightIntegrator.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Kopernicus\Plugins\Kopernicus.Components.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Kopernicus\Plugins\Kopernicus.Parser.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Kopernicus\Plugins\Kopernicus.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\KittopiaTech\KittopiaTech.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Kopernicus-release-1.5.1-1\build\GameData\ModuleManager.3.1.0.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Kopernicus-release-1.5.1-1\build\GameData\Kopernicus\Plugins\Kopernicus.Components.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Kopernicus-release-1.5.1-1\build\GameData\Kopernicus\Plugins\Kopernicus.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Kopernicus-release-1.5.1-1\build\GameData\Kopernicus\Plugins\Kopernicus.OnDemand.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Kopernicus-release-1.5.1-1\build\GameData\Kopernicus\Plugins\Kopernicus.Parser.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\ModularFlightIntegrator\ModularFlightIntegrator.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\scatterer\scatterer.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Sigma-Binary-master\GameData\Sigma\Binary\Plugins\SigmaBinary.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Sigma-Binary-master\[Source]\Distribution\SigmaBinary.dll (this message is harmless)
Non platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\Squad\Plugins\KSPSteamCtrlr.dll (this message is harmless)

Note the duplicated directory Kopernicus-release-1.5.1-1\build\GameData\ and the multiple directories for Sigma Binary.  In general, when a mod download includes a GameData directory, you copy everything from that GameData directory into your GameData directory, and just ignore everything else.  

 

For reference here is what the equivalent portion of my log looks like from my test run.

Non platform assembly: D:\Games\Kerbal.Space.Program.1.5.1.Vanilla.copy\GameData\ModuleManager.3.1.0.dll (this message is harmless)
Non platform assembly: D:\Games\Kerbal.Space.Program.1.5.1.Vanilla.copy\GameData\Kopernicus\Plugins\Kopernicus.OnDemand.dll (this message is harmless)
Non platform assembly: D:\Games\Kerbal.Space.Program.1.5.1.Vanilla.copy\GameData\ModularFlightIntegrator\ModularFlightIntegrator.dll (this message is harmless)
Non platform assembly: D:\Games\Kerbal.Space.Program.1.5.1.Vanilla.copy\GameData\Kopernicus\Plugins\Kopernicus.Components.dll (this message is harmless)
Non platform assembly: D:\Games\Kerbal.Space.Program.1.5.1.Vanilla.copy\GameData\Kopernicus\Plugins\Kopernicus.Parser.dll (this message is harmless)
Non platform assembly: D:\Games\Kerbal.Space.Program.1.5.1.Vanilla.copy\GameData\Kopernicus\Plugins\Kopernicus.dll (this message is harmless)
Non platform assembly: D:\Games\Kerbal.Space.Program.1.5.1.Vanilla.copy\GameData\KittopiaTech\KittopiaTech.dll (this message is harmless)
Non platform assembly: D:\Games\Kerbal.Space.Program.1.5.1.Vanilla.copy\GameData\Squad\Plugins\KSPSteamCtrlr.dll (this message is harmless)

(As already mentioned, I haven't installed Sigma Binary, scatterer or hyperedit).

 

I would check all your mods, to see whether you have made any other similar mistakes.

 

If that doesn't fix things, then I would recommend starting with a clean copy of KSP, somewhere outside of Steam (so Steam won't update it unexpectedly).  Then install one or two mods,  check that everything loads and seems to work, then install a couple more mods, and again check that everything loads and seems to work.  That way if something does break, it is much easier to identify the minimal set of mods that causes problems.  If, after attempting that, you are still having problems then post again.  Let us know what that minimal set of mods is.  (Include the precise mod versions, and whether you installed them manually, or from CKAN.  If manually installed, then probably even provide a link to the webpage(s) you downloaded them from.  Provide a new logfile, so people can have a look to see whether they can spot any problems).

 

Also, as Deddly said, remember it's Christmas, which means many people are away or distracted by other things.

 

Edited to add a link to Linuxgurugamer explain how to install a typical mod.

https://forum.kerbalspaceprogram.com/index.php?/topic/107661-ksp-145-x-science-ksp-science-report-and-checklist-v517/&do=findComment&comment=3511464

 

Edited by AVaughan

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.