Thomas P.

[1.7.3-1 + Backports] Kopernicus & KittopiaTech

Recommended Posts

1 hour ago, Cyrus Playz said:

Should I install the source code too?

No, just install the release linked in the first post. All you want is the "Kopernicus-1.5.1-1.zip" and "KittopiaTech-1.5.1-1.zip" files, then installed like normal.

Share this post


Link to post
Share on other sites
2 hours ago, Cyrus Playz said:

Should I install the source code too?

You talking asking Sigma Binary?  

 

I would just grab the latest release from https://github.com/Sigma88/Sigma-Binary/releases , then copy the contents of the gamedata directory into your gamedata directory.  You don't need the source archives, unless you want to build the mod from source.  (If you have multiple of Sigma88's mods, then I think most or all of them go into gamedata/Sigma).

Edited by AVaughan

Share this post


Link to post
Share on other sites

I've been having an issue where kopernicus doesn't load: https://drive.google.com/open?id=13CUwt-9j8d06-KsTgj5IrQzBHMIycup0https://drive.google.com/open?id=145BkDtROA0NzvIsQ7Beb3z4feABNlNBnhttps://drive.google.com/open?id=190y02-ISi8WWINM3wIKQObFBb-k6gjSK

It says kopernicus just won't start... and isn't loading files. Their is only planet packs MFI and kopernicus itself in the game-data.

Anyone able to respond to wait or to say how to fix it. because I can be patient.

Edited by Shawn Kerman
Https fix

Share this post


Link to post
Share on other sites
5 hours ago, Shawn Kerman said:

I've been having an issue where kopernicus doesn't load: https://drive.google.com/open?id=13CUwt-9j8d06-KsTgj5IrQzBHMIycup0https://drive.google.com/open?id=145BkDtROA0NzvIsQ7Beb3z4feABNlNBnhttps://drive.google.com/open?id=190y02-ISi8WWINM3wIKQObFBb-k6gjSK

It says kopernicus just won't start... and isn't loading files. Their is only planet packs MFI and kopernicus itself in the game-data.

Anyone able to respond to wait or to say how to fix it. because I can be patient.

Those links don't seem to be public.  I'm guessing they are logfiles?

The most likely reason Kopernicus doesn't load is that you are trying to use the 1.5.1 version with KSP 1.6, (or that you are missing one of its dependencies module manager or modular flight integrator).

 

Share this post


Link to post
Share on other sites
On 8/27/2017 at 7:02 PM, AR3S_TGL said:

 

I'm running 1.5.1 at the time MFI was loaded and I had module manager 3.1.1

 

 

Share this post


Link to post
Share on other sites

When i load ksp it says ''Kopernicus will not work on this version of ksp, please don't try to open your savegames!'' So..... I was wondering what can happen if i do that and if is it really bad?

Share this post


Link to post
Share on other sites
1 hour ago, winnermah said:

When i load ksp it says ''Kopernicus will not work on this version of ksp, please don't try to open your savegames!'' So..... I was wondering what can happen if i do that and if is it really bad?

It doesn't do anything. It's more of a warning that if you load a save from a modded system into this stock system, it will break somehow.

Share this post


Link to post
Share on other sites

For me in the log it gives out the error of: [ERR 20:25:44.297] AssemblyLoader: Exception loading 'Kopernicus': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0

when I get that error kopernicus doesn't load anything..

Share this post


Link to post
Share on other sites
2 hours ago, Shawn Kerman said:

For me in the log it gives out the error of: [ERR 20:25:44.297] AssemblyLoader: Exception loading 'Kopernicus': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0

when I get that error kopernicus doesn't load anything..

No idea what causes that.  I suggest double checking that the version of Kopernicus match your KSP version.  (Kopernicus is locked to its target KSP version, and won't load with any other KSP version. The latest version of KSP is 1.6.  It released just before christmas, and there hasn't been a release of Kopernicus for 1.6).    Double checking that you have recent version of Kopernicus's dependencies.   (Kopernicus 1.5.1 ships a copy of Module Mananger 3.1.0 and a version Modular Flight Integrator.  You might want to try with those bundled versions, just in case newer versions break something).

If your version of Kopernicus matches your KSP version, and you have the dependencies installed, then upload a copy of you logs somewhere, and post a link here.  

Share this post


Link to post
Share on other sites
11 minutes ago, AVaughan said:

No idea what causes that.  I suggest double checking that the version of Kopernicus match your KSP version.  (Kopernicus is locked to its target KSP version, and won't load with any other KSP version. The latest version of KSP is 1.6.  It released just before Christmas, and there hasn't been a release of Kopernicus for 1.6).    Double checking that you have recent version of Kopernicus's dependencies.   (Kopernicus 1.5.1 ships a copy of Module Mananger 3.1.0 and a version Modular Flight Integrator.  You might want to try with those bundled versions, just in case newer versions break something).

If your version of Kopernicus matches your KSP version, and you have the dependencies installed, then upload a copy of you logs somewhere, and post a link here.  

Do the links above not work? I'll be happy to repost them ( the logs were when I was using MFi, module manager 3.1.1, kopernicus 1.5.1-1 and ksp 1.5.1)

http://www.mediafire.com/folder/g7l4bd0038bgmjw,pbby5sch05pcws6,rt9aoh6v7s5vlj9/shared

Edited by Shawn Kerman
Links

Share this post


Link to post
Share on other sites
21 hours ago, winnermah said:

When i load ksp it says ''Kopernicus will not work on this version of ksp, please don't try to open your savegames!'' So..... I was wondering what can happen if i do that and if is it really bad?

It depends on what you have loaded in the save. What will happen is that the planets will load in their default stock configuration. If you have missions around or on custom planets like OPM or Extrasolar, then those vessels suddenly won't have a home, and KSP will remove them. Not sure the impact on reparented bodies (like Eeloo in OPM and other mods). If your game save used stock planets plus other things, and you have no missions other than on or within the SOI of stock planets, then it's probably safe to load the save and work in it - but there are no guarantees.

If you really want to know, back up your save game folder someplace safe, and try it out - just be prepared for the potential it'll be all screwed up on load or after Kopernicus is updated and your save is reloaded, and that you might have to go back to the backup. As with all things in KSP, back up your saves before installing / making changes to mods, modded saves, or mod configurations, or freeze your version by not upgrading or by setting the "beta settings" in Steam. Practice safe modding!  ;-)

 

Share this post


Link to post
Share on other sites
22 minutes ago, panarchist said:

It depends on what you have loaded in the save. What will happen is that the planets will load in their default stock configuration. If you have missions around or on custom planets like OPM or Extrasolar, then those vessels suddenly won't have a home, and KSP will remove them. Not sure the impact on reparented bodies (like Eeloo in OPM and other mods). If your game save used stock planets plus other things, and you have no missions other than on or within the SOI of stock planets, then it's probably safe to load the save and work in it - but there are no guarantees.

If you really want to know, back up your save game folder someplace safe, and try it out - just be prepared for the potential it'll be all screwed up on load or after Kopernicus is updated and your save is reloaded, and that you might have to go back to the backup. As with all things in KSP, back up your saves before installing / making changes to mods, modded saves, or mod configurations, or freeze your version by not upgrading or by setting the "beta settings" in Steam. Practice safe modding!  ;-)

 

i'll try that as well, thanks :}

 

Share this post


Link to post
Share on other sites
25 minutes ago, panarchist said:

It depends on what you have loaded in the save. What will happen is that the planets will load in their default stock configuration. If you have missions around or on custom planets like OPM or Extrasolar, then those vessels suddenly won't have a home, and KSP will remove them. Not sure the impact on reparented bodies (like Eeloo in OPM and other mods). If your game save used stock planets plus other things, and you have no missions other than on or within the SOI of stock planets, then it's probably safe to load the save and work in it - but there are no guarantees.

 

This sounds like something that could be checked in code. Maybe Kopernicus could hook into the world load and check for these things? Like orphan ships, reparented bodies with missing parents, missing planets, missing bodies for active missions? Is that possible technically? This could be a good idea for a separate mod, even.

Share this post


Link to post
Share on other sites
2 hours ago, panarchist said:

It depends on what you have loaded in the save. What will happen is that the planets will load in their default stock configuration. If you have missions around or on custom planets like OPM or Extrasolar, then those vessels suddenly won't have a home, and KSP will remove them. Not sure the impact on reparented bodies (like Eeloo in OPM and other mods). If your game save used stock planets plus other things, and you have no missions other than on or within the SOI of stock planets, then it's probably safe to load the save and work in it - but there are no guarantees.

If you really want to know, back up your save game folder someplace safe, and try it out - just be prepared for the potential it'll be all screwed up on load or after Kopernicus is updated and your save is reloaded, and that you might have to go back to the backup. As with all things in KSP, back up your saves before installing / making changes to mods, modded saves, or mod configurations, or freeze your version by not upgrading or by setting the "beta settings" in Steam. Practice safe modding!  ;-)

 

or OR.... the creator could fix the mod... just saying...isnt that what usually happens with each new ksp version? all the mods break and there is a large chunk of time where users who love mods cant play it because of broken mods

Share this post


Link to post
Share on other sites
2 hours ago, panarchist said:

It depends on what you have loaded in the save. What will happen is that the planets will load in their default stock configuration. If you have missions around or on custom planets like OPM or Extrasolar, then those vessels suddenly won't have a home, and KSP will remove them. Not sure the impact on reparented bodies (like Eeloo in OPM and other mods). If your game save used stock planets plus other things, and you have no missions other than on or within the SOI of stock planets, then it's probably safe to load the save and work in it - but there are no guarantees.

If you really want to know, back up your save game folder someplace safe, and try it out - just be prepared for the potential it'll be all screwed up on load or after Kopernicus is updated and your save is reloaded, and that you might have to go back to the backup. As with all things in KSP, back up your saves before installing / making changes to mods, modded saves, or mod configurations, or freeze your version by not upgrading or by setting the "beta settings" in Steam. Practice safe modding!  ;-)

 

I forgot I could roll my version of KSP back to v1.5.1 via the Beta settings tab in Steam! Thanks for mentioning this, I'll be able to play KSP v1.5.1 until Kopernicus gets updated. Your a lifesaver!

Share this post


Link to post
Share on other sites
2 hours ago, mindseyemodels said:

or OR.... the creator could fix the mod... just saying...isnt that what usually happens with each new ksp version? all the mods break and there is a large chunk of time where users who love mods cant play it because of broken mods

It sounds like you're not familiar with this thread. The creator *DOES* fix the mod, and also has a life. When people bug him for a fix, there's a greater likelihood it'll get delayed, because no one likes to be pestered on each release. The releases are version-locked on purpose to prevent problems. The OP was asking what *would* happen, which is what I was responding to.

3 hours ago, Korfio said:

This sounds like something that could be checked in code. Maybe Kopernicus could hook into the world load and check for these things? Like orphan ships, reparented bodies with missing parents, missing planets, missing bodies for active missions? Is that possible technically? This could be a good idea for a separate mod, even.

Sure, it could, potentially, but that's a lot harder than it sounds, and beyond the scope of the mod. As an example, I have 70-80 mods in play on my main instance of KSP. I can't reasonably expect any of those mod makers to accommodate nor troubleshoot mod conflicts. Honestly, it's a miracle that so many mods cooperate so well with each other - a real testament to the KSP modding community's skill and consideration of each other.

Share this post


Link to post
Share on other sites

Release time!

 

What was released:

- Kopernicus 1.6.0-1
- Kopernicus 1.5.1-2
- Kopernicus 1.4.5-7
- Kopernicus 1.3.1-16
- KittopiaTech 1.6.0-1

What was changed:

- Reworked some of the code to allow a plugin for Interstellar Consortium
- Fix the Sun shining through Jool
- Fix Kittopia Normal Map Generation
- Fix Kittopia not being able to edit bodies who use AtmosphericExtra
- Allow to add multiple HazardousBody configs
- Allow to controls HazardousBody using a greyscale map for heat distribution
- Fix the .version file
- Added the ability to recolor the editor grass
- Spawning a Kopernicus asteroid triggers the stock onAsteroidSpawned event now
- Kittopia windows include a close and a minimize button in their headers now. (This causes some jittering, I hope thats ok)

-> Links are in the OP

Share this post


Link to post
Share on other sites

Ok, I've been doing some troubleshooting with TWB and I think I'm onto something as to why KSP freezes after loading the game when I try to use Kopernicus to load new planets and such.  To be clear, I'm using module manager 3.1.0 (bundled with Kopernicus) and I've updated Modular Flight Integrator to 1.2.6, which is for KSP 1.5. I have all the dependencies for TWB (I think). I've been looking through the logs and I've found this message that appears a lot when Kopernicus is activated:

[WRN 11:43:46.759] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.

(time and date part varies)

This message seems to appear every time Kopernicus tries to do anything. 

Share this post


Link to post
Share on other sites
4 hours ago, Thomas P. said:

What was released:


- Kopernicus 1.6.0-1
- Kopernicus 1.5.1-2
- Kopernicus 1.4.5-7
- Kopernicus 1.3.1-16
- KittopiaTech 1.6.0-1

You people are amazing.   Thank you for your hard work and Happy New Year! Peace.

Share this post


Link to post
Share on other sites
5 hours ago, Thomas P. said:

Release time!

Thank you for your work!! :)

Share this post


Link to post
Share on other sites

Echoing what @theJesuit said.  We are really fortunate to have folks like you putting in so much time and effort. It is really appreciated.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.