Thomas P.

[1.7.3-1 + Backports] Kopernicus & KittopiaTech

Recommended Posts

7 hours ago, guto8797 said:

In case of graphics mods like Spectra that AFAIK make use of kopernicus for texture changes, would it be fine to load the save? I don't think they add new planets, just new scatters and textures.

It's fine to create a new save without Kopernicus, you will simply lose some of the features.

Existing saves will break because Kopernicus replaces the deployable solar panel module with it's own implementation. Safer to wait for an update and keep playing on 1.7.1 in the meantime.

Share this post


Link to post
Share on other sites

Any update or status when this will be compatible/updated for KSP rev 1.7.2?

Share this post


Link to post
Share on other sites

@jbarry39 The update will come when it does. There is no timeline and requesting an update can only make it take longer.

Share this post


Link to post
Share on other sites
49 minutes ago, leomike said:

@jbarry39 The update will come when it does. There is no timeline and requesting an update can only make it take longer.

Okay....Thanks!

Share this post


Link to post
Share on other sites
On 6/15/2019 at 5:50 PM, fulgur said:

I was mainly asking as in the file it says

    "KSP_VERSION":
    {
        "MAJOR": 1,
        "MINOR": 7,
        "PATCH": 1
    }

so I was wondering whether there really was something incompatible with the 1.7.2 patch which would summon the Kraken or whether it was just displaying that message because it's a massive mod which will eat half your ships if the planet they're orbiting / landed on disappears.

If you really want to try, just copy your save file somewhere just in case so you keep an intact file in case it goes wrong.

Share this post


Link to post
Share on other sites

@Quoniam Kerman I believe this will just make AVC believe that the plugin is compatible but it still won't work. You need to recompile the DLL to change the version requirement for Kopernicus to actually work. I've done it myself, but I only use for Spectra; wouldn't dare to test with any mod that actually changes the planets.

Share this post


Link to post
Share on other sites

I would dare, but from the earlier description by @Thomas P. I can guess what’ll happen. 

Its like having a Christmas tree (your game world, planets) with lots of decoration (your crafts). Then imagine your cat taking the tree apart and putting it back together in a weird quantum state. 

nothing’s going to be where it should and you end up having to buy a new tree and decorate it anew. 

Share this post


Link to post
Share on other sites

Some content has been removed, due to pressuring a mod maker about updates, which of course we all know better than to do.

We know that for a variety of reasons. For example, we know it because when we were young, we were taught basic politeness such as "when someone kindly gives you a free gift, it's really rude to complain or make demands about it." And also we know it because it's specifically forbidden by the forum rules we agreed to when we created our accounts (2.2.p, in particular). And we know it because a moderator told us just a few days ago to knock it off.

Since we all know that so well, good thing we're not going to do that anymore, right? Thanks.

Share this post


Link to post
Share on other sites

Looks like KSP is doing another hotfix patch soon anyways

Share this post


Link to post
Share on other sites
3 hours ago, nsgallup said:

Looks like KSP is doing another hotfix patch soon anyways

What?! They are?  How can you tell?

-----

I have a question.  If I do a new install of KSP 1.71 so I can play with this and outer planets mod, will I be able to take that save over to the updated game/Kopernicus later if I get everything updated properly before moving my save?

Also @Thomas P. thanks for keeping at this.  I can't tell you how much we appreciate it.

Share this post


Link to post
Share on other sites
36 minutes ago, jpinard said:

What?! They are?  How can you tell?

-----

I have a question.  If I do a new install of KSP 1.71 so I can play with this and outer planets mod, will I be able to take that save over to the updated game/Kopernicus later if I get everything updated properly before moving my save?

Also @Thomas P. thanks for keeping at this.  I can't tell you how much we appreciate it.

twitter I think

Share this post


Link to post
Share on other sites
5 hours ago, jpinard said:

I have a question.  If I do a new install of KSP 1.71 so I can play with this and outer planets mod, will I be able to take that save over to the updated game/Kopernicus later if I get everything updated properly before moving my save?

Almost definitely.

Share this post


Link to post
Share on other sites
12 hours ago, jpinard said:

What?! They are?  How can you tell?

-----

I have a question.  If I do a new install of KSP 1.71 so I can play with this and outer planets mod, will I be able to take that save over to the updated game/Kopernicus later if I get everything updated properly before moving my save?

Also @Thomas P. thanks for keeping at this.  I can't tell you how much we appreciate it.

They also posted on the forums about 1.7.3 it's going to add the ability to have same ship part interactions so we can make gears and stuff. While I'm glad they're still hard at work after all these years, it can be rough on mod makers having so many updates close together. 

 

Share this post


Link to post
Share on other sites
On 6/21/2019 at 11:53 AM, Jesse-Lacey said:

They also posted on the forums about 1.7.3 it's going to add the ability to have same ship part interactions so we can make gears and stuff. While I'm glad they're still hard at work after all these years, it can be rough on mod makers having so many updates close together. 

 

This is why I think it's impressive so many authors churn out updates as frequently as they do. I mean I've had this game since beta, and there are a couple authors that have been going strong over... what is it, almost ten years now? It's kind of nuts and I can't fathom the time it must take some of them with how complex some mods tend to get. 

Share this post


Link to post
Share on other sites

Has anyone seen this issue before?  Not sure if it is Kopernicus or one of the planet mods I installed?  Notice, the flickering only happens when I'm inside the solar system ring on a flat plane.  Is there anything I can do to fix this?  It's distracting and I need to use that angle quite a bit.

 

 

Share this post


Link to post
Share on other sites
24 minutes ago, jpinard said:

Has anyone seen this issue before?  Not sure if it is Kopernicus or one of the planet mods I installed?  Notice, the flickering only happens when I'm inside the solar system ring on a flat plane.  Is there anything I can do to fix this?  It's distracting and I need to use that angle quite a bit.

I don't know what specifically causes the flickering, but it's a common issue.  There's nothing you can do about it.

Share this post


Link to post
Share on other sites
Posted (edited)
18 minutes ago, OhioBob said:

I don't know what specifically causes the flickering, but it's a common issue.  There's nothing you can do about it.

OK thanks for letting me know.  Can we turn off the planet orbit paths in-game?

Edited by jpinard

Share this post


Link to post
Share on other sites
3 minutes ago, jpinard said:

OK thanks for letting me know.  Can we turn off the planet orbit paths in-game?

In the orbit node use, mode = OFF.

Share this post


Link to post
Share on other sites
1 minute ago, OhioBob said:

In the orbit node use, mode = OFF.

Excellent - thanks!

Share this post


Link to post
Share on other sites
2 hours ago, jpinard said:

Has anyone seen this issue before?  Not sure if it is Kopernicus or one of the planet mods I installed?  Notice, the flickering only happens when I'm inside the solar system ring on a flat plane.  Is there anything I can do to fix this?  It's distracting and I need to use that angle quite a bit.

 

What is that planet on the highly elliptical orbit you have in there? Also, do you have this running on the latest version of KSP? Thanks!

Share this post


Link to post
Share on other sites

So apparently no progress on anything regarding an update for 1.7.2 anytime in our future(?) 

Share this post


Link to post
Share on other sites
54 minutes ago, jbarry39 said:

So apparently no progress on anything regarding an update for 1.7.2 anytime in our future(?) 

So 'apparently' you do not read the thread you are posting in. Stop nagging, you'll only delay things even more. Anyways.. 1.73 will be your best bet. (and it will be buggy as hell with the new colliders, so hotfixes for 1.74-75 will come shortly thereafter)

Share this post


Link to post
Share on other sites
Posted (edited)
21 hours ago, ilikeksp said:

What is that planet on the highly elliptical orbit you have in there? Also, do you have this running on the latest version of KSP? Thanks!

I'm not sure which planet pack he is using, but I know Astronomers Visual Pack adds Sorlon which is an asteroid in a highly elliptical orbit that's similar. It's a pain to try and stop at.

 

Edit: Check Kerbol Origins, I think that might be the planet pack in the video.

Edited by Jesse-Lacey

Share this post


Link to post
Share on other sites
Posted (edited)
22 hours ago, jbarry39 said:

So apparently no progress on anything regarding an update for 1.7.2 anytime in our future(?) 

KSP 1.7.3 patch being underway for shortly, there is no reason to have a 1.7.2 update for now...

@jpinard It is caused by the game engine itself, so it ain't being corrected anytime soon. It shows off when a solar system is bigger than the stock one.

Edited by Quoniam Kerman

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.