Thomas P.

[1.7.3-1 + Backports] Kopernicus & KittopiaTech

Recommended Posts

Hey everyone, just a quick note that the Kopernicus Creativity Marathon is back (finally)!

You can check out the current round here;

 

Share this post


Link to post
Share on other sites

Thats not a suprise. gravParameter overrides all the other three values (mass, geeASL), and you set that to 65138397520

Share this post


Link to post
Share on other sites

Why does my Mars in RSS look like Duna, but all the other planets look like they should?

Share this post


Link to post
Share on other sites

@Thomas P.? Can you please tell me where I have to post questions I have, as you have warned me before for posting too much on the forums. After you warned me you haven't responded to me on where I have to post or how otherwise. If you don't tell me this I can't change anything about it. Hopefully you can now finally tell me. Thanks!

Share this post


Link to post
Share on other sites
Just now, ApertureGaming said:

@Thomas P.? Can you please tell me where I have to post questions I have, as you have warned me before for posting too much on the forums. After you warned me you haven't responded to me on where I have to post or how otherwise. If you don't tell me this I can't change anything about it. Hopefully you can now finally tell me. Thanks!

Ummm...

If you have Kopernicus questions post them in the Kopernicus thread. If you have questions regarding a special mod, post them in the respective thread.

And before asking for support, read the rules in the OP.

Share this post


Link to post
Share on other sites
On 6/2/2016 at 11:21 PM, Padishar said:

After a little chat with @Thomas P., he quickly pointed me in the direction of the code at fault and I have now submitted a PR fixing the issue...

I have now made some further fixes to the on-demand texture loading that reduce the garbage creation still further.  I would appreciate it if interested parties could give it a test and report back on how well it works.  Simply download this zip and extract the two DLLs it contains into your GameData/Kopernicus/Plugins folder (and make sure to remove any configs that disable the on-demand loading).  If you have any issues such as crashes or obviously missing (or wrong) textures then please upload the full output_log.txt/player.log file and either post a link here or in the PR itself mentioning your mods, what you were doing and what went wrong.

Share this post


Link to post
Share on other sites
5 hours ago, Padishar said:

I have now made some further fixes to the on-demand texture loading that reduce the garbage creation still further.  I would appreciate it if interested parties could give it a test and report back on how well it works.  Simply download this zip and extract the two DLLs it contains into your GameData/Kopernicus/Plugins folder (and make sure to remove any configs that disable the on-demand loading).  If you have any issues such as crashes or obviously missing (or wrong) textures then please upload the full output_log.txt/player.log file and either post a link here or in the PR itself mentioning your mods, what you were doing and what went wrong.

I honestly think this is the best thing that has happened to Kopernicus since Kopernicus. I can now run Uncharted Lands without my game going for a coffee break ever 3/4 of a second. This is amazing. :0.0:

Share this post


Link to post
Share on other sites

@Thomas P. How do you change the temperatures of stars to something else besides Kerbol's temperature of 5840 Kelvin?

Share this post


Link to post
Share on other sites
On 5/6/2016 at 1:04 PM, Padishar said:

I have now made some further fixes to the on-demand texture loading that reduce the garbage creation still further.  I would appreciate it if interested parties could give it a test and report back on how well it works.  Simply download this zip and extract the two DLLs it contains into your GameData/Kopernicus/Plugins folder (and make sure to remove any configs that disable the on-demand loading).  If you have any issues such as crashes or obviously missing (or wrong) textures then please upload the full output_log.txt/player.log file and either post a link here or in the PR itself mentioning your mods, what you were doing and what went wrong.

5witmUE.png

@Padishar Thanks

Share this post


Link to post
Share on other sites

Running the new dev build I am currently around Sarnus at a stable 130-150fps. When I waggle and spin the camera around it drops to around 85-90 and hit a low of 65. Quite a considerable gain for me.

Share this post


Link to post
Share on other sites
13 hours ago, Poodmund said:

Running the new dev build I am currently around Sarnus at a stable 130-150fps. When I waggle and spin the camera around it drops to around 85-90 and hit a low of 65. Quite a considerable gain for me.

Is this "waggle and spin" in map mode or normal flight?  If normal flight then we could probably do with delaying the unload of the various other planet related textures (MapSO, CBAttributeMapSO and PQSMod) so rapid camera movement doesn't cause them to be discarded and immediately reloaded.  However, I see there has been timer-based code to do this in the past but it has been removed so I'll need to chat with @Thomas P. about it to ensure there isn't a general problem with doing it.

Edit: I've reimplemented the delayed unloading of the other stuff but I haven't been able to test it yet because I'm on a Win32 machine and an OPM install just won't stay running for more than a scene change or two, even with all but a handful of the Squad parts removed and the settings tweaked for minimum memory use.  Before I trimmed down the parts it wouldn't even get to the main menu, but now I can manage to put a very simple vessel on the pad but trying to recover it, or even just returning to KSC, crashes it due to running out of address space.  I might be able to hyperedit it to another planet but I suspect it will immediately crash so I'll just wait to test it on Win64...

Edited by Padishar

Share this post


Link to post
Share on other sites
3 hours ago, Padishar said:

Is this "waggle and spin" in map mode or normal flight?  If normal flight then we could probably do with delaying the unload of the various other planet related textures (MapSO, CBAttributeMapSO and PQSMod) so rapid camera movement doesn't cause them to be discarded and immediately reloaded.  However, I see there has been timer-based code to do this in the past but it has been removed so I'll need to chat with @Thomas P. about it to ensure there isn't a general problem with doing it.

The problem with my timer code was, that it wasn't working properly, and that the PQS needs the textures always, not only once. My code unloaded the textures after X minutes of being unused, and the access stuff for map SO didn't reset the timer. So I spammed the game with unloading and loading theese textures.

Share this post


Link to post
Share on other sites
2 hours ago, Thomas P. said:

The problem with my timer code was...

Thanks, I'm only going to be delaying the deliberate unloading that happens rather than automatically unloading after a timer so I think it should be safe...

17 hours ago, Poodmund said:

Running the new dev build I am currently around Sarnus at a stable 130-150fps. When I waggle and spin the camera around it drops to around 85-90 and hit a low of 65. Quite a considerable gain for me.

I have now updated the test DLLs I posted before with my latest tweaks.  I'm hoping this will reduce the fps drops when panning the camera around even more.  As before, simply download this zip and extract the two DLLs it contains into your GameData/Kopernicus/Plugins folder.  The unload delay is currently set to 10 seconds so if you stop panning for longer than that then you will still get a glitch when you next pan a body into view.  I intend to also make the delay configurable later today...

Edit: I have just updated the DLLs again to include the onDemandUnloadDelay configuration setting.  This can be set to the desired delay in seconds with the following MM config:

@Kopernicus:FINAL
{
    %onDemandUnloadDelay = 30
}

 

Edited by Padishar

Share this post


Link to post
Share on other sites

I've been having an issue where the normals map displays the wrong side of the planet lit up. I tried kittopia but then the map was too low relative to the terrain. I can get log files and screenshots after school :) 

Share this post


Link to post
Share on other sites
21 hours ago, Kepler68 said:

I've been having an issue where the normals map displays the wrong side of the planet lit up. I tried kittopia but then the map was too low relative to the terrain. I can get log files and screenshots after school :) 

The means there's an issue with the format of the normal map, the RGB channels are all messed up. Also with Kittopia you can raise the height of the export, simply go to the PQS editor and select the planet inside the PQS list and look for mapmaxheight or something like that, should be directly under the resolution option.

Share this post


Link to post
Share on other sites
1 hour ago, qualitycrafted said:

the name of the thread says 1.1.2 but the download is for 1.0.5.
 I'm confused as of this download will work on 1.1.2?

thanks in advance.

Kopernicus v1.0.5 is for KSP 1.1.2

Share this post


Link to post
Share on other sites

@Everyone: Teaser :)

9jAefmT.png

The stars are from @Sigma88's Galactic Neighbourhood.

Edit: Look at the lensflares, not the stars :P

Edited by Thomas P.

Share this post


Link to post
Share on other sites

Whoa. That's beautiful.

The star seems to be oblate... how'd you do that?

Share this post


Link to post
Share on other sites

Are those the stars from galactic neighborhood? They look amazing!!!

EDIT: I just realized what it is! Multiple star flares!!!

Edited by Kepler68

Share this post


Link to post
Share on other sites

Wait, is this Kopernicus 1.1.2 for KSP 1.0.5 or Kopernicus 1.0.5 for KSP 1.1.2?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.