Thomas P.

[1.7.3-1 + Backports] Kopernicus & KittopiaTech

Recommended Posts

Well, I stayed up all night trying to find a solution to this and found nothing. I'll just dump some specs and a summary of the problem here and if someone who is able to help sees this and knows something I can try, I'll be listening. But at this point it seems to be a limitation with Linux and Nvdia that I can't just solve with a few clever installs.

Lenovo Y50

OS: Linux Mint 17.3

CPU: Intel Core i7-4700HQ

GPU: Intel HD 4600 or Nvidia GeForce 860M

Drivers: nivida-352 with Bumblebee and Primus

KSP 1.1.2, Kopernicus 1.0.5

Having problems with OPM, KPlus, Uncharted Lands, and New Horizons, but not Real Solar System or Asclepius/Kronkus. The problem seems to be with the way that the GPU is handling the .dds files it receives, it does not apply the correct texture but rather a yellow and black striped texture. Problem occurs with regular execute, optirun, and primusrun. Textures begin to appear at a certain height above the ground.

Share this post


Link to post
Share on other sites
6 minutes ago, daniel l. said:

Thanks :) And umm one question. Kind of off topic, But how do i make a planet shoot particles out at the exact opposite direction from its sun?

no idea, but maybe in this thread someone knows the answer :)

Share this post


Link to post
Share on other sites

I don't know the details, but I believe that can be done by hooking into the contracts system. Asclepius included custom contracts that placed craft on its surface. Probably not a job for Kopernicus.

Share this post


Link to post
Share on other sites
4 hours ago, cantab said:

I don't know the details, but I believe that can be done by hooking into the contracts system. Asclepius included custom contracts that placed craft on its surface. Probably not a job for Kopernicus.

Well. That might work, But i need it to work in all modes not just career, I was wanting craft to spawn with the frequency of asteroids :)

Share this post


Link to post
Share on other sites
37 minutes ago, daniel l. said:

Well. That might work, But i need it to work in all modes not just career, I was wanting craft to spawn with the frequency of asteroids :)

Well, then you might want to know that you can modify the vessel definition created for the Asteroid. Just make a Craft, launch it, save the savegame, copy the parts you want (Part definitions) into a
Vessel node inside of your Asteroid node.
 

Share this post


Link to post
Share on other sites
Just now, Thomas P. said:

Well, then you might want to know that you can modify the vessel definition created for the Asteroid. Just make a Craft, launch it, save the savegame, copy the parts you want (Part definitions) into a
Vessel node inside of your Asteroid node.
 

Thanks :) I'll try that. BTW is it possible to make asteroids just spawn without  that whole 'unknown object' thing and instead just spawn right in?

Share this post


Link to post
Share on other sites

@daniel l. I've made particles fly right at a planet, I've used that for Infernas in my planet pack Planet Cyran, here's a snippet of the config file

		Particles
		{
			Particle
			{
				target = Cyran
				texture = PlanetCyran/Textures/particle
				minEmission = 50
				maxEmission = 150
				lifespanMin = 1
				lifespanMax = 2
				sizeMin = 2
				sizeMax = 5
				speedScale = 0.05
				rate = -0.5
				randVelocity = 5.0, 5.0, 5.0
				Colors
				{
					color1 = 1.0, 0.16862745098039215686274509803922, 0.0, 1.0
					color2 = 0.8, 0.2, 0.1, 1.0
					color3 = 0.6, 0.25, 0.2, 1.0
					color4 = 0.4, 0.3, 0.3, 1.0
					color5 = 0.4, 0.4, 0.4, 1.0
				}
			}
		}

I recall using the speedScale to make them fly at Cyran (but I could be wrong, in that case it's the 'rate'), perhaps filling in a negative number will make them fly the opposite way. The 'Colors' wrapper is simply a color gradient, it gradually changes the color of the particles, the first entry being the color they have as they are created. Hope this helps.

@Kepler68 I believe you could add 'sphereOfInfluence = X' to the Properties of a planet.

Also, I have a question myself. It's been a while, but I've got an issue that I don't know how to fix. So, Kopernicus experts, if you've got a sec: I've encountered this issue on three planets I've made so far: whenever a craft drops below a certain altitude, the PQS-surface disappears (and by that I mean that atmospheres and stuff are still there, as well as gravity, the surface just vanishes, although the collission mesh is still there)

So, has anyone heard of that problem before, and more importantly, does anyone know how to fix it?

Share this post


Link to post
Share on other sites

I'm having a problem where my solar panels won't change anything. They always say -infinity. I've read that in the past, this mod caused solar panels to not work. Is that still an issue?

Share this post


Link to post
Share on other sites
2 hours ago, killbotvii said:

I'm having a problem where my solar panels won't change anything. They always say -infinity. I've read that in the past, this mod caused solar panels to not work. Is that still an issue?

if you are using Galactic Neighborhood or any other mod that reparents kerbin + moves it far far away from the center of the universe then this is a known bug which has no solution currently

Share this post


Link to post
Share on other sites
5 minutes ago, Sigma88 said:

if you are using Galactic Neighborhood or any other mod that reparents kerbin + moves it far far away from the center of the universe then this is a known bug which has no solution currently

That was the problem. I'd have to restart my save to fix it, so I'm not doing that. At least it makes the solar panels into generators so they still serve some purpose.

Share this post


Link to post
Share on other sites

Apparently people have overseen the question I've added at the end of my previous comment, I was already afraid that that would happen. I'll just repeat myself here:

It's been a while, but I've got an issue that I don't know how to fix. So, Kopernicus experts, if you've got a sec: I've encountered this issue on three planets I've made so far: whenever a craft drops below a certain altitude, the PQS-surface disappears (and by that I mean that atmospheres and stuff are still there, as well as gravity, the surface just vanishes, although the collission mesh is still there) for no apparent reason.

So, has anyone heard of that problem before, and more importantly, does anyone know how to fix it?

Share this post


Link to post
Share on other sites
On 7.6.2016 at 4:20 PM, Padishar said:

...download this zip and extract the two DLLs it contains into your GameData/Kopernicus/Plugins folder...

Looking around Sonnah is considerably smoother than before, it stays mostly at 60 fps (I have vsync on) now.

I noticed one minor glitch: Going back to the main menu results in a white Sonnah, but normal textures still on. Kinda looking like a golf ball :-)

Share this post


Link to post
Share on other sites
15 minutes ago, hirschhornsalz said:

I noticed one minor glitch: Going back to the main menu results in a white Sonnah, but normal textures still on. Kinda looking like a golf ball :-)

Hmmm, that may be a bug in the stuff I added.  I presume you're pretty certain it doesn't happen with the real 1.0.5 version?  I deleted my New Horizons test install (along with about 6 others) a few days ago so I'll have to set another up and give it a try...

Share this post


Link to post
Share on other sites
9 hours ago, Padishar said:

Hmmm, that may be a bug in the stuff I added.  I presume you're pretty certain it doesn't happen with the real 1.0.5 version?  I deleted my New Horizons test install (along with about 6 others) a few days ago so I'll have to set another up and give it a try...

Yes, but it seems a minor glitch - I have had it happened only once and never seen it again later. So it's not easy reproducable. Maybe related to the timed release of textures.

Share this post


Link to post
Share on other sites
14 minutes ago, hirschhornsalz said:

Yes, but it seems a minor glitch - I have had it happened only once and never seen it again later. So it's not easy reproducable. Maybe related to the timed release of textures.

Well, if you do see it again then please check the output_log.txt/player.log as the on-demand texture load/unload should write details of what it is doing in there.  I suspect something odd like you need to have seen the planet in tracking station, map view or flight, have it go out of view and then quit back to the menu before the 10 second delay is up.  This may confuse it into thinking that the texture is still loaded but the scene change actually discarded it automatically.

Like you say, assuming it fixes itself when you load another save, it is a fairly minor issue, but it could affect more situations so I would like to discover why it happened and fix it if my changes are the cause...

 

Share this post


Link to post
Share on other sites

Hi folks,

This thread has been severely pruned, owing to a lengthy sidetracked discussion on the topic of updating the mod.

Just a friendly reminder of a few points that all of you already know and understand (right?), so I know I don't really have to tell you this:

  • When KSP updates to a new version, it can break mods.  Which means players just have to wait.
  • This includes mods such as Kopernicus, which has an explicit version lock in it that the author chose to place.
  • The author has a good reason for putting such a lock in place, so complaining about it is misguided.
  • Complaining about it is especially misguided because unless you're the author of this particular mod, you don't know what the author of this particular mod has to deal with.  Not to put too fine a point on it, you don't have the slightest clue what you're talking about.
  • Complaining is also mean-spirited, since the fact that you have this wonderful mod at all is because of the many, many hours of selfless effort that the author has put into making this shiny toy which he gives you for free.
  • Mod authors owe you nothing.  At all.  Even slightly.  Really.  You haven't given the author anything, so he doesn't owe you anything.
  • By using any mod, you are fully, completely, and voluntarily taking on all risk that the mod won't be updated as fast as you'd like.  That's just how it is.  If you don't like this condition, then don't use the mod.  Or go write your own.
  • If the KSP update caught you by surprise and this causes you inconvenience:  Yes, that sucks.  There are things you can do to avoid not getting caught by surprise like that again, if this matters to you (e.g. watch the forum for impending KSP updates; don't mod your Steam install; etc.)
  • The mod will be ready when the mod author has the time and inclination to do so.  If you're eager for an update, just watch the mod thread and the author will let you know at his (not your) earliest convenience.

@Thomas P. has done (and continues to do) us all a tremendous favor through all his selfless, public-spirited work in maintaining Kopernicus.  Let's show our appreciation by not jostling his elbow and breathing down his neck, shall we?

Thank you, Thomas, for all that you do for us.

Share this post


Link to post
Share on other sites

Alright! You guys have already let them know. 

That's one less thing I have to complain about today.

Edited by Red Iron Crown

Share this post


Link to post
Share on other sites

A small note on the CompatibilityChecker topic: I don't do this for myself. I could (and have done it already) ignore the Kopernicus thread for some days happily. No, I do this for the planet makers, who are awesome enough to release their stuff into the wild, and were blamed when 1.0.5 broke Kopernicus heavily, and noone was patient enough to wait for the update. If the people blame me for messing up --> fine. If they blame someone else for "my" faults (or rather, Kopernicus bugs), then I get angry.

In other means:

Changelog:

  • Fix mesh colliders very often being out-of-sync with renderers in KSP 1.1.
  • ScaledSpace OnDemand optimisations by Padishar
  • Fixed the Asteroid ScenarioModule, because it prevented other Scenarios from getting spawned
  • Added support for multiple Lensflares
  • Added a dependency on ModularFlightIntegrator, and rewrote the Flux code to support heat from multiple stars
  • Made the spacecenter scene less buggy (it is still broken like hell, and I dont find the component responsible for it)
  • Added a loader for star radiation
  • Fixed the luminosity code for stars
  • Added a switch to prevent an AFG from getting created (Atmosphere { addAFG = false })
  • Randomization for the main menu body
  • Fix for main menu bodies using cbNameLater
  • Fixed BUILTIN MapSO
  • Experimental support for custom lensflares, from Unity asset bundles (Light { sunFlare = Kopernicus/Files/flare.unity3d:nameoftheasset)
  • Add new navballSwitchRadiusMultLow to Properties
  • 1.1.3 API changes (sunDotTransform)

Download:
Get the new version here: https://github.com/Kopernicus/Kopernicus/releases/latest
If you encounter issues, please report them on the issue tracker: https://github.com/Kopernicus/Kopernicus/issues

Like my mods?
icon_donate.png    Please consider supporting me and my mods on Patreon or Paypal! I would greatly appreaciate it, since I don't get much money anyways. :)
    However note, that this doesn't grant you anything special, but it will help to keep my motivation up. Therefor it's just an extremly nice way to say "thanks". :)

Share this post


Link to post
Share on other sites

thank you thomas - and nice statement!

Edit: may i ask what the "onDemand" optimization looks like? I disabled it and was fine with that since i didnt care about RAM.
Will this new way still stutter, but less or in which way did u optimize it?

Edited by Speadge

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.