Thomas P.

[1.7.3-2 + Backports] Kopernicus & KittopiaTech

Recommended Posts

5 hours ago, StarStreak2109 said:

Update: This also happens with "only" Kopernicus + OPM installed...

Turns out I'm a noob and can't install mods by hand...

Runs away and hides in shame... :/

Mind sharing with the rest of the class? I am also getting this error, and have gone over my install a few times...

Edited by Errol

Share this post


Link to post
Share on other sites
4 hours ago, Errol said:

Mind sharing with the rest of the class? I am also getting this error, and have gone over my install a few times...

If you're getting that error then it is likely either a bad installation or a bad mod.  Can't help you without more information.  What are you trying to run that needs Koperniucs?  What versions or everything are you using?  A screenshot of your GameData folder would be a big help.

Share this post


Link to post
Share on other sites

Just started building a 1.4.2 install, trying to use OPM. I will try a fresh install with just OPM + dependencies before going further. 

Share this post


Link to post
Share on other sites
On ‎03‎/‎04‎/‎2018 at 4:45 AM, MerlinsMaster said:

Hey guys,

Has anyone heard of an issue where Kopernicus is causing solar panels not to work?  My solar panels are getting zero exposure when in direct sunlight, and I just installed Kopernicus yesterday.  I googled the problem and there was a link to a forum page talking about some kind of fix, but that link is dead.  I'm happy to provide logs, etc, but I'm just trying to find out if this is a known issue or not first.

Have the same issue, found a solution online that involves disabling Kopernicus's version of the solar panels.
original link: 

original explanation:

I'm using Kopernicus and I didn't wanted to uninstall it. So I placed this file in GameData/Kopernicus/Config/Kopernicus.cfg and now Solar Panels (Photovoltaic) are working again.

// Why we are disabling the Kopernicus custom module implementing their multi-star fix:

// - we can't leverage it for background simulation

// - warp fixer de-facto replace their computations anyway

// - a lot of our code assume a single star, multiple stars support is planned for a future release

// - lack of time to further investigate the interactions

 

@PART:HAS[@MODULE[ModuleDeployableSolarPanel]]:NEEDS[Kopernicus]:FOR[Kerbalism]

{

  @MODULE[ModuleDeployableSolarPanel]

  {

    %useKopernicusSolarPanels = false

  }

}

 

Edited by shachar2like

Share this post


Link to post
Share on other sites
11 hours ago, Errol said:

Mind sharing with the rest of the class? I am also getting this error, and have gone over my install a few times...

Nested GameData-folders.... 'nuff said....

Share this post


Link to post
Share on other sites

Seems to be working on a fresh install, now begins the tedious process of introducing mods one by one to find out which one it doesn't like.

Share this post


Link to post
Share on other sites

Hello, I would appreciate some advice. 
On the Kopernicus github wiki, it states under Rings: "These may be flat discs ... or voluminous cylinders." I was wondering what specifically I should change in a ring config to make it a 'voluminous cylinder' as opposed to flat. I have been re-creating accurate Jupiter rings at Jool size, and am trying to make Jupiter's 'halo'

Share this post


Link to post
Share on other sites
58 minutes ago, PortalGunner said:

Hello, I would appreciate some advice. 
On the Kopernicus github wiki, it states under Rings: "These may be flat discs ... or voluminous cylinders." I was wondering what specifically I should change in a ring config to make it a 'voluminous cylinder' as opposed to flat. I have been re-creating accurate Jupiter rings at Jool size, and am trying to make Jupiter's 'halo'

It's been a while, but try "thickness" and "tiles". Example here.

Share this post


Link to post
Share on other sites
45 minutes ago, HebaruSan said:

It's been a while, but try "thickness" and "tiles". Example here.

Is it only possible to make a toroid? Is there any way to make a torus shape instead?
If not then that's unfortunate :/

Edited by PortalGunner

Share this post


Link to post
Share on other sites

I noticed in the Kopernicus changelog for 1.4.2-1: 

Added a way to deform rings, you can add two curves called InnerRadiusMultiplier and OuterRadiusMultiplier to the ring config

I have no idea how they can currently be used but maybe I'll play around with it. 

I'm also experiencing a problem where the atmosphere's of planets (and Scatterer/EVE effects) become invisible when looking through the ring.
Edit2: Any rings after the first one in my config are causing no atmosphere to render behind them. I've swapped them, and it is always the first one in the config that continues to work while any others don't. 

Spoiler

Here, the outer ring is the first in the config. Using a test texture. qtTF7ZV.png

 

Edited by PortalGunner

Share this post


Link to post
Share on other sites

@Thomas P. Could we get an example for the syntax of this please? :)

Added a way to deform rings, you can add two curves called InnerRadiusMultiplier and OuterRadiusMultiplier to the ring config

Share this post


Link to post
Share on other sites
On 4/10/2018 at 8:45 AM, AlexALX said:

Hello, i have fps problem when installing this mod. Actually if i install just this mod without any other mod, on Mun (and in other cases too) i have much lower fps. Without this mod and other graphical mods it is around 60-77 on surface of mun, but when this mod installed it drops to 35-50 without anything else. If use it with mods like SVT + EVE + SVE + Scatterer, then i have ~20 and in some cases even 15, and removing Kopernicus with SVT (as its dependency on it) i have 30-50 fps again (so EVE + SVE + Scatterer eat around 10-20 fps). Why is this happens? What can i do with that to improve my fps? I don't want lost mods what require kopernicus as dependency (basically i'm using it because of SVT).

Hey AlexALX,

So you are using older version of SVT. You show VERSION: 2.0.9 for KSP 1.3.1 in your logs. 

On SVT 2.1.0 version they made these changes which affect performance.

  • Enabled on demand loading of textures
  • All textures have been relocated to a PluginData folder to speed up initial load

I think the latest version for 1.3.1 is SVT 2.1.3, as SVT 2.1.4 say it was updated to 1.42.

So try updating SVT? And maybe double check the versions of your other mods are up to date. 

I hope this helps.

See below for an explanation for OnDemandLoading.

On 1/8/2016 at 1:36 PM, The White Guardian said:

But, there is one more, simple thing you can do to make your pack over 1000 times better!

How, you might ask. The answer is simple: Kopernicus has an incredible feature called OnDemandLoading: it will only load the textures of planets nearby, so if you would be orbiting Duna for instance, it would only load the textures of Duna and Ike, and won't load the others, such as Moho, Dres, and Jool.

This saves a lot of memory! But, in order to make it work with your pack, there are two things that you must do:

- All textures must be stored in a folder called 'PluginData'. There can be multiple PluginData folders, but as long as all textures are saved in a folder called PluginData, you're good.

- All texture formats must be specified. This step is easy: at the end of every 'texture-filepath', add what format it is: .dds, .png, .jpg, etc.

And done! You are now using OnDemandLoading, which means that everyone using your pack will experience exploration with memory optimized.

 

Share this post


Link to post
Share on other sites

@Barar
Thank you for trying to help, but u
nfortunately you bit miss part about SVT - i tried to run kopernicus without SVT and SVT does not affect fps at all (but logs probably was just when i enabled everything). See this:

Quote

EVE/SVE/Scatterer/DistantObject without kopernicus - 30-55
EVE/SVE/Scatterer/DistantObject with kopernicus - 20-26
EVE/SVE/Scatterer/DistantObject with kopernicus + SVT - 20-26 (so SVT doesn't affect fps at all)

Even if SVT was outdated it still doesn't matter about my fps problem at all. My fps problem starting even when i just install kopernicus without anything else.

As for ' PluginData ' folder - do i need to move textures manually here? I can try this, but for example if i'm using just kopernicus without anything else - what textures i need to move?... I'll try to update mods and see if this will change anything, but i don't think so..

Edited by AlexALX

Share this post


Link to post
Share on other sites

Hello guys, I usually never go to the archives in the R&D building of the space center... I took a look there tonight and I got a infinte spam on nullreferences exception. I went to search into the log file and it said this:

"[EXC 01:16:27.413] NullReferenceException
    Kopernicus.RnDFixer.LateUpdate ()"

So this is why I'm here, Kopernicus thinks there is something missing in the R&D building scientific archives.

I'm using OPM mod as well as SVE, EVE,  Scatterer and JX2 antennae.

Edited by Quoniam Kerman

Share this post


Link to post
Share on other sites
32 minutes ago, 1990eam said:

Is there a Kopernicus Expansion for 1.4? I found some github page but can't like it to an actual project so I don't know where to put the files. The KExp OP is outdated.

https://github.com/StollD/KopernicusExpansion-Continued/releases/tag/1.4.2-1

The install instruction aren’t simple enough?

https://github.com/StollD/KopernicusExpansion-Continued/blob/master/README.md

Share this post


Link to post
Share on other sites
11 minutes ago, 1990eam said:

I didn't understand why there was a separate download file for each asset that's part of the mod that's all.

Because they are all separate mods. It’s modular.

Btw, they don’t do anything on their own. Other mods must have the code implemented in order for the plugins to work.

Share this post


Link to post
Share on other sites

Anyone else get this issue?

//===============================================================================================================//
//=====  Kopernicus 1.4.2-1 - (BuildDate: 31.03.2018 11:39:16; AssemblyHash: 5RQlvMFgycyrY5R8Rz32CjWQ1iI=)  =====//
//===============================================================================================================//
[LOG 00:40:50]: Logger "Kopernicus" was created
[LOG 00:40:50]: Injector.Awake(): Begin
[LOG 00:40:50]: Parsing Target name in (Kopernicus.Configuration.Loader) as (System.String)
[LOG 00:40:50]: Parsing Target timeScale in (Kopernicus.Configuration.Loader) as (Kopernicus.NumericParser`1[System.Double])
[LOG 00:40:50]: Parsing Target scale in (Kopernicus.Configuration.Loader) as (Kopernicus.NumericParser`1[System.Double])
[LOG 00:40:50]: Parsing Target Epoch in (Kopernicus.Configuration.Loader) as (Kopernicus.NumericParser`1[System.Double])
[LOG 00:40:50]: Parsing Target useOnDemand in (Kopernicus.Configuration.Loader) as (Kopernicus.NumericParser`1[System.Boolean])
[LOG 00:40:50]: Parsing Target onDemandLoadOnMissing in (Kopernicus.Configuration.Loader) as (Kopernicus.NumericParser`1[System.Boolean])
[LOG 00:40:50]: Parsing Target onDemandLogOnMissing in (Kopernicus.Configuration.Loader) as (Kopernicus.NumericParser`1[System.Boolean])
[LOG 00:40:50]: Parsing Target onDemandUnloadDelay in (Kopernicus.Configuration.Loader) as (Kopernicus.NumericParser`1[System.Int32])
[LOG 00:40:50]: Parsing Target useManualMemoryManagement in (Kopernicus.Configuration.Loader) as (Kopernicus.NumericParser`1[System.Boolean])
[LOG 00:40:50]: Parsing Target mainMenuBody in (Kopernicus.Configuration.Loader) as (System.String)
[LOG 00:40:50]: Parsing Target maxViewingDistance in (Kopernicus.Configuration.Loader) as (Kopernicus.NumericParser`1[System.Double])
[LOG 00:40:50]: Parsing Target scaledSpaceFaderMult in (Kopernicus.Configuration.Loader) as (Kopernicus.NumericParser`1[System.Double])
[LOG 00:40:50]: [Kopernicus]: Configuration.Loader: Failed to load Body: Sun
[LOG 00:40:54]: [Kopernicus] RuntimeUtility Started
[LOG 00:40:54]: StarLightSwitcher.Awake(): Begin
[LOG 00:41:06]: Injector.OnDestroy(): Complete
 

I had SVE and OPM installed and removed Kopernicus so it removed everything that needed it and installed Kop by itself and even without any other mods accessing it it crashes.  It says it failed to load the config.  Everything works without Kop.

Share this post


Link to post
Share on other sites
6 hours ago, Galileo said:

Because they are all separate mods. It’s modular.

Btw, they don’t do anything on their own. Other mods must have the code implemented in order for the plugins to work.

I don't think that's right, actually. The reentry module seemed to add reentry effects, Emissive Oceans seems to sometimes cause Kerbin's oceans to glow (fsr), and Animated Gas Giants seems to work fine. Not sure about the others, however. The only mod I have that might use them is the base Kopernicus.

Edited by PortalGunner

Share this post


Link to post
Share on other sites
4 hours ago, PortalGunner said:

I don't think that's right, actually. The reentry module seemed to add reentry effects, Emissive Oceans seems to sometimes cause Kerbin's oceans to glow (fsr), and Animated Gas Giants seems to work fine. Not sure about the others, however. The only mod I have that might use them is the base Kopernicus.

What are you talking about? I know what the mods do, and they are all separate... Kopernicus doesn’t use them. Planet packs may use them, but the devs have to implement the code. The dlls don’t do anything on their own. I would know, as I add the code for a couple of the dlls in a few of my mods.. so what about my statement wasn’t right?

7 hours ago, mjones1052 said:

Anyone else get this issue?

-snip-

I had SVE and OPM installed and removed Kopernicus so it removed everything that needed it and installed Kop by itself and even without any other mods accessing it it crashes.  It says it failed to load the config.  Everything works without Kop.

What issue? That’s kopernicus starting up...

you will need to do a proper bug report if your game is crashing. I doubt it’s Kopernicus, but we won’t know until we get the right troubleshooting files.

Edited by Galileo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.