Thomas P.

[1.7.3-2 + Backports] Kopernicus & KittopiaTech

Recommended Posts

14 hours ago, ss8913 said:

When I get around to a recompile I'll let you know if it works.  That's fixed a lot of mods for me, even ones that haven't been updated past 1.3.x, such as far and kjr.

Wait, wait, what? FAR needs a simple recompile to be 1.4-compatible?

Share this post


Link to post
Share on other sites

I'm taking the high road and bribing the man.  You've got cash for a beer on PayPal.

lol, you da man Thomas P.!

Share this post


Link to post
Share on other sites
18 hours ago, AdistarVoid said:

Is there anyway of knowing what coordinate each point in the surface texture is. If there is a way of knowing, then that would solve my problem (hopefully).

You can get close.  But it depends on what format image you are using, because different formats are flipped differently.  I use .dds, which is flipped both vertically and horizontally (i.e. rotated 180 degrees) from what you see in game.  If you use .png then they are flipped horizontally only.

I believe you mentioned a .png image.  So in that case the top of the texture is 90o north, and the bottom is 90o south (a .dds is reversed).  Everything in between is linearly spaced.  So if you are say, 1/4th of the way down from the top of the texture, that's corresponds to 45o N latitude.

Longitude works pretty much the same way, but the prime meridian (0o longitude) is 1/4 of the way from left to right.  So, for example, if you have a 4096x2048 texture, the prime meridian is located 1024 pixels in from the left edge.  Also note that east and west are flipped from the normal map directions.  The middle of the texture is 90o W longitude.

Knowing this, you should be able to compute the latitude and longitude of any pixel in the texture, or vice versa.  The computed location should get you close, but there will likely be some error.  You'll probably have to fine tune it to get KSC located precisely where you want it.

Edited by OhioBob

Share this post


Link to post
Share on other sites
3 hours ago, Angstinator said:

Wait, wait, what? FAR needs a simple recompile to be 1.4-compatible?

It's an offtopic, but I believe there is a 1.4-compatible beta release of FAR somewhere on the forum. At least I'm using it with no issues.

Share this post


Link to post
Share on other sites
5 hours ago, OhioBob said:

You can get close.  But it depends on what format image you are using, because different formats are flipped differently.  I use .dds, which is flipped both vertically and horizontally (i.e. rotated 180 degrees) from what you see in game.  If you use .png then they are flipped horizontally only.

I believe you mentioned a .png image.  So in that case the top of the texture is 90o north, and the bottom is 90o south (a .dds is reversed).  Everything in between is linearly spaced.  So if you are say, 1/4th of the way down from the top of the texture, that's corresponds to 45o N latitude.

Longitude works pretty much the same way, but the prime meridian (0o longitude) is 1/4 of the way from left to right.  So, for example, if you have a 4096x2048 texture, the prime meridian is located 1024 pixels in from the left edge.  Also note that east and west are flipped from the normal map directions.  The middle of the texture is 90o W longitude.

Knowing this, you should be able to compute the latitude and longitude of any pixel in the texture, or vice versa.  The computed location should get you close, but there will likely be some error.  You'll probably have to fine tune it to get KSC located precisely where you want it.

Ah, thanks man.
I spent the whole day endlessly changing the latitude & longitude hoping I'd hit land eventually (i dont know how but I managed to get the KSC like 100000KM off the surface)
Lets hope I can finally get the KSC onto the planet now.

Share this post


Link to post
Share on other sites
On 6/27/2018 at 7:18 AM, Thomas P. said:

No

sorry to be annoying, but when do you assume you will be able to release Kopernicus for 1.4.4

Share this post


Link to post
Share on other sites
19 minutes ago, TheEnderman said:

sorry to be annoying, but when do you assume you will be able to release Kopernicus for 1.4.4

You ARE annoying.  Have you even tried reading any of the posts above?

and, it's against the forum rules, 2.2.p:

Quote
  1. Demanding or pressuring for release dates or updates from Take-Two or content creators.

Complete forum rules are here:

https://forum.kerbalspaceprogram.com/index.php?/guidelines/

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
34 minutes ago, linuxgurugamer said:

You ARE annoying.  Have you even tried reading any of the posts above?

and, it's against the forum rules, 2.2.p:

Complete forum rules are here:

https://forum.kerbalspaceprogram.com/index.php?/guidelines/

oh, sorry. i didn't remember that being in the rules

Share this post


Link to post
Share on other sites
16 hours ago, TheEnderman said:

oh, sorry. i didn't remember that being in the rules

It's a common courtesy, for the huge amount of free time and devotion the modders give to this community, shouldn't need to be a rule :)

For an update on any mod-related release schedule, please read this wiki page to know when to expect an update: https://developer.valvesoftware.com/wiki/Valve_Time

Edited by phoenix2004uk

Share this post


Link to post
Share on other sites

So I tried looking at the code, loading it in VS 2015 to see what the incompatibility with KSP 1.4.4 may be and eventuellay help devs with it.

I love this mod and thx to the original authors and contributors for putting together.

 

Unfortunately I've come across a snag I don't quite understand. When trying to compile the Kopernicus.OnDemand project, the class Native byte array has a method returning a ref... this gives me a compile time error: I don't understand why. I'm using framework 3.5

 

Has anyone encountered this issue before ? I've tried a few things: looking for a vs update, changing framework among the main but with no results...

 

Share this post


Link to post
Share on other sites

So Sorry for being an stupid person. I do hate myself already.

 

 

what is it with these auto correct???

I was calling myself an [word removed by moderator]

Edited by Deddly
The language filter is there for a reason, please don't evade it

Share this post


Link to post
Share on other sites

Is there any way to disable the version lock? I would like to at least try Kopernicus in 1.4.4...

Share this post


Link to post
Share on other sites
1 hour ago, Alphard said:

Is there any way to disable the version lock? I would like to at least try Kopernicus in 1.4.4...

if you have the source code and visual studio or a linux mono compiler setup, sure.  just find the compatibility checker routines and modify them, then recompile it.  I'm sure there's a good reason why it's locked though, I doubt this would have the results you're hoping for.

Share this post


Link to post
Share on other sites
Just now, ss8913 said:

if you have the source code and visual studio or a linux mono compiler setup, sure.  just find the compatibility checker routines and modify them, then recompile it.  I'm sure there's a good reason why it's locked though, I doubt this would have the results you're hoping for.

Ok, just going to revert to 1.4.3. Also, does anyone know if OPM 1.4.2 works with 1.4.3 Kopernicus?

Share this post


Link to post
Share on other sites
1 minute ago, Alphard said:

Ok, just going to revert to 1.4.3. Also, does anyone know if OPM 1.4.2 works with 1.4.3 Kopernicus?

It worked for me.

Generally content packs like OPM work fine across minor versions like that, only stuff that affects the core of KSP tends to break.

Share this post


Link to post
Share on other sites

When will the 1.4.4 update come out?

 

Share this post


Link to post
Share on other sites
11 hours ago, Alphard said:

Is there any way to disable the version lock? I would like to at least try Kopernicus in 1.4.4...

1.4.4 is a waste of time (Squad just announced 1.4.5, which exists because 1.4.4 was another rushed and half-baked patch). Go back to 1.4.3.

Try to see from the mod-maker's perspective and try not to rush for KSP updates. They're never the pure and solid gold you may think they are. Thomas.P knows this.

6 hours ago, BGYT said:

When will the 1.4.4 update come out?

That... may depend on how fast 1.4.5 gets here.

Share this post


Link to post
Share on other sites
6 hours ago, BGYT said:

When will the 1.4.4 update come out?

When everyone stops asking for it

On 6/30/2018 at 7:30 PM, bru stmopf said:

So I tried looking at the code, loading it in VS 2015 to see what the incompatibility with KSP 1.4.4 may be and eventuellay help devs with it.

I love this mod and thx to the original authors and contributors for putting together.

 

Unfortunately I've come across a snag I don't quite understand. When trying to compile the Kopernicus.OnDemand project, the class Native byte array has a method returning a ref... this gives me a compile time error: I don't understand why. I'm using framework 3.5

 

Has anyone encountered this issue before ? I've tried a few things: looking for a vs update, changing framework among the main but with no results...

 

ref-returns are a C# 7 feature, which means you need VS 2017 to compile them.

If you don't want to upgrade your installation (I can understand that, last time I tried my system got cursed), you can remove the refs and add this to your GameData to make sure the native byte array method isn't used and cannot cause memory leaks:

@Kopernicus:FINAL
{
	%useManualMemoryManagement = False
}

 

Edited by Thomas P.

Share this post


Link to post
Share on other sites

hi, i'm waiting for 1.4.4,  or 1.4.5,  meanwhile i try to play whit KPS 1.4.3, but kopernicus give me the same problem, is impossible to load the savegame, because the mod don't work, can anyone help me?

Thanks

 

Edited by Milvus

Share this post


Link to post
Share on other sites

For those, like me looking for any and all news, there has been some kopernicus activity in the last couple days on github.

https://github.com/Kopernicus/Kopernicus/commit/a510d469853cee17ae210f5e1a9d3f85aa10af15

"Compile against 1.4.4" ... which I take to mean that a 1.4.4 release is in the works.  That's big news for me as I feared we might have to wait for 1.5.

Edited by Sandworm

Share this post


Link to post
Share on other sites
2 hours ago, Sandworm said:

For those, like me looking for any and all news, there has been some kopernicus activity in the last couple days on github.

https://github.com/Kopernicus/Kopernicus/commit/a510d469853cee17ae210f5e1a9d3f85aa10af15

"Compile against 1.4.4" ... which I take to mean that a 1.4.4 release is in the works.  That's big news for me as I feared we might have to wait for 1.5.

Yep I here has been some minor work done, but I think the dev plans to wait until 1.4.5 since squad has already made it clear that it’s coming quick on the heels of 1.4.4 :/ 

Share this post


Link to post
Share on other sites

A lot of content has been pruned from this thread, in which a lengthy exchange completely derailed the thread into endless bickering over "irritated mod authors!" versus "entitled users!"

Folks, this is the Kopernicus thread.  It's the place where people go if they want to find out the latest information about Kopernicus development, or to get helpful tips if they have technical difficulties with it, that sort of thing.

It is not the place to air your grievances (whether it's "those gosh-darn mod authors shouldn't be so irritable" or "those gosh-darn mod users shouldn't be so entitled").  There's absolutely nothing wrong with having a discussion about the dynamics of author-user interactions, vis-à-vis mods, but this thread is not the place to do itNobody comes here because they want to read endless pages of bickering about things that have nothing to do with the mod.  It's off-topic.  If you want to have such a conversation, fine, but take it elsewhere, please.

For anyone who's still unclear about how all this works, perhaps a quick FAQ is in order.  The following FAQ applies to basically any mod, not just Kopernicus.

  • Q:  When will the updated mod be ready?
  • A:  When it's ready.
  • Q:  No, but could you clarify?  I mean, when?
  • A:  As soon as the mod author has time and inclination to do so, at their convenience.
  • Q:  Yes, but what time frame?  Tomorrow?  Next week?  A month?  When?
  • A:  If the mod author 1. knew when, and 2. wanted to share it, then presumably they would have already done so.  If the information's not there, then it means that the author has chosen not to say anything, in which case the polite thing to do is to respect their decision and not heckle them about it.
  • Q:  But I really want to know.
  • A:  It's nice to want things.  Please bear in mind, though, that so do the thousands of other users who use the mod... and there's only one mod author, who does this as a hobby in their scarce free time, and who has IRL responsibilities (such as job, school, family, whatever) that obviously take precedence.  It's understandable that mod authors can get exhausted trying to keep up with the endless demands on their time from users who have trouble being patient.  Asking this kind of stuff does sap the author's time and energy, and doesn't make the update happen any faster.  Sometimes, quite the reverse.  Also, bear in mind that the mod author doesn't owe you anything.  Not one whit.  Not now, not ever.  So please, just be patient, and it'll be ready when it's ready.
  • Q:  Someone said something I don't like!
  • A:  Alas, we walk through a vale of tears.  This too shall pass.

 

So please, folks.  Questions and answers directly about Kopernicus are on-topic here.  Arguing about how mod authors or mod users should act is not.  Arguing about arguing especially is not. Let's stay on-topic, shall we?

Thank you for your understanding.

Share this post


Link to post
Share on other sites
6 hours ago, Snark said:

elsewhere

I eagerly clicked "elsewhere" hoping it was a link to where we can go vent our grievances

:D

Share this post


Link to post
Share on other sites

Hi all, I had a quick question. Is there is a limit on the minimum radius you can give to a planet/moon? I'm trying to make a moon that's 1km in radius, but when I get close to it, it vanishes from view and I always crash into it. If I try to use the debug menu to go into orbit around it, it always immediately crashes into the moon, no matter how far away I set the orbit. I added the code below:

 

@Kopernicus:AFTER[Kopernicus]
{    
    Body
    {		
		name = Peor
        
        Properties
        {
			radius = 1696
			mass = 1.00383e+15
        }
        
		Orbit
		{
			referenceBody = Duna
			inclination = 1.093
            eccentricity = 0.0151
            semiMajorAxis = 883000
		}
		
		ScaledVersion
        {
            type = Vacuum
            
            Material
            {
                // Common scaled space settings
                texture = MyConfig/Planets/Duna/PluginData/Peor/Color.dds
                normals = MyConfig/Planets/Duna/PluginData/Peor/Normals.dds
                shininess = 0
                specColor = 0,0,0,0
            }
        }
    }
}

 

Share this post


Link to post
Share on other sites
2 hours ago, Siconix said:

Hi all, I had a quick question. Is there is a limit on the minimum radius you can give to a planet/moon?

I don't know if there's a minimum, but I've gone as small as 7000 meters and it worked.  Never tried anything smaller than that.

BTW, I think your config needs to include a template.  I'm not sure it will work without one.  Try something like this:

@Kopernicus:AFTER[Kopernicus]
{
	Body
	{
		name = Peor
		Template
		{
			name = Moho
			removeAllPQSMods = True		// If you do this, you'll need to add back whatever PQSmods you need.
		}
		Properties
		{
			...

 

Edited by OhioBob

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.