Thomas P.

[1.7.3-2 + Backports] Kopernicus & KittopiaTech

Recommended Posts

11 hours ago, gap said:

Silly question here :wink:

Before the 1.7.1 update I have been playing the game with Kopernicus installed mostly because it is one of the mods recommended by Astronomer's Visual Pack, but I haven't installed any custom planetary system mod (nor any other mod relying on Kopernicus), which probably negates the purpose of this mod. Can I keep on playing my current campaign, or I better wait for the upcoming Kopernicus version? 

Kopernicus usually breaks solar panels in old versions of ksp. The version lock does not prevent this. best to remove it from your game data folder if your going to play 1.7.1 until it gets updated.

Share this post


Link to post
Share on other sites

Any G2 when Kopernicus is to be updated to run in 1.7.1?

Missing my OPM Mod :(

Regards With Thanks!

Share this post


Link to post
Share on other sites
3 hours ago, snkiz said:

Kopernicus usually breaks solar panels in old versions of ksp. The version lock does not prevent this. best to remove it from your game data folder if your going to play 1.7.1 until it gets updated.

Thank you for your reply snkiz!
I already removed Kopernicus  from my CKAN mod list. My question was more:  seeing that  previously I had not installed any mod relying on Kopernicus, can I keep playing my old career (stat I started with Kopernicus installed), or not?

Share this post


Link to post
Share on other sites
2 hours ago, jbarry39 said:

Any G2 when Kopernicus is to be updated to run in 1.7.1?

Missing my OPM Mod :(

Regards With Thanks!

When it`s done.

Share this post


Link to post
Share on other sites

It's intriguing to see how many people here are skilled/experienced enough at KSP that they can benefit from mod planet packs, while being inexperienced enough that they let the game auto-update. I wouldn't have expected those demographics to overlap.

"Play modded ksp from a cloned directory" used to be common knowledge.

Share this post


Link to post
Share on other sites
1 minute ago, ExtremeSquared said:

It's intriguing to see how many people here are skilled/experienced enough at KSP that they can benefit from mod planet packs, while being inexperienced enough that they let the game auto-update. I wouldn't have expected those demographics to overlap.

"Play modded ksp from a cloned directory" used to be common knowledge.

Lesson learned.
So far I had thought that any KSP version could be retrieved from Steam, and I would gladly get back to v1.7.0 while some mods are getting updated, but as I see not all the old versions are available for download, and v1.7.0 is not among them...

Share this post


Link to post
Share on other sites
22 minutes ago, gap said:

but as I see not all the old versions are available for download, and v1.7.0 is not among them...

Huh? I can get 1.7.0 via steam and if you need a version which is not listed in the beta dropdown menu, there are a ton of tutorials how to do it, for example this one:

https://steamcommunity.com/sharedfiles/filedetails/?id=1086279994

(Yes, a bit offtopic but you know....it's helpful offtopic :confused:)

Share this post


Link to post
Share on other sites
2 minutes ago, 4x4cheesecake said:

Huh? I can get 1.7.0 via steam and if you need a version which is not listed in the beta dropdown menu, there are a ton of tutorials how to do it, for example this one:

https://steamcommunity.com/sharedfiles/filedetails/?id=1086279994

(Yes, a bit offtopic but you know....it's helpful offtopic :confused:)

Wow, I didn't know that... :confused:

Thank you very much 4x4cheesecake, I will put your suggestion in practice ASAP!

Share this post


Link to post
Share on other sites
32 minutes ago, gap said:

Lesson learned.
So far I had thought that any KSP version could be retrieved from Steam, and I would gladly get back to v1.7.0 while some mods are getting updated, but as I see not all the old versions are available for download, and v1.7.0 is not among them...

Are you sure? I just checked for the same problem of mod waiting and KSP v.1.7.0 is just there.

Share this post


Link to post
Share on other sites

Kopernicus doesn't seem to work on 1.7.1. I used ckan and it doesn't show as compatible with the latest version. I enabled mods for 1.6.X where kopernicus is located and installed it, it installed just fine with the Outer Planets Mod but when I went in game (fresh install, no mods or saves an only kopernicus and OPM) there were no outer planets and the default system was there. I also tried this with the extra solar planets mod and again nothing. Shouldn't Kopernicus have worked even if it is the 1.6.X compatible version? Or did 1.7.1 change things so drastically that the latest version of kopernicus is just simply incompatible?

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Pentazer said:

Kopernicus doesn't seem to work on 1.7.1. I used ckan and it doesn't show as compatible with the latest version. I enabled mods for 1.6.X where kopernicus is located and installed it, it installed just fine with the Outer Planets Mod but when I went in game (fresh install, no mods or saves an only kopernicus and OPM) there were no outer planets and the default system was there. I also tried this with the extra solar planets mod and again nothing. Shouldn't Kopernicus have worked even if it is the 1.6.X compatible version? Or did 1.7.1 change things so drastically that the latest version of kopernicus is just simply incompatible?

[snip]  Go back to about page... let's say 153 and start reading posts until you catch up to here.

[snip]

Edited by Gargamel
Portions Redacted by Moderator

Share this post


Link to post
Share on other sites

Oh I did go back but not that far. The subject matter seemed to be going in a different direction. My bad. I'll go back further.

Share this post


Link to post
Share on other sites

Guys, if we required people to read every thread all the way through before asking a question, then the forum would just be a bullet point list.  Instead of jumping down peoples' throats for asking a polite question, let's just steer them towards the answer in a polite manner?   Thanks!

Side note, if you are reporting a post, please include why you are reporting it, otherwise we just have to guess.  Sometimes, the problem with a post is not obvious. 

Share this post


Link to post
Share on other sites

Hmm, would removing this mod (along with all planet packs of course) from a game which previously had planet packs and various ships with solar panels lead to a boatload of NREs basically everywhere?

Share this post


Link to post
Share on other sites

Removing mod mid-save will surely break the game, but maybe anyone had experience with adding Kopernicus+OPM to existing save?

I mean play 1.7.1 with dlc now and , when mod is updated , add kopernicus+OPM to existing save. OPM do not modify stock planets AFAIK.

 

Share this post


Link to post
Share on other sites
4 hours ago, Saara said:

Removing mod mid-save will surely break the game, but maybe anyone had experience with adding Kopernicus+OPM to existing save?

Kopernicus to an existing save by itself is fine... its what is put on top of kopernicus that may break your save. If you use kopernicus to resize everything 3x (for example), then your station orbiting stock kerbin at 150 km is going to be toast.

Quote

OPM do not modify stock planets AFAIK.

Doesn't it move Eeloo, and make it a moon of Sarnus, in addition to adding craters to it?

Other than Eeloo, I think that you are right.

Share this post


Link to post
Share on other sites

I've removed OPM and Kopernicus from savegames in previous updates (before I learnt to play from a cloned install).  Any craft in orbit of (or landed on) a Kopernicus-enabled body will disappear - in this case that includes all OPM planets/moons and Eeloo, which is moved by OPM.  Any ships on the way to an OPM planet (i.e. in SOI of the sun and on an intercept path) will be fine but will obviously no longer intercept anything.

It is possible to edit the orbits of ships in the sfs file to move them into orbit of the sun if you want to save them from impending doom.  Plenty of guides/info on how to do that on these forums and the wiki.  Or you can hyperedit them back in afterwards. Or just load up a replacement craft and use the regular cheat menu to bung them into orbit.  Whatever works for you.

Solar panels will be in the retracted state when you next load them, because of the changed Kop makes to panels.  You just have to deploy them again.

Best practice is to copy your whole KSP game folder and run the game out of that so it's not autoupdated by Steam (KSP doesn't need Steam online to run).  You can point CKAN to multiple installs of KSP no probs.  Then just use the Steam version for testing new stuff and marvelling at the nostalgia of modless KSP.

Share this post


Link to post
Share on other sites

Well, I'm marvelling at easy mode for the moment. I was playing a career with Mun where Minmus is, Minmus moved to an orbit similar to Dres (as if its an asteroid), and (almost) everything scaled up by 3x (the sun gets tweaks, Dres doesn't scale up, I tweak the moons of Jool), with a 1.25x atmosphere rescale.

Getting to the Mun is a lot harder, and science is a lot harder to grind with the lack of Minmus (so I did up the multipliers a bit for kerbin, and I gave Mun the multipliers of Minmus).

Now my plan is to do the initial science grind in easy mode 1x KSP, and take everything out of orbit before using kopernicus again. That will mean deorbiting a fuel depot around Mun... but hey, I need to get that seismometer data somehow.

All my mun landers will be overbuilt so that they still work fine in 3x (stuff that is landed should be fine for the transition)

Share this post


Link to post
Share on other sites
13 hours ago, Saara said:

Removing mod mid-save will surely break the game, but maybe anyone had experience with adding Kopernicus+OPM to existing save?

I mean play 1.7.1 with dlc now and , when mod is updated , add kopernicus+OPM to existing save. OPM do not modify stock planets AFAIK.

 

I did this once a while back (1.4.x-ish IIRC), and the only issue I encountered was a probe headed for Eeloo ended up going to an empty point in space since Eeloo became a moon of Sarnus.  But everything else was untouched.  If you already have craft at Eeloo, either in orbit or landed, I'm not sure what happens to them. 

Share this post


Link to post
Share on other sites
On 6/4/2019 at 8:37 PM, Gargamel said:

Guys, if we required people to read every thread all the way through before asking a question, then the forum would just be a bullet point list. 

Also, to build upon what Gargamel has said, if users cannot even be expected to read a LARGE pop up every time they load the game saying that "KOPERNICUS IS NOT RUNNING DUE TO NOT BEING INSTALLED CORRECTLY/ON THE CORRECT VERSION OF KSP", then how can we justifiably expect them to read through even more than like, the last two previous posts on a thread.

Anyway, to add to the discussion above, installing Kopernicus and any planet mods that add bodies mid-save is not an issue as long as the mod is no longer using the flight globals index numbers for the planetary bodies (most now do not as this was deprecated a good while back). Adding in a planet mod that edits bodies mid-save could cause issues. Any vessel around said body will follow the body wherever it is moved to and if the surface topology is altered, any surface based vessels could potentially explode due to suddenly being above/below ground. Adding a planet pack mid-save that completely changes the system i.e. new system entirely, will most likely cause the vast majority of your vessels to be deleted.

Removing Kopernicus and any planet mods mid-save should be fine as long as you don't have any vessels around any bodies that are being removed/altered, HOWEVER, as all your solar panels on all vehicles will be using Kopernicus' solar panel module, it is almost guaranteed that all vessels with solar panels that were created with Kopernicus installed will no longer function.

Share this post


Link to post
Share on other sites

Wonder how kopernicus will handle new surface feature from DLC if they have any impact on how kopernicus work.

Each ksp update, i really happy that ksp is not steam drm lock, so we can play with the old version and mod while waiting mod compatibility with new version.  At the opposite we have fallout 4 who force update very often ( Creation Club bulsh****) who prevent modded games to play until f4se update. Have to get a cracked copy for playing quietly....

Please squad, never add steam DRM to KSP. kopernicus forum will becomes "99.9999%" of update reclamation. Remind me of the seagull of nemo film.

We never enough thanks mod developer,  KSP will be less godlike without you.

 Good luck for your development!  

Share this post


Link to post
Share on other sites
Posted (edited)

If KSP did forced updates, somebody would remove the Kopernicus version lock, sooner or later. Remember, the source is available, as per the forum rules, and disabling the checker from there is not exactly difficult. It's just a piece of code copypasted from the forum, completely separate from the actual plugin.

That said, I wouldn't worry. Steam is not the only way to buy KSP, and they have no real means to force the KSP Store users to update.

Edited by Dragon01

Share this post


Link to post
Share on other sites
16 hours ago, Poodmund said:

Also, to build upon what Gargamel has said, if users cannot even be expected to read a LARGE pop up every time they load the game saying that "KOPERNICUS IS NOT RUNNING DUE TO NOT BEING INSTALLED CORRECTLY/ON THE CORRECT VERSION OF KSP", then how can we justifiably expect them to read through even more than like, the last two previous posts on a thread.

Anyway, to add to the discussion above, installing Kopernicus and any planet mods that add bodies mid-save is not an issue as long as the mod is no longer using the flight globals index numbers for the planetary bodies (most now do not as this was deprecated a good while back). Adding in a planet mod that edits bodies mid-save could cause issues. Any vessel around said body will follow the body wherever it is moved to and if the surface topology is altered, any surface based vessels could potentially explode due to suddenly being above/below ground. Adding a planet pack mid-save that completely changes the system i.e. new system entirely, will most likely cause the vast majority of your vessels to be deleted.

Removing Kopernicus and any planet mods mid-save should be fine as long as you don't have any vessels around any bodies that are being removed/altered, HOWEVER, as all your solar panels on all vehicles will be using Kopernicus' solar panel module, it is almost guaranteed that all vessels with solar panels that were created with Kopernicus installed will no longer function.

So is it that Kopernicus is not compatible or is it more accurate to say that OPM is not compatible with the latest version of kopernicus due to all that...refactoring stuff that I can't make sense out of. I'm not really sure what happened but from what Thomas P said, his latest update breaks OPM and every other mod that relies on it? I Think?

Share this post


Link to post
Share on other sites

@Pentazer What Thomas P said is his NEXT update MIGHT break other planet packs. It depends on how the planet pack is put together. The latest released version of Kopernicus is only available for 1.7 or earlier, but not yet for 1.7.1.

OPM is compatible with 1.7, so OPM is compatible with the latest released version of Kopernicus.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.