Thomas P.

[1.7.3-2 + Backports] Kopernicus & KittopiaTech

Recommended Posts

13 minutes ago, Thomas P. said:

My solution works for me and seemingly the majority of the people. If it wouldn't work, people would fork it and remove it. Thats the beauty of opensource after all.

I for one thank you for the time and effort you put into this. I understand modding and how things can break easily. I have a personal mod that I've had to make some minor changes each time KSP changes. I'm part of the (hopefully) majority that can patiently wait until the mod gets updated properly.

Share this post


Link to post
Share on other sites
Posted (edited)

After wading through the last two pages of comments, I just want to say two things:

1. Thankyou, THANKYOU, *THANKYOU*!!!!... to whoever created Kopernicus, and to everyone who has maintained it since.

[SNIP]

(For the record, I'm currently playing KSP version 1.4.5. Why? Because I'm using RSS, and back when I started this instance that was the most recent version that RSS was fully compatible with. I wish I had some of the nice features of KSP 1.5, or 1.6, and I haven't tried any variant of 1.7 yet so I don't know whether to wish I had those, too... But hey, I'm having a good time anyway. When my current "timeline" is all played out, maybe then I'll see what's new in KSP version 1.9.73, or even be tempted to pay for version 2.0.3...? =:o} )

 

Edited by Gargamel
Portions Redacted by Moderator

Share this post


Link to post
Share on other sites

@Thomas P.

A big thank you for all the work you do for this.

Do you have a Paypal or Patreon link?  I'd like to send something your way.

Share this post


Link to post
Share on other sites

Ok guys....  You know how this goes.  Play nice.  Some posts have been removed or edited as they were starting to get personal. 

If you don't agree with somebody, you are not required to engage with them.  If you know a particular poster will just upset you, then don't read it. 

Share this post


Link to post
Share on other sites

The wisdom of running modded KSP from a cloned folder can't be overstated. Saves so much heartache and nerves when updates hit. "Updates? Yeah, I'll get to that when the dust has settled, meanwhile I'll just play on as if nothing happened."
You can also keep a zip of a virgin installation of a version as backup in case you mess up with the mods, the zip somewhat preventing direct (ab)use.

Share this post


Link to post
Share on other sites

Many, many posts have been removed.

Folks. Just a few days ago, it was made clear by the moderator team here in this thread that the topic of the version lock, and arguing about it, are done. Kindly refrain from rehashing it. Do not argue about it here, and if someone else does, just report them and do not continue the argument.

Thank you.

Share this post


Link to post
Share on other sites

Thank you so much for your work on this mod :) I use it with the Outer Planets and it really makes me excited to Kerbal all over again

Share this post


Link to post
Share on other sites

I may have been a bit harsh in asking about updates all the time. I'm sorry. I re-looked at your post and just realized how much work you have put in, and all for free. I would actually donate to you now, but I don't earn my own money yet (underage) and so cannot do such things. I hope ksp last until I make my own money so you can have your reward

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Rover 6428 said:

I may have been a bit harsh in asking about updates all the time. I'm sorry. I re-looked at your post and just realized how much work you have put in, and all for free. I would actually donate to you now, but I don't earn my own money yet (underage) and so cannot do such things. I hope ksp last until I make my own money so you can have your reward

@Rover 6428 I have made a $10 donation on your behalf to http://paypal.me/thmsp. I can send you the "receipt" if desired.

When you're earning money yourself, please send him another donation and return the favor.

Edited by seevee

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/14/2019 at 12:54 AM, linuxgurugamer said:

@Thomas P.

A big thank you for all the work you do for this.

Do you have a Paypal or Patreon link?  I'd like to send something your way.

It's in the OP. I may have sent a bit myself :)

Edited by Jognt

Share this post


Link to post
Share on other sites
18 minutes ago, Galland1998 said:

Anyone got a feel a safe PE to renter at on the new Kerbin is? On stock Kerbin I never had an issue but on this new glorious Kerbin things keep blowing up and I haven't even made the reentry settings harder.

It depends on what planet mod you have installed.

Share this post


Link to post
Share on other sites

@Thomas P. Thank you for such an amazing mod and maintaining it for so long. We all appreciate the hard work you do. Popping in new planets has kept KSP fresh over the years and kept me coming back. It's pretty much an essential for me at this point and hope it's updated soon.

I do understand however the frustration with kopernicus going down with each update. For the average modder every update probably breaks around 4 kopernicus dependent mods. Of course a good solution is to not update or play on a backup install, but people forget or have a tendency to want the latest and greatest. It would be great if the game just had a built in planet creator. 

Share this post


Link to post
Share on other sites
Posted (edited)

Ksp 1.7.2, Kopernicus 1.7.1 - 5

"This Mod is incompatible with the current version of KSP. Please do not try to open your saved games."

Can I ignore this or will I have to wait for the update?

Thanks in advance.

Edited by fulgur
This is a great mod.

Share this post


Link to post
Share on other sites
Posted (edited)
4 minutes ago, fulgur said:

Ksp 1.7.2, Kopernicus 1.7.1 - 5

"This Mod is incompatible with the current version of KSP. Please do not try to open your saved games."

Can I ignore this or will I have to wait for the update?

Well, if you want to find out exactly why that warning message is there you're free to ignore it. :D

I'll warn you ahead of time though: That message is definitely there for a reason. ;)

Edit: My apology for my sarcastic tone above ;) I'm just a smartass. :P
I realize the message looks a lot like the many many other "incompatible version, please use 1.x.x" messages we get from mods that work fine, but this message is legit. Note the specific warning to not open your saved game, which implies consequences for that if you were to do so.

Edited by Jognt

Share this post


Link to post
Share on other sites
26 minutes ago, fulgur said:

Ksp 1.7.2, Kopernicus 1.7.1 - 5

Well I mean you answered your own question :P

Share this post


Link to post
Share on other sites

I was mainly asking as in the file it says

    "KSP_VERSION":
    {
        "MAJOR": 1,
        "MINOR": 7,
        "PATCH": 1
    }

so I was wondering whether there really was something incompatible with the 1.7.2 patch which would summon the Kraken or whether it was just displaying that message because it's a massive mod which will eat half your ships if the planet they're orbiting / landed on disappears.

Share this post


Link to post
Share on other sites
4 minutes ago, fulgur said:

I was mainly asking as in the file it says

    "KSP_VERSION":
    {
        "MAJOR": 1,
        "MINOR": 7,
        "PATCH": 1
    }

so I was wondering whether there really was something incompatible with the 1.7.2 patch which would summon the Kraken or whether it was just displaying that message because it's a massive mod which will eat half your ships if the planet they're orbiting / landed on disappears.

This mod has a strict version check and it simply doesn't function without version matching.

Share this post


Link to post
Share on other sites
2 minutes ago, fulgur said:

I was mainly asking as in the file it says

    "KSP_VERSION":
    {
        "MAJOR": 1,
        "MINOR": 7,
        "PATCH": 1
    }

so I was wondering whether there really was something incompatible with the 1.7.2 patch which would summon the Kraken or whether it was just displaying that message because it's a massive mod which will eat half your ships if the planet they're orbiting / landed on disappears.

This comes up every time KSP updates. Kopernicus is hard locked to a specific version of KSP in the mod code itself (last few pages of this thread had to be pruned by mods due to a big argument on this). Planet changes will NOT load. That's why the message specifically says not to load the save game. Kopernicus goes much deeper than most mods, so it's much more sensitive to version changes.

Share this post


Link to post
Share on other sites
Posted (edited)

In case of graphics mods like Spectra that AFAIK make use of kopernicus for texture changes, would it be fine to load the save? I don't think they add new planets, just new scatters and textures.

Edited by guto8797

Share this post


Link to post
Share on other sites
5 minutes ago, guto8797 said:

In case of graphics mods like Spectra that AFAIK make use of kopernicus for texture changes, would it be fine to load the save? I don't think they add new planets, just new scatters and textures.

You should be ok I'd think, if it's just visuals. Though I'd recommend backing up the save and be ready to revert to that point on the chance that something does break when Kopernicus updates.

Share this post


Link to post
Share on other sites
22 minutes ago, guto8797 said:

In case of graphics mods like Spectra that AFAIK make use of kopernicus for texture changes, would it be fine to load the save? I don't think they add new planets, just new scatters and textures.

Looking at the Spectra thread also, it's safe to delete the Kopernicus folder and still have Spectra run, you just won't have the snazy terrain and map terrain textures. That's what I'm doing until the next update.

In related news, keep the awesome work with this mod. Don't worry about rushing and take as much time as you need.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, fulgur said:

so I was wondering whether there really was something incompatible with the 1.7.2 patch which would summon the Kraken or whether it was just displaying that message because it's a massive mod which will eat half your ships if the planet they're orbiting / landed on disappears.

Actually, both. That's why Kopernicus shows that message; because it hasn't been properly vetted to confirm that the slight patch upgrade (.1 -> .2) won't summon a Kraken that will eat your save because the solar system disappeared. :P

Edit: For saves where Kopernicus is only used to change the texture of a planet I think you can just remove Kopernicus and play with the default textures. Since I don't understand its inner workings I'd err on the safe side and at the very least backup my save.

Edited by Jognt

Share this post


Link to post
Share on other sites

I agree with the others, this mod is amazing and the modders deserve all the thanks they get and more.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.