Thomas P.

[1.7.3-2 + Backports] Kopernicus & KittopiaTech

Recommended Posts

Without this modification, KSP simply does not exist. Where can I find out about the development status of the new version?

Although I most likely think that KSP 2 will be released than the version of Kopernicus 1.8.X

Edited by OOM

Share this post


Link to post
Share on other sites
5 hours ago, OOM said:

Without this modification, KSP simply does not exist. Where can I find out about the development status of the new version?

Although I most likely think that KSP 2 will be released than the version of Kopernicus 1.8.X

You can always check progress on GitHub. 

 

If you can't wait, roll back to 1.7.3 and patiently wait for a 1.8.x release.

 

Share this post


Link to post
Share on other sites

To ask about something completely different:

Is there any reason to install KittopiaTech? I just use Kopernicus to resize the system and for whatever beautifier mod that requires it.

Share this post


Link to post
Share on other sites
1 hour ago, KerbMav said:

Is there any reason to install KittopiaTech?

No.  KittopiaTech is a tool for planet pack developers.  There's no reason for the end user to have it installed.  In fact, it's best not to because it can actually cause some problems.

 

Share this post


Link to post
Share on other sites

Some off-topic content has been removed.  Folks, a gentle reminder that this is the Kopernicus thread; please try to keep discussion to that topic.

Thank you for your understanding.

Share this post


Link to post
Share on other sites
1 hour ago, Kroslev Kerman said:

does it work on 1.8?

Please go back and read some of the posts before yours.

No, this does not work on 1.8.x

An update is in progress.  Korpernicus is always version locked. The forum post title will be updated to 1.8 when released I'm sure.

Either play on 1.7.3 or wait.

Edited by Cruesoe

Share this post


Link to post
Share on other sites

Much content has been removed, due to pressuring mod authors for updates, which as we all know (right?) is not okay.  Aside from being rude and entitled, it's also explicitly forbidden by the forum rules, specifically 2.2.p.

Folks, please remember that mod authors do this in their precious and scarce spare time, for free, as a hobby, so they can give us all shiny toys for free.  As such, we owe them a debt of gratitude, but they owe us nothing-- in particular, they do not owe us "speedy" updates, nor do they owe us progress reports.

We understand that you're impatient and excited, since Kopernicus is such a vital, useful mod.  It's great that you love the mod, and likely you mean well.  Please understand, though, that there are tens of thousands of people waiting for the update, and asking about it simply doesn't help matters.

Updating a mod like Kopernicus takes a lot of time.  It's many hours of work.  Likely it's not even knowable in advance how much time it'll take, even for the maintainers; that's how software works.  And please remember that these are people, with plenty of IRL obligations (work, school, family, etc.) which obviously take priority over a hobby such as modding.

For anyone who is still unclear on the concept, perhaps a brief refresher is in order:

  • Q: When will the Kopernicus update be ready?
  • A: As soon as the maintainers have the time and inclination to do so.
  • Q:  No, but I mean, when?  I want to know!
  • A:  It's nice to want things.  However, this is not a knowable thing, per the explanation above.
  • Q:  Would it help make it happen faster if I interrupt the authors and pester them for updates while they're trying to get stuff done?
  • A:  Why, no, as a matter of fact.  No, it wouldn't.  Breathing down people's necks and jostling their elbows does not, oddly enough, help the efficiency of the process.  Thanks for asking.
  • Q:  But then what can I do?
  • A:  You can be patient.  Just like everyone else is.
  • Q:  But being patient is hard.
  • A:  Then you could always find some other toy to play with that won't require patience from you.

Thread is now unlocked; please don't make us regret doing so, okay?

Thank you to everyone for your continued patience and understanding.

 

Share this post


Link to post
Share on other sites

Yes, yes we will all be patient and wait for the new version.
I went to GitHub and saw that the development really goes when the author has time for this. 

Edited by OOM

Share this post


Link to post
Share on other sites

Я пытаюсь построить планету с океанами. Но они слишком низкие. К сожалению, во всех уроках, которые я смотрел, не было никакой информации о высоте океана и о том, где его менять. Может кто-нибудь помочь?

(Извините за мой английский. Я же русский :))

Quote

[Moderator's translation]
I am trying to build a planet with oceans.  However, they are too low.  Unfortunately, in all the tutorials I watched, there was no information about the height of the ocean and where to change it.  Can anyone help?

(Sorry for my English.  I'm Russian. :))

 

Edited by Snark
Translation added by moderator

Share this post


Link to post
Share on other sites
5 hours ago, CharDreemur said:

[Moderator's translation]
I am trying to build a planet with oceans.  However, they are too low.  Unfortunately, in all the tutorials I watched, there was no information about the height of the ocean and where to change it.  Can anyone help?

(Sorry for my English.  I'm Russian. :))

Hello @CharDreemur, and welcome to the forums!  :)

I'm not an expert at Kopernicus planet-building myself, but I think it's the case that the height of the ocean cannot be changed.  I believe that it's hard-coded to be at zero altitude.  (Someone please correct me if I'm wrong!)  So, when you're designing a planet, you don't change the height of the ocean.  Instead, you change the height of the land.  Terrain elevation is allowed to be negative, so if you have a planet with an ocean, any land with negative elevation will be underwater.

By the way:  Please note that when posting outside the international forums, all posts must be in English.  We do have lots of people here who aren't English speakers, so it's totally fine if you aren't perfect!  ;)  You can always use Google Translate or some similar tool to assist.  Or, if you would like to post in Russian, you can use the Russian forumСпасибо за Ваше понимание.

Share this post


Link to post
Share on other sites

Doesn't it strike you as odd that he's apologizing for his English while writing in Russian? :) Makes me think there was an autotranslator derp involved. 

Share this post


Link to post
Share on other sites
3 hours ago, Dragon01 said:

Doesn't it strike you as odd that he's apologizing for his English while writing in Russian? :) Makes me think there was an autotranslator derp involved. 

Either that or the apology was warranted. :D 

Sorry, couldn’t resist. ;) 

Share this post


Link to post
Share on other sites

Hi! Just stopping by to say that I love this mod, it expands the horizons of KSP and opens up so many doors, it can make the game 100x better! It's a critical part of all of my mod lists.

Everyone should remember that the more time it takes to develop, the more work will be put into it, and the better it will be when it comes out. That's why I was happy KSP2 got delayed, because that means the developers recognized that they couldn't do the game justice and also meet the deadline, so they opted for higher quality. Take Skyrim, for example. It's one of my favorite games of all time, but imagine what it could have been if it wasn't rushed to meet the 11/11/11 release date. The launch of the James Webb Space Telescope has been delayed 10 years now, but if it had launched on schedule back in 2011, it probably would have broken already. In a time when so many developers are releasing criminally unfinished games, it gives me hope when people take the extra time to put out the best possible product. So stop nagging and let them finish.

Best of luck with the update, can't wait to play it!!!

Share this post


Link to post
Share on other sites
2 hours ago, walkman01 said:

The launch of the James Webb Space Telescope has been delayed 10 years now, but if it had launched on schedule back in 2011, it probably would have broken already

Northrup Grumman is having a field day with tax dollars, the more they delay, the more they milk out of it

Share this post


Link to post
Share on other sites

Ohh, sorry. I just use the translator built into the browser and it automatically translated the text that I wrote in English and I accidentally sent it. Thanks for the help! :D

Edited by CharDreemur
typo

Share this post


Link to post
Share on other sites

Okay. I was able to make the ocean, but is it somehow... buggy? Its texture is weird. I will be very grateful if someone explains how to fix this.

Ocean.png?width=841&height=469

Share this post


Link to post
Share on other sites

And now I discovered another bug. Apparently making mods with planets is more difficult than I thought. The lighting of the planet is rotated 90 degrees from what it should have been. I have absolutely no idea what caused it and how to fix it. I feel really dumb.unknown.png

unknown.png

Share this post


Link to post
Share on other sites
1 hour ago, CharDreemur said:

And now I discovered another bug. Apparently making mods with planets is more difficult than I thought. The lighting of the planet is rotated 90 degrees from what it should have been. I have absolutely no idea what caused it and how to fix it. I feel really dumb.unknown.png

unknown.png

That's because you are exporting/saving your normal maps incorrectly. 

Share this post


Link to post
Share on other sites
17 minutes ago, Galileo said:

That's because you are exporting/saving your normal maps incorrectly.

Yes, I experimented a bit and was able to fix it.

Share this post


Link to post
Share on other sites

Ey, can you upgrade to 1.8.1? I tried to launch KSP with OPM, and it won't load past: "Verifying Expansion: Breaking Ground SquadExpansion/Serenity".

Share this post


Link to post
Share on other sites
18 minutes ago, kerbalk said:

Ey, can you upgrade to 1.8.1? I tried to launch KSP with OPM, and it won't load past: "Verifying Expansion: Breaking Ground SquadExpansion/Serenity".

Ey, can you please read back a page and see that pestering the devs won't make it happen any faster? 

It's not something you just "upgrade".

If you want to play with planet packs, you need to be on 1.7.3.

Edited by Galileo

Share this post


Link to post
Share on other sites
Just now, Galileo said:

Ey, can you please read back a page and see that pestering the devs won't make it happen any faster? 

ok, ok sorry, i was just asking

Share this post


Link to post
Share on other sites

Checking the status on GitHub, work does appear to be ongoing, though I would like to ask confirmation as to whether the release is planned for 1.8.1, or if you're holding out for 1.8.2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.