Thomas P.

[1.8.1-1] Kopernicus & KittopiaTech

Recommended Posts

21 minutes ago, KerikBalm said:

@Nightside As far as I know, you can only define latitude, longitude, and altitude ranges... not biomes... I know, it dissappoints me too.

However, for the surface features added by breaking ground, you define those by biome

Ahh, that is interesting.

Share this post


Link to post
Share on other sites

Hi, I found an "issue" where there's actually nothing wrong with Kopernicus but turns out a snippet of code can help make Kerbin look better.

So recently I went back to playing KSP and downloaded version 1.9.1

It just looks great as we all know

Spoiler

1-9-1-fresh-install.png1-9-1-fresh-install-ts.png

Latyer I thought I was up for a greater challenge, but not yet ready for RSS, GPP or JNSQ. So I looked for some way to give Kerbin axial tilt and make it twice as big. Found this old but still functional python script, Harder Solar System

But, the horror, now Kerbin's atmosphere was lit all the way around. Must be some Kopernicus bug, ¿right?

Spoiler

1-8-1-fresh-install.png1-8-1-fresh-install-ts.png

Wrong. I spent a couple hours trying to troubleshoot all the mods, just to find out that's just the way stock 1.8.1 Kerbin looks like.

So I copied some RSS configs, fiddled a bit in Kittopia and came up with some code to get rid of that white ring
 

@Kopernicus:FINAL
{
    @Body[Kerbin]
    {
        %ScaledVersion
        {
            %Material
            {
                color = 1.4,1.4,1.4,1
                rimPower = 3
                rimBlend = 1.5

                Gradient
                {
                    0.0 = 0.45, 0.55, 0.7, 1.0
                    0.3 = 0.2,0.15,0.05,1.0
                    0.6 = 0.0,0.0,0.0,1.0
                    1.0 = 0.0,0.0,0.0,1.0
                }
            }
        }
    }
}

So just copying that in a .cfg file makes the atmosphere look like this.

Spoiler

1-8-1-koper-patch.png1-8-1-koper-patch-ts.png

I guess those values can still be adjusted a bit, and maybe a similar workaround can be used for Laythe. But for now I'm just putting that info there in case it can help anyone.

And I was also thinking, since 1.9.1 Kerbin looks so much better, would it be possible to take all that graphics data trough a Kittopia dump, so it can be used with 1.8.1 Kopernicus?

Share this post


Link to post
Share on other sites

can you please update this to 1.9.1?

Share this post


Link to post
Share on other sites

Well, I guess yet another Monday doesn't matter all that much...

Share this post


Link to post
Share on other sites

I am having bug, I have no other mods other than AK and mods needed for it to run, but the mod will not load at all and it goes to stock system

Share this post


Link to post
Share on other sites
2 hours ago, kspnerd122 said:

I am having bug, I have no other mods other than AK and mods needed for it to run, but the mod will not load at all and it goes to stock system

If you're on 1.9.1, Kopernicus isn't updated to that yet. If you're on Steam, you can use the beta function in the properties page to roll back to 1.8.1 so that Kopernicus will work. If you're already on 1.8.1, are you getting any error messages? If not, then following the instructions here will get the best results.

Share this post


Link to post
Share on other sites
48 minutes ago, kspnerd122 said:

but im on 1.7.3

Kopernicus is version-locked.  That means you need to use the version of Kopernicus that matches your game version.

I'm not sure where or if you can get an older version of Kop.  Maybe someone else will post that info.

Share this post


Link to post
Share on other sites
Posted (edited)

https://github.com/Kopernicus/Kopernicus/releases/ has past releases. 88 of them at the time of writing.

Edited by Corax

Share this post


Link to post
Share on other sites

Seems like a new update (1.1 shared horizon) is coming for KSP so might as well delay the update for 1.9.1 until we have that one.

Share this post


Link to post
Share on other sites
4 hours ago, EasyAce said:

Seems like a new update (1.1 shared horizon) is coming for KSP so might as well delay the update for 1.9.1 until we have that one.

And such is the pain of the ksp life. It really is a never ending cycle of waiting for Kopernicus to update, and then immediately getting a game update. Then having to choose between an older version of the game without the shiny new additions..  or forsake the larger solar systems. It truly says something about this mod however. To many it is a necessity of a playthrough, as it is the case for me. The game is no longer worth playing without it. So cheers to the mod author! They really have made something that is loved. 

Share this post


Link to post
Share on other sites
7 hours ago, EasyAce said:

Seems like a new update (1.1 shared horizon) is coming for KSP so might as well delay the update for 1.9.1 until we have that one.

Just so you know, the update coming out on July 1st is 1.10, not 1.1. Version numbers aren't decimals, they just look like them.

Share this post


Link to post
Share on other sites
On 5/16/2020 at 4:32 PM, MaxxQ said:

Kopernicus is version-locked.  That means you need to use the version of Kopernicus that matches your game version.

I'm not sure where or if you can get an older version of Kop.  Maybe someone else will post that info.

Ckan

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/18/2020 at 3:16 PM, EasyAce said:

Seems like a new update (1.1 shared horizon) is coming for KSP so might as well delay the update for 1.9.1 until we have that one.

 

On 5/18/2020 at 10:22 PM, ForgiLaGeord said:

Just so you know, the update coming out on July 1st is 1.10, not 1.1. Version numbers aren't decimals, they just look like them.

What is this 1.1 or 1.10 or w/e update you guys are talking about?

Edited by Errol

Share this post


Link to post
Share on other sites
6 minutes ago, Errol said:

 

What is this 1.1 or 1.10 or w/e update you guys are talking about?

1.10

Share this post


Link to post
Share on other sites

Do I understand correctly that I need (the full and only) Kopernicus to re-arrange planets as in Snarkiverse or is there a way to do it without it?

 

Share this post


Link to post
Share on other sites
2 hours ago, kubi said:

Do I understand correctly that I need (the full and only) Kopernicus to re-arrange planets as in Snarkiverse or is there a way to do it without it?

 

You understood correctly 

Share this post


Link to post
Share on other sites
11 hours ago, kubi said:

Do I understand correctly that I need (the full and only) Kopernicus to re-arrange planets as in Snarkiverse or is there a way to do it without it?

 

Never mind. HyperEdit can do some basics too, so I can have some fun before SoonTM

Share this post


Link to post
Share on other sites

@Sigma88 You guys doing alright?  Hope everyone is staying safe.  This year has been horrible so far. 

 

I think it's all too easy to forget that mod makers are real people giving a gift to the community and that they need our support and compassion.  Especially now with the plague in full effect.  Stay safe and stay the F away from eachother!

Share this post


Link to post
Share on other sites

I'm not too familiar with naming convention for updates, but I would have thought that the next update after 1.9, would be 2.0?  Or will this officially be 1.1.0, and every update now will be 1.1.x?

Share this post


Link to post
Share on other sites
53 minutes ago, Bosun said:

I'm not too familiar with naming convention for updates, but I would have thought that the next update after 1.9, would be 2.0?  Or will this officially be 1.1.0, and every update now will be 1.1.x?

KSP's versioning scheme already addressed this question when v0.9 was followed by v0.10.

https://wiki.kerbalspaceprogram.com/wiki/Version_history

TjDhlk4.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.