Jump to content

[1.8.1-1] [PLEASE FORK ME] Kopernicus & KittopiaTech


Thomas P.
 Share

Recommended Posts

5 hours ago, BlueZed said:

Playing a version 1.8.1 from a separate drive with latest AVP & Kopernicus. ‘‘Twas fine four hours ago but now got the Nyan Cats also. No warning about saved games but KSC is underwater. 
 

Restarted and Nyan Cats still there. KSC & gameplay is okay. 

Subnautical Space Center glitch happens here and there even in stock game. I don't think it's related.

Link to comment
Share on other sites

9 hours ago, BlueZed said:

Playing a version 1.8.1 from a separate drive with latest AVP & Kopernicus. ‘‘Twas fine four hours ago but now got the Nyan Cats also. No warning about saved games but KSC is underwater. 
 

Restarted and Nyan Cats still there. KSC & gameplay is okay. 

I also just booted up and saw Nyan Cats. Also no warning for saves so..?

Link to comment
Share on other sites

I was seeing a post about this all over the the KSC fan page.  I kept telling people (stupidly) that it was Kopernicus until someone corrected me lmao!  Apologies to anyone that came here because of me. :P  And apologies to Galileo for any undo stress I may have induced by sending people here!

Link to comment
Share on other sites

1 minute ago, StoneWolfPC said:

I was seeing a post about this all over the the KSC fan page.  I kept telling people (stupidly) that it was Kopernicus until someone corrected me lmao!  Apologies to anyone that came here because of me. :P  And apologies to Galileo for any undo stress I may have induced by sending people here!

No stress here. I’m only slightly annoyed that the nyan cat is used both as a way to show a problem (version mismatch) and as cute joke during specific dates. It harmless, but 90% of users go nuts. I just tried to nip it in the bud this time around.

Link to comment
Share on other sites

So I, too, tried compiling Kopernicus against 1.9 and gave it a shot using JNSQ. Aside from scattering doing weird things like causing the oceans to disappear, the game "works". However, Kopernicus seems to want to force on the "ultra" terrain shaders, which causes the logs to be spamed with messages of the form: 

Material doesn't have a texture property '_NormalTex'

Material doesn't have a texture property '_AtlasTex'

and there is a pretty extreme performance penalty, especially when switching scenes, both of which I assume it are due to JNSQ not being ready for the ultra shader yet. Therefore, my question is: is there a way to force Kopernicus to just play nice and use the "high" shader setting instead of overriding my choices in the graphics options?

Link to comment
Share on other sites

2 minutes ago, Lechrenski said:

So I, too, tried compiling Kopernicus against 1.9 and gave it a shot using JNSQ. Aside from scattering doing weird things like causing the oceans to disappear, the game "works". However, Kopernicus seems to want to force on the "ultra" terrain shaders, which causes the logs to be spamed with messages of the form: 

Material doesn't have a texture property '_NormalTex'

Material doesn't have a texture property '_AtlasTex'

and there is a pretty extreme performance penalty, especially when switching scenes, both of which I assume it are due to JNSQ not being ready for the ultra shader yet. Therefore, my question is: is there a way to force Kopernicus to just play nice and use the "high" shader setting instead of overriding my choices in the graphics options?

You should probably just wait till an official release, daily progress is being done on updating it.

Link to comment
Share on other sites

8 minutes ago, Lechrenski said:

So I, too, tried compiling Kopernicus against 1.9 and gave it a shot using JNSQ. Aside from scattering doing weird things like causing the oceans to disappear, the game "works". However, Kopernicus seems to want to force on the "ultra" terrain shaders, which causes the logs to be spamed with messages of the form: 

Material doesn't have a texture property '_NormalTex'

Material doesn't have a texture property '_AtlasTex'

and there is a pretty extreme performance penalty, especially when switching scenes, both of which I assume it are due to JNSQ not being ready for the ultra shader yet. Therefore, my question is: is there a way to force Kopernicus to just play nice and use the "high" shader setting instead of overriding my choices in the graphics options?

I need to know the commit that you compiled. And you need to post your Logs-Kopernicus.zip just like every other person that wants to report a bug.

Edited by Thomas P.
Link to comment
Share on other sites

Just now, Thomas P. said:

I need to know the commit that you compiled. And you need to post your logs just like every other person that wants to report a bug.

I didn't realize this was a bug. I thought it was expected behaviour that I'd just have to work around.

OK, give me a bit of time and I will compile the very latest, launch the game, and post the logs.

Link to comment
Share on other sites

Just now, Lechrenski said:

I didn't realize this was a bug. I thought it was expected behaviour that I'd just have to work around.

OK, give me a bit of time and I will compile the very latest, launch the game, and post the logs.

Kopernicus forcing the ultra shader is not a bug. But all code that requires the ultra shader should be guarded with checks for it so that is definitly a bug.

Although "forcing the ultra shader" is not really correct: it will force the highest available quality for every body, it just happens to be the ultra shader on kerbin. And this only applies to the template that a body is based off, you are able to change the used shader through the config just like you were in the past.

Link to comment
Share on other sites

35 minutes ago, Lechrenski said:

herefore, my question is: is there a way to force Kopernicus to just play nice and use the "high" shader setting instead of overriding my choices in the graphics options?

sure, actually the solution is easier than what you would expect.

 

you basically just have to take the current latest release of kopernicus, install it like you would normally, and just play.

On ksp 1.8.1 :)

Link to comment
Share on other sites

1 minute ago, Sigma88 said:

sure, actually the solution is easier than what you would expect.

 

you basically just have to take the current latest release of kopernicus, install it like you would normally, and just play.

On ksp 1.8.1 :)

Not a problem. It just seemed this was the sort of forward compatibility issue that might have a solution. I didn't mean to be a pain.

Link to comment
Share on other sites

17 minutes ago, Thomas P. said:

I think I found the issue and pushed a commit to fix it. Would be cool if you could test it.

Alright, I'm trying this out now. I still get the message that Kopernicus requires terrain settings ultra when I try to change it, but if I understand you, that's just because it's saying it wants the highest usable settings, so no worries there.

Logs look a lot cleaner and performance seems to have vastly improved. Thank you! I'll keep "testing", but it looks like this is working so far!

Link to comment
Share on other sites

9 hours ago, Lechrenski said:

which I assume it are due to JNSQ not being ready for the ultra shader yet

I appreciate you! To think the Kopernicus release is dependent on JNSQ :D 

@Thomas P. see that? Kopernicus depends on JNSQ. This needs to be changed in the CKAN metadata. Thanks.

Edited by Galileo
Link to comment
Share on other sites

On 2/6/2020 at 3:33 PM, Sigma88 said:

this type of issue is very common when you cheat a craft into the orbit of a different planet.

Did you use the cheat menu to hack your plane over there?

 

if so, what happens if you then save, and re-load the game?

this is usually the fix

Has this issue been resolved because I have this without cheating to eve. I also reloaded to be on the safe side. I kind of reacted to slow to it and left the surface but my flag is still there. If you want to I can provide you my gamedata folder. Anything to help out :)  I do have 130 mods installed however so that could be an issue. 

7bMS97J.png

I would like to add that I have landed on pretty much all planets including OPM ones with 1.8.1 and the all are working perfect. 

Link to comment
Share on other sites

1 hour ago, dave1904 said:

Anything to help out :)  I do have 130 mods installed however

It's basically impossible to find a bug with 130 mods installed.

What you could do is find the minimum amount of mod that causes the bug, then we might be able to find a cause.

This bug expecially seems to have very similar symptoms to other bugs that have already been reported on github, however seeing your screenshot it seems to me that this is a different one with similar symptoms

Link to comment
Share on other sites

32 minutes ago, Sigma88 said:

It's basically impossible to find a bug with 130 mods installed.

What you could do is find the minimum amount of mod that causes the bug, then we might be able to find a cause.

This bug expecially seems to have very similar symptoms to other bugs that have already been reported on github, however seeing your screenshot it seems to me that this is a different one with similar symptoms

Ill try getting it done tomorrow. Always glad to be of some use with my limited knowledge :) 

Edited by dave1904
Link to comment
Share on other sites

Ok so I guess you get this a lot but I'm wondering when will the mod be updated to 1.9? Asking because I have some interstellar travel mods installed and doing a new science mode save with them and hoping that by the point I reach basic interstellar travel this mod along with some planet packs will be updated 

Link to comment
Share on other sites

Quote
2 hours ago, Mlgisawsome02 said:

Ok so I guess you get this a lot but I'm wondering when will the mod be updated to 1.9? Asking because I have some interstellar travel mods installed and doing a new science mode save with them and hoping that by the point I reach basic interstellar travel this mod along with some planet packs will be updated 

 

Per Thomas P -- "Every time someone asks when the next release will be ready, the date gets pushed back a week."

Link to comment
Share on other sites

Is Kopernicus still doesn't work well with the stock scattering system (trees and other stuff)? I'm getting some significant dips in performance just flying on Kerbin (as low as 25 fps on 100 part craft) when scattering is enabled. The game behaves normally when I either remove Kopernicus or disable the scattering system completely.

Link to comment
Share on other sites

20 hours ago, dave1904 said:

Has this issue been resolved because I have this without cheating to eve. I also reloaded to be on the safe side. I kind of reacted to slow to it and left the surface but my flag is still there. If you want to I can provide you my gamedata folder. Anything to help out :)  I do have 130 mods installed however so that could be an issue. 

I would like to add that I have landed on pretty much all planets including OPM ones with 1.8.1 and the all are working perfect. 

I had 104 mod installe, and some bug, i have disistalled kerbal and all the mod, and have reistalle it. i have deleted some mod (blue dogs and others) because now i have the dlc. and i have no problem.
the only solution reistall it one at atime

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...