Jump to content

[1.8.1-1] [PLEASE FORK ME] Kopernicus & KittopiaTech


Thomas P.
 Share

Recommended Posts

8 hours ago, KerikBalm said:

I only know how to add pre-existing scatters to a new planet (like making hte trees normally only found on Kerbin appear on Duna), but I know of at least one mod that adds entirely new terrain scatters (or are they BG surface features? I don't know) - and I do not know how to do that.

And what I do know what to do, my understanding is a bit fuzzy on some points.

I understood well enough for this though:

  Hide contents

To my mod world rald, I added grass tufts that appear underwater and at low elevation:

https://imgur.com/QYkFv6m

With grey rocks that appearing at the same elevation (and higher)

TChEncj.png

lRUK6Vf.png

h9NdEez.png

xwdxTPi.png

6suGWpS.png

Red duna rocks that appear at the higher elevations

agnGejn.png

wftci4L.png

rovbjlk.png

And I've tried trees too, but I ultimately cut them.

1956BVO.png

VFUadVs.png

LMZGKYb.pngand I made a mod adding small asteroids in orbits similar to Dres... my first attempt at giving them scatter had the density way too high.

crlJ5Js.png

 

Thanks! I'm thinking about adding terrain scatters to RSS, but I'm a bit clueless on how to do that. From what I understand, Kopernicus also allows us to enable scatter colliders; trying to land on Europa's penitentes would be... interesting, to say the least :D

Link to comment
Share on other sites

hi also sorry how come I still get this error in KSP version 1.8.1 using latest Kopernicus am I doing some thing wrong.

 

Kz49TTf.jpg

 

Reason I ask I am running a fair few other mods and I was using Kopernicus as its reqiured for beyond home.

With these two mods installed I some times get a black screen when I first load the game.

So I have to END TASK (KSP) and restart and some times it works fine though I also get the issue above about colliders that cause stutter and issues with SIM speed.

Sorry for all the questions :P

Thanks

Edited by stk2008
Link to comment
Share on other sites

10 minutes ago, stk2008 said:

hi also sorry how come I still get this error in KSP version 1.8.1 using latest Kopernicus am I doing some thing wrong.

It's not an error, it's a warning and nothing to be worried about. Kopernicus checks the surroundings in a certain distance for scatter object and if there are any, it will add a collider to them but once you are "out of range" of a scatter object, it removes the collider again. I guess this is supposed to reduce the RAM usage. These kind of log messages can be used by the mod creator to verify, this part of the mod is working properly.

No idea what's happend when your game shows just a black screen but when it happens the next time, you may want to save a copy of the log file and upload it for others to look at.

Link to comment
Share on other sites

is there a way to disable the creation of colliders on these objects because it does cause the sim speed to go yellow a lot when this happens.

Thank you I shall upload the log next time.

I am going to install a second copy of KSP for just Kopernicus,beyond home,EVE,scatterer and sigma skybox replacment and get back to you on that OG file.

Thanks again :)

Link to comment
Share on other sites

1 hour ago, stk2008 said:

is there a way to disable the creation of colliders on these objects

yes, you can add a MM patch to your game to disable it:

@kopernicus:final
{
	@body,*
	{
		@pqs
		{
			@mods
			{
				@landcontrol
				{
					@scatters
					{
						@value,*
						{
							@components
							{
								!scattercolliders {}
							}
						}
					}
				}
			}
		}
	}
}

Just create a textfile within your GameData folder, name it however you like and change the filename extension to .cfg. Then copy&paste the patch into it, save the file and restart the game.

I personally like to add custom patches in a specific folder which is named like "zzz_Final" or something like that, to keep everything sorted.

Link to comment
Share on other sites

thank you so so much I shall deffo do this.

I was just testing again and here is what I have got so far.

With

Kopernicus

Beyond home

Sigma raplacment sky

Games starts up fine every time all the time no hangong after loading screen

 

With all my mods 100+ but no

Kopernicus

Beyond home

Sigma raplacment sky

game does also not freeze as far as I can tell.

 

But with all my mods and

Kopernicus

Beyond home

Sigma raplacment sky

Game seems to freeze a lot or all the time last few lines in the log are

 

[DeadlyReentry.FixMaxTemps] Adding ModuleAeroReentry to part Honest John Improved Nuclear UGM
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

[DRE] rebalancing OP maxTemp for part LittleBoy
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

[DRE] rebalancing OP maxTemp for part LittleBoy
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

[DeadlyReentry.FixMaxTemps] Adding ModuleAeroReentry to part LittleBoy
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

d3d11: failed to create 2D texture id=5908 width=18 height=18 mips=5 dxgifmt=77 [D3D error was 80070057]

 
(Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 496)

 

here is the full log though https://drive.google.com/open?id=1l0CGgJXWgkfEKd0XJoMvNP2g-huxWt1h

 

If some one could peek at it you would make me one happy man I have spent days trying to get this going I have resorted to just not using beyond home,kopernicus ETC ETC.

 

Thanks so so much @4x4cheesecake

 

 

 

 

Edited by stk2008
Link to comment
Share on other sites

12 hours ago, KerikBalm said:

I only know how to add pre-existing scatters to a new planet (like making hte trees normally only found on Kerbin appear on Duna), but I know of at least one mod that adds entirely new terrain scatters (or are they BG surface features? I don't know) - and I do not know how to do that.

And what I do know what to do, my understanding is a bit fuzzy on some points.

I understood well enough for this though:

  Reveal hidden contents

To my mod world rald, I added grass tufts that appear underwater and at low elevation:

https://imgur.com/QYkFv6m

With grey rocks that appearing at the same elevation (and higher)

TChEncj.png

lRUK6Vf.png

h9NdEez.png

xwdxTPi.png

6suGWpS.png

Red duna rocks that appear at the higher elevations

agnGejn.png

wftci4L.png

rovbjlk.png

And I've tried trees too, but I ultimately cut them.

1956BVO.png

VFUadVs.png

LMZGKYb.pngand I made a mod adding small asteroids in orbits similar to Dres... my first attempt at giving them scatter had the density way too high.

crlJ5Js.png

 

Thanks! I'm trying to add terrain scatter to the RSS bodies, but I'm completely clueless on how to do that. Trying to land on Europa's penitentes would be a proper challenge...

Link to comment
Share on other sites

ok I am totaly stumped I though I got it I removed DEADLY REENTRY and boom got into main menu after loading TWICE.

So re added it to make sure and got into main menu I AM SO DAMN LOST HERE :(

 

EDIT
 

No idea still messing with this is so random.

If I close the AVC window once it tells me about out of date mods ETC ETC then it some times seems to work more often.

An way 3 days on this I cant do no more :(

Edited by stk2008
Link to comment
Share on other sites

2 hours ago, stk2008 said:

The log is pretty clean for an install with that amount of mods, nothing really sticks out which would explain your issues. Did you monitor your RAM usage already? Planet packs usually add quite a bit to the RAM usage so maybe you just ran out of memory or you're close to it.

Btw you can also try to remove just the planet pack but not kopernicus. If it loads fine, the reason is not kopernicus itself ;)

Link to comment
Share on other sites

Thanks so much for looking at the for me.

I did and RAM goes to about 8/9GB after its so called fully loaded and just sits there on a black screen but then IF I click the screen it will turn white and ask close or wait for program I notice EVEN IF I click wait RAM drops to like 500MB some thing aint right at all.

I have 16GB of RAM.

 

Also yep testing now will remove planet pack.

 

Link to comment
Share on other sites

hmmmm it worked again with out planet pack that once but with every thing else installed.

but its worked with planet packed intsalled before any way...its way way to random and it takes a while to load up every time as said 3 damn days on and off with this :(.

 

Every time it does fail to load though I get this with out fail

(Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 496)

d3d11: failed to create 2D texture shader resource view id=8209 [D3D error was 80070057]

 
(Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 460)

d3d11: failed to create 2D texture id=8167 width=10 height=10 mips=4 dxgifmt=77 [D3D error was 80070057]

 
(Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 496)

d3d11: failed to create 2D texture shader resource view id=8167 [D3D error was 80070057]

 
(Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 460)

d3d11: failed to create 2D texture id=6367 width=10 height=10 mips=4 dxgifmt=77 [D3D error was 80070057]

 
(Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 496)

d3d11: failed to create 2D texture shader resource view id=6367 [D3D error was 80070057]

 
(Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 460)

d3d11: failed to create 2D texture id=8213 width=10 height=10 mips=4 dxgifmt=77 [D3D error was 80070057]

 
(Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 496)

d3d11: failed to create 2D texture shader resource view id=8213 [D3D error was 80070057]

 
(Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 460)

d3d11: failed to create 2D texture id=8203 width=10 height=10 mips=4 dxgifmt=77 [D3D error was 80070057]

 
(Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 496)

d3d11: failed to create 2D texture shader resource view id=8203 [D3D error was 80070057]

 
(Filename: C:\buildslave\unity\build\Runtime/GfxDevice/d3d11/TexturesD3D11.cpp Line: 460)

 

says about dx11 that cant be good.

I have a 1080 NONE Ti version but still a pretty beefy GPU.

Drivers maybe?. let me see :) will update them but I aint confident oh I am so stressed now it frustrating to hell as its so random :(

 

Interesting

 

https://forum.unity.com/threads/d3d11-error-causing-builds-to-crash-on-some-devices.519599/

 

Any way very sorry I just realised I am posting in this thread when its not really the issue so sorry.

I might start a new thread on main forum.

Thanks so so much for all the help.

 

just for completness it very well may be video memory i have 8GB which is pretty high but KSP must want more lol some times

 

9o0uhHL.png

 

Edited by stk2008
Link to comment
Share on other sites

4 hours ago, stk2008 said:

ok I am totaly stumped I though I got it I removed DEADLY REENTRY and boom got into main menu after loading TWICE.

So re added it to make sure and got into main menu I AM SO DAMN LOST HERE :(

 

EDIT
 

No idea still messing with this is so random.

If I close the AVC window once it tells me about out of date mods ETC ETC then it some times seems to work more often.

An way 3 days on this I cant do no more :(

I'm not 100% on this, but I read about miniAVC causing problems at the moment? Try the mod ZeroMiniAVC and see if that helps.

Link to comment
Share on other sites

Hi yeah I heard some thing about that going around.

I am sure I had zeroMiniAVC installed and read to remove it and use FULL AVC..I might be wrong no idea TBH.

I am running full KSP.AVC 1414 at the moment.

YxjmfcD.png

should I try zerominiavc then?

 

Thanks again all

HMMM I stand corrected its a mod to help with miniavc issues

I have reistalled and and I am retesting my mod pack

thanks chap I shall get back to you :)

 

 

Edited by stk2008
Link to comment
Share on other sites

3 hours ago, KingKerb said:

Just wondering, how do I remove an atmosphere from a stock planet?

@Kopernicus:FINAL
{
  @Body[Kerbin]
  {
    @Atmosphere
    {
      %enabled = true
    }
  }
}

at least, to put it simply. There may be more options check the wiki for full properties listings

Link to comment
Share on other sites

20 hours ago, stk2008 said:

ok I am totaly stumped I though I got it I removed DEADLY REENTRY and boom got into main menu after loading TWICE.

Im not sure if this helps, i don't know the exact circumstances, but I know there were some issues with Deadly Reentry and RSS/RO/RP1 crashing/freezing before Main Menu.

In the RP-1 Installation Guide it states:

  1. Go into GameData\DeadlyReentry\Plugins and replace the .dll with this one:  <I deleted the link, if im not mistaken its not allowed to post .dll without source code, so please go to https://github.com/KSP-RO/RP-0/wiki/RO-&-RP-1-Installation-for-1.8.1 and scroll down to "Updating Broken Mods">
    • This is required for now because otherwise current DRE will randomly crash your game before the main menu.

 

 

Edited by ValiZockt
Link to comment
Share on other sites

Hmm... I think this is how I'd add scatters...

LandControl
{
	altitudeBlend = 0.1
	altitudeFrequency = 12
	altitudeOctaves = 2
	altitudePersistance = 0.6
	altitudeSeed = 12249
	createColors = True
	createScatter = True
	heightMap = BUILTIN/Home2 (G) for Aster
	latitudeBlend = 0.1
	latitudeFrequency = 5
	latitudeOctaves = 5
	latitudePersistance = 0.6
	latitudeSeed = 47373
	longitudeBlend = 0.6
	longitudeFrequency = 4
	longitudeOctaves = 4
	longitudePersistance = 0.6
	longitudeSeed = 768453
	useHeightMap = False
	vHeightMax = 40000
	order = 999
	enabled = True
	name = _LandClassOcean
	scatters
	{
		Value
		{
			materialType = DiffuseWrapped
			material = BUILTIN/scatter_rock_kerbin
			mesh = BUILTIN/boulder
			castShadows = True
			densityFactor = 0.25
			maxCache = 512
			maxCacheDelta = 64
			maxLevelOffset = 0
			maxScale = 1.5
			maxScatter = 10
			maxSpeed = 200
			minScale = 0.15
			recieveShadows = True
			name = boulder
			seed = 123887
			verticalOffset = -0.25
			instancing = False
			delete = False
			Material
			{
				mainTex = BUILTIN/rock00
				color = 1,1,1,0.621999979
				diff = 0.2
			}
		}
	}
	landClasses
	{
		Value
		{
			alterApparentHeight = 0
			alterRealHeight = 0
			color = 0.180000007,0.100000001,0.0700000003,1
			coverageBlend = 1
			coverageFrequency = 2
			coverageOctaves = 4
			coveragePersistance = 0.5
			coverageSeed = 121214
			name = BaseSun
			latDelta = 1
			latitudeDouble = True
			lonDelta = 0
			minimumRealHeight = 0
			noiseBlend = 0.5
			noiseColor = 0.280000001,0.100000001,0.0700000003,1
			noiseFrequency = 8
			noiseOctaves = 4
			noisePersistance = 0.5
			noiseSeed = 453737
			delete = False
			altitudeRange
			{
				endEnd = 1
				endStart = 1
				startEnd = -1
				startStart = -1
			}
			latitudeDoubleRange
			{
				endEnd = 1
				endStart = 1
				startEnd = 0
				startStart = 0
			}
			latitudeRange
			{
				endEnd = 1
				endStart = 1
				startEnd = 0
				startStart = 0
			}
			longitudeRange
			{
				endEnd = 0.5
				endStart = 0.5
				startEnd = 0
				startStart = 0
			}
			scatters
			{
				Value
				{
					density = 1
					scatterName = boulder
					delete = False
				}
			}
		}
	}
}

...but goddamn, I can't find any documentation for any these fields! Why are there even two scatters nodes?! :D

Link to comment
Share on other sites

28 minutes ago, Tonas1997 said:

Hmm... I think this is how I'd add scatters...

LandControl
{
	altitudeBlend = 0.1
	altitudeFrequency = 12
	altitudeOctaves = 2
	altitudePersistance = 0.6
	altitudeSeed = 12249
	createColors = True
	createScatter = True
	heightMap = BUILTIN/Home2 (G) for Aster
	latitudeBlend = 0.1
	latitudeFrequency = 5
	latitudeOctaves = 5
	latitudePersistance = 0.6
	latitudeSeed = 47373
	longitudeBlend = 0.6
	longitudeFrequency = 4
	longitudeOctaves = 4
	longitudePersistance = 0.6
	longitudeSeed = 768453
	useHeightMap = False
	vHeightMax = 40000
	order = 999
	enabled = True
	name = _LandClassOcean
	scatters
	{
		Value
		{
			materialType = DiffuseWrapped
			material = BUILTIN/scatter_rock_kerbin
			mesh = BUILTIN/boulder
			castShadows = True
			densityFactor = 0.25
			maxCache = 512
			maxCacheDelta = 64
			maxLevelOffset = 0
			maxScale = 1.5
			maxScatter = 10
			maxSpeed = 200
			minScale = 0.15
			recieveShadows = True
			name = boulder
			seed = 123887
			verticalOffset = -0.25
			instancing = False
			delete = False
			Material
			{
				mainTex = BUILTIN/rock00
				color = 1,1,1,0.621999979
				diff = 0.2
			}
		}
	}
	landClasses
	{
		Value
		{
			alterApparentHeight = 0
			alterRealHeight = 0
			color = 0.180000007,0.100000001,0.0700000003,1
			coverageBlend = 1
			coverageFrequency = 2
			coverageOctaves = 4
			coveragePersistance = 0.5
			coverageSeed = 121214
			name = BaseSun
			latDelta = 1
			latitudeDouble = True
			lonDelta = 0
			minimumRealHeight = 0
			noiseBlend = 0.5
			noiseColor = 0.280000001,0.100000001,0.0700000003,1
			noiseFrequency = 8
			noiseOctaves = 4
			noisePersistance = 0.5
			noiseSeed = 453737
			delete = False
			altitudeRange
			{
				endEnd = 1
				endStart = 1
				startEnd = -1
				startStart = -1
			}
			latitudeDoubleRange
			{
				endEnd = 1
				endStart = 1
				startEnd = 0
				startStart = 0
			}
			latitudeRange
			{
				endEnd = 1
				endStart = 1
				startEnd = 0
				startStart = 0
			}
			longitudeRange
			{
				endEnd = 0.5
				endStart = 0.5
				startEnd = 0
				startStart = 0
			}
			scatters
			{
				Value
				{
					density = 1
					scatterName = boulder
					delete = False
				}
			}
		}
	}
}

...but goddamn, I can't find any documentation for any these fields! Why are there even two scatters nodes?! :D

I'm wading through this myself currently. I also haven't found much documentation. But I finally figured some of it out.

I basically looked some of the best examples I could find that did what I want:

 ...LandControl{scatters{...       is where you define new scatter objects (see Ecumenopolis and KSRSS mods for examples)

...LandControl{LandClasses{scatters...             is how you define where those objects will be placed:                  (see KSRSS mod)

The some of the Lat/Lon values in LandClasses are degrees, but shifted and converted to percents.

I haven't found a way to link specific scatters to biomes does anyone know if that is possible?

Link to comment
Share on other sites

33 minutes ago, Nightside said:

I haven't found a way to link specific scatters to biomes does anyone know if that is possible?

This is the billion dollar question. It makes sense for biome-specific scatters to exist - even more so than latitude-based placement.

Link to comment
Share on other sites

51 minutes ago, Nightside said:

I haven't found a way to link specific scatters to biomes does anyone know if that is possible?

Not at the moment.  I started a conversation with the Kopernicus devs about possibly adding that as a feature.  The initial reaction was that it might be possible, but as far as I know, there's really not much happening on Kopernicus at the moment.  Perhaps they'll look at it more seriously if and when work on Kopernicus ramps back up.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...