Jump to content

[1.9.x] REKT Escape Pod Mod


Recommended Posts

2 minutes ago, DStaal said:

Sounds like it's working as intended then.  It is a config thing, and you need it for both or neither - but the idea was that the pod only needed enough EC to freeze you.  The rescue ship supplies the power to unfreeze.

Just have to make sure to turn on the generator BEFORE you try to freeze the Kerbal. I was confused for a bit before I decided to try it that way. I thought it would blow all the EC before you could freeze, but it seemed to work fine.

Link to post
Share on other sites
  • 2 months later...

@linuxgurugamer, I mentioned some fixes to REKT pod bouyancies a while back, but had some RL issues that distracted me for a while. I just remembered about all this stuff, and was wondering if any changes had been made in regards to that, or should I figure out how to try and get a pull request done?

Link to post
Share on other sites
2 hours ago, AmpCat said:

@linuxgurugamer, I mentioned some fixes to REKT pod bouyancies a while back, but had some RL issues that distracted me for a while. I just remembered about all this stuff, and was wondering if any changes had been made in regards to that, or should I figure out how to try and get a pull request done?

I don't think I did anything after May 25

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
  • 2 weeks later...
  • 3 months later...

Hi All. :confused:

I tried these the last time they come out for 1.7.8. And none did what was claimed?

They all tumbled out of control no matter the design or Air brakes etc.

Plus all just burn up and exploded in the Kerbin Atmosphere?

Just as well I only had them on testing with none of my lovely Kerbals on board them.

So I don't think I be getting this version for the new 1.8.1 ksp.

I stick to the stock game escape round pods.

They work fine and take up a 1/4 the room of these fancy pods!

I sure someone will tell me these are better? 

Maybe they are Okay. But I think I pass. :wink:

Link to post
Share on other sites
On 12/14/2019 at 8:28 AM, Steller dude 63 said:

Hi All. :confused:

I tried these the last time they come out for 1.7.8. And none did what was claimed?

They all tumbled out of control no matter the design or Air brakes etc.

Plus all just burn up and exploded in the Kerbin Atmosphere?

Just as well I only had them on testing with none of my lovely Kerbals on board them.

So I don't think I be getting this version for the new 1.8.1 ksp.

I stick to the stock game escape round pods.

They work fine and take up a 1/4 the room of these fancy pods!

I sure someone will tell me these are better? 

Maybe they are Okay. But I think I pass. :wink:

Work just fine for me.  (Note that only one of the pods is designed for atmosphere - and it's designed to descend with the areobrakes out.)  KSP 1.8.1 - I don't think I've tested in 1.7.x, but they don't appear to have changed behavior anytime recently.

Link to post
Share on other sites
  • 4 weeks later...

Hello, I have a problem. When I try to place this escape mod in symmetry mode then it bugs out like on the screenshot and I can't click it anymore. Removing Snacks mod helps.0aS89HC.png

EDIT: Nevermind it happens not only with these escape pods.

Edited by GraczNet
Link to post
Share on other sites
  • 1 month later...

Is roll on the OTAV only coming from the reaction wheels? When testing this, the only aerodynamic surface actually doing something was the pitch stabiliser (but it clips into the engine, which is a bit weird). In the menu I have "Deploy" and "Deploy Winglets" - "Deploy" doesn't seem to do anything (for the "stabilisation equipment", deploy works fine - it extends the aerobrake). There's an angled aft part of the winglets that clips into the main body - I guess that should be a moving part, but it does nothing.

On another note: It would be nice to have a second docking port on the other side of the Inline docking port, so more Kerbals can be rescued ;)

Link to post
Share on other sites
15 hours ago, infinite_monkey said:

Is roll on the OTAV only coming from the reaction wheels? When testing this, the only aerodynamic surface actually doing something was the pitch stabiliser (but it clips into the engine, which is a bit weird). In the menu I have "Deploy" and "Deploy Winglets" - "Deploy" doesn't seem to do anything (for the "stabilisation equipment", deploy works fine - it extends the aerobrake). There's an angled aft part of the winglets that clips into the main body - I guess that should be a moving part, but it does nothing.

I haven't had any issues.  Post a screenshot and a craft file, you might be missing something

15 hours ago, infinite_monkey said:

On another note: It would be nice to have a second docking port on the other side of the Inline docking port, so more Kerbals can be rescued

It would.  Care to make the model for it?

Link to post
Share on other sites

Done :) 

By the way, there are some subfolders called RETIRED, and some parts from there caused errors showing up in KSP.log. What are they for? Can they safely be deleted?

30ellt0.png?1

As for the OTAV control issues with the "Lift Generators" (AKA winglets):

  • the control surfaces clip through the body in the SPH, but not on the runway
  • after deploying the winglets, the control surfaces look deployed, despite the status being retracted
  • default modes are: pitch disabled (not sure if that makes sense), roll enabled (makes totally sense), yaw enabled (doesn't make sense IMHO)
  • they don't react to any input
  • after deploying them, the only input they react to is pitch (after enabling that)
  • deploy angle and default limiter default to -25 - why negative values?
  • changing the deploy angle doesn't seem to do anything, until it reaches the maximum (or close to that) of -38, where suddenly it deploys downwards instead of upwards. At that point, it also reacts to roll and yaw (but only in one direction, since it is already completely deployed)

In general, how is the OTAV supposed to maneuver away from a station? Only using the engine, no RCS at all? I have Mandatory RCS installed, which reduces reaction wheel authority to a minimum, so the only way to maneuver is the engine's gimbal.

Link to post
Share on other sites
On 3/13/2020 at 11:05 PM, infinite_monkey said:

So, modeling is complete, but the nodes don't work. They all show up fine in the VAB with the green spheres, but they don't attach. Any hints?

H8g0bPA.png

 

Quite possible they are backwards

6 hours ago, infinite_monkey said:

As for the OTAV control issues with the "Lift Generators" (AKA winglets):

  • the control surfaces clip through the body in the SPH, but not on the runway
  • after deploying the winglets, the control surfaces look deployed, despite the status being retracted
  • default modes are: pitch disabled (not sure if that makes sense), roll enabled (makes totally sense), yaw enabled (doesn't make sense IMHO)
  • they don't react to any input
  • after deploying them, the only input they react to is pitch (after enabling that)
  • deploy angle and default limiter default to -25 - why negative values?
  • changing the deploy angle doesn't seem to do anything, until it reaches the maximum (or close to that) of -38, where suddenly it deploys downwards instead of upwards. At that point, it also reacts to roll and yaw (but only in one direction, since it is already completely deployed)

In general, how is the OTAV supposed to maneuver away from a station? Only using the engine, no RCS at all? I have Mandatory RCS installed, which reduces reaction wheel authority to a minimum, so the only way to maneuver is the engine's gimbal.

It's been a while since I looked at this.  It was probably intended to be  maneuvered by use of reaction wheels (internal), with Mandatory RCS you will need to put a few RCS thrusters in strategic locations with a minimum of monoprop. 

Link to post
Share on other sites
  • 3 weeks later...
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...