SpinkAkron

[1.7, 1.6, 1.5, 1.4] UnKerballed Start v1.0.5 (updated Apr 13, 2019)

Recommended Posts

Posted (edited)

I additionally noticed what may be a bug (not sure if it's arising from a conflict with another mod) in the LV-T05 "Cogswell." it appears that its attachment node is vertically offset by a large margin, sitting well above the top of the engine: https://imgur.com/dxO60vp

**correction, both nodes are vertically offset away from their correct positions

Edited by YamiHikari

Share this post


Link to post
Share on other sites
1 hour ago, YamiHikari said:

I have AdvancedTextures, but everything was working with that before I added Restock. Around the time I added Restock, I also added ModularLaunchPads and the KerbalReusabilityExpansion (as well as two relevant utility mods), but I don't think anything in those affected textures. I may try removing AdvancedTextures and see if that helps . . .

Do the T30 and T45 engines have the same issue with Advanced Textures installed?  I tried AT some time ago but uninstalled it due to issues. I don't recall the exact reason but I don't think it was related to UKS .

@theonegalensent me a bunch of new mod configs that I need to get integrated (including Restock+).  I'm hoping to get v1.0.1 released today.

Share this post


Link to post
Share on other sites
16 minutes ago, SpinkAkron said:

Do the T30 and T45 engines have the same issue with Advanced Textures installed?  I tried AT some time ago but uninstalled it due to issues. I don't recall the exact reason but I don't think it was related to UKS .

@theonegalensent me a bunch of new mod configs that I need to get integrated (including Restock+).  I'm hoping to get v1.0.1 released today.

The T30 and T45 are having no texture issues, and actually show the new Restock textures. Not all UKS parts are black, but the issue is mostly affecting the new engines.

Share this post


Link to post
Share on other sites
1 hour ago, YamiHikari said:

I additionally noticed what may be a bug (not sure if it's arising from a conflict with another mod) in the LV-T05 "Cogswell." it appears that its attachment node is vertically offset by a large margin, sitting well above the top of the engine: https://imgur.com/dxO60vp

**correction, both nodes are vertically offset away from their correct positions

Yep. Each mod that changes the stock engines generally needs an adjustment to the nodes. Big downside to rescaling stock engines.   I'll add a fix for Restock.

 

23 minutes ago, YamiHikari said:

The T30 and T45 are having no texture issues, and actually show the new Restock textures. Not all UKS parts are black, but the issue is mostly affecting the new engines.

Hmm...  I'm seeing the new Restock models/textures on the T10, T15, and RT-1.  This is without AT. I'm not using DX11 or opengl either.  I'll have to do some experimenting and see if I can recreate the issues you're seeing.

Share this post


Link to post
Share on other sites
27 minutes ago, SpinkAkron said:

Yep. Each mod that changes the stock engines generally needs an adjustment to the nodes. Big downside to rescaling stock engines.   I'll add a fix for Restock.

 

Hmm...  I'm seeing the new Restock models/textures on the T10, T15, and RT-1.  This is without AT. I'm not using DX11 or opengl either.  I'll have to do some experimenting and see if I can recreate the issues you're seeing.

Specific engines I'm having problems with include LV-405, LV-10-37, and BA-8, if that helps.

Share this post


Link to post
Share on other sites
Posted (edited)
54 minutes ago, YamiHikari said:

Specific engines I'm having problems with include LV-405, LV-10-37, and BA-8, if that helps.

I've tried both Advanced Textures and Textures Unlimited with and without -force-opengl or -force-d3d11.  I cannot get any parts to show black textures.  I'm using an Nvidia card.  What screen are you seeing them in?

Unfortunately, I also can't recreate the issues you're having with the attachment nodes.  I had to make adjustments for Ven's Stock Revamp and assumed it was the same issue with Restock, but it's lining up fine for me.

Try uninstalling Unkerballed Start and checking the Gamedata folder to make sure there's nothing left behind. Then reinstall. 

Can you post your full modlist?

Also make sure to test with a new save.  Old saves can have remnants of old parts.

Edited by SpinkAkron

Share this post


Link to post
Share on other sites
Posted (edited)

1.0.1 Update

Fixed the tier 13 tech costs. I had them the same as tier 12.
Added RealPlume configs
Added @theonegalen configs for AirplanesPlus, MAD, Mk3Airliner, ReStockPlus, KAX, TAC Self Destruct

save game impact: Minimal


Please let me know if there are any issues

 

Edited by SpinkAkron

Share this post


Link to post
Share on other sites

MM error with the new version

Spoiler

 

[WRN 2019-03-10 09:40:57.718] 1 warning related to GameData/UnKerballedStart/parts/UKSliquidEngineLVT05.cfg
[WRN 2019-03-10 09:40:57.718] 1 warning related to GameData/UnKerballedStart/parts/UKSliquidEngineLVT10.cfg
[WRN 2019-03-10 09:40:57.718] 1 warning related to GameData/UnKerballedStart/parts/UKSsolidBoosterRT1.cfg

 

[WRN 2019-03-10 09:38:11.357] more than one pass specifier detected, ignoring all but the first: UnKerballedStart/parts/UKSliquidEngineLVT05/@PART[UKSliquidEngineLVT05]:FOR[RealPlume]:NEEDS[SmokeScreen,!ReStock]:AFTER[zzzUnKerballedStart]

[WRN 2019-03-10 09:38:11.357] more than one pass specifier detected, ignoring all but the first: UnKerballedStart/parts/UKSliquidEngineLVT10/@PART[UKSliquidEngineLVT10]:FOR[RealPlume]:NEEDS[SmokeScreen,!ReStock]:AFTER[zzzUnKerballedStart]

[WRN 2019-03-10 09:38:11.357] more than one pass specifier detected, ignoring all but the first: UnKerballedStart/parts/UKSsolidBoosterRT1/@PART[UKSsolidBoosterRT1]:FOR[RealPlume]:NEEDS[SmokeScreen,!ReStock]:AFTER[zzzUnKerballedStart]

 

 

 

Share this post


Link to post
Share on other sites
4 hours ago, eLDude said:

MM error with the new version

D'oh!  Thanks.  It's just a warning so I'll fix in the next release.

Share this post


Link to post
Share on other sites
Posted (edited)

For those who may be interested, I've started a Let's Play series using UnKerballed Start and Kerbal Operating System (kOS) .  I added an excerpt from the first episode with the UKS overview to the top of the first post.

Let's Play KSP Hardercore with UKS & kOS

Mod list

Spoiler


--- Mod List ---
AdjustableModPanel
AlternateResourcePanel
BAMCont
BackgroundResources
CapCom
Chatterer
ClickThroughBlocker
CollisionFXUpdated
CommunityCategoryKit
CommunityResourcePack
CommunityTechTree
ContractConfigurator
ContractConfigurator-CleverSats
ContractConfigurator-FieldResearch
ContractConfigurator-KerbalAcademy
ContractConfigurator-KerbinSpaceStation
ContractConfigurator-RemoteTech
ContractConfigurator-Tourism
ContractParser
Contract_Pack_Rover_Missions
CustomBarnKit
DMagicOrbitalScience
DeadlyReentry
DistantObject
DistantObject-default
EarnYourStripes
EditorExtensionsRedux
EngineLighting
EnvironmentalVisualEnhancements
FerramAerospaceResearchContinued
FilterExtensions
FilterExtensionsDefaultConfig
FinalFrontier
FlightTracker
IndicatorLights
IndicatorLightsCommunityExtensions
JanitorsCloset
KSP-AVC
KerbalAlarmClock
KerbalChangelog
KerbalConstructionTime
KerbalEngineerRedux
MK1StkOpenCockpit
MagiCore
MakingLessHistory
MandatoryRCS
MemGraph
MemorialWall
MissingHistory
MoarFEConfigs
ModularFlightIntegrator
ModuleManager
MonthlyBudgets
MyTweaks*
OhScrap
PartInfo
PoodsCalmNebulaSkybox
ProgressParser
ReStock
ReStockPlus
RealPlume
RealPlume-StockConfigs
ReentryParticleEffect
RemoteTech
SCANsat
SETI-Contracts
Scatterer
Scatterer-config
Scatterer-sunflare
SciFiVisualEnhancements
ScienceSituationInfo
ScrapYard
SigmaReplacements-SkyBox
SmokeScreen
SpaceAge
StageRecovery
StockNoContracts
Strategia
TACLS
TextureReplacer
ToolbarController
TriggerAu-Flags
UnKerballedStart
kOS
x.Science

 

Edited by SpinkAkron
mod list added

Share this post


Link to post
Share on other sites
Posted (edited)

@SpinkAkron Noticed that unlocking aeronautics does not get wing parts with the rest of early plane parts. Wings cost one extra science point and have there own node.

Wondered if you got that idea from the SETI tree?

There is a reason we did it that way. B9 Procedural wings where used instead if available. If a player did not have that mod installed there was an option to use the stock wings. Yemo did however did not want to "clutter up" the VAB &SPH with parts that he was never going to use. So the compromise he came up with was an extra node just for wings at one extra science point. That way players that wanted stock wings saw them appear easily for one science point. Whilst players on procedural wings did not see them. It was a good compromise that kept everyone happy. I just thought you might like the story of how that wings node got created in the old SETI mod.

Just a through. It is up to you and this is a brand new mod. The cost of these things is $10,000 each without modification. I bring them down in price and place them in with rest of the early plane parts. However here is just some code to move them for now. Try them and see how it feels.

Finally thank you very much for sharing this mod. I really like it :cool:

//aeronautics
@PART[B9_Aero_Wing_Procedural_TypeA]:NEEDS[CommunityTechTree,B9_Aerospace_ProceduralWings]:BEFORE[zzzUnKerballedStart]
{
		@TechRequired = aeronautics
}
@PART[B9_Aero_Wing_Procedural_TypeB]:NEEDS[CommunityTechTree,B9_Aerospace_ProceduralWings]:BEFORE[zzzUnKerballedStart]
{
		@TechRequired = aeronautics
}
@PART[B9_Aero_Wing_Procedural_TypeC]:NEEDS[CommunityTechTree,B9_Aerospace_ProceduralWings]:BEFORE[zzzUnKerballedStart]
{
		@TechRequired = aeronautics
}

@kcs123 Ha ha, sorry just noticed that you mentioned B9 wings early on in the thread and the old story of the SETI compromise. Shame that thread was lost again. Nice to see your still around on the forum :wink:. I will leave this post up anyway it case the code is still useful.

Edited by nobodyhasthis2
typo

Share this post


Link to post
Share on other sites
34 minutes ago, nobodyhasthis2 said:

@SpinkAkron Noticed that unlocking aeronautics does not get wing parts with the rest of early plane parts. Wings cost one extra science point and have there own node.

Wondered if you got that idea from the SETI tree?

Yes, that's one of several ideas from SETI, which is the inspiration for this mod.  My reasoning was less the B9 parts and more to keep the clutter down for those of us not interested in planes. There are few more added wings nodes @theonegalen is using for the aero mods he's contributing.

Share this post


Link to post
Share on other sites
18 hours ago, nobodyhasthis2 said:

@kcs123 Ha ha, sorry just noticed that you mentioned B9 wings early on in the thread and the old story of the SETI compromise. Shame that thread was lost again. Nice to see your still around on the forum :wink:. I will leave this post up anyway it case the code is still useful.

No worries, no harm done :). Still lurking forums, it maintain my knowledge of english language at reasonable level, although real life hitting me hard, so no longer have much time for playing game as I would like to. Attempting to help people as much as I can and as much as I can recall from past, though.

Share this post


Link to post
Share on other sites

Hi there!!

I just heard about this mod from @theonegalen and I too am getting the warnings

Since.. I am not a mod person at all, these are okay to run with?

Thank you for a tech tree that is challenging.. :)

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, gamerscircle said:

Hi there!!

I just heard about this mod from @theonegalen and I too am getting the warnings

Since.. I am not a mod person at all, these are okay to run with?

Thank you for a tech tree that is challenging.. :)

They are from the Realplume configs I added. I don't think they cause any harm. Worst case would be the Real Plumes wouldn't work for the new parts. If you have Restock installed, it has it's own Plumes that gets pickedup in my rescaled parts which looks much better anyway.

** Edit **

I don't have any other changes on my list, so I'll go ahead and release a fix for the MM warnings so we won't have to worry about it anymore.

 

Edited by SpinkAkron

Share this post


Link to post
Share on other sites

The problem with RealPlume configs is that certain mods use :FOR[RealPlume] when what they should be using is :NEEDS[RealPlume] or :AFTER[RealPlume]. :FOR[RealPlume] makes module manager think that RealPlume is installed even when it's not. This, then, causes errors because every mod that has configs set up correctly starts looking for the RealPlume files that don't exist.

I'm not quite sure why it seems to come up with RealPlume more often than it does with other mods, but I think it might be because RP requires image files to be loaded, whereas something like TAC-LS does not.

Share this post


Link to post
Share on other sites
8 minutes ago, theonegalen said:

The problem with RealPlume configs is that certain mods use :FOR[RealPlume] when what they should be using is :NEEDS[RealPlume] or :AFTER[RealPlume]. :FOR[RealPlume] makes module manager think that RealPlume is installed even when it's not. This, then, causes errors because every mod that has configs set up correctly starts looking for the RealPlume files that don't exist.

I'm not quite sure why it seems to come up with RealPlume more often than it does with other mods, but I think it might be because RP requires image files to be loaded, whereas something like TAC-LS does not.

Well if folks just copy a Realplume config without looking too closely, like I did, that probably perpetuates it.

Share this post


Link to post
Share on other sites
Posted (edited)

Version 1.0.2 Released

Fixed Real Plume configs to eliminate MM warnings.

savegame inpact: none

Edited by SpinkAkron

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks... confirmed .. 

I have wanted to use replume, but the audio for the engines are just way too high in volume.

Edited by gamerscircle

Share this post


Link to post
Share on other sites
On 3/9/2019 at 6:19 PM, SpinkAkron said:

Yep. Each mod that changes the stock engines generally needs an adjustment to the nodes. Big downside to rescaling stock engines.   I'll add a fix for Restock.

Hey, so I'm using ReStock and I still do get a _huge_ wrong offset on the UKSliquidEngineLVT10 and UKSliquidEngineLVT05. I had to add the following to make them work:

@PART[UKSliquidEngineLVT10]:NEEDS[ReStock]:BEFORE[zzzUnKerballedStart]
{
	@node_stack_top = 0.0, 4.50913125, 0.0, 0.0, 1.0, 0.0
	@node_stack_bottom = 0.0, -3.5896125, 0.0, 0.0, -1.0, 0.0
}


@PART[UKSliquidEngineLVT05]:NEEDS[MissingHistory]:BEFORE[zzzUnKerballedStart]
{
	@node_stack_top = 0.0, 0.45, 0.0, 0.0, 1.0, 0.0, 0
	@node_stack_bottom = 0.0, -.42, 0.0, 0.0, -1.0, 0.0, 0
}

I'm actually slightly confused as to why it's "BEFORE" and not "FOR," but that's what the patch for Missing History used, so I followed it.

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, ModZero said:

Hey, so I'm using ReStock and I still do get a _huge_ wrong offset on the UKSliquidEngineLVT10 and UKSliquidEngineLVT05. I had to add the following to make them work:

I'm not seeing that issue.  I think someone reported something similar on the Restock forum thread.

Ok, I'm  seeing it on the LVT45 but not the LVT10 and LVT05, for whatever reason.  It looks like this is an incompatibility between Missing History and Restock.  See here for the fix:  RESTOCK/Missing History fix

I'll see if I can do something with the mods support configs to find an easier fix.

Edited by SpinkAkron

Share this post


Link to post
Share on other sites
Posted (edited)
13 hours ago, SpinkAkron said:

It looks like this is an incompatibility between Missing History and Restock.

...this is confusing, as I didn't put Missing History into this install. The only other way is if something else is triggering MM patches for it.

EDIT: ...and RealPlume-Stock has a 'MissingHistory' subdirectory, which AFAIK would trigger that, yes. Ugh.

EDIT2: that's not it. I got the issue with an install that contains _only_ ReStock, UnKerballedStart, Squad, SquadExpansion and MM 4.0.2.
Image of the issue and my GameData here. My patch (which I incorrectly copied - yes, I didn't put it in a single file but rudely mixed with yours) fixes it:

@PART[UKSliquidEngineLVT10]:NEEDS[ReStock]:BEFORE[zzzUnKerballedStart]
{
	@node_stack_top = 0.0, 4.50913125, 0.0, 0.0, 1.0, 0.0
	@node_stack_bottom = 0.0, -3.5896125, 0.0, 0.0, -1.0, 0.0
}

@PART[UKSliquidEngineLVT05]:NEEDS[ReStock]:BEFORE[zzzUnKerballedStart]
{
	@node_stack_top = 0.0, 0.45, 0.0, 0.0, 1.0, 0.0, 0
	@node_stack_bottom = 0.0, -.42, 0.0, 0.0, -1.0, 0.0, 0
}

 

Edited by ModZero

Share this post


Link to post
Share on other sites

Note: I'm not a very experienced kerbonaut;

Is there a contract pack you'd recommend to help with the progression? Previously I used SETI-Contracts, now sure if they'll just work out of the box with this mod since I think in SETI it assumes that you have access to pilot-ed flight sooner. I could be entirely wrong about that though..

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, ModZero said:

...this is confusing, as I didn't put Missing History into this install. The only other way is if something else is triggering MM patches for it.

Sorry, I'll keep digging.

 

56 minutes ago, wyzeetv said:

Note: I'm not a very experienced kerbonaut;

Is there a contract pack you'd recommend to help with the progression? Previously I used SETI-Contracts, now sure if they'll just work out of the box with this mod since I think in SETI it assumes that you have access to pilot-ed flight sooner. I could be entirely wrong about that though..

For the career, I use SETI-Contracts for every playthrough.  I love it and I think it works great with this tech tree.   Exploration Plus is also good if you want your career less guided.

I don't care for the stock contracts, so I use Stock No Contracts, replacing them with contract packs:  Bases and Stations Reborn, Clever Sats, Field Research, Kerbal Academy, Remote Tech , Tourism Plus,  and Rover Missions.

 

 

3 hours ago, ModZero said:

...this is confusing, as I didn't put Missing History into this install. The only other way is if something else is triggering MM patches for it.

EDIT: ...and RealPlume-Stock has a 'MissingHistory' subdirectory, which AFAIK would trigger that, yes. Ugh.

EDIT2: that's not it. I got the issue with an install that contains _only_ ReStock, UnKerballedStart, Squad, SquadExpansion and MM 4.0.2.
Image of the issue and my GameData here. My patch (which I incorrectly copied - yes, I didn't put it in a single file but rudely mixed with yours) fixes it:


@PART[UKSliquidEngineLVT10]:NEEDS[ReStock]:BEFORE[zzzUnKerballedStart]
{
	@node_stack_top = 0.0, 4.50913125, 0.0, 0.0, 1.0, 0.0
	@node_stack_bottom = 0.0, -3.5896125, 0.0, 0.0, -1.0, 0.0
}

@PART[UKSliquidEngineLVT05]:NEEDS[ReStock]:BEFORE[zzzUnKerballedStart]
{
	@node_stack_top = 0.0, 0.45, 0.0, 0.0, 1.0, 0.0, 0
	@node_stack_bottom = 0.0, -.42, 0.0, 0.0, -1.0, 0.0, 0
}

 

Ok, I uninstalled Missing History and have am able to recreate the problem now.  I'll get a fix out ASAP.

Edited by SpinkAkron

Share this post


Link to post
Share on other sites
13 minutes ago, SpinkAkron said:

For the career, I use SETI-Contracts for every playthrough.  I love it and I think it works great with this tech tree.   Exploration Plus is also good if you want your career less guided.

I don't care for the stock contracts, so I use Stock No Contracts, replacing them with contract packs:  Bases and Stations Reborn, Clever Sats, Field Research, Kerbal Academy, Remote Tech , Tourism Plus,  and Rover Missions.

Might be good idea to put that info in OP, as optional or recommended mods, below those that are required. CKAN is also capable to offer list of recommended mods for best experience, but you have to contact someone from CKAN staff for more detailed info. IIRC, it is just certain file with listed mods in JSON format or something, but can't tell for sure how exactly to do that.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.