SpinkAkron

[1.8.x] UnKerballed Start v1.1.0 (updated Oct 27, 2019)

Recommended Posts

5 hours ago, Gordon Dry said:

But besides that, I just recognized that BDB is not supported yet.

I guess I wished / assumed that it would be supported and this fact made my confusion even deeper.

Is that also a function of community tech tree? UKS can certainly assign nodes per part, etc. --unless you mean a different sort of unsupported?

Edited by Beetlecat

Share this post


Link to post
Share on other sites
On 11/10/2019 at 11:24 AM, njd80 said:

If you use ReStockPlus, the new version deprecates the Mallet and the Striker, because KSP 1.8 adds the Mite and the Shrimp.
So - you are left with zero propulsion options in the Start and BasicRocketry tech tree nodes.

This can be remedied by using the following patch to undepreciate the Striker and Mallet:

@PART[restock-srb-mallet-1]:NEEDS[ReStockPlus]:FINAL
{
	@category = Engine
	subcategory = 0
	-TechHidden = dummy
}

@PART[restock-srb-striker-1]:NEEDS[ReStockPlus]:FINAL
{
	@category = Engine
	subcategory = 0
	-TechHidden = dummy
}

 

Share this post


Link to post
Share on other sites

Hello @SpinkAkron, I'd like to make a suggestion for the tech tree. In my current playthrough, I was a bit surprised to suddenly get the new "Pollux", which is an 1,875m solid booster from the... Making History I think... DLC. It sits in "Heavy Rocketry", together with the thumper, which is a bit out of place I think :D It looked really funny when I was recently struggling to get a craft off the ground and thought "hey, let's slap two SRBs on", and the first one I clicked suddenly occupiued the whole screen and was bigger than the rest of my craft :D

I think letting players struggle with 1.25 a bit is really important, and as such the Pollux comes too early, it's like cheating at that moment, because it can get anything off the ground and almost into orbit by itself at that point

Share this post


Link to post
Share on other sites

I also think sorting the SRB and tank parts into tech tree nodes by diameter would work nicely.   Right now, it seems like you unlock a tech node and get the shortest tanks in two or three different diameters, then unlock the next node and get the next longer lengths for those same diameters.  So, you end up cobbling rockets together from lots of short tanks and never using the longer ones because you've moved on to larger diameter tanks by the time you unlock the long ones.  Having to use lots of short tanks isn't a difficulty challenge...  it's just an annoyance for aesthetics and artificially inflates the needed part count for a craft.

If you want to retain length progression with the tanks, I would still suggest sticking to one diameter per tech node.  So, you would end up with something like:

Short 1.25m tanks > Long 1.25m tanks > Short 1.875m tanks > Long 1.875m tanks > Short 2.5m tanks > Long 2.5m tanks > etc.

Keeping the little probe tanks off in a parallel side node still make sense.

The excellent RP-1 tech tree is structured something like this and it plays through very nicely.

Edited by RoboRay

Share this post


Link to post
Share on other sites

@RoboRay Agreed, well said. Let me just add that I was not necessarily advocating for diameter progression, but simply for difficulty progression. The Pollux is just mega-OP at the point I was at

Share this post


Link to post
Share on other sites
1 hour ago, avalancha said:

@RoboRay Agreed, well said. Let me just add that I was not necessarily advocating for diameter progression, but simply for difficulty progression. The Pollux is just mega-OP at the point I was at

Yeah, but it struck me that the issue you noted with tech tree progression is kind of related to the one I was struggling with this weekend and helped me figure out how to express it.

One of the things I really like about the RP-1 tech tree is that it doesn't force you to stack a lot of short tanks because you "don't know how to make tall tanks" yet.  It's really the diameter of the tanks that drives difficulty. 

I like building rockets that look good and a stack of the same little texture pattern over and over doesn't do that.   I tend to use several different lengths of tanks to break up the texture patterns and, with UKS granting wider tanks at the same tank it grants longer length narrower tanks, I end up not using the longer tanks much at all.

Edited by RoboRay

Share this post


Link to post
Share on other sites

@SpinkAkron this project really could need a Github repo

My addition so far:

Bluedog Design Bureau, only Mercury and Gemini

GameData\UnKerballedStart\Mod Support\Bluedog_DB.cfg

New version see below

I'm tired, so I stop here for now.

@CobaltWolf btw

Edited by Gordon Dry
tiny edit

Share this post


Link to post
Share on other sites

I just recognized that the GameData\Bluedog_DB\Compatibility\CommunityTechTree\CTT.cfg already overwrites some of those, because it's :FINAL

@CobaltWolf should not be :FINAL I would say.

Edit:

I suggest :FOR[Bluedog_DB]

This way it would be compatible to UnKerballedStart and ProbesBeforeCrew and what not.

See
https://github.com/CobaltWolf/Bluedog-Design-Bureau/pull/742

 

 

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
On 11/13/2019 at 11:35 AM, Pleb said:

This can be remedied by using the following patch to undepreciate the Striker and Mallet:


@PART[restock-srb-mallet-1]:NEEDS[ReStockPlus]:FINAL
{
	@category = Engine
	subcategory = 0
	-TechHidden = dummy
}

@PART[restock-srb-striker-1]:NEEDS[ReStockPlus]:FINAL
{
	@category = Engine
	subcategory = 0
	-TechHidden = dummy
}

 

Where should we make this change ? In witch file ? 

Share this post


Link to post
Share on other sites
1 hour ago, lokee81 said:

Where should we make this change ? In witch file ? 

Just create a patch file. For example, go into the GameData folder, create a folder called Patches then create a text file and rename it restock-changes.cfg then copy and paste the text from my other post.

Share this post


Link to post
Share on other sites

Haven't looked at KSP for awhile, but I have fond memories of SETI and am very glad to see someone picking up the torch for an overhaul mod like this. Kudos for picking a permissive license that will allow the mod to live instead of dying like SETI did.

Just one little thing, on the thread title this mod is indicated as being 1.8.x compatible, but the spacedock download link hasn't been updated to reflect this so I want to make sure I'm getting the newest version of the mod and not an older version.

Share this post


Link to post
Share on other sites
8 hours ago, Lord Aurelius said:

Haven't looked at KSP for awhile, but I have fond memories of SETI and am very glad to see someone picking up the torch for an overhaul mod like this. Kudos for picking a permissive license that will allow the mod to live instead of dying like SETI did.

Just one little thing, on the thread title this mod is indicated as being 1.8.x compatible, but the spacedock download link hasn't been updated to reflect this so I want to make sure I'm getting the newest version of the mod and not an older version.

Compatibility for KSP 1.7.x was added after update for KSP 1.8.x. Info about it is on previous page:

On spacedock web page click on changelog and you will see there proper version to download. Or you can use CKAN, whatever you prefere.
You may also want to use additional compatibility patches from community, posted in this thread after release if you use some of mods that are not already covered by default.

Share this post


Link to post
Share on other sites

Does this mod work on latest 1.8.1 KSP? Title says it is for [1.8.x] but it is not appearing on CKAN.

Share this post


Link to post
Share on other sites
10 hours ago, spock19 said:

Does this mod work on latest 1.8.1 KSP? Title says it is for [1.8.x] but it is not appearing on CKAN.

Yes, it works. This mod only contain MM patches, does not use any plugin DLL file, so it will work just fine. For CKAN, it need only version file to be updated, but you can also set in CKAN configuration to accept mods made for KSP 1.8.0, so you don't need to install this manualy.

Share this post


Link to post
Share on other sites
On 2/3/2019 at 5:44 PM, SpinkAkron said:

Jet Propelled Science Buggy!

I'm playing this game after a long time. There used to be a way to build a buggy in some mod named "Unmammed Before Manned", using some kind of rover (I think it was stock rover). Is it possible to do that now? Is there a possibility of adding that feature since land vehicles were more common than rockets in early industrial age of humans?

Share this post


Link to post
Share on other sites
16 hours ago, spock19 said:

I'm playing this game after a long time. There used to be a way to build a buggy in some mod named "Unmammed Before Manned", using some kind of rover (I think it was stock rover). Is it possible to do that now? Is there a possibility of adding that feature since land vehicles were more common than rockets in early industrial age of humans?

You can build any kind of ground vehicles if you unlock required parts trough career game. UBM have made tiny rover wheels available from start. Now, those are pushed slightly up in tech tree, so you will need to unlock some tech tree nodes first. Or you can build improvised vehicle with parts on disposal.

Otherwise, you may want to create your own MM patches to put those rover wheels in earlier tech tree nodes. Or, you may use GAP mod that offer certain parts from the begining as "experimental" for a small fee. Those contracts work with any tech tree, not just UKS.

Share this post


Link to post
Share on other sites

I installed this mod: Grounded. It met my requirements. You can install it if you want to build a science buggy in the beginning.

Share this post


Link to post
Share on other sites

Reinstalled KSP for 1.8.1 finally!

Fired up UKS, only to be confused why the Basic Rocketry node appeared empty, and now I see it's because the default download on spacedock downloads version 1.08 instead of 1.1. Going to get back to playing here with the updated version in about an hour!

I hope you're doing well, @SpinkAkron, and having a good new year!

Share this post


Link to post
Share on other sites
On 1/1/2020 at 6:25 PM, spock19 said:

I'm playing this game after a long time. There used to be a way to build a buggy in some mod named "Unmammed Before Manned", using some kind of rover (I think it was stock rover). Is it possible to do that now? Is there a possibility of adding that feature since land vehicles were more common than rockets in early industrial age of humans?

If you don't have much RAM left over, Omega's Stockalike Utility Vehicles (no textures required) is a very good choice to add this. :)

Edited by theonegalen

Share this post


Link to post
Share on other sites

Not sure if @theonegalen is still doing development of this mod but adding support for more mods that work with Kerbalism since it only has a limited number of mods that either don't conflict with Kerbalism or Unkerballed Start.  Such mods as:  Bluedog Design Bureau, Duna Direct, SXT Continued, and MOLE.  Also are all of USI mods compatible (Konstruction, FTT, Malemute, Explore, Sounding Rocketsr) or just MKS/LS and dependencies? Thanks for all that you and SpinkAkron have done.  It nice to have mods like this.

Share this post


Link to post
Share on other sites
On 1/14/2020 at 3:59 PM, theonegalen said:

Reinstalled KSP for 1.8.1 finally!

Fired up UKS, only to be confused why the Basic Rocketry node appeared empty, and now I see it's because the default download on spacedock downloads version 1.08 instead of 1.1. Going to get back to playing here with the updated version in about an hour!

I hope you're doing well, @SpinkAkron, and having a good new year!

Where would i get the 1.1 version?

EDIT: Nevermind, found the alternate versions on spacedock

Edited by vardicd

Share this post


Link to post
Share on other sites
10 hours ago, venturaguy101 said:

Not sure if @theonegalen is still doing development of this mod but adding support for more mods that work with Kerbalism since it only has a limited number of mods that either don't conflict with Kerbalism or Unkerballed Start.  Such mods as:  Bluedog Design Bureau, Duna Direct, SXT Continued, and MOLE.  Also are all of USI mods compatible (Konstruction, FTT, Malemute, Explore, Sounding Rocketsr) or just MKS/LS and dependencies? Thanks for all that you and SpinkAkron have done.  It nice to have mods like this.

BDB is so huge that I am not going to ever make a full config for it. I have worked on configs for SXT Continued and some for MOLE, but they are not complete. Angel-125 is one of the few modders who actually leverages the part upgrade system in stock, and MOLE is excellently placed as it is, so I remember that there wasn't much to do there. Unless I'm getting confused with back when I used to do UnmannedBeforeManned.

I don't use USI mods anymore, so I haven't done anything with those, and probably won't. I did use Exploration, and I think Sounding Rockets is compatible, but I'm not sure. @SpinkAkron could probably speak with more authority on that.

Share this post


Link to post
Share on other sites

hey @theonegalen / @SpinkAkron - the CustomBarnKit.cfg is not disabled by default in 1.1. Wouldn't be a problem if grabbing directly from Spacedock as it gives you 1.0.8 by default, but CKAN is pulling 1.1 for KSP 1.8.

Could you please disable it again, as it's going to break Bureaucracy when I release, unless I write MM patches specifically for when UnKerballedStart is installed (which I don't really want to do when this seems like it's been left on by mistake)

Edited by severedsolo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.