• 0
Pacca

SAS balanced craft always fall over even with pilot control disabled

Question

I'm trying to make small rovers with only one or two wheels, which balance themselves using reaction wheels. At first glance, it seems like an easy thing to do, considering how notoriously strong reaction wheels are in KSP. I made a few designs that had a few SAS modules, a probe core, and a set of two wheels. It works just fine if you make one and say, roll it down a hill; it stays upright and moves forwards without issue. But for some odd reason, reaction wheels seem to always react to player control, even when they're set to "SAS only"; attempting to actually engage the rover wheels by pressing any of the directional keys causes it to fall over.

 

I tried to troubleshoot using highly simplified designs that only used three parts, a probe core, SAS module, and a set of wheels. Despite ensuring that all reaction wheels (including the ones in the command modules) were set to SAS only, it would always suffer the exact same problem. Attempting to engage the wheels causes it to stop directing itself and fall down. Releasing the keys allows it to re-right itself if it has the ability to.

 

I'm aware that this is kind of a silly thing to do, but I want to make sure it's possible before I start working on a 3D model for a silly little item I might want to mod into the game.

Edited by Pacca
missing filler word

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 1

No clue what's going on there with the reaction wheels running while set to 'SAS Only' but I guess there is a pretty easy to solution to your primary issue:

You can bind different keys for 'Steer Left/Right' and 'Drive Forward/Backwards'. The keybindings are located in the game settings -> Input -> Vessel. By default, pitch up/down and drive forward/backwards are controlled by the same keys, so rebinding them should solve your issue :)
 

Share this post


Link to post
Share on other sites
  • 0
32 minutes ago, 4x4cheesecake said:

No clue what's going on there with the reaction wheels running while set to 'SAS Only' but I guess there is a pretty easy to solution to your primary issue:

You can bind different keys for 'Steer Left/Right' and 'Drive Forward/Backwards'. The keybindings are located in the game settings -> Input -> Vessel. By default, pitch up/down and drive forward/backwards are controlled by the same keys, so rebinding them should solve your issue :)
 

That does it! Thanks for the tip 8W5P1jC.png

Share this post


Link to post
Share on other sites
  • 0

I'll try to look into it too and see if there's a bug involved, somewhere.

 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.