• 0
Sign in to follow this  
TheSpacePlaneArchitect

Can't play the game.

Question

7 answers to this question

Recommended Posts

  • 0

Looks like you messed up a few mods here:

  • You got a KerbalEngineer .dlls in your GameData directory, which doesn't belong there
  • Some of your mods are for newer KSP versions, some for older than 1.3.1:
    • Interstellar 1.20.2 is released for KSP 1.4.5, try 1.19.6 instead
    • Firespitter 7.3 is released for KSP 1.1.3, try 7.6 instead
    • CCK v.3 is released for KSP 1.4.1, try 2.0.2.0 instead

These are at least the mods I can find so far. Get the correct mod versions for KSP 1.3.1 and fix the messed up install of Kerbal Engineer and try it again ;)

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, 4x4cheesecake said:

Get the correct mod versions for KSP 1.3.1

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, TheSpacePlaneArchitect said:

Hello! I replaced the mods, removed those that i don't need, but it is still crashing. https://ufile.io/ijkwz

The game crashes whhile loading the parts of interstellar which kinda makes sense since the version you've installed now is even newer than the last one (1.20.15 is released for KSP 1.5.1) and Firespitter is still installed in the old version for KSP 1.1.3.

Checkout the link provided by @Gargamel to be sure, you get the correct versions. You can also try CKAN, most of these mods are available there (that's actually how I find all the compatible version numbers^^).

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
54 minutes ago, 4x4cheesecake said:

The game crashes whhile loading the parts of interstellar which kinda makes sense since the version you've installed now is even newer than the last one (1.20.15 is released for KSP 1.5.1) and Firespitter is still installed in the old version for KSP 1.1.3.

Checkout the link provided by @Gargamel to be sure, you get the correct versions. You can also try CKAN, most of these mods are available there (that's actually how I find all the compatible version numbers^^).

Weird, i downloaded these mods from curseforge, and it said that it was for 1.3.1. Welp, guess i need to use CKAN instead. Thanks!

Share this post


Link to post
Share on other sites
  • 0
8 minutes ago, TheSpacePlaneArchitect said:

Weird, i downloaded these mods from curseforge, and it said that it was for 1.3.1. Welp, guess i need to use CKAN instead. Thanks!

Oh, you are right, there are actually some backports for KSP 1.3.1 and 1.20.16 seem to be the latest release for KSP 1.3.1. Sorry, I totally missed that.

Anyway, Firespitter will definitly need an update: https://github.com/snjo/Firespitter/releases/tag/v7.6.0

Probably the NearFeature parts as well, hard to say if the version number for these mods are listed properly in the log.

In generall, I would always recommend to use spacedock or CKAN instead of curseforge. Spacedock is maintained way better and via the 'changelog' tab, you can easily find the proper mod versions. CKAN also provides a version tab but it's usually not necessary to check the version manually there but most mods contain a link to the forum page or github repository which can be quiet handy ;)

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, 4x4cheesecake said:

curseforge

Curse also has back versions, as shown in the link above, but yes, curse is usually harder to navigate. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this