Jump to content

[1.9.x] OSE Workshop Reworked - KIS Addon


linuxgurugamer
 Share

Recommended Posts

1 minute ago, Tonka Crash said:

From looking in the code there's no undocumented setting to bypass the exclusion, but you could always try using the 1.21 KIS.dll where it didn't exist. KIS also adds the mid size cargo box that holds 6 experiments using +PART and makes the small one equippable as a backpack. 

am thinking of doing that (1.21).

Any further and should continue in KIS thread. (apologies to LGG)

Issue is doing more than one or two on a distant surface would take a whole lot of cargo space - hence why workshop (or simple construction) would be best.

Link to comment
Share on other sites

  • 1 month later...

I'm not sure if this has been reported already, however it appears that OSE workshop is completely incompatible with KSP  1.7.3. There are no options for it in the settings menu, and right-clicking the workshops does not bring up the GUI.

This is rather unfortunate, as I happened to be in the middle of a large colony building operation when I updated to 1.7.3. The only other mod that similarly produce individual parts would be Ground Construction, but it's hardly a replacement - what normally takes OSE 30 seconds takes GC around 15 minutes (including fabricating the "DIY kit", repositioning it, deploying it, constructing the part, and launching it).

Edit to original post: On a hunch, I removed Ground Construction to see if there was a conflict between the two (there is a file for an MM config for ground construction in the OSE folder, however it is blank). Upon loading up the game and opening a new save (so that I wouldn't lose the ships with Ground Construction parts in my old save), I found that the settings appear once more, and that I can interact with the parts.
It took me a few minutes to figure out the new mechanics - how you have to unpack the workshop, and how you cannot produce parts while on the runway, but I eventually got it to work.

So, it appears that the conflict between OSE workshop and Ground Construction is so great that it seems to essentially overwrite OSE entirely, making it so that you cannot access any settings or interact with the workshops at all.

Edit 2: After adding Ground Construction back in after loading the game once without it, I'm able to open up the OSE workshop menus. However, while I can select a part for production, occasionally production will stop at 100%, and the part will not be placed in an inventory, just staying in the queue forever. It appears to only happen with workshops on vessels that were launched before the whole switcheroo "fix" I described earlier. Still might be something to look in to. The recycling menu also appears to be broken, at least on the pre-switcheroo vessels.

It's odd that, at first, it didn't work *at all* with Ground Construction - only after loading the game once with OSE and without GC, and then loading it again with both installed, then restarting it to load it once more, did the two appear to coexist.

I hope that there is some way that I can help you in resolving this. If you need any logs, I can provide them.

Edited by Raptor22
Ran several tests on a hunch, removing and replacing files. Noticed a few new things.
Link to comment
Share on other sites

On 8/3/2019 at 12:23 AM, Raptor22 said:

Edit 2: After adding Ground Construction back in after loading the game once without it, I'm able to open up the OSE workshop menus. However, while I can select a part for production, occasionally production will stop at 100%, and the part will not be placed in an inventory, just staying in the queue forever. It appears to only happen with workshops on vessels that were launched before the whole switcheroo "fix" I described earlier. Still might be something to look in to. The recycling menu also appears to be broken, at least on the pre-switcheroo vessels.

It's odd that, at first, it didn't work *at all* with Ground Construction - only after loading the game once with OSE and without GC, and then loading it again with both installed, then restarting it to load it once more, did the two appear to coexist.

I hope that there is some way that I can help you in resolving this. If you need any logs, I can provide them.

Looking into this, I noticed that it's not easy to realize that the workshop may have run out of a resource.

Could you start the game, right-click on the workshop and read the contents of the PAW menu carefully, if it's out of one or more resources, the text will be near or at the top of the PAW.

Meanwhile, i'm going to add a better notification of resource starvation.

Link to comment
Share on other sites

23 minutes ago, linuxgurugamer said:

Looking into this, I noticed that it's not easy to realize that the workshop may have run out of a resource.

Could you start the game, right-click on the workshop and read the contents of the PAW menu carefully, if it's out of one or more resources, the text will be near or at the top of the PAW.

Meanwhile, i'm going to add a better notification of resource starvation.

There was no resource starvation. Trust me, I've used this mod for over a year, and have printed out thousands of parts over dozens of missions. I made sure to have every possible resource - exotic minerals, rare metals, and material kits, as well as printing parts like structural trusses which only need material kits. Restarting the game had no effect - I had to recover the vessel and launch a new one.

Edited by Raptor22
Link to comment
Share on other sites

4 minutes ago, Raptor22 said:

There was no resource starvation. Trust me, I've used this mod for over a year, and have printed out thousands of parts over dozens of missions. I made sure to have every possible resource - exotic minerals, rare metals, and material kits, as well as printing parts like structural trusses which only need material kits. Restarting the game had no effect - I had to recover the vessel and launch a new one.

Ok.

Can you send me a save file along with a log file of that save?

Link to comment
Share on other sites

Just now, linuxgurugamer said:

Ok.

Can you send me a save file along with a log file of that save?

That may be a bit of a problem. On Sunday I deleted the save and started a new one - I wish that I had thought to keep it. Sorry, I'll be sure to send you the files if the issue appears again in my new save.

Link to comment
Share on other sites

23 minutes ago, Raptor22 said:

That may be a bit of a problem. On Sunday I deleted the save and started a new one - I wish that I had thought to keep it. Sorry, I'll be sure to send you the files if the issue appears again in my new save.

It's possible there is a small roundoff error inside, I'll see what I can do

Link to comment
Share on other sites

v0.03 pushed on Github

needless to say - thank you to @blowfish, I was 96% there and well, the fishblew me over the top. :P:cool:

Spoiler

 + converted (successfully) with some inferred inspiration from @blowfish both the 3000 and 6000 containers. Created new part.cfg as didn't want to markup working versions.
+ added (barebones) cck support
+ DuctTape mesh
 + Created B9TankTypes.cfg - This will need a balance pass to adjust for cargo density
 + need to add [Ore] to tanks
 + B9 fully integrated, switch to new cargo, and the texture changes as well.
 + currently can switch contents in flight (as long as is emptry) - think should remain that way
 + will polish more later.
 + added tags to all parts

pipe dream: since KIS and BreakingGroundScience don't like each other, would it be possible to direct those items to StockStorage?

Edited by zer0Kerbal
Link to comment
Share on other sites

On 8/6/2019 at 3:41 AM, zer0Kerbal said:

v0.03 pushed on Github

needless to say - thank you to @blowfish, I was 96% there and well, the fishblew me over the top. :P:cool:

  Reveal hidden contents

 + converted (successfully) with some inferred inspiration from @blowfish both the 3000 and 6000 containers. Created new part.cfg as didn't want to markup working versions.
+ added (barebones) cck support
+ DuctTape mesh
 + Created B9TankTypes.cfg - This will need a balance pass to adjust for cargo density
 + need to add [Ore] to tanks
 + B9 fully integrated, switch to new cargo, and the texture changes as well.
 + currently can switch contents in flight (as long as is emptry) - think should remain that way
 + will polish more later.
 + added tags to all parts

pipe dream: since KIS and BreakingGroundScience don't like each other, would it be possible to direct those items to StockStorage?

I'm not sure about the changing contents in flight.  Different materials require different kinds of tanks, reflected in the costs of the tank.

I had to redo the balance in B9TankTypes.cfg, of the resources, the numbers were way too high.

 

Status Update for everyone:

While debugging on my stream this week, I was struck by hard it was to see and do things, so I've been working on some Quality of Life improvements

I've added the following features to the current built (not yet released):

  • Highlighting of modules which run out of something
  • Tooltips on all the buttons
  • Stop warp when running out of something
  • Show popup when running out of something
  • Full B9 support, removing the old Firespitter configs.  Much cleaner display

Also, to address a possible floating point roundoff error, I've changed the test for when something is complete from 100% to 99.9999%, hopefully this will address the issue that @Raptor22 had

 

 

Link to comment
Share on other sites

17 minutes ago, linuxgurugamer said:

'Im not sure about the changing contents in flight.  Different materials require different kinds of tanks, reflected in the costs of the tank.

I had to redo the balance in B9TankTypes.cfg, of the resources, the numbers were way too high

Make sense. I will add ore to the switch (and some other minor cosmetic things) later this week.

Thought as much about quantities - 6000 material kits could print an entire class b asteroid. :P

The new recipes work for BreakingGround; and as expected the new groundScience parts hit 100% and KIS won't let them go into inventory. Possible to have them directed to SerenityStorage instead? (that would be allot of code I suspect). The ScienceArms printed just fine, and slapped them on the outside - tried to scan, but the part just said nothing in range.

Missing from the GUI are categories for Robotics, Cargo,

Concerning the switch from FS to B9 - two observations:

  1. objective: B9 takes up a signifigantly smaller disk footprint (184KB (disk) & 136KB (dll) VS. 856KB (disk) 856KB (360KB - pdb) (dll))
  2. subjective: B9 seems to be more responsive/snappier.
Link to comment
Share on other sites

21 minutes ago, zer0Kerbal said:

The new recipes work for BreakingGround; and as expected the new groundScience parts hit 100% and KIS won't let them go into inventory. Possible to have them directed to SerenityStorage instead? (that would be allot of code I suspect). The ScienceArms printed just fine, and slapped them on the outside 

May not be that bad, I'll  look into it

22 minutes ago, zer0Kerbal said:

Missing from the GUI are categories for Robotics, Cargo,

Considering those are new, doesnt surprise me.

If I can get this integrated with the stock inventory, they will be added

Link to comment
Share on other sites

  • 2 weeks later...

New release, 1.2.11

  • Thanks to @zer0kerbal for this:
    • Breaking Ground patch
    • Majority of conversion to B9PartSwitch
  • Added recipies for GroundConstruction parts
  • Added highlighting of lab when error occurs
  • Added tooltips to top row of buttons in workshop
  • Added tooltips to part list
  • Adjusted progress completion from 100 to 99.999f, in both the workshop and recycler in case of any possible floating point errors
  • **** Added ToolbarController as a dependency ****
  • **** Added SpaceTuxLibrary as a dependency ****
  • Replaced LoadTexture code with the ToolbarController code
  • Replaced use of ResourceBroker in the recycler with the same calls in the Workshop
  • Added highlighting of recycler when error occurs
  • Added popup dialog when error occurs, gives option to open workshop if it isn't open
Edited by linuxgurugamer
Link to comment
Share on other sites

I seem to have an issue after updating to 1.2.11. The parts all appear in the selector, however, they do not function at all, as no OSE - specific buttons show up in the right click menus for the workshop parts. Looking in KSP.log shows the following lines:

Quote

[LOG 23:47:44.291] PartLoader: Compiling Part 'KIS/Parts/container1/part/KIS_Container1'
[ERR 23:47:44.306] Cannot find a PartModule of typename 'OseModuleInventoryPreference'

[LOG 23:47:59.175] PartLoader: Compiling Part 'Squad/Parts/Science/LargeCrewedLab/largeCrewedLab/Large_Crewed_Lab'
[ERR 23:47:59.193] Cannot find a PartModule of typename 'OseModuleCategoryAddon'

[LOG 23:48:05.381] PartLoader: Compiling Part 'Workshop/Parts/OSE_Converter/Converter/OSE_Converter'
[LOG 23:48:05.408] PartLoader: Part 'Workshop/Parts/OSE_Converter/Converter/OSE_Converter' has no database record. Creating.
[LOG 23:48:05.415] DragCubeSystem: Creating drag cubes for part 'OSE.Converter'
[LOG 23:48:05.512] PartLoader: Compiling Part 'Workshop/Parts/OSE_Workshop/Workshop/OSE_Workshop'
[ERR 23:48:05.520] Cannot find a PartModule of typename 'OseModuleWorkshop'


[ERR 23:48:05.521] Cannot find a PartModule of typename 'WorkshopAnimateGeneric'

[ERR 23:48:05.521] Cannot find a PartModule of typename 'WorkshopDamageController'

[LOG 23:48:05.527] PartLoader: Part 'Workshop/Parts/OSE_Workshop/Workshop/OSE_Workshop' has no database record. Creating.
[LOG 23:48:05.529] DragCubeSystem: Creating drag cubes for part 'OSE.Workshop'
[LOG 23:48:05.574] PartLoader: Compiling Part 'Workshop/Parts/OSE_Workshop/WorkshopAICore/OSE_WorkshopAiCore'
[ERR 23:48:05.580] Cannot find a PartModule of typename 'OseModuleRecycler'

Which seems to show that the PartModules arent loading, for some reason.

Mods Used:

 

ClickThroughBlocker 0.1.7.2

ToolbarControl 0.1.8.2

B9PartSwitch 2.10.0

CommunityResourcePack 1.2.0.0

Firespitter 7.13.0

KIS 1.22

Workshop 1.2.11.0

 

I think these are the bare minimum for OSE workshop to work. Am i missing any? Downgrading to 1.2.10.0 does not have this issue and works ok.

EDIT: log file is here: https://gofile.io/?c=2D7sHt

 

 

Edited by Whizzkid
Added Log File
Link to comment
Share on other sites

23 hours ago, Whizzkid said:

I seem to have an issue after updating to 1.2.11. The parts all appear in the selector, however, they do not function at all, as no OSE - specific buttons show up in the right click menus for the workshop parts. Looking in KSP.log shows the following lines:

Which seems to show that the PartModules arent loading, for some reason.

Mods Used:

 

ClickThroughBlocker 0.1.7.2

ToolbarControl 0.1.8.2

B9PartSwitch 2.10.0

CommunityResourcePack 1.2.0.0

Firespitter 7.13.0

KIS 1.22

Workshop 1.2.11.0

 

I think these are the bare minimum for OSE workshop to work. Am i missing any? Downgrading to 1.2.10.0 does not have this issue and works ok.

EDIT: log file is here: https://gofile.io/?c=2D7sHt

 

 

I'm seeing this as well.  None of my workshops are functional.

Link to comment
Share on other sites

50 minutes ago, zer0Kerbal said:

KAS?

No, I'm looking into it now

You all are missing the new dependency.

I don't know how to make it more obvious.  I put it in large bold letters in red, both in the release notes and the OP:

  • **** Added SpaceTuxLibrary as a dependency ****

All of you who are having problems had to have installed it by hand, because there was an issue with the CKAN update.

CKAN has now been updated properly

Edited by linuxgurugamer
Link to comment
Share on other sites

5 minutes ago, MaxPeck said:

Were starting to get to a point where I have almost as many dependency libraries as I do mods. 

This new library is actually going to make it a bit simpler down the road, I'm planning on eventually merging the ClickThroughBlocker and ToolbarController into it to reduce the libraries

Problem with CKAN was my fault, there are three different Workshop entries, I updated the wrong one.  Being fixed now

Link to comment
Share on other sites

1 hour ago, linuxgurugamer said:

I don't know how to make it more obvious.  I put it in large bold letters in red, both in the release notes and the OP:

  • **** Added SpaceTuxLibrary as a dependency ****

Where can I obtain that?  The OP lists ToolbarController and SpaceTuxLibrary as dependencies, but doesn't have download links like it does for the other dependencies.  (I have TC already, but not STL.)

Link to comment
Share on other sites

6 minutes ago, Wyzard said:

Where can I obtain that?  The OP lists ToolbarController and SpaceTuxLibrary as dependencies, but doesn't have download links like it does for the other dependencies.  (I have TC already, but not STL.)

https://spacedock.info/mod/2210/SpaceTux Library

https://github.com/linuxgurugamer/SpaceTuxLibrary/releases

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...