linuxgurugamer

[1.5.1, 1.6.1, 1.7.2] AECS Motion Suppressor (air brake, engine, & control surfaces)

Recommended Posts

Posted (edited)

This mod is derived from the old Control Surface Toggle mod.  original thread is here:  https://forum.kerbalspaceprogram.com/index.php?/topic/164626-*

Immersion gets shattered when you are in space and your control surfaces flap uselessly while maneuvering.  Also, it's quite funny when you are on a planet with an SSTO which has airbrakes, and the airbrakes open when you hit the brakes.  

What really annoys me is the useless engine gimbaling when I'm just rotating the vessel, etc.

This mod fixes all that, seamlessly and automatically.  For those who want to, you can manually disable/enable all control surfaces by right-clicking on one of the parts.  There are now events, so you can also do that using action groups

Pics later

Availability

Available in CKAN

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

Glad to see Control Surface Toggle brought up to date.  Your additions sounds pretty promising too.  Thanks again for all your work!

Share this post


Link to post
Share on other sites

Conflict with MechJeb: MechJeb no control thrust vector of engine in space(((((

Share this post


Link to post
Share on other sites
40 minutes ago, rebel-1 said:

Conflict with MechJeb: MechJeb no control thrust vector of engine in space(((((

Not sure I understand you.  Are you saying that it doesn't work with Mechjeb in space?

Share this post


Link to post
Share on other sites
Posted (edited)
16 minutes ago, linuxgurugamer said:

Not sure I understand you.  Are you saying that it doesn't work with Mechjeb in space?

MechJeb autopilot in space no conrol thrust vectoring with this mod. Engine gimbaling is blocked. And autopilot unable hold maneur node.

Edited by rebel-1

Share this post


Link to post
Share on other sites
10 minutes ago, rebel-1 said:

MechJeb autopilot in space no conrol thrust vectoring with this mod. Engine gimbaling is blocked. And autopilot unable hold maneur node.

Ok, I'm trying to understand exactly what you are saying, please tell me if I have it correct (I assume english isn't your first language):

When the mod is installed, all gimbaling (ie: thrust vectoring) is disabled when MechJeb is also installed, so that Mechjeb is unable to hold a maneuver node because of the lack of gimbaling.

So, I have some questions:

  • Was this during a launch?
  • Before the maneuver, please confirm the engines were turned off
  • And, do the following test, please:  Do a quicksave, then activate the engines manually and see if they gimbal  when you use manual control

Share this post


Link to post
Share on other sites
1 minute ago, linuxgurugamer said:

Ok, I'm trying to understand exactly what you are saying, please tell me if I have it correct (I assume english isn't your first language):

When the mod is installed, all gimbaling (ie: thrust vectoring) is disabled when MechJeb is also installed, so that Mechjeb is unable to hold a maneuver node because of the lack of gimbaling.

So, I have some questions:

  • Was this during a launch?
  • Before the maneuver, please confirm the engines were turned off
  • And, do the following test, please:  Do a quicksave, then activate the engines manually and see if they gimbal  when you use manual control

With manual control gimbal is working. Problem only with MJ autopilot.

Share this post


Link to post
Share on other sites
1 hour ago, rebel-1 said:

With manual control gimbal is working. Problem only with MJ autopilot.

Perhaps an example .craft and a sequence of steps to bring up the issue.

Taking a wild guess, is a craft on MJ autopilot unable to use the engine gimballing to align to or hold on a manuever node to execute it?

Share this post


Link to post
Share on other sites

I'm also having an issue with gimballing not work, but it occurs with SAS, not just mechjeb. It doesn't gimbal at all, unless it's in a KRASH simulation.

Share this post


Link to post
Share on other sites
Posted (edited)

New release, 1.3.1

  • Added code to detect changes in vessel and update accordingly
  • Added code to detect vessel changes
  • Removed check for mainThrottle == 0 (needed to allow MechJeb to work properly)
  • Added events and actions to allow all gimbals to be enabled, disabled, and reset
  • Changed check from 5x a second to 4x a second
  • Changed the OnStart to Start in ModuleEngineGimbal

@rebel-1 @Jacke  @dlrk  This update should fix your problems

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
3 hours ago, linuxgurugamer said:

  This update should fix your problems

Thanks

Share this post


Link to post
Share on other sites

New release, 1.3.1.1

  • Version bump for 1.7.2

Share this post


Link to post
Share on other sites

Many thanks for this and all of the mods you are taking care of.

cheers.

Share this post


Link to post
Share on other sites

There was another one called Smart Actuation, which I kinda missed, thanks

Share this post


Link to post
Share on other sites

Appreciate the update.  This great mod should be stock.

Share this post


Link to post
Share on other sites

I'm not entirely sure what the problem was, but this mod was somewhat abruptly blocking engine gimballing in flight.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.