Nertea

[1.10.1+] Restock - Revamping KSP's art (September 1)

Recommended Posts

I'm having a bit of a problem with ReStock and a whitelist.  I have a mod, the Kurrikane, which has the following whitelist file:

Kurrikane.restockwhitelist

:^VenStockRevamp/Squad/Parts/Aero/BasicFin:Squad/Parts/Aero/basicFin/basicFin:.mu
:^VenStockRevamp/Squad/Parts/DockingPorts/MK16:Squad/Parts/Utility/parachuteMk1/model:.mu
:^VenStockRevamp/Squad/Parts/Heatshields/HeatShieldS0:Squad/Parts/Aero/HeatShield/HeatShield0:.mu
:^VenStockRevamp/Squad/Parts/Propulsion/InlineXenon:Squad/Parts/FuelTank/xenonTank/model:.mu
:^VenStockRevamp/Squad/Parts/Propulsion/TT-38K:Squad/Parts/Utility/decouplerRadialTT-38K/model:.mu
Squad/Parts/Aero/basicFin/basicFin.mu
Squad/Parts/Aero/HeatShield/HeatShield0.mu
Squad/Parts/Engine/OMSEngine/NewModel.mu
Squad/Parts/FuelTank/xenonTank/model.mu
Squad/Parts/Utility/decouplerRadialTT-38K/model.mu
Squad/Parts/Utility/parachuteMk1/model.mu

and the MODEL stanza from one of the part files:

	MODEL
	{
		model = Squad/Parts/Utility/parachuteMk1/model
		texture = model000, Kurrikane/Parts/Chute/model000
	}

I have no idea where I got the VenStockRevamp syntax from.  My issue is that while the .mu file seem to be there,  the texture is not there, leaving all  the parts a grey color with no detail.

This works fine in a stock game.

Any ideas what might be going on?

Share this post


Link to post
Share on other sites
1 minute ago, linuxgurugamer said:

I have no idea where I got the VenStockRevamp syntax from.  My issue is that while the .mu file seem to be there,  the texture is not there, leaving all  the parts a grey color with no detail.

I don't think those VenStockRevamp lines will do anything.  There's probably a log line complaining that they don't exist.

The textures are likely blacklisted as well.  Just like the models they would need to be whitelisted.

Share this post


Link to post
Share on other sites
3 minutes ago, blowfish said:

I don't think those VenStockRevamp lines will do anything.  There's probably a log line complaining that they don't exist.

The textures are likely blacklisted as well.  Just like the models they would need to be whitelisted.

Thank you

Share this post


Link to post
Share on other sites
13 hours ago, blowfish said:

I don't think those VenStockRevamp lines will do anything.  There's probably a log line complaining that they don't exist.

The textures are likely blacklisted as well.  Just like the models they would need to be whitelisted.

Still happening.  Here is the updated whitelist:

Squad/Parts/Aero/basicFin/basicFin.mu
Kurrikane/Parts/fin/BasicFin_orange_StripeAdjustedHvy.png
Kurrikane/Parts/fin/BasicFin_orange_StripeAdjusted.png

Squad/Parts/Aero/HeatShield/HeatShield0.mu
Kurrikane/Parts/HeatShield/heatshield.dds

Squad/Parts/FuelTank/xenonTank/model.mu
Kurrikane/Parts/FuelTank/model001.dds
Kurrikane/Parts/FuelTank/model000.dds


Squad/Parts/Utility/decouplerRadialTT-38K/model.mu
Kurrikane/Parts/Decoupler/model000.dds
Kurrikane/Parts/Decoupler/model001.dds

Squad/Parts/Utility/parachuteMk1/model.mu
Kurrikane/Parts/Chute/model000.dds

Kurrikane/Parts/Engine/K-101.mu
Kurrikane/Parts/Engine/JebsJunkyard.dds
Kurrikane/Parts/Engine/JebsJunkyard_Emissive.dds
Kurrikane/Parts/Engine/JebsJunkyard_normal.dds
Kurrikane/Parts/Engine/fairing.dds

And here is the log file:

https://www.dropbox.com/s/yq32n4131ip9ej2/KurrikaneLog.zip?dl=0

The important lines from the log file are here:

Load(Texture): Kurrikane/Parts/Chute/model00

.
.
.

PartLoader: Compiling Part 'Kurrikane/Parts/Chute/SondeChute/miniSondeChute'
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

PartCompiler: Cannot replace texture as cannot find texture 'model000' to replace

Path to the directory is: Kurrikane\Parts\Chute

Model stanza:

	MODEL
	{
		model = Squad/Parts/Utility/parachuteMk1/model
		texture = model000, Kurrikane/Parts/Chute/model000
	}

I verified that the part is working correctly in a non-restock game

Share this post


Link to post
Share on other sites
5 hours ago, linuxgurugamer said:

Still happening.  Here is the updated whitelist:

Spoiler


Squad/Parts/Aero/basicFin/basicFin.mu
Kurrikane/Parts/fin/BasicFin_orange_StripeAdjustedHvy.png
Kurrikane/Parts/fin/BasicFin_orange_StripeAdjusted.png

Squad/Parts/Aero/HeatShield/HeatShield0.mu
Kurrikane/Parts/HeatShield/heatshield.dds

Squad/Parts/FuelTank/xenonTank/model.mu
Kurrikane/Parts/FuelTank/model001.dds
Kurrikane/Parts/FuelTank/model000.dds


Squad/Parts/Utility/decouplerRadialTT-38K/model.mu
Kurrikane/Parts/Decoupler/model000.dds
Kurrikane/Parts/Decoupler/model001.dds

Squad/Parts/Utility/parachuteMk1/model.mu
Kurrikane/Parts/Chute/model000.dds

Kurrikane/Parts/Engine/K-101.mu
Kurrikane/Parts/Engine/JebsJunkyard.dds
Kurrikane/Parts/Engine/JebsJunkyard_Emissive.dds
Kurrikane/Parts/Engine/JebsJunkyard_normal.dds
Kurrikane/Parts/Engine/fairing.dds

 

ReStock isn't going to blacklist anything in Kurrikane/ so those lines won't help - the problem is (for example) Squad/Parts/Utility/parachuteMk1/model000.dds is still blacklisted.  I believe it needs to exist for KSP to be able to replace it.  So that (and anything else used on those models) needs to be whitelisted.

Edited by blowfish

Share this post


Link to post
Share on other sites
59 minutes ago, blowfish said:

ReStock isn't going to blacklist anything in Kurrikane/ so those lines won't help - the problem is (for example) Squad/Parts/Utility/parachuteMk1/model000.dds is still blacklisted.  I believe it needs to exist for KSP to be able to replace it.  So that (and anything else used on those models) needs to be whitelisted.

ah.  Ok, got it.  thx

Share this post


Link to post
Share on other sites

I really like how you fit everything to gether. for example, if you want a gray rocket with orange like soyuz its very simple. same for if you want a black/white.

Share this post


Link to post
Share on other sites
23 hours ago, IronKerbal said:

Are the Wings going to be revamped?

Nope, they are fine. 

On 12/7/2019 at 7:52 PM, Jebihean Kerman said:

Hi mi new to restock and all of you mi just asking why is the the space shuttle cockpit and other part like 2 MK plane cockpit and also the external seat and  other parts of the DLC making history / DLC breaking ground have not been restock yet?

Because of these 3 reasons:

1) None of the aero parts are being redone
2) Anything MH you get is a personal favor
3) The team has other commitments to life and stuff and could only cover 250+ parts in about a year. 

On 12/7/2019 at 9:50 PM, RyanRising said:

You know, I feel kind of bad nitpicking, given that you lot have put so much work into this mod, but it seems to me that the small 1.25m tank (FL-T100)'s black and white texture is a bit out of place. The stripes on it have trifold symmetry, where most of the other tanks have quad or double symmetry, and where those can work with each other, they don't mix so well with the 3-way stripes. There was probably a reason for this choice, and I'd be interested to know what it is, but for me it does mess with the unity of this mod's aesthetic.

It's a Porkjet Original (tm) so the quality is a little lower than the rest of the work. Don't know if we'll get around to adjusting that ever, most signs point to no.

On 12/8/2019 at 8:30 AM, Atlas Gaming said:

Odd bug - not sure if caused by ReStock but my Experiment Storage Unit (the stock crate looking thing) has seemed to change to 4 super thin pillers. Like it's just the edge outline and is empty (clear) in the middle. I'll try excluding it from restock to see if that fixes it or if there is some other mod changing it - any idea how I can tell what mods are applying patches to it?

I'm assuming you resolved this as there are no more posts!

Share this post


Link to post
Share on other sites
9 hours ago, Nertea said:
On 12/8/2019 at 11:30 AM, Atlas Gaming said:

Odd bug - not sure if caused by ReStock but my Experiment Storage Unit (the stock crate looking thing) has seemed to change to 4 super thin pillers. Like it's just the edge outline and is empty (clear) in the middle. I'll try excluding it from restock to see if that fixes it or if there is some other mod changing it - any idea how I can tell what mods are applying patches to it?

I'm assuming you resolved this as there are no more posts!

I have this same issue, @Atlas Gaming did you solve it?  Is it ReStock or something else?

Share this post


Link to post
Share on other sites
13 hours ago, Nertea said:
On 12/8/2019 at 11:30 AM, Atlas Gaming said:

Odd bug - not sure if caused by ReStock but my Experiment Storage Unit (the stock crate looking thing) has seemed to change to 4 super thin pillers. Like it's just the edge outline and is empty (clear) in the middle. I'll try excluding it from restock to see if that fixes it or if there is some other mod changing it - any idea how I can tell what mods are applying patches to it?

I'm assuming you resolved this as there are no more posts!

@Nertea I've isolated the problem.

It happens when Indicator Lights, Indicator Lights Community Extensions and Restock is installed.  Remove any one and it's ok. 

I'll ping @Snark since Indicator Lights is his mod

In the log, I found one light added 4 times to the ScienceBox, which is probably one of the causes

Share this post


Link to post
Share on other sites

@linuxgurugamer - the fix for that can be found here: 

Quote

 

Yup -- ILCE has a typo when defining the storage unit; it's missing a "-1" at the end of the name. It should look like here in IndicatorLights_Restock.cfg (at line #857)


//Science Box
@PART[ScienceBox]:AFTER[ReStock]:NEEDS[IndicatorLights]
{
	-MODEL,* {}
	MODEL
	{
		model = ReStock/Assets/Science/restock-sciencebox-radial-1
	}

 

 

 

Share this post


Link to post
Share on other sites

Hi guys.

I have developped a config file for Restockplus / Rigid Legs for Tweakscale (latest release) which is currently upon reviewing.

Anyone curious enough can install it : https://github.com/xot1643/TS-Restockplus/blob/master/config/Restockplus_Tweakscale.cfg

Please consider a disposable KSP installation, I don't want your savegames be corrupted.

Share this post


Link to post
Share on other sites

@DarkNounours I'd suggest using %type and %defaultScale to prevent any risk of them getting duplicated if there's another patch somewhere trying to set TweakScale config for the same part(s). Or if somebody accidentally copies the patch file into their directory in two separate locations.

Share this post


Link to post
Share on other sites

I have an issue(?) where a lot of the parts seem to have misplaced attachment nodes.  This causes lots of overlap and glitchy-looking connections.  For example, any tanks stacked on top of each other overlap by about .5m.  This causes the texture to flicker about.  If I knew how to record a screen cap gif I'd show it.

Anyone else having this type of thing?

Share this post


Link to post
Share on other sites
9 hours ago, linuxgurugamer said:

Indicator Lights Community Extensions

Yup that was it... I got rid of the lights... they are cute but don't really add function so can live without em. 

Share this post


Link to post
Share on other sites
10 hours ago, Aelfhe1m said:

@DarkNounours I'd suggest using %type and %defaultScale to prevent any risk of them getting duplicated if there's another patch somewhere trying to set TweakScale config for the same part(s). Or if somebody accidentally copies the patch file into their directory in two separate locations.

I am quite new to the game of making KSP config files. I found a file with %type and %defaultScale already provided with the Tweakscale mod: SSPXR_Tweakscale.cfg

@PART[sspx-adjusting-base-25-1,sspx-adjusting-base-cradle-25-1]:NEEDS[TweakScale]
{
	%MODULE[TweakScale]
	{
		%name = TweakScale
		%type = SSPXR_stack25
		%defaultScale = 2.5
	}
}

Do you mean my blocks should look like this ? With my specific definitions of scaling types ? 

To be honest I made the file like stock config files and most of the files provided with the Tweakscale mod are not using these variables.

 

6 hours ago, charliesoap4 said:

I have an issue(?) where a lot of the parts seem to have misplaced attachment nodes.  This causes lots of overlap and glitchy-looking connections.  For example, any tanks stacked on top of each other overlap by about .5m.  This causes the texture to flicker about.  If I knew how to record a screen cap gif I'd show it.

Anyone else having this type of thing?

Well I think I have applied exactly the same configurations than the stock parts. I tested the file in 1.8.1 only at the moment.

EDIT : I have just played with tanks in my VAB and have not seen what you are talking about. Do you have a partname so that I can check ?

191214090842552207.png

Edited by DarkNounours

Share this post


Link to post
Share on other sites

I've been having an issue with Restock and the stock launch clamps.

Initially, the clamps would remain attached to the vehicle and would not show up in staging. When on the launchpad, they would not extend to the ground. To solve this problem, I whitelisted the stock texture, which appeared to solve these problems. However, this created colored lines showing up on the vessel, like this:

qYvBwEk.jpg

Does anyone know how to fix this?

Edit: Turns out I was using the debug version of KJR Next. Hopefully this helps anyone with the same issue!

Edited by pt1243
Figured out what was wrong

Share this post


Link to post
Share on other sites
Just now, DarkNounours said:

I was dying to design such a craft :D

191214013022293222.png

191214013037649583.png

191214013040368290.png

what what is it? :o
ps. Put nuclear engines there.

Edited by OOM

Share this post


Link to post
Share on other sites
21 minutes ago, OOM said:

what what is it? :o
ps. Put nuclear engines there.

Well, could be a space egg :o

Nukes are nice for deltav but have less thrust to land on celestial bodies. 

Share this post


Link to post
Share on other sites

I've been using restock/restock+ 0.1.4 since I found it a few months ago, and only found out today that there was a new version with a load of newly restock-ified parts. Which is good- in most cases: the new versions of structural parts (and new parts from restock+ e.g. the new modular girder parts) are a nice addition, the new 1.875 parts like the reaction wheel and battery are also good (although slightly treading on the Missing History mod's toes), the new round fuel tanks could prove useful for side boosters and the lights on the grabber claw (and the new smaller claw) will be useful too.

The one thing I have a problem with is the reworked paint schemes for the Making History 1.875m fuel tanks, and it's a fairly simple one: they don't match! The stock paint jobs don't really match either, to be fair, but I was expecting the restock-ified versions to all have the same number of stripes on them in black-and-white mode. For some reason, the TX220, TX900  and 1.25-1.875m TX151L tanks have two black stripes and yet the TX440 and TX1800 have four, which matches the stock versions and also matches the engines that come with making history as well as the new medium reaction wheel, and indeed almost all of the other black and white patterned stock fuel tanks from 1.25m up to 5m. The TX900 is particularly odd, as the black stripes are double thickness at the very bottom edge but regular thickness further up which is unlike any other part.

The orange and grey versions do look a lot better than stock, if more grey and less orange which is a bit blander, and the addition of grey/orange versions of many parts e.g. engine shrouds and decouplers is also a good thing, but those black and white 1.875m patterns just don't look right especially with several different sized tanks in a stack and/or when using the cheetah/bobcat engines which also have black and white caps (suggestion for the next update: orange caps and fairings for the cheetah and bobcat). 

The T100 tank having 3 stripes I can live with, as it's a very early game part that I don't use much/at all as soon as bigger tanks come along, but those 1.875m tanks are pretty useful later in the game and the half-and-half stripe scheme just isn't right- I greatly prefer the new TX1800 as it looks much better in a stack now with the black pattern starting right at the top rather than part way down, but the TX900 is really odd looking beside it and I don't see why that should be.

A few other things I've noticed just rummaging around in the parts list: The LV-1 Ant engine isn't switching paint for me, it's stuck on the plain metal look and the white version doesn't appear; the RE-I2 Skiff engine claims to have a 1.875m tank butt version but it's actually 2.5m, and I can't get the white version- the tank butt itself is always orange and grey even with a white fairing (that might just be me misinterpreting the description to mean the tank butt would be white instead of just the fairing, as most of the other engine models have orange/grey themes for the rocket itself even if the shroud is white); the TX220-R 1.875m fuel tank has a plain metal version, but none of the other 1.875m tanks do, so I'm not sure when this would get used; and the shrouds on the 10m heat shield are too short for the bottom connecting node so it floats above whatever it's stacked on top of.

I don't mean to sound critical- clearly a huge amount of work has gone into making this mod and I'm very impressed with it, I particularly like the 'dark' colour scheme for 1.25m sized parts and would like to see that rolled out further e.g. to the 0.625m size bracket- but by day I'm a software tester and get paid to be picky, so I can't help bringing that mindset along. The flip side is that I'll try to be as detailed as possible if I find something that seems off, and do some investigating if I can to find the root cause to help get it fixed. (I'm currently using Restock and Restock+ v1.0.1 from CKAN in an otherwise mod-free KSP v1.8.1 instance for testing purposes; how did I miss the big new version by almost a whole month? :rolleyes:)

A couple of final suggestions: restock-ify the C7 1.25m-2.5m fuel tanks so that they at least have an orange version instead of just plain white, and add insulated versions of the modular girder hub, adapter and small adapter.

Share this post


Link to post
Share on other sites

Obviously trying to unify a style is not easy, especially when working on free time, everyone on his side with no real lead designer to give extremely precise requirements. I quite understand this very much. This is why I am a heavy user of Tweakscale which allows me to pick a part because of its look in order to fit perfectly a ship I am building.

PS :  the yellow stripes on the reworked engines, especially on white boattail variants, are not to my taste but I believe this is a matter of tastes and colours.

Edited by DarkNounours

Share this post


Link to post
Share on other sites

I might be able to explain a few of those things...

20 hours ago, jimmymcgoochie said:

The one thing I have a problem with is the reworked paint schemes for the Making History 1.875m fuel tanks, and it's a fairly simple one: they don't match! The stock paint jobs don't really match either, to be fair, but I was expecting the restock-ified versions to all have the same number of stripes on them in black-and-white mode. For some reason, the TX220, TX900  and 1.25-1.875m TX151L tanks have two black stripes and yet the TX440 and TX1800 have four, which matches the stock versions and also matches the engines that come with making history as well as the new medium reaction wheel, and indeed almost all of the other black and white patterned stock fuel tanks from 1.25m up to 5m. The TX900 is particularly odd, as the black stripes are double thickness at the very bottom edge but regular thickness further up which is unlike any other part.

The orange and grey versions do look a lot better than stock, if more grey and less orange which is a bit blander, and the addition of grey/orange versions of many parts e.g. engine shrouds and decouplers is also a good thing, but those black and white 1.875m patterns just don't look right especially with several different sized tanks in a stack and/or when using the cheetah/bobcat engines which also have black and white caps (suggestion for the next update: orange caps and fairings for the cheetah and bobcat). 

The T100 tank having 3 stripes I can live with, as it's a very early game part that I don't use much/at all as soon as bigger tanks come along, but those 1.875m tanks are pretty useful later in the game and the half-and-half stripe scheme just isn't right- I greatly prefer the new TX1800 as it looks much better in a stack now with the black pattern starting right at the top rather than part way down, but the TX900 is really odd looking beside it and I don't see why that should be.

You're welcome to your opinion, but I disagree (except the 3x on the FLT-100, I honestly did not notice that before and don't think it's great). 

Also, please don't compare things to hideous ugly engines like the cheetah and bobcat. They're still MH garbage. 

20 hours ago, jimmymcgoochie said:

The LV-1 Ant engine isn't switching paint for me, it's stuck on the plain metal look and the white version doesn't appear

There is no second variant here - should probably ensure the stock switcher is removed. Please make a github issue. 

20 hours ago, jimmymcgoochie said:

TX220-R 1.875m fuel tank has a plain metal version, but none of the other 1.875m tanks

There was a plan to make 1.875m metal variants but it got axed. There are a few leftovers from that - I left them in for people, I can take them out if it is preferred...

20 hours ago, jimmymcgoochie said:

the RE-I2 Skiff engine claims to have a 1.875m tank butt version but it's actually 2.5m, and I can't get the white version- the tank butt itself is always orange and grey even with a white fairing (that might just be me misinterpreting the description to mean the tank butt would be white instead of just the fairing, as most of the other engine models have orange/grey themes for the rocket itself even if the shroud is white);

This may need a tooltip adjustment but it's functioning as intended. The stock variant calls it a boattail but it's really not, it's just a mount. Just another example of why working with MH stuff is so hard/stupid

20 hours ago, jimmymcgoochie said:

shrouds on the 10m heat shield are too short for the bottom connecting node so it floats above whatever it's stacked on top of.

Please make a Github issue so this report does not get lost!

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.