Jump to content

[1.11.1] Restock - Revamping KSP's art (KSP 1.11, Jan 31)


Recommended Posts

I want to install Restock+, but I see that a lot of the parts are disabled for those who own the Making History expansion. I do own that expansion, but don't particularly like the parts from it.

So, is there any way to either disable Making History (I have not been able to find a method by searching around), or to enable those Restock+ parts despite Making History being installed?

Link to post
Share on other sites
1 minute ago, wasmic said:

I want to install Restock+, but I see that a lot of the parts are disabled for those who own the Making History expansion. I do own that expansion, but don't particularly like the parts from it.

So, is there any way to either disable Making History (I have not been able to find a method by searching around), or to enable those Restock+ parts despite Making History being installed?

Everything in RS+ that is disabled by MH is basically duplicative of the MH parts. If you use RS+ with MH, it will make your MH parts look better, which may make you like those parts more. Try it and see.

Link to post
Share on other sites
Just now, PocketBrotector said:

Everything in RS+ that is disabled by MH is basically duplicative of the MH parts. If you use RS+ with MH, it will make your MH parts look better, which may make you like those parts more. Try it and see.

Ah, okay, so it does replace the MH parts. The wording in the OP made me think that nothing at all would happen if MH is installed. Thank you!

Link to post
Share on other sites

A soyuz-like pod in the style of the restock'd MH ball pods would be a great addition to ReStock+. Tantares is a brilliant mod and I actually have it installed, but it's absolutely massive and a lot of people prefer not to have quite as many parts as Tantares has to offer.

Link to post
Share on other sites
1 hour ago, The Dressian Exploder said:

A soyuz-like pod in the style of the restock'd MH ball pods would be a great addition to ReStock+. Tantares is a brilliant mod and I actually have it installed, but it's absolutely massive and a lot of people prefer not to have quite as many parts as Tantares has to offer.

I'm really sorry for offtop, but...

First of all, there's HGR mod if you want just minimum. It's quite dated, but still supported and nice looking (if not to zoom super close...)

Spoiler

ACtC-3ftkui9Kmcj7A0VegqTnX8mEn23yPDS6p05

And it's very strange reasoning not to use Tantares, because adding is hard, removing is easy :)

Edited by evileye.x
Link to post
Share on other sites
19 hours ago, wasmic said:

Ah, okay, so it does replace the MH parts. The wording in the OP made me think that nothing at all would happen if MH is installed. Thank you!

I added a clarifying sentence, but from the FAQ:

Q: What's going on with the Making History-like parts?
A: If you own Making History, the Restock+ parts that overlap with the MH parts
(fuel tanks, etc), will not be added. Instead, those parts will have their art replaced.

Link to post
Share on other sites

Hey, I really liked the stock model for the nosecone better, because it fits on the mk3 cockpit much better. So I decided to try to whitelist it and all that with my limited experience, and I think I might need help.

It looks like this: 

img%5D

There is no art asset. I am confused. This is what my files, whitelists and etc look like:

img%5D

Is this another 1.11 thing Ive discovered, or is there something wrong on my end?

Here's the log as always:

https://drive.google.com/file/d/1cqF7R4MAb7qY4QJU-Sq5O0NCjAXFhKJS/view?usp=sharing

Link to post
Share on other sites
12 minutes ago, kerbalxploder said:

Hey, I really liked the stock model for the nosecone better, because it fits on the mk3 cockpit much better. So I decided to try to whitelist it and all that with my limited experience, and I think I might need help.

It looks like this: 

img%5D

There is no art asset. I am confused. This is what my files, whitelists and etc look like:

img%5D

Is this another 1.11 thing Ive discovered, or is there something wrong on my end?

Here's the log as always:

https://drive.google.com/file/d/1cqF7R4MAb7qY4QJU-Sq5O0NCjAXFhKJS/view?usp=sharing

The textures for the nosecone aren't in the same directory as the .cfg and .mu files. Instead they are in:

Squad/Parts/Utility/rockomaxAdapters/Assets/

You could whitelist the entire directory for simplicity, but that will also load in the 3d models for the two 1.25 to 2.5 adaptors. Not that big of a deal, but it will unnecessarily increase the load time by a bit. If that matters, you could selectively whitelist the following 5 files:

Squad/Parts/Utility/rockomaxAdapters/Assets/Rockomax_Adapters_diffuse
Squad/Parts/Utility/rockomaxAdapters/Assets/Rockomax_Adapters_diffuse_O
Squad/Parts/Utility/rockomaxAdapters/Assets/Rockomax_Adapters_diffuse_W
Squad/Parts/Utility/rockomaxAdapters/Assets/Rockomax_Adapters_normal
Squad/Parts/Utility/rockomaxAdapters/Assets/Rockomax_Adapters_normal_O

 

Edited by TBenz
Link to post
Share on other sites
15 hours ago, TBenz said:

The textures for the nosecone aren't in the same directory as the .cfg and .mu files. Instead they are in:



Squad/Parts/Utility/rockomaxAdapters/Assets/

You could whitelist the entire directory for simplicity, but that will also load in the 3d models for the two 1.25 to 2.5 adaptors. Not that big of a deal, but it will unnecessarily increase the load time by a bit. If that matters, you could selectively whitelist the following 5 files:



Squad/Parts/Utility/rockomaxAdapters/Assets/Rockomax_Adapters_diffuse
Squad/Parts/Utility/rockomaxAdapters/Assets/Rockomax_Adapters_diffuse_O
Squad/Parts/Utility/rockomaxAdapters/Assets/Rockomax_Adapters_diffuse_W
Squad/Parts/Utility/rockomaxAdapters/Assets/Rockomax_Adapters_normal
Squad/Parts/Utility/rockomaxAdapters/Assets/Rockomax_Adapters_normal_O

 

I just tested this. This time the nose cone didn't load. Am I misinterpreting something?

 

Edit: Yes I was, I erased the Aero/aerodynamicNoseCone/

All good now, thank you for your help!

Edited by kerbalxploder
Link to post
Share on other sites

Hey guys its been a while.

Ok so I uninstalled Real plume after reading its not compatible and I dont have restock+ installed. Do I need to remove smokescreen also?

Another question, I cant change the horn count on the RV 105 RCS Thruster block, is that a conflict here or something else?

 

EDIT: So loaded a stock KSP and everything worked, then added Restock and the Thruster stopped working, also the MK1/MK2 illuminater lights dont work right. However the new added lights do.

No other mods except manager. Is this something known or do I need Restock +  ? 

When I loaded the stock KSP, good grief I forgot how much better this mod makes it.

Edited by viperwolf
Link to post
Share on other sites
1 hour ago, viperwolf said:

Hey guys its been a while.

Ok so I uninstalled Real plume after reading its not compatible and I dont have restock+ installed. Do I need to remove smokescreen also?

Another question, I cant change the horn count on the RV 105 RCS Thruster block, is that a conflict here or something else?

 

EDIT: So loaded a stock KSP and everything worked, then added Restock and the Thruster stopped working, also the MK1/MK2 illuminater lights dont work right. However the new added lights do.

No other mods except manager. Is this something known or do I need Restock +  ? 

When I loaded the stock KSP, good grief I forgot how much better this mod makes it.

Restock and Restock+ are not yet supported for KSP 1.11.0, so some things are not yet 'working'.

Also RealPlume is supported for restock I'm not sure what you mean.

Link to post
Share on other sites
21 minutes ago, KeaKaka said:

Restock and Restock+ are not yet supported for KSP 1.11.0, so some things are not yet 'working'.

Also RealPlume is supported for restock I'm not sure what you mean.

 I just started back at it Today, so the update makes sense.

About the Real Plume, while i was searching over the thread. I saw someone talking that Real Plume Stock was not compatible?  I just started over anyway bc my mods where pretty old, even though I use Ckan to update them.

I try and run bare minimum mods, but this one(one of my favorites) is really nice to have. Ill happily wait for an update at some point. Thank you!!!!!!

Edited by viperwolf
Link to post
Share on other sites
17 hours ago, viperwolf said:

 I just started back at it Today, so the update makes sense.

About the Real Plume, while i was searching over the thread. I saw someone talking that Real Plume Stock was not compatible?  I just started over anyway bc my mods where pretty old, even though I use Ckan to update them.

I try and run bare minimum mods, but this one(one of my favorites) is really nice to have. Ill happily wait for an update at some point. Thank you!!!!!!

Waterfall has patches for most of the relevant Restock stuff, and I made some for a few of the others, like the Spark and Twitch, and the small Restock+ RCS

Link to post
Share on other sites
1 hour ago, EnderKid2 said:

Waterfall has patches for most of the relevant Restock stuff, and I made some for a few of the others, like the Spark and Twitch, and the small Restock+ RCS

Thank You, Ill search for it now.

Link to post
Share on other sites
1 minute ago, viperwolf said:

Thank You, Ill search for it now.

and I am unsure how to send files here, so I dunno about sending you my patches

Edited by EnderKid2
Link to post
Share on other sites
4 hours ago, EnderKid2 said:

and I am unsure how to send files here, so I dunno about sending you my patches

Im assuming your patches are the ones that fix the RCS  thruster and lights?

 

Just an Update: Before I waste anyone else's breath, I found the discussion talking about these very issues. Sorry

 

Edited by viperwolf
Link to post
Share on other sites
3 hours ago, viperwolf said:

Im assuming your patches are the ones that fix the RCS  thruster and lights?

thrusters and the spark/twitch engines

we're a tad off-topic though

Edited by EnderKid2
Link to post
Share on other sites

I'm using 1.11 and the Twin Boar doesn't have the restock texture, but there is one with restock textures when I go for example to filter by recources and a stock one aswell

Link to post
Share on other sites

That's because displaying parts by filters doesn't respect the TechHidden parameter for some reason that only SQUAD knows... so deprecated parts still show up in these searches. That's why the original Twin Boar is appearing here.

The reason why the Twin Boar v2 doesn't have the ReStock model and texture is due to the fact that this mod currently doesn't support KSP 1.11.0 as has been said on quite a few occasions over the last few pages.

For reference, if you compare the version that this mod is stated for to the changelog to the current version of KSP, you'll be able to figure out what parts will have issues... hell, that's what the ReStock team does. :D

Link to post
Share on other sites
55 minutes ago, Rocketry101 said:

Ksp 1.11 is here so update so tat the new 5 port rcs variants work

Keep in mind, please, that what seems like appreciation to the poster can sound like an order or demand to the mod maker. And they tend to get a lot of them. Asking about updates is fine, but a "please" makes it sound nicer. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...