Nertea

[1.7.x] Restock - Revamping KSP's art (May 10, KSP 1.7 + fixes)

Recommended Posts

Posted (edited)
14 hours ago, marcb said:

not my case... triple-check already ! and the mod is loaded as the blacklist seems applied.

ckan does install other mods correctly... that was mainly to rule out an install error on my side.

Problem solved after a fresh install and reinstalling ReStock and Engineer Redux mods through CKAN. Not sure what caused the issue. I still have the faulty install on the side, if a dev want me to dig a bit more. If not, I'll simply wipe it out :)

Edited by marcb
Problem solved before the message has been moderated :)

Share this post


Link to post
Share on other sites
On 3/8/2019 at 2:05 PM, kurgut said:

No, In all my attempts the craft was oriented retrograde of course. Yes, they're some realchutes (radial), but the actual real chute parts, not stock (using for a while, so don't think it's this).

Anyway, I did like 10 reentry tests, and it wan't nominal. But I'll test further before considering this as an issue,  with just a command pod heatshield/ with a shuttle/etc (reentry profiles I know), to see if there's really a difference.

I've seen something similar. My last 3 craft, 2 of them hit the ground at 600+m/s coming in from a standard 70K orbit, but one hit terminal velocity of 200m/s up around 8Km and landed nicely - just as I was expecting. Also no FAR, etc. here. So at the very least I think it's intermittent. Those were all different craft, so maybe it's related to specific parts in use? Almost as though one part such as the heat shield has a near zero drag coefficient where we only see the effect when it's not occluded during reentry. 

Share this post


Link to post
Share on other sites

if we just install real plume not the stock real plume config does restock's plume still work? 

Share this post


Link to post
Share on other sites
1 hour ago, ssd21345 said:

if we just install real plume not the stock real plume config does restock's plume still work? 

The best way to do it is to install both Real plume and real plume stock configs and then go to GameData/RealPlume-Stock and delete the Squad folder in there. Despite the name, the real plume stock folder has patches for many mods (about 40) not just stock parts.

This way you are guaranteed to have real plumes for any mods that support it and also have Restocks plumes for the revamped squad parts.

Share this post


Link to post
Share on other sites
On 3/9/2019 at 3:56 AM, Nertea said:

Isn't that what you're testing? Plus that config file, that is. 

A copy of the logfile would be nice. 

Spoiler

[LOG 22:53:34.852] [RealChute]: Loading settings file.
[ERR 22:53:34.971] [RealChute]: Could not find the transform "B_ParachuteLargeRotator" in the library

[LOG 22:53:36.269] parachuteLarge added to ship - part count: 2
[LOG 22:53:42.442] deleting part parachuteLarge
[ERR 22:53:44.621] [RealChute]: Could not find the transform "B_ParachuteLargeDrogueRotator" in the library

[LOG 22:53:45.976] parachuteDrogue added to ship - part count: 2
[LOG 22:53:51.728] deleting part parachuteDrogue
[ERR 22:53:53.991] [RealChute]: Could not find the transform "B_ParachuteRoot004" in the library

[LOG 22:53:55.286] parachuteSingle added to ship - part count: 2
[LOG 22:54:02.422] deleting part parachuteSingle
[ERR 22:54:06.806] [RealChute]: Could not find the transform "B_ParachuteRoot005" in the library

[LOG 22:54:08.275] radialDrogue added to ship - part count: 2
[ERR 22:54:09.378] [RealChute]: Could not find the transform "B_ParachuteRoot" in the library

[LOG 22:54:10.726] parachuteRadial added to ship - part count: 3
[LOG 22:54:18.924] deleting part parachuteRadial
[LOG 22:54:21.276] deleting part radialDrogue

This is using the compatibility patch: https://github.com/PorktoberRevolution/ReStocked/blob/master/Distribution/Restock/GameData/ReStock/Compatibility/RealChute.cfg (that looks like the following)

...
@PART[radialDrogue]:AFTER[RealChute]:NEEDS[ReStock]
{
  @MODULE[RealChuteModule]
  {
    @PARACHUTE
    {
      @preDeploymentAnimation = semiDeployLarge
      @deploymentAnimation = fullyDeployLarge
      @capName = RadialChuteCapDrogue
      @parachuteName  = B_ParachuteRoot005
    }
  }
}
...

The above patch is should be correct, but B_ParachuteRoot005 and all the other custom canopies will need to defined in the file(?): https://github.com/StupidChris/RealChute/blob/master/Output/GameData/RealChute/Materials/TextureLibrary.cfg

The work is, I guess, on RC's side?

Share this post


Link to post
Share on other sites
6 hours ago, johnsonwax said:

I've seen something similar. My last 3 craft, 2 of them hit the ground at 600+m/s coming in from a standard 70K orbit, but one hit terminal velocity of 200m/s up around 8Km and landed nicely - just as I was expecting. Also no FAR, etc. here. So at the very least I think it's intermittent. Those were all different craft, so maybe it's related to specific parts in use? Almost as though one part such as the heat shield has a near zero drag coefficient where we only see the effect when it's not occluded during reentry. 

Ok, I consulted with an expert and he suggested that my suspicion was probably right and likely a corrupted drag cube config in the part database. Deleting PartDatabase.cfg and letting it rebuild (simply restart KSP) appears to have solved the problem. Valentina appreciates the more predictable return procedure. 

Share this post


Link to post
Share on other sites
Posted (edited)

For restock +

Suggestion: Increase the general engine sound volume (don't have an exhaustive list, but I noticed that a quite a few of them).

The engines sounds are pretty lower than the stocks ones.

Edit: I've got real plume tho* (don't know if it mess with sounds)

Doing some tests right now:

----> Sound is low only for solid boosters, and for Lv-303 so far

Edited by kurgut

Share this post


Link to post
Share on other sites

So I'm getting a glitch where the parachute parts have crazy drag. I don't have Restock + and I've tried installing and reinstalling but this issue persists.

Share this post


Link to post
Share on other sites

Restock 0.1.2

  •  Fixes to address SurfaceLights compatibility (requires updated SurfaceLights, #522)
  •  Fixes to address RealChute compatibility (also rebuild your PartDatabase)
  •  Fixes to address RealPlume compatibility (requires updated RealPlume)
  •  Fixed Communotron HG-55 being rotated 180° to the stock version
  •  Fixed Basic variant Spark shroud (#521, #539)
  •  Fixed incorrect dimensions on SC-9001 Material Bay (#542)
  • Fixed Communotron HG-55 being rotated 180° to the stock version (#529)
  •  Fixed Rhino plume (#538)
  •  Fixed symmetry of 0.625m heat shield (#536)
  •  Tuned Stayputnik reflectivity

Restock+ 0.1.2

  •  Fixed incorrect dimensions on SC-9001R Material Bay (#542)
  •  Fixed mesh hole in 3.75m battery (#531)
  •  Fixed bottom node of Anvil SRB being too high (#534)
  •  Fixed Communotron HG-20 not appearing in the tech tree (#527)
  •  Replaced SKLE-2-3 adapter colldiers with hollow version (#528)
  •  Enabled patch to allow a tweakable to rotate both replaced lights
     

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, kurgut said:

For restock +

Suggestion: Increase the general engine sound volume (don't have an exhaustive list, but I noticed that a quite a few of them).

The engines sounds are pretty lower than the stocks ones.

Edit: I've got real plume tho* (don't know if it mess with sounds)

Doing some tests right now:

----> Sound is low only for solid boosters, and for Lv-303 so far

I think Twin Boar is too silent too.

On the other hand, the Rapier engine is way too loud. Same goes for other airbreathing engines, although Restock doesn't touch them.

Edit: 

Quote
  • Fixed Communotron HG-55 being rotated 180° to the stock version
  •  Fixed Basic variant Spark shroud (#521, #539)
  •  Fixed incorrect dimensions on SC-9001 Material Bay (#542)
  • Fixed Communotron HG-55 being rotated 180° to the stock version (#529)

Oh no! These 180° rotations cancel out! What have you done!?

 

Edited by MuchozolF

Share this post


Link to post
Share on other sites
57 minutes ago, Harry.Reds said:

So I'm getting a glitch where the parachute parts have crazy drag. I don't have Restock + and I've tried installing and reinstalling but this issue persists.

As suggested recently in the thread, close the game, navigate to KSP's root folder, Drive:/Path/Kerbal Space Program/, and delete the file 'PartDatabase.cfg' and then re-run the game and see if it resolves the issue.

Share this post


Link to post
Share on other sites

@Nertea, on SpaceDock, the new Restock+ version is the "standard" Restock file

And thanks a lot to you and other modders for this, this is just brilliant <3 

Share this post


Link to post
Share on other sites
Posted (edited)

ye, restock + download link on spacedock gives you restock instead.

And gj on update :)

@NerteaIt's fine on Github tho

Edited by kurgut

Share this post


Link to post
Share on other sites
56 minutes ago, Poodmund said:

As suggested recently in the thread, close the game, navigate to KSP's root folder, Drive:/Path/Kerbal Space Program/, and delete the file 'PartDatabase.cfg' and then re-run the game and see if it resolves the issue.

It's worth checking the parachute mesh is called "canopy", or bits of the code will base things off the fully open size. As far as I know this doesn't include drag though. So clearing out the old drag vibes should work.

Share this post


Link to post
Share on other sites

With this update, I'm not able anymore to switch between the different service bays variant, is it known around?

Just screenshoted in VAB

7X774V6.png

Share this post


Link to post
Share on other sites
3 minutes ago, kurgut said:

With this update, I'm not able anymore to switch between the different service bays variant, is it known around?

Thats not the Restock service bay... are you trying to install Restock and Ven's at the same time?

Share this post


Link to post
Share on other sites
Just now, cineboxandrew said:

Thats not the Restock service bay... are you trying to install Restock and Ven's at the same time?

crap, ty, just forgot to tweak again vens cfg stuff..

Yes, I use Ven's only for solar panels which I like more (but shhht!)

Share this post


Link to post
Share on other sites

is anyone else experiencing only one door opening in the animation of the  SC-9001 Science Jr in the VAB?

 

-cheers

Share this post


Link to post
Share on other sites
24 minutes ago, iSquared said:

is anyone else experiencing only one door opening in the animation of the  SC-9001 Science Jr in the VAB?

  

-cheers

Thanks for reporting this, I just pushed a fix which will be included in the next update

Share this post


Link to post
Share on other sites

These part revamps are way better than the stock updates that have been trickling in.  I especially love the new parachutes.

Share this post


Link to post
Share on other sites
Posted (edited)

Here's a thing. (This might be the first mod that uses Restock as a dependency?)

Edited by PocketBrotector

Share this post


Link to post
Share on other sites

When pivoting lights, the light effect doesn't change direction accordingly, restock issue?

(not the best screenshot, but you got me)

here in reversed rotation, light effect still the same

rTSkN1N.png

Share this post


Link to post
Share on other sites
On 3/9/2019 at 7:42 PM, tater said:

A few of the parts right now in SSTU merely reuse stock parts, so when they change, the mod isn't pointing at them any more.

 

On 3/9/2019 at 5:54 PM, Sudragon said:

You might want to have a word with @Shadowmage. Restock seems to be messing up parts of SSTUlabs' , so far I've seen problems with the LVN cluster-able variants.

Already in discussions to clean these up -- there will be a solution in place before too much longer.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.