Nertea

[1.7.x] Restock - Revamping KSP's art (May 10, KSP 1.7 + fixes)

Recommended Posts

Very nice mod, thank you very much!

Quick question: the new HG-55 antenna deploys in the other direction than the original, downwards in the picture below (only a problem inconvenience for existing crafts). I don't suppose there is a simple way to keep the old one and have the new additionaly?

p1Mc6ZO.png?2

Share this post


Link to post
Share on other sites
Posted (edited)

 

22 minutes ago, Divico said:

Very nice mod, thank you very much!

Quick question: the new HG-55 antenna deploys in the other direction than the original, downwards in the picture below (only a problem inconvenience for existing crafts). I don't suppose there is a simple way to keep the old one and have the new additionaly?

p1Mc6ZO.png?2

From which mod is these solar panels?

Edited by Danilo Coelho

Share this post


Link to post
Share on other sites

I gotta congratulate you guys on a great and extensive mod!

I won't personally be using it without modification because there are certain revamps that I like less than Stock, however I hope Squad takes some hints from in particular the docking ports, batteries and antennas.

Share this post


Link to post
Share on other sites
Posted (edited)

For those interested, I've just released an update to SXTContinued with the whitelist

Also Bargain Rockets

Also Better Science Labs

Also CCTV

Also Kerbonov

(hmmm, seems that there is a theme going.... )

 

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
Posted (edited)

Hmm... couple of small bugs/incompatibilities.

The 0.625m inline Reaction Wheel has an issue with the lights from IndicatorLights being positioned floating in space and extra-large. This appears to be because the stock 0.625 Reaction Wheel has a Rescale Factor of 0.5 built in, while the ReStock part does not... so the Indicator Lights people doubled the scale and position coordinates for the lights. It's easily corrected by undoing this doubling in their config file. A patch could do the same... just not sure if that would be more appropriate to put here or there.

Quote

    //-------------------------------------------------------------------------
    // INDICATOR MESHES
    //-------------------------------------------------------------------------

    // The lights we add have to be double the scale & position of what we'd
    // normally want, because this part has a rescaleFactor of 0.5 applied to
    // it for legacy reasons.

Second, the FL-T400 and FL-T800, for me, have their attachment nodes misplaced, well inside the models. I also don't see any "newness" of those models/textures... they just look like the Making History models. Is there some way to force the game to use ReStock parts even if Making History is installed?

qDnHqfh.png

Edit: Okay, I removed Community Part Titles, thinking something with renaming the parts might have broken the model replacements...

The result is baffling.

Now the FL-T800 is fine, nodes in the correct places.

The FL-T400 is still off...

And now the FL-T200 is off.

The proportion that the nodes are misplaced seems proportional to the length of the fuel tank, as if maybe it's using one model file and it's just stretching the length dimension and applying different textures? But... why would different ones be misplaced depending on a part renaming mod?

Edited by FirroSeranel

Share this post


Link to post
Share on other sites

What an amazing job you guys did. It's a really great mod. I would have paid for this, and would be more satisfied than when I paid for the making history expansion.

 

I have a few modded parts appearing without textures, and I'm trying to come up with the whitelist for them, but I think I'm doing something wrong. For example, the two mass drivers from the Stockalike Mining Extension mod are rendered with some white parts, which I assume are stock textures missing, even though the part directory seems to have copies of the stock textures.

       MODEL 
       {
               model = MiningExpansion/Parts/Size1Driver/Model
               texture = Mainsail2, Squad/Parts/Engine/liquidEngineMainsail/model002
               texture = Size3AdvancedEngineDiffuse, Squad/Parts/Engine/Size3AdvancedEngine/Size3AdvancedEngineDiffuse
               texture = ksp_s_processorSmall_diff, Squad/Parts/Resources/MiniISRU/ksp_s_processorSmall_diff
               texture = TriBitDrill, Squad/Parts/Resources/RadialDrill/TriBitDrill
       }

I created a MiningExpansion.restockwhitelist file like this:

Squad/Parts/Engine/liquidEngineMainsail/
Squad/Parts/Engine/Size3AdvancedEngine/
Squad/Parts/Resources/MiniISRU/
Squad/Parts/Resources/RadialDrill/


But it doesn't seem to have any effect. 

Share this post


Link to post
Share on other sites
Posted (edited)

WEEHEEE! IT'S HERE!

...i'm as slow as i am always.

On 3/6/2019 at 11:20 AM, Nertea said:

TT-14 Decoupler (Nertes): Tiny radial decoupler suitable for 0.625m boosters

Fix the typo (Nertes)

p.s. oscar-a half the oscar b ;)

p.p.s. Well, I deleted half of the stock parts, time to upgrade the other half.

Edited by Gapone

Share this post


Link to post
Share on other sites
32 minutes ago, FirroSeranel said:

Second, the FL-T400 and FL-T800, for me, have their attachment nodes misplaced, well inside the models. I also don't see any "newness" of those models/textures... they just look like the Making History models. Is there some way to force the game to use ReStock parts even if Making History is installed?

Something similar came up during testing a few times. The culprit always seemed to be something wrong with the stock fuel tank configs.

Does this happen all of the time, or only when loading an existing vessel, or reverting to the VAB from flight?

I think the problem was related to upgrading KSP from 1.5 to 1.6 without doing a clean installation. Some of the old 1.25m fuel tank configs were doing something weird and caused problems like this. Deleting and re-downloading the Squad folder always fixed the problem.

Share this post


Link to post
Share on other sites

I really needed a shielded junior docking port, so I used the newly hollowed nosecone as a cover: 

qhJ1xxe.jpg

Spoiler

nP9V4DN.jpg

If only inflatable airlocks would dock with the 1.25 docking ports, I wouldn't come up with this marvel of engineering 

 

Also, the Rapier is one of my favorite revamps so far. Right next to the Mk2 Lander can and the heat shields.d0rkH7I.png

 

Share this post


Link to post
Share on other sites
Posted (edited)
14 minutes ago, DMagic said:

Something similar came up during testing a few times. The culprit always seemed to be something wrong with the stock fuel tank configs.

Does this happen all of the time, or only when loading an existing vessel, or reverting to the VAB from flight?

I think the problem was related to upgrading KSP from 1.5 to 1.6 without doing a clean installation. Some of the old 1.25m fuel tank configs were doing something weird and caused problems like this. Deleting and re-downloading the Squad folder always fixed the problem.

Is there an easy way to do that? If I just delete a certain part of it, will Steam detect it and re-download it? I tend to do some QoL tweaks to some of the Squad parts (fixing some bugs, increasing speed/power of wheels because I'm impatient, etc).

Edit: Yes, Steam did detect and re-download individual folders, so I just deleted and re-downloaded all but Wheels. (Hopefully they fixed the lack of surface attachment on the big ISRU unit. <.< That's the main bug I always go in and fix.)

About to try again and see if the node glitch is still happening.

Edit Edit: That seems to have fixed it. Thanks!

 

Edited by FirroSeranel

Share this post


Link to post
Share on other sites
3 hours ago, Divico said:

Very nice mod, thank you very much!

Quick question: the new HG-55 antenna deploys in the other direction than the original, downwards in the picture below (only a problem inconvenience for existing crafts). I don't suppose there is a simple way to keep the old one and have the new additionaly?

p1Mc6ZO.png?2

Reported this as #529, will fix if I find time today

Share this post


Link to post
Share on other sites
8 hours ago, MuchozolF said:

So yeah, the Spark shrouds are gone where they should, in the 0.1.1 release, so Ants decided it's their time to shine. This time I'll submit the issue to GitHub.

 

Terriers are freaking out too, in my campaign. I have messed with them though, so I think, I should deal with it on my own. Just in case though, I'ma say: I have fixed my Sparks and Terriers; prior to 0.1.1, manually. Ants didn't require my attention, as they were just fine in 0.1.0.

 

Edit: I've just added a comment to the interstage fairings issue. No need to add a new thing, it seems.

I'm not sure about the Ant... the thing is, the original model never had a shroud so not sure what to do there. 

If you fixed the Sparks and Terriers manually before, they'll be broken again (this update forced the names back to Squad's originals), sorry about that, but better for the future. 

8 hours ago, Brigadier said:

KSP 1.6.1, Restock/Restock+ 0.1.0, GPP, RealPlume (plus a host of others but these seem to be the relevant ones).

Everything appeared ok before Restock and Restock+ installation earlier today.  I had a mission which had completed it's contract and was deorbiting.  I saw and resolved the solar panel issue by recycling them.  First symptom I noticed was that there were no reentry effects below 50km when there should have been.  Then I noticed that without any assistance - no chutes deployed, no propulsion active - the craft was decelerating rapidly, all by itself eventually reaching <200 m/sec at 20+ km.  I staged chute arming but there were no animations although there was sound and the craft slowed further.  Console log heavily spammed with Real Chute exceptions.  There was no full chute deployment (sound or visuals) but the craft decelerated to and maintained 30 m/sec.  Part context menu appeared correctly.

Output_log hereKSP log here.

I can post craft file, if necessary.  I can post to GitHub, too, if required.

Pinging @stupid_chrisas well.

I reverted to my last known save and can repeat the process.  It's late so I will troubleshoot tomorrow.

I have located the problem and there will be a fix in the next version

5 hours ago, Zorg said:

There are issues with RealPlume for some engines (Most are fine). I thought about doing corrections in the realplume configs but I was very impressed by the stock plumes the ReStock team has done. So I just deleted the squad folder inside GameData/RealPlume-Stock so that I get Restock plumes for stock engines and still have RealPlume for my other mod parts.

(most of the realplume fixes look quite simple though for anyone motivated to do so)

Yeah working also on a compatibility patch for realPlume for the next version

4 hours ago, adm-frb said:

Really nice mod and much better than stock

My only quibble is with the mk1-3 Command Pod which no longer fits sumghai's excellent SDHI Service Module.

https://forum.kerbalspaceprogram.com/index.php?/topic/48073-16x-sdhi-service-module-system-v401-25-december-2018/&tab=comments#comment-683549

I've tried whitelisting the stock mk1-3 Command Pod to get it back but to no effect. Would be nice if the part was switchable as I really don't want to remove the restock version mk1-3 command pod

 

You need to whitelist AND remove the appropriate moduleManager configuration. I suspect sumghai worked around the awful way stock defined the nodes, which we addressed ourselves. 

2 hours ago, FirroSeranel said:

Hmm... couple of small bugs/incompatibilities.

The 0.625m inline Reaction Wheel has an issue with the lights from IndicatorLights being positioned floating in space and extra-large. This appears to be because the stock 0.625 Reaction Wheel has a Rescale Factor of 0.5 built in, while the ReStock part does not... so the Indicator Lights people doubled the scale and position coordinates for the lights. It's easily corrected by undoing this doubling in their config file. A patch could do the same... just not sure if that would be more appropriate to put here or there.

Working with Snark on this one too. 

2 hours ago, lodestar said:

What an amazing job you guys did. It's a really great mod. I would have paid for this, and would be more satisfied than when I paid for the making history expansion.

I have a few modded parts appearing without textures, and I'm trying to come up with the whitelist for them, but I think I'm doing something wrong. For example, the two mass drivers from the Stockalike Mining Extension mod are rendered with some white parts, which I assume are stock textures missing, even though the part directory seems to have copies of the stock textures.


       MODEL 
       {
               model = MiningExpansion/Parts/Size1Driver/Model
               texture = Mainsail2, Squad/Parts/Engine/liquidEngineMainsail/model002
               texture = Size3AdvancedEngineDiffuse, Squad/Parts/Engine/Size3AdvancedEngine/Size3AdvancedEngineDiffuse
               texture = ksp_s_processorSmall_diff, Squad/Parts/Resources/MiniISRU/ksp_s_processorSmall_diff
               texture = TriBitDrill, Squad/Parts/Resources/RadialDrill/TriBitDrill
       }

I created a MiningExpansion.restockwhitelist file like this:


Squad/Parts/Engine/liquidEngineMainsail/
Squad/Parts/Engine/Size3AdvancedEngine/
Squad/Parts/Resources/MiniISRU/
Squad/Parts/Resources/RadialDrill/


But it doesn't seem to have any effect. 

You might want to post your log. Usually missing texture = broken and won't load part though, not white. 

 

To any other bugs we missed, this thread is moving fast and it's hard to keep up. Please ping one of the devs if you don't see your issue on git or replied to here. 

Share this post


Link to post
Share on other sites
Posted (edited)

I did some work on RealPlume patches, but that was in early February, so some things might be re-broken since then. Plus I couldn't crack RAPIER and Vector yet. Hopefully I will retest this in a couple of days and update the patches.

For those who want to scamper into action with wild abandon:

https://github.com/KSP-RO/RealPlume-StockConfigs/pull/79

https://github.com/Vladimir-csp/RealPlume-StockConfigs/tree/master/GameData/RealPlume-Stock/Squad

https://github.com/Vladimir-csp/RealPlume-StockConfigs/tree/master/GameData/RealPlume-Stock/ReStockPlus

 

Edited by Psycho_zs

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Nertea said:
5 hours ago, adm-frb said:

Really nice mod and much better than stock

My only quibble is with the mk1-3 Command Pod which no longer fits sumghai's excellent SDHI Service Module.

https://forum.kerbalspaceprogram.com/index.php?/topic/48073-16x-sdhi-service-module-system-v401-25-december-2018/&tab=comments#comment-683549

I've tried whitelisting the stock mk1-3 Command Pod to get it back but to no effect. Would be nice if the part was switchable as I really don't want to remove the restock version mk1-3 command pod

 

You need to whitelist AND remove the appropriate moduleManager configuration. I suspect sumghai worked around the awful way stock defined the nodes, which we addressed ourselves. 

Adding to this. After you whitelist the textures, here are the steps to delete the modulemanager config

  • Go into GameData/ReStock/Patches/Command
  • Open restock-command-pods.cfg in a text editor
  • Delete this section and save the config
// Mk1-3 Pod
@PART[mk1-3pod]
{
  @author = Chris Adderley (Nertea)
  !mesh = DELETE
  !MODEL,* {}
  !MODULE[ModuleAnimateGeneric] {}
  @node_stack_bottom = 0.0, -0.318, 0.0, 0.0, -1.0, 0.0, 2
  MODEL
  {
    model = ReStock/Assets/Command/restock-mk1-3-pod
    position = 0.0, 0.0, 0.0
    scale = 1,1,1
    rotation = 0, 0, 0
  }
}

   You'll have to do this each time ReStock gets updated unfortunately.

Edited by Tyko

Share this post


Link to post
Share on other sites
Posted (edited)
15 hours ago, NaissUu said:

Can i use other mods while i using this ? Likes Realplume,spaceX and the other ?

Welcome to the forums!

It should work just fine with most other mods - especially those that just add new parts. Since ReStock changes Stock parts, other mods that add parts should work.

Mods like RealPlume make changes to stock parts - in this case it replaces the stock plumes with new ones. In most cases those types of mods will work with ReStock because the new textures/models are intended to be drop-in replacements for Stock. There may be some conflicts though. There are others discussing RealPlume in this thread, so you may want to take a look at what their suggestions are.

Edited by Tyko

Share this post


Link to post
Share on other sites

Just wanted to say Thanks to Nertea and the rest of the guys who worked in this. It's an awesome and incredible mod and the models all look amazing.

Thanks for your hard work.

Share this post


Link to post
Share on other sites
32 minutes ago, Tyko said:

Adding to this. After you whitelist the textures, here are the steps to delete the modulemanager config

  • Go into GameData/ReStock/Patches/Command
  • Open restock-command-pods.cfg in a text editor
  • Delete this section and save the config

// Mk1-3 Pod
@PART[mk1-3pod]
{
  @author = Chris Adderley (Nertea)
  !mesh = DELETE
  !MODEL,* {}
  !MODULE[ModuleAnimateGeneric] {}
  @node_stack_bottom = 0.0, -0.318, 0.0, 0.0, -1.0, 0.0, 2
  MODEL
  {
    model = ReStock/Assets/Command/restock-mk1-3-pod
    position = 0.0, 0.0, 0.0
    scale = 1,1,1
    rotation = 0, 0, 0
  }
}

   You'll have to do this each time ReStock gets updated unfortunately.

Done... 

Got the original mk1-3 command pod back!!!!! Yes 

Share this post


Link to post
Share on other sites
43 minutes ago, adm-frb said:

Done... 

Got the original mk1-3 command pod back!!!!! Yes 

Glad it worked. Just remember to go in and make that same change if you download a new version of ReStock  :)    I expect there's a way to write a MM config that would force Stock textures using AFTER:[ReStock]   I just haven't tried building one yet. If you're handy with MM give it a try.

Share this post


Link to post
Share on other sites

I've just had a look at this mod...  So much of this is absolutely stunning work.  The new gold standard, to be sure.   My interest in Squad's revamps has just disappeared.

 

I see Restock+ replaces some MH content.  I asked about this a few months ago, and it seemed then there was no plans to cover anything Making History.  I guess this may've changed a bit now?  Could you guys share your plans to cover anything MH?

Share this post


Link to post
Share on other sites
Posted (edited)

 

18 hours ago, Nertea said:
19 hours ago, d4harp said:

I feel like this logic is backwards. If the restock+ textures/models already exist, why revert back to the making history version?

In a making history install, the vanilla styled 1.8m decoupler stands out like a sore thumb amongst all the restock decouplers.

The new models and textures are used to replace the MH parts in exactly the same way stock parts are replaced. The RS+ part is hidden so as not to pollute the part catalog.

*snip*

 

Since no one has brought it up since:

I thiiink that it's "backwards" not because duplicate-functionality parts are hidden, but because it's the Restock parts that are hidden. Why not hide MH parts? It's an unusual choice, is there a deeper reason behind it?

Edited by MuchozolF

Share this post


Link to post
Share on other sites
2 hours ago, Nertea said:

I have located the problem and there will be a fix in the next version

Much appreciated.  Might you have time to explain what was going wrong with RealChutes?  Can I work around it somehow before the next Restock release?

As others have said, kudos to entire team for their spectacular work.

Share this post


Link to post
Share on other sites
1 minute ago, Tyko said:

Glad it worked. Just remember to go in and make that same change if you download a new version of ReStock  :)    I expect there's a way to write a MM config that would force Stock textures using AFTER:[ReStock]   I just haven't tried building one yet. If you're handy with MM give it a try.

I know next to nothing about module manager, unfortunately. I've created new parts before, but only through copying stock config files, changing the part names and tweaking variables and have never published anything. What I'd really like to do is learn how create true variants like you have with the mk 1 command pod, the cheetah engine and the stock version of the F-1 (I forget what it's called)

Share this post


Link to post
Share on other sites
20 minutes ago, klesh said:

I've just had a look at this mod...  So much of this is absolutely stunning work.  The new gold standard, to be sure.   My interest in Squad's revamps has just disappeared.

 

I see Restock+ replaces some MH content.  I asked about this a few months ago, and it seemed then there was no plans to cover anything Making History.  I guess this may've changed a bit now?  Could you guys share your plans to cover anything MH?

Still no promises, anything you get is a bonus!

11 minutes ago, MuchozolF said:

 

Since no one has brought it up since:

I thiiink that it's "backwards" not because duplicate-functionality parts are hidden, but because it's the Restock parts that are hidden. Why not hide MH parts? It's an unusual choice, is there a deeper reason behind it?

Hiding MH parts would be annoying IMO. If you hid them, players with MH and RS+ installed would see only the RS+ part, build a ship with them, and then be surprised if they removed RS+ and the ship broke. However, the reverse (ship breaking if MH is removed) makes more sense to the less mod-savvy player - remove stock content and of course you expect breakage. 

9 minutes ago, Brigadier said:

Much appreciated.  Might you have time to explain what was going wrong with RealChutes?  Can I work around it somehow before the next Restock release?

As others have said, kudos to entire team for their spectacular work.

It's untested, but you can see if it works here: https://github.com/PorktoberRevolution/ReStocked/tree/master/Distribution/Restock/GameData/ReStock/Compatibility

Basically looks like RealChute relies on specific model features of the stock chutes. 

Share this post


Link to post
Share on other sites
Posted (edited)

@adm-frb There is something you can do that's even more elegant than just removing the ReStock patch. You get to keep the reskinned one and the stock pod both (although as separate parts, not as variants of the same part), and you don't have to go and delete the ReStock config again every time you update the mod. As long as you keep the whitelist file and the MM patch below, it should just continue working unchanged through updates.

Try putting the following into a blank text file somewhere in your GameData folder:

+PART[mk1-3pod]:NEEDS[ReStock]:FIRST
{
    @name = mk1-3pod-old
    @title = Mk1-3L Legacy Command Pod
}

Save your file, change the file extension from .txt to .cfg, and you're done.

Whenever ReStock is installed, this patch spawns a copy of the stock Mk1-3 pod before Module Manager even loads ReStock, changes the internal part ID of the copy to be different from the original (required for the copy to exist, but also prevents ReStock's patches from affecting it), and changes the ingame display name slightly (optional, but recommended). Now - assuming you also restore the ReStock patch you previously deleted - you'll have two three-person pods in your game: the original Squad one, and the fancy ReStock one.

 

Edited by Streetwind

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.