Flupster

[KSP 1.9.0] [x] Science! Continued - KSP Science report and checklist (V5.23)

Recommended Posts

It would be really great if this mod could track the new DLC science like mun stones, robot arm analysis, and deployed surface science.

Share this post


Link to post
Share on other sites

Just checked the changes made by 1.7.2.02556 and it looks like they fixed the applyScienceScale applying to deployed* science. It doesn't look like they fixed it applying to the vanilla science (at least not at first glance). I'll see if I can do a quick test later but I'd be surprised if anything changed for the non-deployed science vs 1.7.1.

Edit: Huh.. *scratches head* ...it works... *scratches head* ...why does it work..? :blink: subject value is still dropping like a brick due to applyScienceScale, but data value is no longer affected. :blink:

If anyone can free me from this puzzling sensation, please, share thy knowledge with me.

Edited by Jognt

Share this post


Link to post
Share on other sites

This has shown up for me a couple of times now. Sometimes there are these science situations apparently available at Kerbin's ROC. I've never seen this before, and they're only sometimes there. Other times, or after a reload, they're gone again. Is this some kind of bug? Or is there (somehow) some science that I'm missing?

2NFUFWf.png

Share this post


Link to post
Share on other sites
1 hour ago, Tekaoh said:

This has shown up for me a couple of times now. Sometimes there are these science situations apparently available at Kerbin's ROC. I've never seen this before, and they're only sometimes there. Other times, or after a reload, they're gone again. Is this some kind of bug? Or is there (somehow) some science that I'm missing?

 

ROC are the new surface feature stuff. My guess is it stands for Random Object Creator or something, internally they're constantly mentioned as ROC.

Maybe [x] Science! hasn't given them a proper place yet, or maybe there's actually a place called that too.

Share this post


Link to post
Share on other sites

Gravity scan, Seismic scan and Atmosphere analysis doenst seems to give the science what the [x] science says 
All these science were run three times and [x] science displays its complete but after recovering the vehicle the actual amount I get is less. And even if I run the experiments afterwards science is capped at lower value than [x] science displays

https://imgur.com/JjBc5jp

Share this post


Link to post
Share on other sites
3 hours ago, Astatine85 said:

Gravity scan, Seismic scan and Atmosphere analysis doenst seems to give the science what the [x] science says 
All these science were run three times and [x] science displays its complete but after recovering the vehicle the actual amount I get is less. And even if I run the experiments afterwards science is capped at lower value than [x] science displays

https://imgur.com/JjBc5jp

This was fixed in KSP 1.7.2.

Share this post


Link to post
Share on other sites

I just realized that even though Science parts using DMagic's ScienceAnimate MODULE don't work with [x] science, Science parts with DMagic's ScienceAnimateGeneric MODULE _do_ work with [x] science.

I wrote a small patch to replace instances of DMScienceAnimate with DMScienceAnimateGeneric. Haven't tested it yet, but I'm hopeful it'll finally make those last few experiments work :).

*Once I've tested it and confirmed it works, I'll post the patch here for others to use.

edit: tested it. Patch is a few posts down. No idea why the x science code for the generic DMModule works but the non-generic does not though. 

Edited by Jognt

Share this post


Link to post
Share on other sites

I don't know if there'd be a point to a feature request, but...  would it be too much to ask to have the [x]Science! Selected Object window not reopen every single time I switch focus in the Tracking Station?

Share this post


Link to post
Share on other sites
42 minutes ago, Fraktal said:

I don't know if there'd be a point to a feature request, but...  would it be too much to ask to have the [x]Science! Selected Object window not reopen every single time I switch focus in the Tracking Station?

I think that's a bug then. I can remember it respecting my choice way back when I used that window. In fact.. I don't even know where it's hanging out in my current install. o_O

Share this post


Link to post
Share on other sites

@Flupster Just as a sort of FYI, the Universal Storage combo material bay and mystery goo units have a strange interaction with the x science mod, in that the x science mod will register the units and give you the option to run the experiments, but clicking the button doesn't seem to actually gather science, but confuses the modules to think they've been run. I get a message that says can not run experiment, science module is full. However, right clicking on the modules does not show any stored reports, and there is no option to reset the modules. 

Posted in both forums because i'm not sure which side would need adjusted to fix, assuming this isn't just a bug on my end.

Share this post


Link to post
Share on other sites
21 hours ago, vardicd said:

@Flupster Just as a sort of FYI, the Universal Storage combo material bay and mystery goo units have a strange interaction with the x science mod, in that the x science mod will register the units and give you the option to run the experiments, but clicking the button doesn't seem to actually gather science, but confuses the modules to think they've been run. I get a message that says can not run experiment, science module is full. However, right clicking on the modules does not show any stored reports, and there is no option to reset the modules. 

Posted in both forums because i'm not sure which side would need adjusted to fix, assuming this isn't just a bug on my end.

Yeah it's known. It doesn't work properly with many Orbital Science experiments either. There was a discussion about it on page 2 and (judging by the response of the maintainer) I don't think that's something that'll receive attention soon.

It'd be great if everything worked out of the box, but we'll just have to keep doing some experiments the old fashioned way.

Edited by Jognt

Share this post


Link to post
Share on other sites
On 5/4/2019 at 2:07 PM, ggksp said:

I have a strange bug, using X Science and Remote Tech in 1.7 - When I don't have a connection, I'm still able to click in xscience's Here and Now window to trigger experiments. Anyone know what might cause this? I have Kerbal's comm system enabled with plasma blackout and no extra ground stations. It's possible I don't know how to configure remote tech with ksp's default comm system, so any help is appreciated!

That probably requires a bit of integration with Remote Tech.

I’ve just started looking into this with Science Alert

Share this post


Link to post
Share on other sites
6 hours ago, linuxgurugamer said:

That probably requires a bit of integration with Remote Tech.

I’ve just started looking into this with Science Alert

My personal reaction is "No thanks".  (Note I talking about [X] Science, I haven't used Science Alert in the last few years.).  Whilst I could use Remote Tech's flight computer to schedule science collection whilst out of communication, for me that is more hassle than it is worth.   (If other players want to that is fine.  If they do that, then they can just close the here and now window, or ignore its buttons).

In a real space missions they probably either collect the data continuously, or have someone to calculate the correct time to make the observation.    Stock type science experiments just aren't setup for continuous observations, and using the flight computer to schedule science collection is cumbersome, error prone and tedious.   In the same manner I tend to just use mechjeb to execute maneuvers when out of comms.  Whilst playing with RP-0, the flight computer caused a couple of epic failures to execute maneuver nodes because it was unable to oriented the ship in the correct direction). 

Personally, gameplay and a more useable UI are more important to me than realistic simulations of signal delay/comms blackout.  (If you want a realistic simulation then remember that real spacecraft flight controllers/engineers have days/weeks/months to plan, program, rehearse and practice any actions that spacecraft need to do whilst out of comms).    

Share this post


Link to post
Share on other sites
On 7/3/2019 at 12:54 AM, Jognt said:

I just realized that even though Science parts using DMagic's ScienceAnimate MODULE don't work with [x] science, Science parts with DMagic's ScienceAnimateGeneric MODULE _do_ work with [x] science.

I wrote a small patch to replace instances of DMScienceAnimate with DMScienceAnimateGeneric. Haven't tested it yet, but I'm hopeful it'll finally make those last few experiments work :).

*Once I've tested it and confirmed it works, I'll post the patch here for others to use.

Finally got around to some testing, seems to work fine. Here's the patch:

@PART:HAS[@MODULE[DMModuleScienceAnimate]]:NEEDS[DMModuleScienceAnimateGeneric]:FINAL
{
	@MODULE[DMModuleScienceAnimate]
	{
		@name = DMModuleScienceAnimateGeneric
	}
}

Note that it requires @DMagic's "DMModuleScienceAnimateGeneric" mod which you can find on CKAN

Note-2: It only works for the parts that used DMModuleScienceAnimate to begin with. So if they didn't show up before in x science, they still won't show up. But if they do, they'll work.

Edited by Jognt

Share this post


Link to post
Share on other sites

@Flupster

Would you be willing to accept a PR which removes the toolbar code and replaces it with the ToolbarController? It ends up removing 5 files and about 1000 lines of code.  I've done this for another mod by the same author, which used the same code

 

Share this post


Link to post
Share on other sites

Sorry if this has already been asked, I tried looking through all the posts and didn't see anything.

 

Has the stutter from xscience been fixed? or is it still an issue? About a year ago I remember people identified that Xscience was causing a stutter in KSP, and someone had posted a .dll or something that fixed it. Is that integrated into the mod now? Or is stutter still something that xscience creates?

 

Thanks,

Share this post


Link to post
Share on other sites
48 minutes ago, Crixomix said:

Is that integrated into the mod now?

Not sure exactly what changes were in those unofficial builds, and frankly I'm too lazy to do a compare. There were some performance improvements a while back, but you'll probably have to just suck it and see.

 

50 minutes ago, Crixomix said:

is stutter still something that xscience creates

Stutter is something that every mod that runs code creates to some degree, because unitys garbage collector sucks. I haven't noticed any massive performance problems with the latest [x]Science myself though.

Share this post


Link to post
Share on other sites

@Flupster, can you please implement filtering for 'Here and Now' window, something like science threshold to filter very low science experiments and dont react on them. Like this:

kQSuMC.gif

This is how i implemented it locally for myself using your code. Also i added science value in brackets for each experiment.

This is my suggestion. I hope others will support my idea :) if so like my post.

Edited by Dizor

Share this post


Link to post
Share on other sites
34 minutes ago, Dizor said:

@Flupster, can you please implement filtering for 'Here and Now' window, something like science threshold to filter very low science experiments and dont react on them. Like this:

This is how i implemented it locally for myself using your code. Also i added science value in brackets for each experiment.

This is my suggestion. I hope others will support my idea :) if so like my post.

That’s a nice idea, why not submit your changes to him in a PR on github?

Share this post


Link to post
Share on other sites
On 7/27/2019 at 10:04 PM, linuxgurugamer said:

That’s a nice idea, why not submit your changes to him in a PR on github?

Done ;)

Share this post


Link to post
Share on other sites
5 hours ago, Flupster said:

@linuxgurugamer do you want to do your proposed change PR also? then I can check both yours and @Dizor and release new version

Not very active atm but can do it by the end of the week

Yes, but probably won't  be able to get to it until the weekend

Share this post


Link to post
Share on other sites
7 hours ago, Flupster said:

@linuxgurugamer do you want to do your proposed change PR also? then I can check both yours and @Dizor and release new version

Not very active atm but can do it by the end of the week

Any chance to take a quick look at the code for DMagic's science module? I noticed that DMScienceAnimateGeneric experiments work flawlessly with x science, whereas the DMScienceAnimate ones don't. Perhaps a typo somewhere?

Share this post


Link to post
Share on other sites
2 hours ago, Jognt said:

I noticed that DMScienceAnimateGeneric experiments work flawlessly with x science, whereas the DMScienceAnimate ones don't.

I noticed this yesterday too.  The buttons in the "science here & now" window don't work with DMagic parts like the magnetometer boom.  (The button still appears, but clicking it doesn't perform the experiment.)

Share this post


Link to post
Share on other sites
Just now, Wyzard said:

I noticed this yesterday too.  The buttons in the "science here & now" window don't work with DMagic parts like the magnetometer boom.  (The button still appears, but clicking it doesn't perform the experiment.)

I don’t know  @Flupster his thoughts about it, but you can always use the MM patch I posted earlier in the thread to replace the DMScienceAnimate modules with DMScienceAnimateGeneric modules. 

Seems to work fine so far. The parameters are equal for both modules as far as I can tell. 

Note: DMScienceAnimateGeneric is a separate mod install. (Also does nice visual things with ReStock science parts when installed)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.