Flupster

[KSP 1.9.0] [x] Science! Continued - KSP Science report and checklist (V5.23)

Recommended Posts

Yeah, not a terrible idea now that I think about it. I design ships and landers with extra space just for the science containers so I only have to go to a place once. I also hate leaving points laying around - I like to complete the gains. I'll try it out; thanks for the suggestion. 

Share this post


Link to post
Share on other sites
12 hours ago, Wyzard said:

I'm confused as to why this mod calls MusicLogic.SetVolume at all — how is that related to science?  Is it some sort of weird bug workaround?

Perhaps it’s due to this mod playing a sound when science is available?

Share this post


Link to post
Share on other sites

Could someone post their recompile until either A) the current maintainer updates the mod or B) a new maintainer takes charge? Thank you in advance.

Edited by nightstalker101s

Share this post


Link to post
Share on other sites
2 hours ago, nightstalker101s said:

Could someone post their recompile until either A) the current maintainer updates the mod or B) a new maintainer takes charge? Thank you in advance.

My bad dude

I'm just getting over the flu after going on vacation for a week, I'll get a new version up tonight sometime

 

New build is up @ https://github.com/Flupster/KSP-X-Science/releases/download/5.23/x.Science.5.23.zip

CKAN should pick it up soon :)

Final edit: CKAN has picked it up, collect all the science for me, thanks!

Edited by Flupster

Share this post


Link to post
Share on other sites

@fhmiv @siimav

i think ... i am not realy understand how to compile  c#
Orz ... i try use v5.23 source code to compile
not work ...

so ... i will try start with KSP WIKI "Creating your first module" XD

 

thank for help me

 

 

Share this post


Link to post
Share on other sites
1 hour ago, oJelly said:

@fhmiv @siimav

i think ... i am not realy understand how to compile  c#
Orz ... i try use v5.23 source code to compile
not work ...

so ... i will try start with KSP WIKI "Creating your first module" XD

 

thank for help me

 

 

If your goal is just to use this mod; the author updated it so you should be good to go. 

@Flupster pardon my repeating this. X science works fine with orbital science if I replace all dmscienceanimate modules with his generic (CKAN) version. Is there a specific problem preventing it from working with the regular dmscienceanimate module?

Share this post


Link to post
Share on other sites
5 hours ago, Jognt said:

如果您的目標只是使用此mod;作者更新了它,所以您應該一切順利。 

@Flupster請  原諒我的重複。如果我將所有dmscienceanimate模塊替換為其通用(CKAN)版本,則X科學可與軌道科學配合使用是否存在阻止其與常規dmscienceanimate模塊一起使用的特定問題?

it is good time to learn c#

so I will keep try it 

but ... I also want play KSP

so hard to choose one

XD

Share this post


Link to post
Share on other sites

hi. i have problem with collecting science in ksp dessert airfield/launch site and woomerang launch site. when i get there, it says i´m in desert biome (for dessert airfield) but in X science tab it is marked as shores biome - for example "Crew report while landed at Kerbin´s Desert Airfield (Shores). the same goes for woomerang site - it is in grassland biome but X science shows shores. is it X science bug or KSP bug? and is it possible to repair it somehow?

Share this post


Link to post
Share on other sites

Hi @Flupster, i answered to you on github. You can merge my PR "Science threshold feature for Here and Now window"

Spoiler

kQSuMC.gif

 

Share this post


Link to post
Share on other sites

dont know if this has been asked already but is there any way to fix the combatibility issues between this mod and universal storage 2? right now if i run one of the science modules on U.S.2 through xscience i cant retrive the science because it says the science module is full, but if i do it by just clicking it works just fine.

Share this post


Link to post
Share on other sites

While the DMModuleScienceAnimateGeneric patch by @Jognt fixes the "Magnetometer Boom" issue, but, for example, "Micro Goo Containment Pod" uses DMRoverGooMat, and still has the same issue: experiment showed up, but do not performed via [x]science gui.    

 

 

Edited by flart

Share this post


Link to post
Share on other sites

@Flupster, my PR contains a bunch of performance fixes as well. I strongly recommend you to make a merge.

Share this post


Link to post
Share on other sites
On 11/11/2019 at 4:41 AM, HarY_cz said:

hi. i have problem with collecting science in ksp dessert airfield/launch site and woomerang launch site. when i get there, it says i´m in desert biome (for dessert airfield) but in X science tab it is marked as shores biome - for example "Crew report while landed at Kerbin´s Desert Airfield (Shores). the same goes for woomerang site - it is in grassland biome but X science shows shores. is it X science bug or KSP bug? and is it possible to repair it somehow?

I noticed the same problem.  I'm running v 5.22 of [x] Science on KSP v1.7.3. 

When I'm on the Dessert Launch Pad or Airfield, the science experiments available at my location (left-most preset filter) are all blank.  However, if I search for the available experiments on this vessel (second preset from the left) and then keyword filter on "desert air" or "desert launch", I get all of the experiments that should be available.

Seems like this might be a preset filter spelling difference for "dessert" vs "desert"?  I don't see a mention of it in the 5.23 release and/or on v1.8.0 KSP, but I could test it additionally if that helps.

Share this post


Link to post
Share on other sites

Using 5.23 (the latest version from CKAN), I find that there's a delay before the available experiments are evaluated. For example, I did a lot of Mun, Minmus, and Duna exploration in Career mode, but  [x] Science! acts like I haven't even done the space-situation crew reports yet.

Screenshot 1

If I go into the R&D archives, it's clear that many of those experiments have already been fully run. 

Then, only after visiting R&D, [x] Science finally updates to show what I've done.

 

 

 

Share this post


Link to post
Share on other sites
On 12/4/2019 at 7:03 AM, Dizor said:

@Flupster, my PR contains a bunch of performance fixes as well. I strongly recommend you to make a merge.

Compiled this myself with your PR integrated. I hope @Flupster rolls these changes into the main branch soon, it definitely feels snappier and the min science slider is great for a probes before crew style playthrough, where you end up with a bunch of half finished science experiments that you can't complete without crew bugging you on the way to Mun/Minmus.  Good work!

Edited by DeliriumTrigger

Share this post


Link to post
Share on other sites

Sorry guys I've been hella busy with IRL, I've merged the PR and released version 5.26 which includes the changes

I also managed to mess up v5.24 and set the min KSP version to 1.0.0 instead of 1.9.0

Does anyone know how to get that reverted from CKAN?

Edited by Flupster

Share this post


Link to post
Share on other sites
9 hours ago, Flupster said:

Sorry guys I've been hella busy with IRL, I've merged the PR and released version 5.26 which includes the changes

I also managed to mess up v5.24 and set the min KSP version to 1.0.0 instead of 1.9.0

Does anyone know how to get that reverted from CKAN?

@HebaruSan

Edited by MechBFP
Sorry, I can only tag you, it won't let me type any text now lol.

Share this post


Link to post
Share on other sites
11 hours ago, Flupster said:

Sorry guys I've been hella busy with IRL, I've merged the PR and released version 5.26 which includes the changes

I also managed to mess up v5.24 and set the min KSP version to 1.0.0 instead of 1.9.0

Does anyone know how to get that reverted from CKAN?

Started here, thanks @MechBFP

https://github.com/KSP-CKAN/CKAN-meta/pull/1829

EDIT: Done

Edited by HebaruSan

Share this post


Link to post
Share on other sites
11 hours ago, Flupster said:

Sorry guys I've been hella busy with IRL, I've merged the PR and released version 5.26 which includes the changes

I also managed to mess up v5.24 and set the min KSP version to 1.0.0 instead of 1.9.0

Does anyone know how to get that reverted from CKAN?

Just an FYI the latest version appears to have a bug, the “Here and “Now” section doesn’t appear to work. 
I have a Gravioli detector on my ship and no matter what I set the “min science” to, or if I turn the window on and off, it doesn’t detect it. 
Possibly doesn’t detect any other experiment either, but I had to run so couldn’t verify completely.

Here is a pic I took of the experiments on my ship and the blank here and now window:

fiD9hN7.jpg

Edited by MechBFP

Share this post


Link to post
Share on other sites
On 2/16/2020 at 5:28 PM, HebaruSan said:

EDIT: Done

That's what I like most our little community: people care for each other, help each other :)

Share this post


Link to post
Share on other sites
On 2/16/2020 at 11:30 AM, MechBFP said:

Just an FYI the latest version appears to have a bug, the “Here and “Now” section doesn’t appear to work. 
I have a Gravioli detector on my ship and no matter what I set the “min science” to, or if I turn the window on and off, it doesn’t detect it. 
Possibly doesn’t detect any other experiment either, but I had to run so couldn’t verify completely.

It seems to be working okay for me... Unless there's something different about your setup. Any other mods installed that might be causing a conflict or something?

Share this post


Link to post
Share on other sites
18 minutes ago, Tekaoh said:

It seems to be working okay for me... Unless there's something different about your setup. Any other mods installed that might be causing a conflict or something?

Everything seemed to work for me as well, with one exception. I did notice at one point i collected some science and had to load a quicksave a few moments later. the quicksave was just a bit before i gathered the science and once the quicksave had loaded, xscience acted as if the science had still been collected. it didn't reflect the fact that the experiments had been, un-run by the quickload.

Share this post


Link to post
Share on other sites
55 minutes ago, Tekaoh said:

It seems to be working okay for me... Unless there's something different about your setup. Any other mods installed that might be causing a conflict or something?

I’ll have to try it again. Installed the update mid-flight, so that might be why. I’ll try launching a new ship instead and see if that makes a difference.

Share this post


Link to post
Share on other sites
5 hours ago, vardicd said:

Everything seemed to work for me as well, with one exception. I did notice at one point i collected some science and had to load a quicksave a few moments later. the quicksave was just a bit before i gathered the science and once the quicksave had loaded, xscience acted as if the science had still been collected. it didn't reflect the fact that the experiments had been, un-run by the quickload.

Looks like the quick loading/save game loading is the problem, but it only occurs within the same SOI as far as I can tell.

A newly launched ship was fine altogether until I quick loaded. All the results I had taken in sun orbit did not appear again after the quick load, but as soon as I entered Kerbin’s SOI, I could take results that I had taken before at Kerbin before quick loading.

Edited by MechBFP

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.