Gameslinx

[1.7.3] Beyond Home 1.2.0 - After Kerbol has Died - HUGE UPDATE

Recommended Posts

Posted (edited)
18 hours ago, Gameslinx said:

When I feel like the mod has reached a good state, yes I think I'll support this :)

I second this motion.  I love exploring Beyond Home planets but I miss the challenge of getting into orbiting, so an optional stock scaled Kerbin or even 2.6x scaled option would be welcome!

Edited by Friznit

Share this post


Link to post
Share on other sites

Actually, I like the fact that the low orbit of Rhodes is lower than Kerbin. I do not see why it should be the same as Kerbin. It's another planet after all. Also, since the orbit is lower, we lose less time struggling on sending base/shuttle to space and spend more time on fun stuff like exploration. This is breeze of fresh air and offers a different feel than Kerbin, which is the idea behind a new system mod. Please leave it like that! It also offers new AWESOME options for SSTO aircraft. It is now possible to do smaller one. I see that low orbit thing as a nice feature and new opportunity. That really put a smile in my face.

Thanks for preparing that DeltaV map! It is a bit hard to plan without it. I love the mod, I really do. It feels like a new game to me. GREAT WORK.

I am not far in the exploration yet. I just started to orbit Amstrong. Is there any specific object to pull science from like in the 1.7 release?

 

 

 

 

Share this post


Link to post
Share on other sites
3 minutes ago, Frag2000 said:

Actually, I like the fact that the low orbit of Rhodes is lower than Kerbin. I do not see why it should be the same as Kerbin. It's another planet after all. Also, since the orbit is lower, we lose less time struggling on sending base/shuttle to space and spend more time on fun stuff like exploration. This is breeze of fresh air and offers a different feel than Kerbin, which is the idea behind a new system mod. Please leave it like that! It also offers new AWESOME options for SSTO aircraft. It is now possible to do smaller one. I see that low orbit thing as a nice feature and new opportunity. That really put a smile in my face.

Thanks for preparing that DeltaV map! It is a bit hard to plan without it. I love the mod, I really do. It feels like a new game to me. GREAT WORK.

I am not far in the exploration yet. I just started to orbit Amstrong. Is there any specific object to pull science from like in the 1.7 release?

 

 

 

 

This is a very rough delta V map. It won't work for Gateway, but should be fine elsewhere.

What do you mean by pulling science from an object? If you don't have breaking ground installed (Not sure how it behaves with it) you should be able to get science from any rock or tree or surface feature!

unknown.png

 

Share this post


Link to post
Share on other sites

Next episode is out :)

 

 

Share this post


Link to post
Share on other sites

@Gameslinx, I'm really enjoying this system.  I have noticed a few issues, however.

1.  Armstrong is made of "Trampolinium".  Landers using legs bounce enough to achieve escape velocity even with legs set for zero spring.  I've only been able to land there without using legs.

2.  Deployed science seismographs don't seem to work at all on Lua.  I crashed a pretty hefty transfer stage about 3km away and got zero energy and 100% distance attenuation, for a total of 0.000 science points.

3.  I had to delete Scatterer as it was really choking my system (as it always does, so not a BH problem).  However, without Scatterer, the system looks rather stark and not nearly as pretty  Are there any EVE configs that address not having Scatterer?

4.  On Lua, a rover with the Mk 2 Lander Can set to be the brick-like version with the folding rover wheels on the corners does a faceplant every time the terrain slope goes up slightly.  This might be due to having a scanning arm mounted on the can's front node but I haven't had this problem with the same rover design on other (stock) planets so I'm wondering....  Further testing required on this one but I thought I'd better mention it.

Share this post


Link to post
Share on other sites
28 minutes ago, Geschosskopf said:

Armstrong is made of "Trampolinium".  Landers using legs bounce enough to achieve escape velocity even with legs set for zero spring.  I've only been able to land there without using legs.

I'm aware of this, I think I had this happen to be during the last episode in the series I'm recording. Thanks - I labelled it off as a 1.7.3 problem as I hadn't had it happen before. I'll look into that. I hope to have it fixed by the next update.

29 minutes ago, Geschosskopf said:

Deployed science seismographs don't seem to work at all on Lua.  I crashed a pretty hefty transfer stage about 3km away and got zero energy and 100% distance attenuation, for a total of 0.000 science points.

Not sure what's causing this. Again, I'll look into it. I'm assuming you have science set to 100%.

29 minutes ago, Geschosskopf said:

I had to delete Scatterer as it was really choking my system (as it always does, so not a BH problem).  However, without Scatterer, the system looks rather stark and not nearly as pretty  Are there any EVE configs that address not having Scatterer?

The mod is quite young and I've already sorted out half of the planets for the next update. When scatterer is not installed, i'm fixing up the atmosphere gradients (as some are still orange!) and their scaledspace gradients. I might add EVE glows too. Cheers!

30 minutes ago, Geschosskopf said:

On Lua, a rover with the Mk 2 Lander Can set to be the brick-like version with the folding rover wheels on the corners does a faceplant every time the terrain slope goes up slightly.  This might be due to having a scanning arm mounted on the can's front node but I haven't had this problem with the same rover design on other (stock) planets so I'm wondering....  Further testing required on this one but I thought I'd better mention it.

I have a feeling i know what's causing this. Can you find Lua.cfg in BeyondHome/Configs and remove this code - see if that works?

PhysicsMaterial
			{
				bounceCombine = Average
				frictionCombine = Maximum
				bounciness = 0
				staticFriction = 5
				dynamicFriction = 4.8
			}

Thanks for the reports. Hopefully I have them all solved for the next update (which is already a huge one as it is!)

Share this post


Link to post
Share on other sites
4 hours ago, Geschosskopf said:

I had to delete Scatterer as it was really choking my system (as it always does, so not a BH problem).  However, without Scatterer, the system looks rather stark and not nearly as pretty  Are there any EVE configs that address not having Scatterer?

Yo, I just finished the rest of the EVE configs. How's this? Obviously, there are some limitations to what I can actually do with EVE so I have tried my best to replicate the atmosphere effects. I'll pass the config on to you early if you'd like.

oPN63G6.jpg

28ccpF2.png

anjbHdf.jpg

Jb4o19Z.jpg

Share this post


Link to post
Share on other sites
8 hours ago, Gameslinx said:

I'm aware of this, I think I had this happen to be during the last episode in the series I'm recording. Thanks - I labelled it off as a 1.7.3 problem as I hadn't had it happen before. I'll look into that. I hope to have it fixed by the next update.

RE:  Bouncing on Armstrong

I just watched your video above and don't know if we were having the same issue due to the vastly larger size of your ship compared to mine.  I'm sure it has something to do with the never-to-be-sufficiently-damned Unity lander legs, the number and setting of the legs used, and the mass of the ship.

My issue was that as soon as 1 leg touched the ground, my ship would be catapulted sky-high at a MUCH greater velocity than it landed with.  Decreasing the spring in the legs made this worse, so in the end I just landed on the heatshield, which did not bounce enough to notice.  For a look at the ship and a full description of the various landing attempts, see this post, starting with the 4th pic.

https://forum.kerbalspaceprogram.com/index.php?/topic/186474-beyond-hope-travelling-circus-episode-02-bark-at-the-moon/&tab=comments#comment-3639297

 

8 hours ago, Gameslinx said:

Not sure what's causing this. Again, I'll look into it. I'm assuming you have science set to 100%.

RE:  Getting Nothing from Deployed Seismograph Thingy

Actually, I have science rewards set at 200% because my space program is a government entity, not a private corporation ;)   The Goo and Weather Station thingies in this same collection of deployed science stuff are working just fine, spamming me with reports of transmitting miniscule amounts of Science!  And even the seismograph thingy triggered when I crashed the ship, it just showed zero impact energy and 100% distance attenuation so zero points scored.

I note in the stock file GameData\SquadExpansion\Serenity\Resources\DeployedScience.cfg that the seismograph has lines for each stock planet listing numbers for "energy".  These numbers appear to be somehow proportional to the planet's gravity.  Then I looked through the Beyond Home files and didn't see any similar code.  So I'm guessing that if you don't make a "BH_DeployedScience.cfg" file and provide "energy" values for all your new planets, then the seismograph's algorithm multiplies by zero and you get zero points.  Just a theory.

8 hours ago, Gameslinx said:

I have a feeling i know what's causing this. Can you find Lua.cfg in BeyondHome/Configs and remove this code - see if that works?


PhysicsMaterial
			{
				bounceCombine = Average
				frictionCombine = Maximum
				bounciness = 0
				staticFriction = 5
				dynamicFriction = 4.8
			}

 

OK, I'll let you know.

 

3 hours ago, Gameslinx said:

Yo, I just finished the rest of the EVE configs. How's this? Obviously, there are some limitations to what I can actually do with EVE so I have tried my best to replicate the atmosphere effects. I'll pass the config on to you early if you'd like.

Damn, that looks excellent!  Sure, I'd like to try that ;) 

Share this post


Link to post
Share on other sites
1 hour ago, Geschosskopf said:

Damn, that looks excellent!  Sure, I'd like to try that ;) 

Atmosphere colours will be fixed in the update. I can't send the actual AtmosphereFromGround colour fixes because I changed actual planet configs, so they might reference objects that don't exist.

However the EVE patch should sort that out anyway. But just a note in case you encounter a problem related to the atmosphere colour.

Here you go - Put this in GameData/BeyondHome/EVE:

https://www.dropbox.com/s/c91g8pubj3p877n/glows.cfg?dl=0

1 hour ago, Geschosskopf said:

RE:  Bouncing on Armstrong

Just landed with this little craft here

 CssTSrR.jpg

No bouncing! I'll try and recreate it a few times but until then - I didn't experience anything here

 

Share this post


Link to post
Share on other sites
3 hours ago, Gameslinx said:

Here you go - Put this in GameData/BeyondHome/EVE:

Schweet!  Thanks!

Also, I commented out the lines in the Lua.cfg you mentioned above and that totally solved my rover problems there.

Share this post


Link to post
Share on other sites

Really nice mod

can't wait for the one where kerbal will have to find a way to survive in a depleted of stars universe

Share this post


Link to post
Share on other sites

@Gameslinx I found a possible glitch with Lua Biomes.  On the equator near 45^ E is a large crater that differs from the others in having dry land on most of its bottom instead of a lake.  The questionable area is towards the eastern side of this basin, where there are a few small puddles in the lowest ground within the crater.  The puddles don't actually have any liquid in them--the ground is just painted blue like the shores surrounding the lakes in other craters.  This area of "puddles" is a different biome from the surrounding Mossy Lowlands, but it's Rocky Midlands instead of something dealing with lakes.

This struck me as odd because Rocky Midlands are at much higher elevation elsewhere around the crater.  In general, from highest elevation to lowest, the region of this crater goes as follows:

  • Main Ridge Highlands (upper parts of surrounding mountains)
  • Rocky Midlands (lower parts of surrounding mountains)
  • Atmospheric Midlands (slopes of the crater walls from from its floor to the surrounding higher ground)
  • Mossy Lowlands (most of the crater floor)

Thus, it seems strange that there's a patch of Rocky Midlands at the lowest point within the crater.

Share this post


Link to post
Share on other sites

Hey, just a quick note: I love the idea of this mod! And it seems to be quite sophisticated already, especially with the fancy visuals and I already spent quite some good time "Beyond Home".

Maybe it would be nice to update the install instructions for up-to-date gameversion, but I guess you already had that in mind for your next update.

I expected a much bigger impact on framerate, in fact your mod seems to be optimized very well regarding this, gj!

Thanks for your work, keep going! :)

Share this post


Link to post
Share on other sites
35 minutes ago, mid0r said:

Hey, just a quick note: I love the idea of this mod! And it seems to be quite sophisticated already, especially with the fancy visuals and I already spent quite some good time "Beyond Home".

Maybe it would be nice to update the install instructions for up-to-date gameversion, but I guess you already had that in mind for your next update.

I expected a much bigger impact on framerate, in fact your mod seems to be optimized very well regarding this, gj!

Thanks for your work, keep going! :)

The install instructions are correct, aren't they? :)

Let me know what I missed and i'll fix it asap!

Share this post


Link to post
Share on other sites
On 8/5/2019 at 6:40 PM, Gameslinx said:

The install instructions are correct, aren't they? :)

Let me know what I missed and i'll fix it asap!

Hey gameslinx :)
I think the link to download the mods (I noticed it on Kopernicus) does not match good "mod/KSP version" version relation. When we download Kopernicus from your link (with a 1.7.3 KSP), it says it's not the good version, and will probably break the save.

Regarding what I was about to say before I saw the last messages, I'm currently getting back to Beyond Home after a break because I missed it.

I was wondering something : Would BH work with contract packs like "Contract Pack : Clever Sats" or "Contract Pack : Giving Aircraft a Purpose" ?
I wanted to start all over again with a new career, but I wish I could use those mods that are (imo) a MUST HAVE in order for the career to be more interesting.

Thanks again for your work, I noticed an enormous performance increase since the last time I played, this is fantastic.

Share this post


Link to post
Share on other sites
4 minutes ago, Wastel said:

Hey gameslinx :)
I think the link to download the mods (I noticed it on Kopernicus) does not match good "mod/KSP version" version relation. When we download Kopernicus from your link (with a 1.7.3 KSP), it says it's not the good version, and will probably break the save.

Regarding what I was about to say before I saw the last messages, I'm currently getting back to Beyond Home after a break because I missed it.

I was wondering something : Would BH work with contract packs like "Contract Pack : Clever Sats" or "Contract Pack : Giving Aircraft a Purpose" ?
I wanted to start all over again with a new career, but I wish I could use those mods that are (imo) a MUST HAVE in order for the career to be more interesting.

Thanks again for your work, I noticed an enormous performance increase since the last time I played, this is fantastic.

I JUST REALISED HOW MUCH OF AN IDIOT I AM

Github readme has been updated to match the current version, including download links (fixed Kopernicus and Scatterer download links!)

Also those contract packs should work fine with Beyond Home :)

ENJOY and sorry for messing up lol

Share this post


Link to post
Share on other sites
2 hours ago, Gameslinx said:

I JUST REALISED HOW MUCH OF AN IDIOT I AM

Github readme has been updated to match the current version, including download links (fixed Kopernicus and Scatterer download links!)

Also those contract packs should work fine with Beyond Home :)

ENJOY and sorry for messing up lol

It's okay :-)

Here is an other suggestion : Making Less History seems to be more than a suggested mod, this is a MANDATORY mod for your pack to work (prevents from not being able to recover vessels). Why don't you add it in the installation guide so people can enjoy your modpack even though they skipped the little part where you talk about this mod? :-)

Share this post


Link to post
Share on other sites
2 hours ago, Wastel said:

It's okay :-)

Here is an other suggestion : Making Less History seems to be more than a suggested mod, this is a MANDATORY mod for your pack to work (prevents from not being able to recover vessels). Why don't you add it in the installation guide so people can enjoy your modpack even though they skipped the little part where you talk about this mod? :-)

I shall, I keep forgetting things... Thank you!

I'm not 100% if MLH still causes the bug where you can't recover vessels. I don't own the DLC myself so I can't test it on the current version and the latest KK, unfortunately. I'll add it to the instructions, thank you

Share this post


Link to post
Share on other sites
17 hours ago, Gameslinx said:

I shall, I keep forgetting things... Thank you!

I'm not 100% if MLH still causes the bug where you can't recover vessels. I don't own the DLC myself so I can't test it on the current version and the latest KK, unfortunately. I'll add it to the instructions, thank you

This bug is not caused by the MLH mod, it is caused by your planet pack. The MLH mod actually fixes the bug, that is why I suggested to add it in the installation guide.

I tested your modpack without MLH two days ago, and I can confirm I wasn't able to recover my vessel once it landed back on Rhode. I then installed MLH, launched the same vessel in the same conditions, and I've been able to recover it this time ;)

Share this post


Link to post
Share on other sites

Erm maybe i'm a bit thick , but for some reason , after I had finally found a flat spot on Hydrus erm………. I hit CTRL K thinking here we lets build a base here and nothing happened , talk about gutted , took me ages to find the right spot .

 

So is this a bug or am I thick lol :lol: Coz KK is borked ? 

Share this post


Link to post
Share on other sites
9 minutes ago, Puggonaut said:

Erm maybe i'm a bit thick , but for some reason , after I had finally found a flat spot on Hydrus erm………. I hit CTRL K thinking here we lets build a base here and nothing happened , talk about gutted , took me ages to find the right spot .

 

So is this a bug or am I thick lol :lol: Coz KK is borked ? 

I'm not sure. Try making sure you're on the most recent Kerbal Konstructs (I know i link an outdated one in my install instructions, which I have now fixed) and try again.

If you're on the most recent KK, try downgrading!

Share this post


Link to post
Share on other sites
23 hours ago, Gameslinx said:

I'm not sure. Try making sure you're on the most recent Kerbal Konstructs (I know i link an outdated one in my install instructions, which I have now fixed) and try again.

If you're on the most recent KK, try downgrading!

Okidoki will give it a go , have you got a recommended version of KK ?

Share this post


Link to post
Share on other sites
9 minutes ago, Puggonaut said:

Okidoki will give it a go , have you got a recommended version of KK ?

I don't. I'm still on the KK from BH 1.1, lol

Share this post


Link to post
Share on other sites

Hi all, unfortunately my graphics card which has been serving me wonders over the last 3 years has sadly given up the ghost. 2 of the 3 fans have failed at the same time and I'm not able to use it for the foreseeable future in fear of it overheating.

Thankfully the card itself still works and isn't damaged, but I'm sending it off for repair or for a replacement as I'm still covered by its 3 year warranty period, if possible.

During this period, I won't be able to develop the mod or upload videos. I don't know if I'm able to even load the game without a dedicated GPU, so any critical bugs will be unfixable until it gets back to me.

I will still be providing support for people who have trouble installing the mod or encounter a config bug, but I don't feel confident releasing a fix without having it be tested first.

I'll let everyone know when I get my hands on a GPU, and when I'm able to start development again.

Thank you all for the continued support of the mod and those who follow the YouTube series, I hope to get back to everyone soon :)

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.