Jump to content

[1.9.1 - 1.10.x] Beyond Home 1.5.0 (Supports Parallax)


Gameslinx
 Share

Recommended Posts

56 minutes ago, Jhorriga said:

None of the structures seem to be showing up. for example, I've visited where the terraformers on lua should be but they're absent. What could be causing this problem? I'm not running any mods that would prevent them from spawning, and I have all the graphics settings maxed out.

Forgot to add screenshots3242E87A69E003889B9C24DA4CB6DCA08B5C85BFBB6FF585A6D8B2A73FD79189E08958D2484FAC4D

Link to comment
Share on other sites

N0PNZxe.png

I went to Gateway and i noticed that the ground was not visible. Is this how its supposed to be ? I saw some videos where it had ground. I still cam collide with "nothing" and it has hills. is this fixable?

 

https://camo.githubusercontent.com/de538070d3df3f482f27552eb863c63e8815dc6eb3b4d779da908aba81021803/68747470733a2f2f692e696d6775722e636f6d2f707471516f39752e706e67

I was expecting something like this.

 

Edited by BlackEyedPhantom
Link to comment
Share on other sites

Anyone have any ideas what's causing this?  I'm having an issue with beyond home where anytime I enter orbit of the tempus system barycenter, I get massive fps drop and the log is spammed with exceptions like this:

[LOG 09:07:47.422] Something went wrong with a quad! System.NullReferenceException: Object reference not set to an instance of an object
  at PQSModExpansion.PQSMod_Subdivide.OnQuadBuilt (PQ quad) [0x00002] in <59a91b1760d141c1a83c20c379e94c09>:0 

This is a fresh 1.11.2 install with beyond home installed with minimal mods through ckan.  I mention the fix for the pink textures below, and it occurs even before making that fix.  This also occurs in my 1.10.1 game file, which was where I first noticed it and has a more extended mod list.  Full log from the 1.11 game is here: KSP.log.  I just cheated a single command pod into orbit.  Happy to try any debugging if anyone has any suggestions.

 

@mszegedy @theleg I had the same issue with the pink textures, running on linux.  I was able to solve it by using the mac shaders instead of linux.  Go to KSP folder, then GameData/Parallax/Shaders/ and rename Parallax-macosx.unity3d to Parallax-linux.unity3d.  The mac and windows shader files are both ~200 kb, but the linux one is only 11 kb.  I don't know enough about unity to know if that points to anything, but I found it odd.

Edited by Aezon
added some info
Link to comment
Share on other sites

On 5/20/2021 at 5:08 AM, theleg said:

Did you find the solution? I am facing the same issue on Ubuntu, i.e., the ground is pink...see my above post for the video.

No, I "solved" it by switching to Windows. I'm still not sure where the pink comes from. It must be something at the driver level. I don't think I tried it with both Nvidia's driver and Nouveau, just the Nvidia one. But I'm not optimistic.

Link to comment
Share on other sites

1 hour ago, mszegedy said:

No, I "solved" it by switching to Windows. I'm still not sure where the pink comes from. It must be something at the driver level. I don't think I tried it with both Nvidia's driver and Nouveau, just the Nvidia one. But I'm not optimistic.

 

On 5/26/2021 at 6:48 PM, Aezon said:

@mszegedy @theleg I had the same issue with the pink textures, running on linux.  I was able to solve it by using the mac shaders instead of linux.  Go to KSP folder, then GameData/Parallax/Shaders/ and rename Parallax-macosx.unity3d to Parallax-linux.unity3d.  The mac and windows shader files are both ~200 kb, but the linux one is only 11 kb.  I don't know enough about unity to know if that points to anything, but I found it odd.

Did you try this before switching? I haven't tried it, because I have already started a science mode in stock KSP, but if it worked for you, please let me know...

Link to comment
Share on other sites

Hello all who may see this post. In my game the solar panels seems to not function properly when Fate is eclipse by Destiny. Even though the binary suns are both suns the panels would indicated "Blocked by Destiny" when Fate circles behind Destiny. This would indicate my solar panels only gather sunlight from Fate and not from Destiny although both are stars and thus should work regardless which star is blocking which. This has made probes extremely unreliable as the eclipse event happens pretty often and they would randomly lose power mid operation, forcing frequent autosaves. Does anyone have any insight on why this is happening and how to solve this?

My game is lightly modded with quality of life in mind, although most of the installed mods do not mess with solar panel operation other than these that i suspect may have to do with it

Near Future Solar Core and Near Future Solar
Dynamic battery storage
 

Link to comment
Share on other sites

I have a question......

In this planet pack, there isn’t a Kerbin, but a Rhode. But how to make it? In my own pack, I tried lots of ways, but I failed.

If I don’t set "!Body[Kerbin] {}", it can be load by Kopernicus, but there is a Kerbin. If I set that, Kopernicus can’t read it.

Here is the beginning part of the .cfg: 

Spoiler

@Kopernicus:AFTER[KOPERNICUS]
{

   Body

   {

       name = Krinas

       cacheFile = GalaxiesBeyondtheWorld/cache/HR5756System/Krinas.bin

       barycenter = false

       randomMainMenuBody = true

       useOnDemand = true 

      Debug

       {

           exportMesh = true

           update = true

       }
        Template

       {

           name = Kerbin

           removePOS = true

           removeAtmosphere = true

           removeBiomes = true

           removeOcean = true

           removeAllPOSMods = true

       }
        Properties

       {

           displayName = Krinas

           description = Krinas is the only living planet in the HR5756 system. It is about 1.2 times the size of the earth and has a moon-like satellite. The satellite is also tidally locked, and only one side of it can be seen from Krinas. /n/n There is an ocean of liquid water on Krinas, with an average temperature of 20°C (the average temperature of the Earth is 15°C)

            radius = 6424449

           mass = 7.16E+24

           gravParameter = 477757444000000

            rotates = true

           rotationPeriod = 91584

           initialRotation = 0

           inverseRotThresholdAltitude = 40000

           tidallyLocked = false

           isHomeWorld = true

           timewarpAltitudeLimits = 0 0 0 0 0 0 0 0

           biomeMap = GalaxiesBeyondtheWorld/Core/Textures/PluginData/Krinas_biome.dds

Link to comment
Share on other sites

4 hours ago, Peter JY said:

I have a question......

In this planet pack, there isn’t a Kerbin, but a Rhode. But how to make it? In my own pack, I tried lots of ways, but I failed.

If I don’t set "!Body[Kerbin] {}", it can be load by Kopernicus, but there is a Kerbin. If I set that, Kopernicus can’t read it.

Here is the beginning part of the .cfg: 

  Reveal hidden contents

@Kopernicus:AFTER[KOPERNICUS]
{

   Body

   {

       name = Krinas

       cacheFile = GalaxiesBeyondtheWorld/cache/HR5756System/Krinas.bin

       barycenter = false

       randomMainMenuBody = true

       useOnDemand = true 

      Debug

       {

           exportMesh = true

           update = true

       }
        Template

       {

           name = Kerbin

           removePOS = true

           removeAtmosphere = true

           removeBiomes = true

           removeOcean = true

           removeAllPOSMods = true

       }
        Properties

       {

           displayName = Krinas

           description = Krinas is the only living planet in the HR5756 system. It is about 1.2 times the size of the earth and has a moon-like satellite. The satellite is also tidally locked, and only one side of it can be seen from Krinas. /n/n There is an ocean of liquid water on Krinas, with an average temperature of 20°C (the average temperature of the Earth is 15°C)

            radius = 6424449

           mass = 7.16E+24

           gravParameter = 477757444000000

            rotates = true

           rotationPeriod = 91584

           initialRotation = 0

           inverseRotThresholdAltitude = 40000

           tidallyLocked = false

           isHomeWorld = true

           timewarpAltitudeLimits = 0 0 0 0 0 0 0 0

           biomeMap = GalaxiesBeyondtheWorld/Core/Textures/PluginData/Krinas_biome.dds

Rhode is technically Kerbin to the game. 

Link to comment
Share on other sites

On 5/29/2021 at 11:36 PM, Artyloo said:

@Gameslinx any updates on when BH will support Parallax 1.2? I can't wait to play around with the new collisions!

Same man! I really want it to be updated with KSP 1.12 update and BH 1.6? Maybe? 

On 5/22/2021 at 9:55 PM, BlackEyedPhantom said:

N0PNZxe.png

I went to Gateway and i noticed that the ground was not visible. Is this how its supposed to be ? I saw some videos where it had ground. I still cam collide with "nothing" and it has hills. is this fixable?

 

https://camo.githubusercontent.com/de538070d3df3f482f27552eb863c63e8815dc6eb3b4d779da908aba81021803/68747470733a2f2f692e696d6775722e636f6d2f707471516f39752e706e67

I was expecting something like this.

 

By the way this is still the same for me. Any ideas how to fix it?

Link to comment
Share on other sites

  • 4 weeks later...
On 6/4/2021 at 4:24 AM, manngai22 said:

Hello all who may see this post. In my game the solar panels seems to not function properly when Fate is eclipse by Destiny. Even though the binary suns are both suns the panels would indicated "Blocked by Destiny" when Fate circles behind Destiny. This would indicate my solar panels only gather sunlight from Fate and not from Destiny although both are stars and thus should work regardless which star is blocking which. This has made probes extremely unreliable as the eclipse event happens pretty often and they would randomly lose power mid operation, forcing frequent autosaves. Does anyone have any insight on why this is happening and how to solve this?

My game is lightly modded with quality of life in mind, although most of the installed mods do not mess with solar panel operation other than these that i suspect may have to do with it

Near Future Solar Core and Near Future Solar
Dynamic battery storage
 

I don't know if you're still playing Beyond Home and my comment is still relevant, but you can go to the Kopernicus Github (make sure you got the latest release installed), look at the assets of the release and download 'MultiStarSolarPanels.cfg'.  Put the file into the 'Config' - folder of Kopernicus. I'm not sure if you have to delete the original 'SolarPanels.cfg' file, so if it doesn't work, remove this and try again.

Link to comment
Share on other sites

  • 2 weeks later...
On 5/20/2021 at 2:08 AM, theleg said:

Did you find the solution? I am facing the same issue on Ubuntu, i.e., the ground is pink...see my above post for the video.

I got it working on Ubuntu, using the LinuxPlayer (not Proton), and KSP 1.12.1.3142. 

Two things:

Be sure to use Parallax 1.0.1; trying to use a more recent Parallax causes other issues.

Edit settings.cfg, and set `UNSUPPORTED_LEGACY_SHADER_TERRAIN = True`.  That fixed the missing and/or magenta textures for me.

It almost works with the latest Parallax, but some of the lighting is a bit wonky.  But the latest Parallax on Windows (or with Proton) is far more broken.

On 3/19/2021 at 8:48 AM, WasteL67 said:

If it didn't change since, you need to install the mod Kerbal Konstructs. Then, the Lua base will be available to unlock with in-game money from the VAB at the top-right button.

On 1.12, the Lua base was already unlocked for me; I didn't pay to use it or anything.  I suspect that's a bug.

Link to comment
Share on other sites

hey!

I'm playing beyond home 1.5.0 in 1.12 in carrier mode and I founded some contract bugs: Their are funny, but sometime they are totally impossible. 

idk if it's the right place to repost bugs so excuse me if it's not.

I have screenshots: 

r295BMQ.png

the first one was a repairing contract about a satellite aging around rhode, but around ash ObsezWN.pngthe second one was a spash down contrat but on the ash sea (a funny one yes but I don't know if it's normal)

IcFX9np.pngthe  last contrat was a satellite contract: but really close and around destiny 

I hope to be useful by posting this.

Link to comment
Share on other sites

I have a strong suspicion that the glitchy terrain on Gateway and other bodies like Kohm is due to changes in Kopernicus. It looks like these buildings are considered terrain scatters, and there have been substantial reworkings on how those are handled since this mod was released.

I tried playing around with ScatterCullDistance and ScatterCleanupDelta to no avail. I had the same behavior in 1.10.2 as well as 1.12.0.

Link to comment
Share on other sites

  • 3 weeks later...
On 7/12/2021 at 4:21 PM, BlackEyedPhantom said:

Hello. I have this issue where terrain scatters will just spawn mid air or sideways, like fallen trees or both. How can i fix this?

KSP version: 1.12

Beyond home: 1.5.2

Kopernikus Planetary System Modifier: 2:release-1.12.1-55

x9vdqnG.png

I have almost the same problem, but for me it happens right away, at Rhode, near the start of the game.

KSP 1.10.1.

BeyondHome 1.4.0, installed via CKAN, telling CKAN to only grab KSP 1.10.x compatible versions of things.

And yes, I have terrain detail on high.

Here's two screenshots:

https://imgur.com/a/BWBGO83

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...