Jump to content

[1.12.x] NOT RO - Kerbal Construction Time - Unrapid Planned Assembly


linuxgurugamer
 Share

Recommended Posts

1 minute ago, infinite_monkey said:

So there's a menu where your recovered ship should go? Well, then it makes totally sense to take that into account for recovery time as well :D

Not exactly. That other mod would physically move the KSC locations so it just whichever one you currently had selected. Launch sites are generally treated like launchpads, not a whole other KSC. Theoretically the support for other KSCs is still in there but I haven't perused the source in a few years at this point.

Link to comment
Share on other sites

Hi everyone, I've recently started having a problem with KCT. Never had this problem before, so a bit weird how random it is. I have a starting build rate of 0.0001bps and have to sink an upgrade point straight into the VAB or I have well over 6000 days for a starting sounding rocket. Anyone have any ideas? Thanks :)

This is KCT for ksp 1.7.3

Edited by RyEE94
​​​​​​​Should perhaps mention ksp 1.7.3 rp1
Link to comment
Share on other sites

It does. Using it on 1.8.1 and 1.9.1.

 

EDIT:

If I may, I'd like to suggest a feature, unless somebody here has some clever mathery that does what I want; I couldn't find a solution. Here goes:

I'd like to connect the possible amount of upgrade points to the facility level, such that say for a level 0 VAB, you can't go higher than x build points per second, for level 1, y amount, and for level 3 z amount. Same but ideally separately, for SPH and R&D.

In my specific case, I'd settle for (level+1)^2, because it counts from zero, and that results in 1, 4, and 9 BP/s respectively. However I have to enforce that rule myself. It would be awesome if KCT could do that for me...

Edited by Corax
Avoiding to double post
Link to comment
Share on other sites

On 3/10/2020 at 5:22 PM, infinite_monkey said:

Is it just me doing something wrong or is KCT ignoring the launch site selected in the stock menu in the VAB? I always need to select it from the KCT menu.

Yeah the mod removes functionality there. 

 

On a connected note does anyone know the proper procedure for getting launch pads added via kerbal constructs into the selection menu? I have them unlocked and they show up in the VAB just fine but they don't show up in the KCT menu so I can't roll out to them. Is there a setting somewhere do I need KSC switcher? If anyone knows please let me know

Link to comment
Share on other sites

21 minutes ago, LORDPrometheus said:

Yeah the mod removes functionality there. 

 

On a connected note does anyone know the proper procedure for getting launch pads added via kerbal constructs into the selection menu? I have them unlocked and they show up in the VAB just fine but they don't show up in the KCT menu so I can't roll out to them. Is there a setting somewhere do I need KSC switcher? If anyone knows please let me know

Actually I'm experiencing the opposite problem–launch pads that AFAICT shouldn't be open still show up in KCT's launch site selection list...

Link to comment
Share on other sites

5 minutes ago, Corax said:

Actually I'm experiencing the opposite problem–launch pads that AFAICT shouldn't be open still show up in KCT's launch site selection list...

Well quite frankly I would rather have your problem. Did you have to change any settings to make the launchpads appear or did they just work from the start? Maybe you could take a screenshot of your KCT settings and post it here? 

Link to comment
Share on other sites

22 hours ago, LORDPrometheus said:

Well quite frankly I would rather have your problem. Did you have to change any settings to make the launchpads appear or did they just work from the start? Maybe you could take a screenshot of your KCT settings and post it here? 

I don't think KCT has anything to offer in its settings regarding this, rather both KCT and KK have their own, not fully compatible ways of doing things. Both were around long before Squad even implemented more than one launch site, and never intended players to switch to other sites, so mods had to find their own ways to do this.

For me, Kerbal Konstructs has always been the more troublesome of the two, with sites being open although I closed them (or specified they should start closed), and also sites I open that don't respect that I paid lots of funds, and simply are closed again the next time I look. I still love them both, and couldn't imagine playing KSP without either.

 

EDIT:

Settings:

Spoiler

Kerbal Konstructs

Gameplay Settings:

GamePlay Settings:

-Enable RemoteTech GroundStation[sic]: greyed out

-Enable CommNet GroundStations: disabled

Difficulty Settings:

+Open bases only when landed

max facility range: 300

-Disable Remote Recoovery[sic]

Misc Settings:

+Show Icons only with LS selector

Master Volume: 100%

-Focus last LaunchSite

 

Settings:

Misc Settings:

Visibility Range: 25000

-Enable inflight highlighting

Editor Settings:

+Spawn preview models

-Use alternative editor camera

-RenderCamera for underground

Directory for new Instances: INTERNAL

Directory for new Instances:KerbalKonstructs/NewInstances

Debug Settings:

-Debug Mode

 

Cheats:

-Launch from any Site

-Open everything

-Show hidden bases

+Leave Stock CommNet

 

Kerbal Construction Time

All enabled except

-"Shared Upgrade Pool (KSCSwitcher)"

-"Auto Stop TimeWarp"

-"Debug Logging"

 

 

 

Edited by Corax
Settings, for what it may be worth
Link to comment
Share on other sites

  • 2 weeks later...

I started getting this strange message in the middle of my career after a time warp for a rocket construction completed. It wasn't doing this until about year 5 (I use a large multiplier for KCT so stuff takes a long time). It doesn't do this after warping for researched tech, only after warping for a craft.

Player log file is here: https://drive.google.com/open?id=1iUIpgHUl5VEVc7ofCIwa3yp1FOLjPAVf

EDIT: It is actually adding those science points to my science, so I can't just ignore it without exiting and editing my save file to get rid of the added science.

Spoiler

YyDtO7l.jpg

 

Edited by Kwebib
Link to comment
Share on other sites

3 minutes ago, Kwebib said:

I started getting this strange message in the middle of my career after a time warp for a rocket construction completed. It wasn't doing this until about year 5 (I use a large multiplier for KCT so stuff takes a long time). It doesn't do this after warping for researched tech, only after warping for a craft.

Player log file is here: https://drive.google.com/open?id=1iUIpgHUl5VEVc7ofCIwa3yp1FOLjPAVf

EDIT: It is actually adding those science points to my science, so I can't just ignore it without exiting and editing my save file to get rid of the added science.

As far as I know, you get science points for building vessels.

Link to comment
Share on other sites

I wonder why it only started doing that after so many years in game though. Maybe it started after I upgraded to level 2 R&D?

EDIT: I found this post by magico13 in his old thread:

Quote

If the "science per day" you're referencing is the "Development" rate, that isn't science you earn, that's how quickly tech nodes unlock. The "Research" rate gives you science for building vessels, but you have to actively be building things to get that, and it's 0 by default, and it's totally optional to use.

I'll take another look at my settings and see if something got switched on somehow.

Edited by Kwebib
Link to comment
Share on other sites

2 hours ago, Tonas1997 said:

I might be wrong, but wasn't there a "settings" button somewhere in the GUI that allowed us to change the KCT presets mid-game? I wanted to disable the automatic KAC alarms but couldn't reopen the configuration window anywhere :/

You should be able to get to settings by right-clicking the toolbar button at the main space center screen.

Link to comment
Share on other sites

On 3/31/2020 at 4:21 PM, Tonas1997 said:

I might be wrong, but wasn't there a "settings" button somewhere in the GUI that allowed us to change the KCT presets mid-game? I wanted to disable the automatic KAC alarms but couldn't reopen the configuration window anywhere :/

Yes, it was replaced with right-clicking.  No need to clutter up the toolbar with unnecessary buttons.

This was mentioned in one of the change notes

Link to comment
Share on other sites

If I may, I'd like to suggest a feature:

There are a few dialogue boxes that would benefit from displaying more information, namely the confirmation dialogue for "Scrap Vehicle", and the crew selection dialogue when you "Launch Vehicle": Both would be much more comprehensive–and less prone to user error ; ) –if they would display the name of the craft you are going to scrap or launch, respectively. Also, if the crew selection dialogue could display which site the vehicle is going to be launched from, that would be immensely helpful too.

Nothing pressing, but would be awesome to have that additional info.

 

PS.:

Another thing that just occurred to me that might make for an interesting challenge: Would it be possible to block the functionality of buildings while they are being upgraded? To be precise, the KSC level upgrades, not KCT upgrade points. It seems strange from an immersion standpoint that I can build new vessels, and even more so conduct difficult scientific research, at full speed while construction workers are busy tearing down and rebuilding the place... Mainly VAB, SPH, and R&D, but the others might benefit from that, too. Since craft construction as well as research speed are already tied to KCT building upgrades, it might be "as simple" (haha) as temporarily masking all invested upgrade points until the upgrade is finished.

Most difficult I would imagine would be how to handle the effects on Mission Control, if one has contracts running, and Administration with active strategies–on the other hand, it might be sufficient to simply block access to it so one cannot accept new contracts, while still being able to complete ones that were previously accepted.

Edited by Corax
Link to comment
Share on other sites

Hi there! A readme at the main page (on github) has a paragraph:

Quote

Expand Building Plans dialog. Add menu items 1. add to integration building list 2. Load prebuilt assemblies (Load 1 from integration list, all others list listed in subassemblies) (all assemblies aftger first are loaded as a subassembly) (During integration, no parts are available) (Need to trigger subassembly view) Have whitelist of parts to be used during integration struts fuel lines Build times for integrated vessel will be 1/10 of the total time to build the assemblies, plus the time to build whatever new parts were added Check total number of parts (ignoring the whitelisted parts) to make sure no extra parts have been added (ie: duplications, etc)

It makes me think there is a way of merging craft from storage, especially the sentence I've marked in bold. I have done a few attempts to get what exactly these instrucions tell me to do, but with no success. Can anyone give me a full step-by-step guide with pictures?

Edited by DarthPointer
Link to comment
Share on other sites

  • 2 weeks later...

Hello! I have been looking to make my career save more interesting (that is, harder). That, for me, would mean a KCT install, as well as the rest of the suite (basically the stuff linked to in OP). However, I'm a bit hesitant before I download. Last time I had this installed, about 18 months ago, I ran into an issue. All it took was a "revert to VAB" after on the pad I realized I had the wrong Kerbals in the command pod. This subsequently created a pop-up message saying that something was seriously wrong, and I should say something on this forum. I didn't ...   I looked at the log and saw literally hundreds of Unity errors (Don't have it anymore). I then uninstalled it and found that there was a weird error involving a NRE at 'situation' when switching to space center view from anywhere. I fixed it by reinstalling ALL of my 100+ mods.

 

I'm aware that based on this limited description, there's nothing you can do to fix the initial problem.

I just wanted to post this here as a (belated) bug report, and to see if this still persists (Of course, it probably has something to do with another mod than KCT).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...