linuxgurugamer

[1.6.1, 1.7.2] Kerbal Construction Time - Unrapid Planned Assembly

Recommended Posts

28 minutes ago, linuxgurugamer said:

The current version for RO has my fix for that.

Does it? I had a look on https://github.com/KSP-RO/KCT and it didn't have your fix merged in.

Share this post


Link to post
Share on other sites

I think I've figured out how to replicate a strange issue with recovered crafts. I found that if I "recover active vessel" through KCT, then edit it and save, it would sometimes disappear from my list entirely. I believe this happens only if you undo the first action you take while editing the craft, and save edits at the end. Stuff like editing fuel levels or opening/closing doors doesn't count, as that stuff all gets ignored by undo.

I'm running KSP 1.6.1 with KCT 1.4.6.1

Share this post


Link to post
Share on other sites
5 hours ago, Flibble said:

Does it? I had a look on https://github.com/KSP-RO/KCT and it didn't have your fix merged in.

I see.  OK, I've merged in the changes that RO has done in to a branch, will look into fixing a couple of bugs and releasing it soon.  My version is for stock, but includes all the changes for RO

Share this post


Link to post
Share on other sites

I merged your master branch with RO earlier and built it, but when I ran it in game the GUI was broken. Not really sure why as the mod seemed fine other than that.

Share this post


Link to post
Share on other sites
Posted (edited)
27 minutes ago, Flibble said:

I merged your master branch with RO earlier and built it, but when I ran it in game the GUI was broken. Not really sure why as the mod seemed fine other than that.

Did you merge the PR I had submitted?

 

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

I'll be merging in the latest changes from the RO version, and then will look for the two bugs, once done I'll be pushing my changes back to RO

Share this post


Link to post
Share on other sites
On 5/17/2019 at 7:33 AM, Flibble said:

Does it? I had a look on https://github.com/KSP-RO/KCT and it didn't have your fix merged in.

You are correct, that was something I fixed after the merge.

 

Share this post


Link to post
Share on other sites

I have an issue with KCT that just displays a grey box when loaded in - no buttons etc. (1.7 version) anyone else having a similar issue? 

Share this post


Link to post
Share on other sites
1 hour ago, Marstiphal said:

I have an issue with KCT that just displays a grey box when loaded in - no buttons etc. (1.7 version) anyone else having a similar issue? 

First, make sure all dependencies are up-to-date

Then, please provide a log file (see my sig for info)

Share this post


Link to post
Share on other sites
Posted (edited)

I'm having the same issue...

I opened an issue with the log

Edited by kirmie44

Share this post


Link to post
Share on other sites
12 hours ago, Marstiphal said:

All the dependencies are up-to-date, here is the log file

https://drive.google.com/open?id=1aX5stvIX5VkMQ5xKpm22YstTfoNg6SXI

many thanks

Sorry to say that you are missing a dependency.

You do not have Magicore installed.  If you go back to the OP, right under the big KCT emblem, you can find the links.  I just changed the title color to red to make it more obvious

3 hours ago, kirmie44 said:

I'm having the same issue...

I opened an issue with the log

Same problem as above

Share this post


Link to post
Share on other sites
5 hours ago, linuxgurugamer said:

Sorry to say that you are missing a dependency.

You do not have Magicore installed.  If you go back to the OP, right under the big KCT emblem, you can find the links.  I just changed the title color to red to make it more obvious

Same problem as above

 

No idea how I managed that but thanks! This is by far my fav mods, so glad its being continued. Do you have a way to donate?

Share this post


Link to post
Share on other sites
7 minutes ago, Marstiphal said:

 

No idea how I managed that but thanks! This is by far my fav mods, so glad its being continued. Do you have a way to donate?

https://www.patreon.com/linuxgurugamer

glad its all working

Share this post


Link to post
Share on other sites

thanks for the help, I didnt realize that mod disapeared from my mod directory

It would be cool if there was a kerbl konstructs plug that made it so these buildings/launch sites had locations at each place. like three kscs side by side!

Share this post


Link to post
Share on other sites

Is there any way to temporarily disable KCT w/o mucking around with the mod files in the Gamedata folder? There are some saves that I do want to use KCT on, and some that I don’t, but I don’t want to have to repeatedly uninstall and reinstall KCT.

Share this post


Link to post
Share on other sites
4 minutes ago, TonedMite133805 said:

Is there any way to temporarily disable KCT w/o mucking around with the mod files in the Gamedata folder? There are some saves that I do want to use KCT on, and some that I don’t, but I don’t want to have to repeatedly uninstall and reinstall KCT.

 Make a separate install for the other saves. It's not a good idea to install and uninstall mods like that and a single save but there's nothing in the license which prevents you from making a copy of the entire game in another location

Share this post


Link to post
Share on other sites
Posted (edited)

Just a heads-up that the front page has some flaws that had me deeply confused for a while, but I've sorted it all out.  I humbly suggest changing it, and I've done the work already to make it easier.  The links to the suggested companion mods to this one are pointed at the old forum posts for some mods, but not for others.  For a long time, I thought I couldn't use this mod because some of its companion mods had not been updated since KSP 1.4 and were critically broken, but--as I eventually learned--they have been updated though I could not find them.  Google also pointed me to the same old version posts and it was only after I began to do a more thorough investigation that I discovered the new versions.

Specifically, the links to ScrapYard and StageRecovery need to be updated.  I can't be the only person who has been confused by this, and it is such a simple thing to update the links.  Here's the data:

ScrapYard link is: 

ScrapYard Link should be: 

StageRecovery link is: 

StageRecovery link should be: 

It occurs to me that perhaps it was your intention to preserve the discussion history, because each of the old forum posts does have a reply at the very end that points to the new version.  In fairness, it was my poor assumption that the referenced mod was outdated and inaccessible to me.  As far as I can tell (I may be incorrect), KRASH, Crew R&R, and OhScrap all point to the newest form of the mod, although somehow the OhScrap mod has a presence in the ScrapYard list on GitHub, which also confused me at first because I was suddenly unsure if they were the same or different mods (I thought perhaps OhScrap was the continued version of a retired ScrapYard).

The general subject here for me is:  how can I easily make sense out of all these mods so that I can choose which ones I want to use, and how do I select the version that I want for the version of KSP that I'm running?  This is especially critical right now, as I'm sure people who read this today know (or will soon discover) that KSP 1.7.1 was released today as an amendment for Breaking Ground and mods are broken again.  For my part, I'm reverting to KSP 1.6.1 so I can play with some new mods (new to me, anyway).  About the only thing that I'm going to really miss from 1.7.0+ is the improved maneuver node editor, because everything else they added has been available through Kerbal Engineer Redux for a long time.

In any case, I'd like to express many thanks to linuxgurugamer for his work on the many mods he has created for this game that I love so much!

Edited by Tolnorus

Share this post


Link to post
Share on other sites

Does this mod work in 1.7 with the new DLC?

 

Share this post


Link to post
Share on other sites

>>> Does this mod work in 1.7 with the new DLC?

My experience was that, after the update it did not work. But I removed it and reinstalled both KCT and Magicore and it was working again.

Share this post


Link to post
Share on other sites

I have an issue with a recovered plane. When I relaunch it, the controls become hard to use - it feels like I have some weird asymmetric drag or similar as it will pull to one side (usually the left). I had my kOS autopilot set to maintain heading and it required 6 degrees of bank to fly in a straight line (before recovery it would fly straight with 0 degree bank). When I switched over to manual controls I found it really hard to fly as it was pulling to the side so hard.

Is this likely to be something not getting reset properly when the  ship is recovered? I'm using FAR and B9 procedural wings, so there are a few extra settings over stock, maybe it's one of them?

Share this post


Link to post
Share on other sites

@linuxgurugamer Just letting you know that we on the RO fork will no longer be supporting KSP versions <1.6.1. So if plan on doing a PR back to RO fork with your changes then you don't have to account for older KSP versions. Also feel free integrate your clickthrough blocker into this mod.

Share this post


Link to post
Share on other sites
17 minutes ago, siimav said:

@linuxgurugamer Just letting you know that we on the RO fork will no longer be supporting KSP versions <1.6.1. So if plan on doing a PR back to RO fork with your changes then you don't have to account for older KSP versions. Also feel free integrate your clickthrough blocker into this mod.

Thanks for the heads up.  What about the ToolbarController?  I've been holding off on adding those two because of compatibility with the RO branch

Share this post


Link to post
Share on other sites
3 minutes ago, linuxgurugamer said:

Thanks for the heads up.  What about the ToolbarController?  I've been holding off on adding those two because of compatibility with the RO branch

Sure, you can add the ToolbarController as well.

Share this post


Link to post
Share on other sites
1 minute ago, siimav said:

Sure, you can add the ToolbarController as well.

Ok.  I have some bugs to fix and code to merge, may be a week or so, but it's now near the top of my TODO list

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.