Well actually KSP 1.8 is being upgraded to Unity 2019.2.2f1 (this was announced yesterday) and a new parttools will be released for it. Part tools works with the Unity version the game runs on. So currently KSP 1.7.3 is unity 2017.1.3p1 and so to use parttools you must use that version.
    • Like
    5