• 0
Sign in to follow this  
Cloakedwand72

KSP 1.7 Loosing control of ship and game?

Question

I turn off the satellite network requirement & play the game as normal. After launch while its outta atmosphere it locks complete control of ship and game and I can't revert to VAB or SPH or main game screen why is that? This is happening in the new update.  

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 1

It happens to me too, in my case reliable way to trigger it is to do a burn at maneuver node, somtimes it happens every couple of seconds.  I keep ALT+F12 screen open all the time, there is a button to release all control locks

Share this post


Link to post
Share on other sites
  • 0

  I find that this happens quite often when you are trying to play in IVA mode as well.  You will be flying normally, and then you are completely locked out of all keyboard commands.  The only thing that I can do is manually use the throttles inside the cockpit.  Trying to stream on Twitch and not being able to do anything but hit CTRL+Alt+Delete to leave the game, as you cannot go anywhere when this happens, is highly frustrating!

Share this post


Link to post
Share on other sites
  • 0
On 4/23/2019 at 4:12 PM, rossmohax said:

It happens to me too, in my case reliable way to trigger it is to do a burn at maneuver node, somtimes it happens every couple of seconds.  I keep ALT+F12 screen open all the time, there is a button to release all control locks

This should be your first step.   Alt-F12 and find the "Release Input locks" button.   If it continues to a point where you constantly have to free the input locks, we'll need some logs and such to diagnose what is going on. 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

I have had this happen once myself, but only once. When it happens you can’t press alt+f12 to get the debug menu. 

In my case I was stuck in map mode, and I could still click on stuff, and press tilde on the keyboard to switch planets, but pressing m would not exit map view, and escape would not bring up the main menu either. I had to force kill the game. When it loaded the save it was before I had time warped and made the manevour burn, so the persistent file never got updated between the time it last saved and the game frosted up.

Edited by MechBFP

Share this post


Link to post
Share on other sites
  • 0

Happened to me in my Triple Lander mission and my Green Good mission. I usually fix it with a debug or restarting the computer

collecting-solar-power.png?w=1000

My last triple lander had trouble with the landing

When I tried to record this scene it started turning on landing legs and the maneuvers started to Over fuel required and started to show incorrect data

game-lag.png?w=1000

But again I reseted it and it worked fine, and I landed too

highlands.png?w=1000

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this