Since 1.6 I've been seeing more frequent random crashes with really no clue where they come from, so I've been spending time since 1.7 chasing exceptions in the KSP.log. Today I found a fix for a TypeLoadException I was getting during startup. I know KSP plugins should target .NET 3.5, but how critical is this? Could this be a source of random crashes or is it just sloppy programming by the modders?  What I tracked down is: Decoupler Shroud was compiled against .NET 4.6.1 @navot