jrodriguez

[KSP 1.9.0] VesselMover Continued (Feb, 2020)

Recommended Posts

47 minutes ago, EdwardB3020 said:

Can someone explain this? 

https://imgur.com/zrdcNIq

 

The vessel might be re-rooted? Everytime I see vessel going RUD is because they have been built with an old version of KSP and/or with a mix of re-root and part clipping

Share this post


Link to post
Share on other sites
On 4/20/2020 at 6:19 PM, EdwardB3020 said:

Can someone explain this? 

https://imgur.com/zrdcNIq

 

Your vessel has been re-rooted. VesselMover doesn't like vessel which re-root parts.

3 hours ago, combater2006 said:

Question: is it 1.9.1 compatible???

yes

Share this post


Link to post
Share on other sites

hello there,

got a little problem with the mod, when i try to spawn a vessel he always appears stuck on the ground like this:

HqIfoYs.pngI can't switch to the vessel because it says it's moving and it make the game really laggy too.

I tried on different save, on different launchpad and with different vessel but it's always the same.

I tried to remove all the mods i got and with different version of the mod but nothing change.

Any idea what can cause this ?

 

Share this post


Link to post
Share on other sites
2 hours ago, Raoul Duke said:

hello there,

got a little problem with the mod, when i try to spawn a vessel he always appears stuck on the ground like this:

HqIfoYs.pngI can't switch to the vessel because it says it's moving and it make the game really laggy too.

I tried on different save, on different launchpad and with different vessel but it's always the same.

I tried to remove all the mods i got and with different version of the mod but nothing change.

Any idea what can cause this ?

 

Usually, all the problems related with spawning vessels using vessel mover are caused by a change of the root part. If you start building a new ship and stick with the same root part you should not have any problem.



 

Share this post


Link to post
Share on other sites

I tried with other ship with the the same root part and also tried to spawn just a 1 part ship to test but its the same.

Share this post


Link to post
Share on other sites

It's not been mentioned in this thread but it seems a) like a great pity VesselMover is unable to situate a craft upon the surface of any planet other than Kerbin; and b) that it would not be hard to modify it to do so?

VM declines to take control of a vessel that "is not landed".  I'd be quite happy to Alt-F12 my vessel into low orbit around, say, Eve, and then activate VM to take it under control and lower it to the surface at the location I desire.

Would you please consider this?  Here's why it is important.  The design of a craft that is intended to fly on Eve might perhaps ONLY fly on Eve (not Kerbin, Duna or Laythe) and therefore, its testing needs to occur on Eve.

Share this post


Link to post
Share on other sites
1 hour ago, Hotel26 said:

It's not been mentioned in this thread but it seems a) like a great pity VesselMover is unable to situate a craft upon the surface of any planet other than Kerbin; and b) that it would not be hard to modify it to do so?

VM declines to take control of a vessel that "is not landed".  I'd be quite happy to Alt-F12 my vessel into low orbit around, say, Eve, and then activate VM to take it under control and lower it to the surface at the location I desire.

Would you please consider this?  Here's why it is important.  The design of a craft that is intended to fly on Eve might perhaps ONLY fly on Eve (not Kerbin, Duna or Laythe) and therefore, its testing needs to occur on Eve.

You could use the cheat menu 'set position' function in conjunction with Vessel Mover.

Edited by RealKerbal3x

Share this post


Link to post
Share on other sites
1 minute ago, RealKerbal3x said:

You could use the cheat menu 'set position' function in conjunction with Vessel Mover

I am very familiar with Set Orbit which will set you in orbit in space, but will not land you.  I did Alt-F12: Cheats: Set Orbit but don't see Set Position anywhere.

Share this post


Link to post
Share on other sites
Just now, Hotel26 said:

I am very familiar with Set Orbit which will set you in orbit in space, but will not land you.  I did Alt-F12: Cheats: Set Orbit but don't see Set Position anywhere.

It's a recent addition in 1.9, if you're not yet on that version. It should appear as an option under Set Orbit.

It's a bit difficult to get the hang of, as it requires entering target coordinates. But using Vessel Mover in conjunction with it should be easier, as VM just uses simple drag handles.

Share this post


Link to post
Share on other sites
1 hour ago, Hotel26 said:

It's not been mentioned in this thread but it seems a) like a great pity VesselMover is unable to situate a craft upon the surface of any planet other than Kerbin; and b) that it would not be hard to modify it to do so?

VM declines to take control of a vessel that "is not landed".  I'd be quite happy to Alt-F12 my vessel into low orbit around, say, Eve, and then activate VM to take it under control and lower it to the surface at the location I desire.

Would you please consider this?  Here's why it is important.  The design of a craft that is intended to fly on Eve might perhaps ONLY fly on Eve (not Kerbin, Duna or Laythe) and therefore, its testing needs to occur on Eve.

HyperEdit mod already does that and much more. Personally I always use HyperEdit to land on other planets and once I am there then I use Vessel Mover to spawn more vessels quickly.

Finally. I'm not going to add any other feature to this mod. I'm just doing the basic maintenance to make it work for each KSP release.

Share this post


Link to post
Share on other sites
31 minutes ago, jrodriguez said:

I'm just doing the basic maintenance to make it work for each KSP release.

Fair enough, and thanks for that, too!  Have a good day.

Share this post


Link to post
Share on other sites

I thinks i found a solution to my problem if anyone encounter it.

So i instaled the mod with CKAN rather than manualy and now it spawn stuff fine.

Don't really now what changed tho, i looked the ckan files for the mod and the one gived on github but they seems to be exactly the same.

Anyway thanks for the answer and for keeping those great mods alive !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.