Jump to content

[1.3.1, 1.4.x, 1.5.x, 1.6.x, 1.7.x] Kerbal Joint Reinforcement Continued v3.4.0 [25-04-2019]


pap1723
 Share

Recommended Posts

On 11/1/2020 at 6:18 PM, Lisias said:

Well, it costs nothing to come back to this issue now and then. :)

KJR Continued is the old and faithful (and sometimes buggy nowadays) KJR, with some fixes needed by modern KSP as new parts and changes happened.

KJR/Next is a kinda rewrite of the KJR, fixing the root cause of some problems and so no workarounds and punctual fixes are needed at all. It's also way faster on less beefier machines, but at expenses of framerate when parts are destroyed.

In a nutshell, if you have a pretty powerful rig and do videos, you will probably be better served by Continued because the old KJR uses more CPU (what you would have more than enough) on the normal flying, but it does not taxes the CPU when parts are destroyed (what can be an issue if you want to publish a video on Youtube). Everybody else will be, probably, better served by Next.

 

Wee need the KSP.log to diagnose the problem - if there's a problem at all, KJR is "transparent", it loads and just works without pesking the user with controls or other UI dingbats. :)

Would you already ask the difference between "Kerbal Joint Reinforcement - Next" and "Kerbal Joint Reinforcement Continued"? (or do they do different things?) Is it still that? (since both have been recently updated)

Link to comment
Share on other sites

49 minutes ago, BeethovenFM said:

Would you already ask the difference between "Kerbal Joint Reinforcement - Next" and "Kerbal Joint Reinforcement Continued"? (or do they do different things?) Is it still that? 

They do the same thing in different ways.

KJR/Next is not updated for 2 years (and it's a year since the last time I tested it), so yeah, everything I said is still valid - at least, for the KSP versions it is still working (I don't remember the last time I tested it, so I can't say if it's working for contemporaneous KSPs).

KJR/c was updated 6 months ago, and it merely disabled one of the features introduced on the immediately previous version, so yeah, everything I said is still valid. Again, for the KSP versions it is working on (you will need to test it yourself, I think). :)

Link to comment
Share on other sites

9 minutes ago, Lisias said:

They do the same thing in different ways.

KJR/Next is not updated for 2 years (and it's a year since the last time I tested it), so yeah, everything I said is still valid - at least, for the KSP versions it is still working (I don't remember the last time I tested it, so I can't say if it's working for contemporaneous KSPs).

KJR/c was updated 6 months ago, and it merely disabled one of the features introduced on the immediately previous version, so yeah, everything I said is still valid. Again, for the KSP versions it is working on (you will need to test it yourself, I think). :)

THanks _o/
Obrigado

Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...

For anyone checking the (currently) last page to see if this mod works on the latest KSP (1.12.2 as of writing):

I didn't have any problems with the Main Menu buttons like the poster above me. However, physics will freak out if doing (stock) EVA construction. I haven't tried KIS/KAS yet, since this is actually first venture into EVA construction of any kind. In my case, I'm testing in the Scenario "Station One" and the moment I move even just a battery to a new location, my Station starts accelerating away from Kerbin for no reason, and SAS cannot control anything.

I would undock a part, and it would just "fall" toward Kerbin, so it only seems to affect the controlled craft.

Discovered this whilst slowly adding mods and using that scenario to optimize performance vs features/visuals on my not-quite-potato of a "mini-PC".

 

Screen Video of the bug, for anyone interested:

https://youtu.be/nhUMnGN18xU

Link to comment
Share on other sites

12 hours ago, MartyrKomplx said:

... physics will freak out if doing (stock) EVA construction ... I would undock a part, and it would just "fall" toward Kerbin ...

I experienced similar problems.

After attaching parts in KSP 1.11.x and 1.12.x, my space stations often started spinning or accelerating.

I've seen the "falling" problem in 1.12.2 even *without* KJR installed. Kerbals going on EVA sometimes exit the capsule at zero orbital speed, so the ship speeds away leaving the Kerbal to fall towards the planet.

The other KJR fork, "Next", also has problems in 1.12.

 

 

 

Link to comment
Share on other sites

  • 1 month later...
5 hours ago, SimilarNumber said:

I've made some changes that attempt to fix the EVA constructions causing phantom forces on ships, as well as recompiling against the latest KSP dll files.
Seems to work fine for me, but I'm not guaranteeing anything.

https://github.com/SimilarNumber/Kerbal-Joint-Reinforcement-Continued

I'm glad that someone took a stab at addressing the EVA construction issue. I noticed that you're using "RunVesselUpdateJointLater" wrong though. As-is the code will not go beyond the WaitForFixedUpdate because you didn't feed the IEnumerator to the StartCoroutine method.

If the code works and you're willing to clean it up to have only the relevant changes, then I would be happy to incorporate it to an official release.

Link to comment
Share on other sites

5 hours ago, siimav said:

I noticed that you're using "RunVesselUpdateJointLater"

That's a good point, I completely messed that one up. Still, the reason I thought I was fixing the issues was that not doing the update was preventing the issues from occurring.

My new attempt at this is to delay the joints update until construction mode is exited. It's far from a perfect solution, but in my limited testing it seems to do the job well enough.

Link to comment
Share on other sites

  • 2 weeks later...
  • Add support for the stock EVA construction feature, thanks @SimilarNumber
  • Improve robotics support. Note however that since the new KSP1.12 docking port doesn't fire onRoboticPartLockChanged event, it will stay locked forever.
  • Enabling the Debug setting now lists all extra joints KJR created and draws them onscreen
  • Fix typo that caused duplicate joints to be created to root part
  • Make CheckMultiJointBetweenParts() check existence of a joint in both directions
Link to comment
Share on other sites

What?  someone found the cause of the force being applied when using construction in Orbit?  If this fixes the issue, I will be very happy.  I hate watching my space station change orbit for no reason and not being able to save.  Eventually found a way to stop it but that sucked.  I stopped using the built-in construction system because of this.

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
Posted (edited)
On 3/23/2022 at 10:01 AM, siimav said:
  • Enable the DockingPortLockedEvents patch in KSPCommunityFixes to properly support the rotation feature on stock docking ports

Interestingly this mod still breaks EVA construction completely for me. While using the default settings, as per the difficulty menu, as soon as I place a part on a ship in orbit my Kerbal essentially gets invisibly "connected" to the ship and the ship gets dragged around as the Kerbal attempts to move around while in EVA. If the kerbal is able to board the ship (such as being on a ladder while in construction mode) then there will be a phantom force that will push on the ship forever.

If I disable all the settings in the difficulty menu, then all the problems go away. So if anyone else runs across this, just disable the settings in the difficulty menu in the KJR tab before doing EVA construction.

Edited by MechBFP
Link to comment
Share on other sites

On 5/14/2022 at 5:37 AM, MechBFP said:

Interestingly this mod still breaks EVA construction completely for me. While using the default settings, as per the difficulty menu, as soon as I place a part on a ship in orbit my Kerbal essentially gets invisibly "connected" to the ship and the ship gets dragged around as the Kerbal attempts to move around while in EVA. If the kerbal is able to board the ship (such as being on a ladder while in construction mode) then there will be a phantom force that will push on the ship forever.

If I disable all the settings in the difficulty menu, then all the problems go away. So if anyone else runs across this, just disable the settings in the difficulty menu in the KJR tab before doing EVA construction.

Thank you so much Mech, this saved my life.

I don't know if it'd be possible @siimav , but having an option that essentially toggles KJR off whenever EVA Construction is enabled would be a game changer for this mod :)

Link to comment
Share on other sites

10 hours ago, Lijazos said:

having an option that essentially toggles KJR off whenever EVA Construction is enabled

Not that easy. Pretty sure a scene change is needed for the additional KJR joints to get cleaned up. In addition to that your station will most likely wobble itself to bits by the time you're finished with EVA construction.

Link to comment
Share on other sites

On 5/17/2022 at 4:50 AM, siimav said:

Not that easy. Pretty sure a scene change is needed for the additional KJR joints to get cleaned up. In addition to that your station will most likely wobble itself to bits by the time you're finished with EVA construction.

Interestingly there is no need for a scene change to work around the problem as I described it.

Simply go EVA, go into the difficulty menu and disable all KJR options, finish EVA construction, go back into the menu and re-enable KJR options. I haven't experienced any unintended side effects yet anyway as a result of doing this. although I haven't done anything too crazy yet.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...