Jump to content

[1.9.x, 1.10.x] Docking Camera KURS Style Re-Adopted (Fixed in 1.9)


Recommended Posts

  • 5 weeks later...

Sorry to butt in, and I'm not sure if I am in the right place.  I am running 1.8.1 on Windows 10, I had the visual problem with Kerbals being visible through all other parts only when seated in EAS-1 Command Seats.

For troubleshooting I started with a vanilla 1.8.1 setup slowly adding all my usual 72 mods.  The visual problem only occurred when KURS camera was added (1.3.7.2).  See the effect in this short thread

I then read through this thread and saw that it was suggested it might be a conflict with another mod, so I started with a clean 1.8.1 install and ONLY installed KURS 1.3.7.2 (via CKAN) and its necessary direct and indirect dependencies being;

  • Click through blocker 0.1.9.5
  • Module manager 4.1.3
  • Toolbar controller 0.1.9.4
  • ZeroMini AVC 1.1.0.1

With only these five mods, the visual problem is present at all times, including when the camera window is inactive.  Only the Kerbal is visible through parts, the seat is occluded correctly.  All other functions of the mod appear to be operating correctly, it is just this visual error.

If there is anything I can supply to assist with the fix, please let me know - I am new to troubleshooting in this way.

Link to post
Share on other sites
8 hours ago, archiebald said:

Sorry to butt in, and I'm not sure if I am in the right place.  I am running 1.8.1 on Windows 10, I had the visual problem with Kerbals being visible through all other parts only when seated in EAS-1 Command Seats.

For troubleshooting I started with a vanilla 1.8.1 setup slowly adding all my usual 72 mods.  The visual problem only occurred when KURS camera was added (1.3.7.2).  See the effect in this short thread

You aren't butting in.

Nice job debugging.  Unfortunately, I'm waiting for the original author, since some of this camera work is beyond me.  This mod was reconstructed from a decompiled dll along with github sources, so the comments aren't totally there

Link to post
Share on other sites
1 minute ago, sciencepanda said:

Would it be possible to add a SpaceX style view, like what's seen on Crew Dragon? Or does anyone know of another mod that already adds this?

Sorry, no.  It's currently broken in 1.9

Link to post
Share on other sites
  • 1 month later...
  • 2 weeks later...

Hi all,

First, excuse me for my badly english....
I have KSP 19.1 and more 100 mods installed. Your mods works in 1.9.1, I see the docking in the small window, and all visions effects works too (night vision etc etc).
The problem is that the main screen duplicate the small window but in a lower resolution and i can\'t see the outside of my rocket and the target like before. 
But perhaps somebody has telling you about this problem.

You make a good job, and i hope that i can help you with my small experience feedback.

Link to post
Share on other sites
On 6/22/2020 at 9:17 AM, Fulcrum said:

Hi all,

First, excuse me for my badly english....
I have KSP 19.1 and more 100 mods installed. Your mods works in 1.9.1, I see the docking in the small window, and all visions effects works too (night vision etc etc).
The problem is that the main screen duplicate the small window but in a lower resolution and i can\'t see the outside of my rocket and the target like before. 
But perhaps somebody has telling you about this problem.

You make a good job, and i hope that i can help you with my small experience feedback.

That's why the title of the thread says "Broken in 1.9.1"

Link to post
Share on other sites
4 hours ago, linuxgurugamer said:

That's why the title of the thread says "Broken in 1.9.1"

I don't speak English very well and I did'nt understand the nuance of language. I thought that it was possible to modify it since the small window was working. Sorry.

Have a good day and many thanks for your job !

Link to post
Share on other sites
On 5/4/2020 at 1:42 PM, linuxgurugamer said:

This mod was reconstructed from a decompiled dll along with github sources ...

I just read this.  That is some dedication, right there.  Thanks for going to all the trouble.  I, for one, am grateful.

Edited by wreckreation
Link to post
Share on other sites
  • 1 month later...

This has now been corrected and my instructions here are no longer needed. Please get the latest version through the standard means! 

 

I have a fix!!!  Temporarily at least.  This should do it until CKAN is setup by a developer with access, ehem @linuxgurugamer, I have created the dll which works (at least on my machine :P).  I'm pretty excited to have fixed it.  All you have to do is replace the DockingCamera.DLL in the   [Kerbal Space Program folder]\GameData\DockingCamKURS\Plugins  folder.

I've shared it in my dropbox which  can be downloaded here: The DLL can be found here: https://www.dropbox.com/sh/gtq9vkrbz6xjcsz/AACYfqSePX6_EmtqCFrFIWGEa?dl=0   

 

 

Edited by dangros
Link to post
Share on other sites
3 minutes ago, dangros said:

I have a fix!!!  Temporarily at least.  This should do it until CKAN is setup by a developer with access, ehem @linuxgurugamer, I have created the dll which works (at least on my machine :P).  I'm pretty excited to have fixed it.  All you have to do is replace the DockingCamera.DLL in the   [Kerbal Space Program folder]\GameData\DockingCamKURS\Plugins  folder.

I've shared it in my dropbox which  can be downloaded here: The DLL can be found here: https://www.dropbox.com/sh/gtq9vkrbz6xjcsz/AACYfqSePX6_EmtqCFrFIWGEa?dl=0    

 

 

Source code, please.  I'll see if I can decompile it, but source is better.

 

Link to post
Share on other sites

So I've never compiled any type of KSP code till now but I'm a C# developer by trade, so when I saw the github email stating the following , I made the changes:

The root cause of this issue in 1.9.x and 1.10.x is the renaming of KSP's main camera from "Camera 01" to "UIMainCamera".
As such, the mod could not retrieve the main camera reference, resulting in this issue.

This change in BaseCamera.cs is sufficient to restore this mod to its glory.
protected List<string> CameraNames = new List<string> { "GalaxyCamera", "Camera ScaledSpace", "Camera 01", "Camera 00" };
to
protected List<string> CameraNames = new List<string> { "GalaxyCamera", "Camera ScaledSpace", "UIMainCamera", "Camera 00" };

 

I gave it a shot but since my environment does not have all the correct references, I added the needed ones.  I also had to comment out the Save image logic b/c I didnt get it to work yet.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...