Jump to content

[1.9.x, 1.10.x] Docking Camera KURS Style Re-Adopted (Fixed in 1.9)


Recommended Posts

2 hours ago, Daniel Prates said:

Hooraah, this thing may come alive again yet!

That's good news. I frequently build stations with radial docking ports, and KSP's stubborn insistence for SAS "hold target" to aim at center of mass rather than the selected docking port often made radial docking frustrating. This mod made docking so much easier and fun. I was crestfallen when this mod broke in 1.9.1.

After a bit of playing, though, I found that I've mastered docking. This mod was like my training wheels and I don't need them any more. KURS docking camera, thanks for the fun times :)

Link to post
Share on other sites
5 hours ago, dangros said:

So I've never compiled any type of KSP code till now but I'm a C# developer by trade, so when I saw the github email stating the following , I made the changes:

The root cause of this issue in 1.9.x and 1.10.x is the renaming of KSP's main camera from "Camera 01" to "UIMainCamera".
As such, the mod could not retrieve the main camera reference, resulting in this issue.

This change in BaseCamera.cs is sufficient to restore this mod to its glory.
protected List<string> CameraNames = new List<string> { "GalaxyCamera", "Camera ScaledSpace", "Camera 01", "Camera 00" };
to
protected List<string> CameraNames = new List<string> { "GalaxyCamera", "Camera ScaledSpace", "UIMainCamera", "Camera 00" };

 

I gave it a shot but since my environment does not have all the correct references, I added the needed ones.  I also had to comment out the Save image logic b/c I didnt get it to work yet.

Ok, thanks, I'll get it updated, and hopefully this will help with a few other mods as well

Link to post
Share on other sites
22 minutes ago, linuxgurugamer said:

New release, 1.3.7.3

  • Thanks to forum user @dangros  for this:
    • Fixed camera by replacing "Camera 01" with "UIMainCamera"

Most of the credit should goto whoever is KSP_Taxiservice on github. He had the actual fix, I just implemented it locally and got the ball rolling.  He/she actually commented on the pull request and I got the email. Stoked it worked though :)

Is there a reason the app/mod isnt using the latest version of unity?

Link to post
Share on other sites
12 hours ago, Blinkboy77 said:

Update clickthroughtblocker and toolboardcontroller for ksp 1.10.x please :) 

They don't need updating.  Assuming you are using CKAN, just tell CKAN that 1.8 and 1.9 mods are compatible, and you should then be able to load them

 

Link to post
Share on other sites
  • 3 weeks later...

Hello everyone.

And a many sincere 'thank yous' to LGG for all the work that is done on behalf of us gaming lunatics.
Is there a way to reduce or remove the screen clutter on the camera view?

The readme refers to this, but it may be the original readme.

Link to post
Share on other sites
On 8/22/2020 at 3:43 PM, DaveLChgo said:

Hello everyone.

And a many sincere 'thank yous' to LGG for all the work that is done on behalf of us gaming lunatics.
Is there a way to reduce or remove the screen clutter on the camera view?

The readme refers to this, but it may be the original readme.

What screen clutter?

Link to post
Share on other sites
  • 2 weeks later...

So I know an empty .cfg file anywhere in /GameData used to crash KSP at loading, I guess thats not the case any moar?
However, it *DOES* still seem to affect at least, loading ANY IVA spaces or props in Unity itself.

Just discovered this while working on an IVA project in Unity, which I had going previously, and just installed KURS yesterday.

Seemingly NOT a game affecting bug, but.... vOv
So no rush, but mebbe something to please address for next release?

Issue created on the repo. ;)

Link to post
Share on other sites
On 8/23/2020 at 3:41 PM, linuxgurugamer said:

What screen clutter?

Within the camera window, the digital readout, the dials at the bottom, the crosshairs.    Basically the HUD.

Originally these could be turned off.  Just was wondering if it was still possible and I'm not seeing it.

Thanks Again.

Link to post
Share on other sites
3 hours ago, DaveLChgo said:

Within the camera window, the digital readout, the dials at the bottom, the crosshairs.    Basically the HUD.

Originally these could be turned off.  Just was wondering if it was still possible and I'm not seeing it.

Thanks Again.

I'll add some settings to allow those to be controlled

Link to post
Share on other sites

Hi all,

I play with KSP 1.10.1 in OpenGL, but in this mod, all cameras shaders are pink, except the "gray scale" shaders.

With Dx12 there are no problem, but my PC crash in Dx..... the reason that i play in OpenGL.

A bug ?

Thanks to you.

Edit: Sorry, it's not yours but the original mod.

 

Edited by Fulcrum
Link to post
Share on other sites

New release, 1.3.7.5

  • settings to enable/disable the cross, summary data, detail text data and rotators
  • Added setting for default window size 
  • Thanks to Twitch user @HansAcker for some Vector3D code to help show the proper distances from the x,y,z
  • Removed static from camera without a target.
  • Added toggles to window for the main options listed above
  • Added velocity indicator
Link to post
Share on other sites
  • 1 month later...
  • 2 weeks later...

Hello, I am new to ksp. I just found this lovely mod and wanted to try it out. When I first installed it, right clicking on the camera did not do anything. Later I found out that I needed two more mods to make this one work. But when I installed those mods, right clicking the camera worked but I still cant find the 'turn on camera' option when I right click docking ports. Am I doing anything wrong? Help would be appreciated as I really want to try out this mod. Thanks!!!

Link to post
Share on other sites
14 minutes ago, dresoccer4 said:

Hi there. I noticed my kerbal in the command seat becomes visible through my ship no matter what. After some research I discovered it may be because of this mod for some reason.  Is there any fix for this that's known at this time?

cheers

No idea, I'll have to look into it

Link to post
Share on other sites

How interesting @linuxgurugamer, my 'ugly camera' is picking a giant navball floating on the horizon:

8JDkEQw.png

Feels like one of those "interpret as you wish" aspects of the ending of the movie "2001 Space Odissey". 

The same weird thing happens in Tarsier's telescopes too, if that is relevant. Wasn't able to reproduce it again and post it here, though, but i saw it happen. 

Edited by Daniel Prates
Link to post
Share on other sites

salut @linuxgurugamer, je suis francais tellement désolé pour les erreurs ... J'ai une question: comment activer la vidéo, le clic droit ne fonctionne pas?

[Added Translation]
Hi @linuxgurugamer, I'm French so sorry for the errors ... I have a question: how to activate the video, the right click does not work?

Edited by James Kerman
Added Translation
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...