jrodriguez

[1.7.x] BDArmory Continued v1.3.0 [05/01/2019]

Recommended Posts

Can i edit the cfg of the Oerlikon to make the explosive rounds explode at a range greater than 3500m?

Share this post


Link to post
Share on other sites
10 hours ago, Relitto said:

Can i edit the cfg of the Oerlikon to make the explosive rounds explode at a range greater than 3500m?

Yes, I believe. Look for something that is 3500, set it to whatever you want.

 

Recommend you to back up your game first.

On 6/25/2019 at 7:42 AM, SkyStreak said:

I'm having some difficulties with BDarmory 1.3.1. Whenever there is a hit, no damage is dealt by the weapons. I'm running with KSP 1.7.1 by the way.

Did you install module manager?

What are your bdac settings?

@jrodriguez why is my gps targetting system missing the mark? 

Bombs and missiles can no longer hit their designated target accurately using gps.

Share this post


Link to post
Share on other sites
20 hours ago, Xd the great said:

Yes, I believe. Look for something that is 3500, set it to whatever you want.

 

Recommend you to back up your game first.

Did you install module manager?

What are your bdac settings?

@jrodriguez why is my gps targetting system missing the mark? 

Bombs and missiles can no longer hit their designated target accurately using gps.

Theres nothing in the cfg set to 3500

Share this post


Link to post
Share on other sites
Posted (edited)

Just a couple of notes for things I've noticed:

1. Guns clipped into other objects don't seem to be fired by the AI anymore; formerly, the AI would not care as long as the firing path was otherwise unobstructed by mesh geometry. It's a pretty edge case, but I use the GAU-8 flipped into the aircraft a lot because 1) less exposed hitbox, 2) it looks better. Not sure if this is intended behavior or not; if it is... that sucks. :P

2. Camera issue; potentially BDA related. In flight, the camera moves ahead of the CoM for some reason instead of staying focused. Not sure if BDA-specific related, or one of the related mods (e.g., PRE).

3. Sound issue; also potentially BDA/related mod related. Sounds are omnipresent throughout a scene; as if all engines are located right next to the camera. Seeing that the previous one is also a camera issue, I'd assume that it's BDA/PRE causing this issue.

 

Also, seemingly around mid-April or May, a small update to BDA may have caused missile self-detonations to return? Unsure, maybe I'm just imagining it. It's not as frequent as the BDA 1.2.2 occurrences either, and the circumstances are a lot less clear. Just that it happens very consistently on certain craft, and not at all on others, or at least very, very low frequency with edge cases from other craft.

Edited by Box of Stardust

Share this post


Link to post
Share on other sites

So I had a ground radar/missile emplacement on an island. I was flying a fighter towards the island, and upon the target loading, suddenly my game switches vessels to the target, then switches back to the plane and the plane explodes. Anyone else know what could be the issue? I had the plane flying with atmosphere autopilot and usually when switching vessels it sill keeps the planes stable and on track.

Share this post


Link to post
Share on other sites
Posted (edited)
11 minutes ago, Tanner Rawlings said:

So I had a ground radar/missile emplacement on an island. I was flying a fighter towards the island, and upon the target loading, suddenly my game switches vessels to the target, then switches back to the plane and the plane explodes. Anyone else know what could be the issue? I had the plane flying with atmosphere autopilot and usually when switching vessels it sill keeps the planes stable and on track.

It is due to PRE. Latest version of PRE has some issues. I'm working on a fix for it

Which version of PRE are you using?

Edited by jrodriguez

Share this post


Link to post
Share on other sites
2 hours ago, jrodriguez said:

It is due to PRE. Latest version of PRE has some issues. I'm working on a fix for it

Which version of PRE are you using?

1.12 or 1.13, ill have to check next time im at my computer, fairly certain 1.13 as i downloaded all my mods only a few days ago

Share this post


Link to post
Share on other sites
7 hours ago, Tanner Rawlings said:

1.12 or 1.13, ill have to check next time im at my computer, fairly certain 1.13 as i downloaded all my mods only a few days ago

Maybe you can try the latest I published yesterday. I still doing fixes and I might publish new version soon.

Share this post


Link to post
Share on other sites

I have been having a problem with my modular missile designs where separators are still triggered by action groups.  I understand that the procedural missile core and the modular missile guidance parts disable the engines from being fired by the action groups, but is there any way to "lock" the separators from being activated by the action groups?

Share this post


Link to post
Share on other sites
8 hours ago, Finalsurvivur said:

I have been having a problem with my modular missile designs where separators are still triggered by action groups.  I understand that the procedural missile core and the modular missile guidance parts disable the engines from being fired by the action groups, but is there any way to "lock" the separators from being activated by the action groups?

No, modular missile module will not disable nothing from being triggered by actions group.

Share this post


Link to post
Share on other sites
On 6/27/2019 at 2:17 PM, Relitto said:

Theres nothing in the cfg set to 3500

Try maxAirDetonationRange = 3800

55 minutes ago, memeconnoiseur said:

hey @jrodriguez how does the heat seeking guidance work? how does the guidance determine whether something is hot or not?

 

Probably written in the code, but there is a threshold as to how strongly these missiles lock on to their target, or get distracted by flares.

Share this post


Link to post
Share on other sites
On 7/4/2019 at 9:11 AM, jrodriguez said:

Maybe you can try the latest I published yesterday. I still doing fixes and I might publish new version soon.

tried it, no longer explodes entire craft, just seems to streamline the craft by ripping the front half of the wings off, craft is still flyable so consider the issue resolved

Share this post


Link to post
Share on other sites
Posted (edited)
19 hours ago, Tanner Rawlings said:

tried it, no longer explodes entire craft, just seems to streamline the craft by ripping the front half of the wings off, craft is still flyable so consider the issue resolved

Do you have installed Kerbal Joint Reinforcement Continued ? It is almost mandatory to have it.

Edited by jrodriguez

Share this post


Link to post
Share on other sites
1 hour ago, jrodriguez said:

Do you have installed Kerbal Joint Reinforcement Continued installed? It is almost mandatory to have it.

D'oh no....

Share this post


Link to post
Share on other sites

@Chris Bolland lets continue our discussion here.

Did you try increasing maxEngageDistance? It worked for me. Also try increasing attack time (something with a value of 80 in the .cfg for bdac bombs)

Share this post


Link to post
Share on other sites
1 hour ago, Xd the great said:

@Chris Bolland lets continue our discussion here.

Did you try increasing maxEngageDistance? It worked for me. Also try increasing attack time (something with a value of 80 in the .cfg for bdac bombs)

I don't have anything like that in my .cfg file. here it is.

PART {     name = ANM65     module = Part     author = VintageXP     mesh = model.mu     rescaleFactor = 0.225          node_stack_top = 0.0, 0.6, -1.12, 0.0, 0.0, -1.0, 0     node_attach = 0.0, 0.0, -1.01, 0.0, 0.0, 0.0, 1          TechRequired = start     entryCost = 0     cost = 800     category = none     subcategory = 0     title = WW2 AN-M65 1000lb Bomb     manufacturer = Roaken Armory     description =  Extremely efficient against buildings, can take down heavily armored ground targets even indirectly. Meant to be mounted on the Structural Bomb Mount.     attachRules = 1,1,1,1,1 // attachment rules: stack, srfAttach, allowStack, allowSrfAttach, allowCollision          mass = 0.445          dragModelType = default     maximum_drag = 0.1     minimum_drag = 0.1     angularDrag = 2     crashTolerance = 12     maxTemp = 1000000000     bulkheadProfiles = srf      MODULE {   name = MissileLauncher     shortName = 1000lb     blastRadius = 59.42 //meters   blastPower = 55.44   blastHeat = 80     thrust = 0 //KN thrust during boost phase   cruiseThrust = 0 //thrust during cruise phase   dropTime = 3 //how many seconds after release until engine ignites   boostTime = 2.2 //seconds of boost phase   cruiseTime = 80 //seconds of cruise phase   guidanceActive = false //missile has guidanceActive   maxTurnRateDPS = 20 //degrees per second   explModelPath = BDArmory/Models/explosion/explosionLarge   explSoundPath = BDArmory/Sounds/explode1   useSimpleDrag = true   simpleCoD = 0,0,-3     missileType = bomb   homingType = none }

Share this post


Link to post
Share on other sites
Spoiler
7 hours ago, Chris Bolland said:

I don't have anything like that in my .cfg file. here it is.

PART {     name = ANM65     module = Part     author = VintageXP     mesh = model.mu     rescaleFactor = 0.225          node_stack_top = 0.0, 0.6, -1.12, 0.0, 0.0, -1.0, 0     node_attach = 0.0, 0.0, -1.01, 0.0, 0.0, 0.0, 1          TechRequired = start     entryCost = 0     cost = 800     category = none     subcategory = 0     title = WW2 AN-M65 1000lb Bomb     manufacturer = Roaken Armory     description =  Extremely efficient against buildings, can take down heavily armored ground targets even indirectly. Meant to be mounted on the Structural Bomb Mount.     attachRules = 1,1,1,1,1 // attachment rules: stack, srfAttach, allowStack, allowSrfAttach, allowCollision          mass = 0.445          dragModelType = default     maximum_drag = 0.1     minimum_drag = 0.1     angularDrag = 2     crashTolerance = 12     maxTemp = 1000000000     bulkheadProfiles = srf      MODULE {   name = MissileLauncher     shortName = 1000lb     blastRadius = 59.42 //meters   blastPower = 55.44   blastHeat = 80     thrust = 0 //KN thrust during boost phase   cruiseThrust = 0 //thrust during cruise phase   dropTime = 3 //how many seconds after release until engine ignites   boostTime = 2.2 //seconds of boost phase   cruiseTime = 80 //seconds of cruise phase   guidanceActive = false //missile has guidanceActive   maxTurnRateDPS = 20 //degrees per second   explModelPath = BDArmory/Models/explosion/explosionLarge   explSoundPath = BDArmory/Sounds/explode1   useSimpleDrag = true   simpleCoD = 0,0,-3     missileType = bomb   homingType = none }

 

Cruise time. Set it to some insanely ridiculously large numbers.

Tell me if my hypothesis is correct.

Share this post


Link to post
Share on other sites
On 7/6/2019 at 2:07 AM, Xd the great said:
  Reveal hidden contents

 

Cruise time. Set it to some insanely ridiculously large numbers.

Tell me if my hypothesis is correct.

Naw, that didn't do anything. Probably because the bomb doesn't have a cruise mode at all.

If I can't change it, it's fine I'll just have to send bombing missions at lower altitude and risk the flak and fighters. I changed the stats on the Flak88s so they fire at 30rpm. I've got 6 batteries of 3 guns each with a max range of 7km and I have to fly at 5km to bomb accurately. I made the tracers invisible so it's a surprise when I'm hit, and I'm constantly biting my nails.

Share this post


Link to post
Share on other sites
1 hour ago, Chris Bolland said:

Naw, that didn't do anything. Probably because the bomb doesn't have a cruise mode at all.

If I can't change it, it's fine I'll just have to send bombing missions at lower altitude and risk the flak and fighters. I changed the stats on the Flak88s so they fire at 30rpm. I've got 6 batteries of 3 guns each with a max range of 7km and I have to fly at 5km to bomb accurately. I made the tracers invisible so it's a surprise when I'm hit, and I'm constantly biting my nails.

This is a .cfg that works for me. See if it helps. Good luck when flying/being shot at.

Spoiler

PART
{
// Kerbal Space Program - Part Config
// 
// 

// --- general parameters ---
name = XDJdamMk83Big
module = Part
author = XDTHEGREAT

// --- asset parameters ---
MODEL
{
    model = BDArmory/Parts/jdamMk83/model
}
rescaleFactor = 1


// --- node definitions ---
node_attach = 0.0, 0.1779008, 0.2834791, 0, 1, 0, 0
node_stack_top = 0.0, 0.1779008, 0.2834791, 0, 1, 0, 0

// --- editor parameters ---
TechRequired = start
entryCost = 0
cost = 200
category = none
subcategory = 0
title = GPS Mk83 JDAM Bomb. 
manufacturer = XDTHEGREAT
description = 2000lb GPS-guided bomb. Packed with really high explosives, so high that kerbals jump into space with the shockwave (as described by Jeb).
// attachment rules: stack, srfAttach, allowStack, allowSrfAttach, allowCollision
attachRules = 1,1,0,0,1

// --- standard part parameters ---
mass = 0.058
dragModelType = default
maximum_drag = 0.02
minimum_drag = 0.02
angularDrag = 2
crashTolerance = 5
maxTemp = 3600

MODULE
{
  name = MissileLauncher
  
  shortName = Mk83 JDAM LR
  
  thrust = 0 //KN thrust during boost phase
  cruiseThrust = 0 //thrust during cruise phase
  dropTime = 1 //how many seconds after release until guidance begins
  boostTime = 0 //seconds of boost phase
  cruiseTime = 800 //seconds of cruise phase
  guidanceActive = true
  maxTurnRateDPS = 20 //degrees per second

  explModelPath = BDArmory/Models/explosion/explosionLarge
  explSoundPath = BDArmory/Sounds/explode1
  
  missileType = bomb
  DetonationDistance = 0
  targetingType = gps
  homingType = AGMBallistic
  optimumAirspeed = 300

  maxStaticLaunchRange = 18000
  
  aero = true
  liftArea = 0.00027
  steerMult = .3
  maxTorque = 4
  
  engageAir = false
  engageMissile = false
  engageGround = true
  engageSLW = false
  
}

MODULE
{
    name = BDExplosivePart
    tntMass = 2000
}


}
 

 

Add this line too:   maxStaticLaunchRange = 18000

Share this post


Link to post
Share on other sites

I installed this a while back, and noticed that the .50 cal turrets apparently don't fire/aim correctly, instead having their targeting thing off to the side of the spaceship. Is there a way to fix this?

Share this post


Link to post
Share on other sites
7 hours ago, mr. engino said:

I installed this a while back, and noticed that the .50 cal turrets apparently don't fire/aim correctly, instead having their targeting thing off to the side of the spaceship. Is there a way to fix this?

Any pics/logs?

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, Xd the great said:

Any pics/logs?

Sadly no, the new update probably broke the mod even more now...

UPDATE: I do have images, but apparently imgur no longer allows albums.

https://imgur.com/1wrJ1L8

https://imgur.com/pT9xTb6

https://imgur.com/S39zYB8

https://imgur.com/A5wmYY7

https://imgur.com/eahXehy

https://imgur.com/aExPtAe

Edited by mr. engino

Share this post


Link to post
Share on other sites
2 hours ago, mr. engino said:

Sadly no, the new update probably broke the mod even more now...

UPDATE: I do have images, but apparently imgur no longer allows albums.

https://imgur.com/1wrJ1L8

https://imgur.com/pT9xTb6

https://imgur.com/S39zYB8

https://imgur.com/A5wmYY7

https://imgur.com/eahXehy

https://imgur.com/aExPtAe

Lets just say that BDAC guns do not work extremely well in space. Did you test them on Kerbin?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.