Jump to content

Infernal Robotics - Next


Recommended Posts

58 minutes ago, mindseyemodels said:

installed the mod but none of the parts were in my parts list... what can I do? does it require a core mod or something?

Can you see a Robotic part tab (not the DLC one though)? If so then that's a sign that the MagicSmokeIndustries folder is in the wrong location. It should be in the GameData folder (same as Squad and SquadExpansion).

Link to post
Share on other sites
21 minutes ago, ZodiusInfuser said:

Can you see a Robotic part tab (not the DLC one though)? If so then that's a sign that the MagicSmokeIndustries folder is in the wrong location. It should be in the GameData folder (same as Squad and SquadExpansion).

cannot see the tab and I had to delete magic smoke industries in order to install this mod on ckan... how do I get both installed at the same time? edit: after trying everything it seems that magic smoke industries and this mod are absolutely incompatible... I try deleting file after file to fix overwrites but nothing changes

Edited by mindseyemodels
Link to post
Share on other sites
1 hour ago, mindseyemodels said:

cannot see the tab and I had to delete magic smoke industries in order to install this mod on ckan... how do I get both installed at the same time? edit: after trying everything it seems that magic smoke industries and this mod are absolutely incompatible... I try deleting file after file to fix overwrites but nothing changes

MagicSmokeIndustries IS Infernal Robotics - Next. No idea what previous version you had installed, nor why CKAN complained. Do you have InnerLock installed perhaps, as that too creates a MagicSmokeIndustries folder. All I can suggest is deleting the folder again then have CKAN put IR Next in again.

Link to post
Share on other sites
3 hours ago, ZodiusInfuser said:

MagicSmokeIndustries IS Infernal Robotics - Next. No idea what previous version you had installed, nor why CKAN complained. Do you have InnerLock installed perhaps, as that too creates a MagicSmokeIndustries folder. All I can suggest is deleting the folder again then have CKAN put IR Next in again.

deleting WHICH folder? because otherwise I wont know... also I do not have inner lock(never heard of that mod til now honestly)

Link to post
Share on other sites
  • 2 weeks later...
2 minutes ago, Semaj97 said:

Wow, I've been using KSP 1.3.1 just to use IR for ages now, glad to see somebody revived it. On another note though, the aesthetic is apparently the same, any plans on improvement there or nah?

Thanks!

Sadly, the aesthetics are unlikely to change. This is in part due to my limited spare time, but also me not being a texture artist. So if they were ever going to get stock-alike textures (the models themselves are fine) it would be because someone joined our team for that specific purpose as there are a lot of parts to do. I would really like to see this happen one day though!

Link to post
Share on other sites
  • 2 months later...
1 hour ago, LtChambers said:

Does anybody else get crashes when resizing stackable extendatrons that are in a stack? Especially when going down in size.

I didn't have those, but tweakscale was changed a lot lately and there was some issues with scaling certain parts in past, but those should be solved by now. But, again, tweakscale was changed a lot recently, so something may or may not be borked. You should provide log files and MM cache files, so everyone will be able to help you sooner.

Could be issue with IR or Tweakscale or strange interactions between two. You can find better info how to find log files in this thread:

Once you provide those, @Rudolf Meier or @Lisias might be able to tell better what is going on.

Link to post
Share on other sites
5 hours ago, LtChambers said:

Does anybody else get crashes when resizing stackable extendatrons that are in a stack? Especially when going down in size.

What @kcs123 said above, with a small remark: I got some issues on scaling the stackables up when stacked - they got displaced from where they should be. Our problems can be related.

I'm also checking these things from my side, just to be on the safe side. I didn't changed anything that I think would inject this behaviour, but yet, i can be wrong and I'm playing too few times on the last months to be sure about this issue.

Publish the KSP.log and ConfigCache (I don't mind here or in TweakScale thread - just ping my name here if you choose to do it here).

Link to post
Share on other sites
On 10/10/2019 at 1:26 AM, kcs123 said:

Once you provide those, @Rudolf Meier or @Lisias might be able to tell better what is going on.

sorry for beeing absent so long

in IR we try not to use TweakScale anymore, that's because many wanted to use IR, but didn't want to install TweakScale (as far as I have understood this, it's because they think that this would be cheating)

but, for the problem... what kind of crash do you see? in the past we had problems with some parts when scaling to too small... but only in the calculation of forces

Link to post
Share on other sites

Thank you so much for updating for recent KSP versions.  This is probably a common story, but I used IR around 2014 and accidentally upgraded KSP after wanting to play again, so the old mods no longer worked, and wasn't able to downgrade to a compatible version for the mods.  I would've given up getting KSP up and running again if you hadn't got this working for the current version.

Just a clip of using the new IR, rebuilt a plane I made in 2014 with new 2019 parts https://streamable.com/rflju

Link to post
Share on other sites

I modeled a real reaction wheel setup using IR, one I saw in a scott manley video to understand reaction wheels better.  Used a rotatron to spin the wheels, and joint pivotron to change their axis of rotation.  When the joint pivotrons rotate, it greatly changes the angular momentum of the wheels, which is transferred into the rest of the craft in the opposite direction.  As in scott manley's video, there are 2 for balance.  I think in practice they'd set it up a lot differently.  It's possible to see how they can be saturated.

By the way, I have noticed this in a few builds, when I have multiple IR components bound to a key using the IR editor window, it slows down the framerate a lot when pressing the keys.  It's visible in the video.

https://streamable.com/uo7va

1cg2v4K.jpg

Link to post
Share on other sites
  • 3 weeks later...
  • 1 month later...

So I've googled a bunch of things but I cant seem to find a solution to get the joints to function outside of the VAB. They hang there limply when i disengage the locks. I have plenty of power on board so I'm not sure what the issue is. I've set up action groups and I've tried controlling the servo groups from the toolbar window with no luck

Link to post
Share on other sites
11 hours ago, JSArrakis said:

So I've googled a bunch of things but I cant seem to find a solution to get the joints to function outside of the VAB. They hang there limply when i disengage the locks. I have plenty of power on board so I'm not sure what the issue is. I've set up action groups and I've tried controlling the servo groups from the toolbar window with no luck

What structural parts you have used between IR parts ? You must ensure that those parts allows fuel crossfeed. That property is not only for fuel but also for electricity. For example, I beams does not allow crossfeed, but truss allows it. You also have to ensure that your craft have control probe as minimum and enough battery or battery + EC generator(solar panel, RTG...).

Also, there is two different IR parts. Controlable and uncontrolable. Controlable parts are using motors to allow moving to desired directions while uncontroled parts allows free moving by help of outside forces, like gravity or air drag etc.

Picture of craft with opened PAW that is used on craft can help to find out what is issue in your case.

Link to post
Share on other sites
3 hours ago, kcs123 said:

What structural parts you have used between IR parts ? You must ensure that those parts allows fuel crossfeed. That property is not only for fuel but also for electricity. For example, I beams does not allow crossfeed, but truss allows it. You also have to ensure that your craft have control probe as minimum and enough battery or battery + EC generator(solar panel, RTG...).

Also, there is two different IR parts. Controlable and uncontrolable. Controlable parts are using motors to allow moving to desired directions while uncontroled parts allows free moving by help of outside forces, like gravity or air drag etc.

Picture of craft with opened PAW that is used on craft can help to find out what is issue in your case.

I'll update with a picture when I get home, but after I realized my original design wasnt working (and before I posted), I created a litmus test by sticking the joint directly against a fuel tank of a lander that I know functions with a small structural arm attached on the other end, just to test out exactly what you are describing. I received the same result after I unlocked the joint. 

I'm pretty sure the joint I'm using is this after looking at the parts pictures while I'm not at my computer. I'm assuming it's a powered joint. It's the first one in the tech tree I've unlocked from IR, the robotron and pivotron are the only ones available to me for now.ZfS2zve_d.jpg?maxwidth=640&shape=thumb&f

I also have access to the G-00 joint: https://wiki.kerbalspaceprogram.com/wiki/G-00_Hinge

The G-00 joint works correctly when placed in the same location, but I'd prefer to use IR joints, especially in future projects

Link to post
Share on other sites
19 hours ago, JSArrakis said:

I'm pretty sure the joint I'm using is this after looking at the parts pictures while I'm not at my computer. I'm assuming it's a powered joint. It's the first one in the tech tree I've unlocked from IR, the robotron and pivotron are the only ones available to me for now.

That same looking part comes in two variations. Uncontroled and powered. IIRC, first one that is available to unlock is uncontroled variant, but I speak from top of my head about it, so take this info with grain of salt. If G-00 hinge part works properly, others should work too. I'm pretty sure that you are using uncontroled part by mistake.

You can try to create similar craft in sandbox game with all parts unlocked, so you can see difference by yourself. It is hard to tell from look of the part is it powered or not, you need to pay attention on part name and description.

Link to post
Share on other sites
1 hour ago, JSArrakis said:

When I got home, I looked at the part and it was an uncontrolled hinge. So my bad, and thanks for the help!

No worries, it is easy to create such mistake and it is even easier to fix, so less things for Rudolf to worry about.

Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...
15 hours ago, AnFa said:

The parts are not moving in live play. They move just fine when I'm in the VAB, but as soon as I step out of it, I can't move them anymore

You may have same issue as JSArrakis. Just couples of posts above:

Provide a bit more info, so we can narrow down what might be issue on your side.

Link to post
Share on other sites
8 hours ago, kcs123 said:

You may have same issue as JSArrakis. Just couples of posts above:

Provide a bit more info, so we can narrow down what might be issue on your side.

I'm running KSP 1.8.1, I have the 2 DLCs, and no matter what I click or set, no a single part from this mod moves. When I go to the "Edit groups" part, and can see the current position, this is what it shows whenever I click to move it (as you will notice, it keeps cycling). They are not locked, they have power connected to them, they are connected directly to the probe core and whenever.

Edited by AnFa
gif link
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...