Jump to content

[1.3.1 - 1.11.x] Outer Planets Mod [v2.2.9] [12th Feb 2021]


Recommended Posts

I'm having trouble with my OPM/Rescale install. Something is wrong with Thatmo. The surface blinks on and off, and when I reach the surface my lander always explodes.

I tried removing Rescale/Sigma and now I can land, but landing gear go through the ground. My lander rests on its engine, but the gear go through the ground. retracting or extending them makes the lander jump.

I tried replacing the Thatmo height, color, and normal dds's with those from Karen, and that worked without Rescale/Sigma, but then same problem showed back up with Rescale/Sigma installed.

Any suggestions on how to fix this?

(this is in KSP 1.8.1)

Edited by Nicias
More information
Link to post
Share on other sites
2 hours ago, Nicias said:

I'm having trouble with my OPM/Rescale install. Something is wrong with Thatmo. The surface blinks on and off, and when I reach the surface my lander always explodes.

I tried removing Rescale/Sigma and now I can land, but landing gear go through the ground. My lander rests on its engine, but the gear go through the ground. retracting or extending them makes the lander jump.

Any suggestions on how to fix this?

(this is in KSP 1.8.1)

If not already, please set your Terrain Detail setting to High and report back with further details.

Ruriayv.png

Please also upload your: Kerbal Space Program/KSP.log file and also the contents of your Kerbal Space Program/logs folder.

Link to post
Share on other sites
1 minute ago, 322997am said:

The mod says that it is compatible with 1.9x. Does this mean that Kopernicus was forked for that version already?

Yes, but it's just a pre-release.  Expect bugs.

 

Link to post
Share on other sites
2 hours ago, Poodmund said:

If not already, please set your Terrain Detail setting to High and report back with further details.

Ruriayv.png

Please also upload your: Kerbal Space Program/KSP.log file and also the contents of your Kerbal Space Program/logs folder.

Same result. Also happening around Plock. I think it happens with all OPM bodies.

Put the logs up here:

https://filebin.net/oedgokihhbx529np

Link to post
Share on other sites

So I'm new, got the game after 1.9 was released but jumped right into modding. Outer Planets Mod was the first one I wanted to get, but it was dependent on Kopernicus and that was version locked so I just waited until it was updated. Thank you guys so much for all the work you do, modders who spend their time making this game so much richer and more alive are responsible for so much joy in the community. I truly appreciate it. 

All that being said, I installed OPM and Kopernicus yesterday and I've had nothing but problems since. I don't see anyone else reporting issues on the Kopernicus thread, so i'm assuming I have some huge conflict with a mod somewhere, especially since my bugs don't seem like issues that should happen with these two mods. For example, I loaded a save and the KSP runway was floating in the air. Another save had a rocket on the launchpad, but I couldn't remove it. It had just disappeared. When I reloaded, the icon to click on the rocket was on top of the tracking station instead. Just now I reloaded a save and the entire space center was underground. 

 

https://streamable.com/1uuxv0

 

Since I'm new, I often don't know when something is an issue with a mod, the base game or just a quirk of the game that happens when I make a mistake. Like a few hours ago, I was waiting for a maneuver node and my dV was bouncing +/- 30dV a couple times a second. I've never seen that before while in stable orbit. The planetary orbits on map view flicker like crazy when I'm not zoomed out. 

 

https://streamable.com/gkw8em

 

Anyway, I don't know if this is Kopernicus, the new Kopernicus fork, or OPM, or one of those mods conflicting with my other mods, was hoping someone could help me out diagnosing this. My complete modlist is pretty big (I'll post it at the bottom) but the biggest suspects would be Kerbalism, EVE, Scatterer, Interstellar Extended, or maybe Custom Barn Kit not being updated? Sorry if this is the wrong thread, I posted in Kopernicus as well, but these are the only two mods I've added in the last two weeks and suddenly everything is wonky. 

 

tl3GK3K.png

Link to post
Share on other sites
55 minutes ago, Nicias said:

Same result. Also happening around Plock. I think it happens with all OPM bodies.

Put the logs up here:

https://filebin.net/oedgokihhbx529np

Something very odd and bad is happening with the PQS mesh of the body here at the end of the log:

Spoiler
[LOG 12:20:18.445] [PlanetariumCamera]: Focus: Untitled Space Craft
[LOG 12:20:21.542] [OD] --> ScaledSpaceDemand.LoadTextures loading OPM/OPM_Textures/PluginData/Karen_color.dds and OPM/OPM_Textures/PluginData/Karen_normal.dds
[LOG 12:20:22.235] [Kopernicus] No new objects this time. (Probability is 50%)
[LOG 12:20:22.235] [Kopernicus] No new objects this time. (Probability is 15%)
[LOG 12:20:22.235] [Kopernicus] No new objects this time. (Probability is 15%)
[LOG 12:20:24.061] Warping to UT:10010.1. Max Rate Allowed: 5.0x.
[LOG 12:20:24.100] Packing Untitled Space Craft for orbit
[LOG 12:20:25.276] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Karen
[LOG 12:20:25.276] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Nissee
[LOG 12:20:25.276] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Thatmo
[LOG 12:20:25.276] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Tal
[LOG 12:20:25.276] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Wal
[LOG 12:20:25.276] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Priax
[LOG 12:20:25.277] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Polta
[LOG 12:20:25.277] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Tekto
[LOG 12:20:25.277] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Slate
[LOG 12:20:25.277] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Eeloo
[LOG 12:20:25.277] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Ovok
[LOG 12:20:25.277] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Hale
[LOG 12:20:25.296] Camera Mode: AUTO
[LOG 12:20:25.298] [ApplicationLauncher] SetVisible: 
[LOG 12:20:25.302] ScaleModList: listSize 287 maxListSize 614
[LOG 12:20:26.857] [PQ] Edge in GetRightmostCornerPQ is null! Caller: Plock Zn2 (PQ) nextQuad: Plock Xp2 (PQ)
[LOG 12:20:26.858] [PQS] cornerQuad in GetRightmostCornerNormal is null! caller: Plock Zn20 (PQ) nextQuad: Plock Xp2 (PQ)
[LOG 12:20:26.858] [PQS] Last edge accessor in GetRightmostCornerNormal is null! Caller: Plock Zn20 (PQ) nextQuad: Plock Zn02 (PQ) cornerQuad Plock Xn0 (PQ)
[EXC 12:20:26.873] NullReferenceException: Object reference not set to an instance of an object
	PQ.GetRightmostCornerPQ (PQ nextQuad) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.GetRightmostCornerNormal (PQ caller, PQ nextQuad) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateEdgeNormals (PQ q) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateEdges () (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateQuads () (at <394a98b9c7624adc895c04290da62640>:0)
	PQS+<UpdateSphere>d__144.MoveNext () (at <394a98b9c7624adc895c04290da62640>:0)
	UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
[WRN 12:20:26.907] Cannot find preset 'High' for pqs 'Plock'
[EXC 12:20:27.008] NullReferenceException: Object reference not set to an instance of an object
	PQ.GetRightmostCornerPQ (PQ nextQuad) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.GetRightmostCornerNormal (PQ caller, PQ nextQuad) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateEdgeNormals (PQ q) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateEdges () (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateQuads () (at <394a98b9c7624adc895c04290da62640>:0)
	PQS+<UpdateSphere>d__144.MoveNext () (at <394a98b9c7624adc895c04290da62640>:0)
	UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
	PQS:StartSphere(Boolean)
	PQS:RebuildSphere()
	PQS:Update()
[ERR 12:20:27.008] PQS Plock: Restarted

[WRN 12:20:27.043] Cannot find preset 'High' for pqs 'Plock'
[EXC 12:20:27.134] NullReferenceException: Object reference not set to an instance of an object
	PQ.GetRightmostCornerPQ (PQ nextQuad) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.GetRightmostCornerNormal (PQ caller, PQ nextQuad) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateEdgeNormals (PQ q) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateEdges () (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateQuads () (at <394a98b9c7624adc895c04290da62640>:0)
	PQS+<UpdateSphere>d__144.MoveNext () (at <394a98b9c7624adc895c04290da62640>:0)
	UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
	PQS:StartSphere(Boolean)
	PQS:RebuildSphere()
	PQS:Update()

 

Did you say that this absolutely does not happen when Sigma: Dimensions is not installed? With S:D installed on my own test bed I have also found that ground scatter is floating in mid air when it spawns in distant places so there may be some issues here.

13 minutes ago, theicon32 said:

So I'm new, got the game after 1.9 was released but jumped right into modding. Outer Planets Mod was the first one I wanted to get, but it was dependent on Kopernicus and that was version locked so I just waited until it was updated. Thank you guys so much for all the work you do, modders who spend their time making this game so much richer and more alive are responsible for so much joy in the community. I truly appreciate it. 

All that being said, I installed OPM and Kopernicus yesterday and I've had nothing but problems since. I don't see anyone else reporting issues on the Kopernicus thread, so i'm assuming I have some huge conflict with a mod somewhere, especially since my bugs don't seem like issues that should happen with these two mods. For example, I loaded a save and the KSP runway was floating in the air. Another save had a rocket on the launchpad, but I couldn't remove it. It had just disappeared. When I reloaded, the icon to click on the rocket was on top of the tracking station instead. Just now I reloaded a save and the entire space center was underground. 

https://streamable.com/1uuxv0

Since I'm new, I often don't know when something is an issue with a mod, the base game or just a quirk of the game that happens when I make a mistake. Like a few hours ago, I was waiting for a maneuver node and my dV was bouncing +/- 30dV a couple times a second. I've never seen that before while in stable orbit. The planetary orbits on map view flicker like crazy when I'm not zoomed out. 

https://streamable.com/gkw8em

Anyway, I don't know if this is Kopernicus, the new Kopernicus fork, or OPM, or one of those mods conflicting with my other mods, was hoping someone could help me out diagnosing this. My complete modlist is pretty big (I'll post it at the bottom) but the biggest suspects would be Kerbalism, EVE, Scatterer, Interstellar Extended, or maybe Custom Barn Kit not being updated? Sorry if this is the wrong thread, I posted in Kopernicus as well, but these are the only two mods I've added in the last two weeks and suddenly everything is wonky. 

The first issue, like I mentioned to Nicias on this page above, I cannot really comment without seeing log files so if you could post them itr would be appreciated. With regards to the 2nd issue of the orbit lines jumping, unfortunately thats an inherent issue with orbits with a very large semi-major axis. This is a long-running Kopernicus issue that, at the moment, we have all just lived with for a long time.

Link to post
Share on other sites
17 minutes ago, Poodmund said:

Something very odd and bad is happening with the PQS mesh of the body here at the end of the log:

  Hide contents

[LOG 12:20:18.445] [PlanetariumCamera]: Focus: Untitled Space Craft
[LOG 12:20:21.542] [OD] --> ScaledSpaceDemand.LoadTextures loading OPM/OPM_Textures/PluginData/Karen_color.dds and OPM/OPM_Textures/PluginData/Karen_normal.dds
[LOG 12:20:22.235] [Kopernicus] No new objects this time. (Probability is 50%)
[LOG 12:20:22.235] [Kopernicus] No new objects this time. (Probability is 15%)
[LOG 12:20:22.235] [Kopernicus] No new objects this time. (Probability is 15%)
[LOG 12:20:24.061] Warping to UT:10010.1. Max Rate Allowed: 5.0x.
[LOG 12:20:24.100] Packing Untitled Space Craft for orbit
[LOG 12:20:25.276] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Karen
[LOG 12:20:25.276] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Nissee
[LOG 12:20:25.276] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Thatmo
[LOG 12:20:25.276] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Tal
[LOG 12:20:25.276] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Wal
[LOG 12:20:25.276] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Priax
[LOG 12:20:25.277] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Polta
[LOG 12:20:25.277] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Tekto
[LOG 12:20:25.277] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Slate
[LOG 12:20:25.277] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Eeloo
[LOG 12:20:25.277] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Ovok
[LOG 12:20:25.277] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Hale
[LOG 12:20:25.296] Camera Mode: AUTO
[LOG 12:20:25.298] [ApplicationLauncher] SetVisible: 
[LOG 12:20:25.302] ScaleModList: listSize 287 maxListSize 614
[LOG 12:20:26.857] [PQ] Edge in GetRightmostCornerPQ is null! Caller: Plock Zn2 (PQ) nextQuad: Plock Xp2 (PQ)
[LOG 12:20:26.858] [PQS] cornerQuad in GetRightmostCornerNormal is null! caller: Plock Zn20 (PQ) nextQuad: Plock Xp2 (PQ)
[LOG 12:20:26.858] [PQS] Last edge accessor in GetRightmostCornerNormal is null! Caller: Plock Zn20 (PQ) nextQuad: Plock Zn02 (PQ) cornerQuad Plock Xn0 (PQ)
[EXC 12:20:26.873] NullReferenceException: Object reference not set to an instance of an object
	PQ.GetRightmostCornerPQ (PQ nextQuad) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.GetRightmostCornerNormal (PQ caller, PQ nextQuad) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateEdgeNormals (PQ q) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateEdges () (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateQuads () (at <394a98b9c7624adc895c04290da62640>:0)
	PQS+<UpdateSphere>d__144.MoveNext () (at <394a98b9c7624adc895c04290da62640>:0)
	UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
[WRN 12:20:26.907] Cannot find preset 'High' for pqs 'Plock'
[EXC 12:20:27.008] NullReferenceException: Object reference not set to an instance of an object
	PQ.GetRightmostCornerPQ (PQ nextQuad) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.GetRightmostCornerNormal (PQ caller, PQ nextQuad) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateEdgeNormals (PQ q) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateEdges () (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateQuads () (at <394a98b9c7624adc895c04290da62640>:0)
	PQS+<UpdateSphere>d__144.MoveNext () (at <394a98b9c7624adc895c04290da62640>:0)
	UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
	PQS:StartSphere(Boolean)
	PQS:RebuildSphere()
	PQS:Update()
[ERR 12:20:27.008] PQS Plock: Restarted

[WRN 12:20:27.043] Cannot find preset 'High' for pqs 'Plock'
[EXC 12:20:27.134] NullReferenceException: Object reference not set to an instance of an object
	PQ.GetRightmostCornerPQ (PQ nextQuad) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.GetRightmostCornerNormal (PQ caller, PQ nextQuad) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateEdgeNormals (PQ q) (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateEdges () (at <394a98b9c7624adc895c04290da62640>:0)
	PQS.UpdateQuads () (at <394a98b9c7624adc895c04290da62640>:0)
	PQS+<UpdateSphere>d__144.MoveNext () (at <394a98b9c7624adc895c04290da62640>:0)
	UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <7d9ec060e791409ab3eb85c61e312ed6>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
	PQS:StartSphere(Boolean)
	PQS:RebuildSphere()
	PQS:Update()

 

Did you say that this absolutely does not happen when Sigma: Dimensions is not installed? With S:D installed on my own test bed I have also found that ground scatter is floating in mid air when it spawns in distant places so there may be some issues here

Yep, without SD it seems to work fine.

Link to post
Share on other sites
6 minutes ago, Drupegod02 said:

Would This work with After Kerbin?

Yes, it does work with After Kerbin.

 

also, how would I land on Ovok? It’s radius is 26km, but it’s soi is only 23km. When I tried landing I ended up inside of it by the time I entered its soi. The other moons are fine

Link to post
Share on other sites
33 minutes ago, JcoolTheShipbuilder said:

also, how would I land on Ovok? It’s radius is 26km, but it’s soi is only 23km. When I tried landing I ended up inside of it by the time I entered its soi. The other moons are fine

I would suggest then there is an issue with your install: https://github.com/Poodmund/Outer-Planets-Mod/blob/master/GameData/OPM/KopernicusConfigs/SarnusMoons/Ovok.cfg#L26

Link to post
Share on other sites
1 hour ago, JcoolTheShipbuilder said:

So, Ovok’s soi should be 94km and not 23km?

also, I’m using the 1.9.1 kopernicus

Ovok's computed SOI is about 23 km, but the sphereOfInfluence parameter in Ovok's config should override that.  If it's not, that might be a bug in 1.9.1-1 Kopernicus.  That version of Kopernicus should not be considered ready for primetime.

Link to post
Share on other sites
1 minute ago, OhioBob said:

Ovok's computed SOI is about 23 km, but the sphereOfInfluence parameter in Ovok's config should override that.  If it's not, that might be a bug in 1.9.1-1 Kopernicus.  That version of Kopernicus should not be considered ready for primetime.

Ok.

Hm.. yes, that could be because of kopernicus. Also, I’m testing kopernicus, and I know there are a few bugs with it. I’m just testing it on a separate install lol.

Link to post
Share on other sites
1 minute ago, JcoolTheShipbuilder said:

Ok.

Hm.. yes, that could be because of kopernicus. Also, I’m testing kopernicus, and I know there are a few bugs with it. I’m just testing it on a separate install lol.

I just loaded up GPP using 1.9.1-1 Kopernicus.  One of GPP's moons uses sphereOfInfluence to override the computed value, and it's working OK.  So it may not be Kopernicus.  Ovok's config looks OK to me, I don't know why it's not working.

Link to post
Share on other sites
12 hours ago, JcoolTheShipbuilder said:

Ok.

Hm.. yes, that could be because of kopernicus. Also, I’m testing kopernicus, and I know there are a few bugs with it. I’m just testing it on a separate install lol.

Ovok's mean radius is 26,000m and its sphere of influence is specified as 94,000m. Therefore its max theoretical apoapsis is 68,000m... I've just tested this in game with KSP 1.9.1 and the latest pre-release build of Kopernicus 1.9.1-1 and it seems to correlate with what it should be:

iBtZaR5.png

This was the highest I could get the apoapsis without the orbit becoming parabolic.

Link to post
Share on other sites
2 hours ago, Souptime said:

Anyone have a transfer window map for this?

What do you mean by "transfer window map"?  If you mean a delta-v map, here's one.  There are others if you Google for them.

Spoiler

BsueGu4.png

 

Edited by OhioBob
Link to post
Share on other sites
1 minute ago, OhioBob said:

What do you mean by "transfer window map"?  If you mean a delta-v map, here's one.  There are others if you Google for them.

BsueGu4.png

I mean like what are the transfer windows for sarnus and beyond?

https://www.google.com/search?q=ksp+transfer+window&sxsrf=ALeKk03ZdOV9xIxb77FtH3PpW3AA5cGeuw:1593890943188&source=lnms&tbm=isch&sa=X&ved=2ahUKEwjWvuq7qrTqAhXwlHIEHZgAA_MQ_AUoAXoECA0QAw&cshid=1593890984331616&biw=1707&bih=868#imgrc=_DmgFM_B6aV7SM like dat

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...